About the Author

Greg Harvey has authored tons of computer books, the most recent being Excel Workbook For Dummies and Roxio Easy Media Creator 8 For Dummies, and the most popular being Excel 2003 For Dummies and Excel 2003 All-In-One Desk Reference For Dummies. He started out training business users on how to use IBM personal computers and their attendant computer software in the rough and tumble days of DOS, WordStar, and Lotus 1-2-3 in the mid-80s of the last century. After working for a number of independent training firms, Greg went on to teach semester-long courses in spreadsheet and database management software at Golden Gate University in San Francisco.

His love of teaching has translated into an equal love of writing. For Dummies books are, of course, his all-time favorites to write because they enable him to write to his favorite audience: the beginner. They also enable him to use humor (a key element to success in the training room) and, most delightful of all, to express an opinion or two about the subject matter at hand.

Greg received his doctorate degree in Humanities in Philosophy and Religion with a concentration in Asian Studies and Comparative Religion last May. Everyone is glad that Greg was finally able to get out of school before he retired.
Dedication

An Erucolindo melindonya

Author’s Acknowledgments

Let me take this opportunity to thank all the people, both at Wiley Publishing, Inc., and at Mind over Media, Inc., whose dedication and talent combined to get this book out and into your hands in such great shape.

At Wiley Publishing, Inc., I want to thank Andy Cummings and Katie Feltman for their encouragement and help in getting this project underway and their ongoing support every step of the way, and project editor Christine Berman. These people made sure that the project stayed on course and made it into production so that all the talented folks on the production team could create this great final product.

At Mind over Media, I want to thank Christopher Aiken for his review of the updated manuscript and invaluable input and suggestions on how best to restructure the book to accommodate all the new features and, most importantly, present the new user interface.
Publisher’s Acknowledgments

We’re proud of this book; please send us your comments through our online registration form located at www.dummies.com/register/.

Some of the people who helped bring this book to market include the following:

**Acquisitions, Editorial, and Media Development**
- **Project Editor:** Christine Berman
- **Senior Acquisitions Editor:** Katie Feltman
- **Copy Editor:** Christine Berman
- **Technical Editor:** Gabrielle Sempf
- **Editorial Manager:** Jodi Jensen
- **Media Development Manager:** Laura Carpenter VanWinkle
- **Editorial Assistant:** Amanda Foxworth
- **Cartoons:** Rich Tennant ([www.the5thwave.com](http://www.the5thwave.com))

**Production**
- **Project Coordinator:** Adrienne Martinez
- **Layout and Graphics:** Stephanie D. Jumper, Barbara Moore, Barry Offringa, Heather Ryan
- **Proofreaders:** John Greenough, Jessica Kramer, Techbooks
- **Indexer:** Techbooks
- **Anniversary Logo Design:** Richard Pacifico

---

**Publishing and Editorial for Technology Dummies**
- **Richard Swadley,** Vice President and Executive Group Publisher
- **Andy Cummings,** Vice President and Publisher
- **Mary C. Corder,** Editorial Director

**Publishing for Consumer Dummies**
- **Diane Graves Steele,** Vice President and Publisher
- **Joyce Pepple,** Acquisitions Director

**Composition Services**
- **Gerry Fahey,** Vice President of Production Services
- **Debbie Stailey,** Director of Composition Services
# Table of Contents

**Introduction**................................. 1
  About This Book................................................................. 1
  How to Use This Book .............................................................. 2
  What You Can Safely Ignore....................................................... 2
  Foolish Assumptions ............................................................... 3
  How This Book Is Organized...................................................... 3
    Part I: Getting In on the Ground Floor ................................. 3
    Part II: Editing Without Tears .............................................. 4
    Part III: Getting Organized and Staying That Way ...................... 4
    Part IV: Digging Data Analysis ............................................ 4
    Part V: Life Beyond the Spreadsheet ...................................... 4
    Part VI: The Part of Tens ..................................................... 5
  Conventions Used in This Book ................................................ 5
    Keyboard and mouse ............................................................ 5
    Special icons ........................................................................ 7
  Where to Go from Here.......................................................... 8

**Part I: Getting In on the Ground Floor**.............................. 9

**Chapter 1: The Excel 2007 User Experience** .................. 11
  Excel’s Ribbon User Interface ............................................... 12
    Manipulating the Office Button ......................................... 12
    Bragging about the Ribbon ................................................ 14
    Adapting the Quick Access toolbar .................................... 18
    Having fun with the Formula bar ........................................ 21
    What to do in the Worksheet area ....................................... 22
    Showing off the Status bar ................................................ 27
  Starting and Exiting Excel ..................................................... 29
    Starting Excel from the Windows Vista Start menu .................. 29
    Starting Excel from the Windows XP Start menu .................... 29
    Pinning Excel to the Start menu .......................................... 30
    Creating an Excel desktop shortcut for Windows Vista ............. 30
    Creating an Excel desktop shortcut for Windows XP ............... 31
    Adding the Excel desktop shortcut to the Quick Launch toolbar ........................................... 32
    Exiting Excel ........................................................................ 32
  Help Is on the Way .............................................................. 33
    Migrating to Excel 2007 from Earlier Versions ....................... 34
    Cutting the Ribbon down to size ......................................... 35
    Finding the Standard Toolbar buttons equivalents .................. 41
Finding the Formatting Toolbar buttons equivalents ......................43
Putting the Quick Access toolbar to excellent use .........................45
Getting good to go with Excel 2007 .................................................49

Chapter 2: Creating a Spreadsheet from Scratch ..........................51
So What Ya Gonna Put in That New Workbook of Yours? ...............52
The ins and outs of data entry ..........................................................52
You must remember this .................................................................53
Doing the Data-Entry Thing .............................................................53
It Takes All Types .............................................................................56
The telltale signs of text ...................................................................56
How Excel evaluates its values .........................................................58
Fabricating those fabulous formulas! ...............................................64
If you want it, just point it out .........................................................67
Altering the natural order of operations .........................................67
Formula flub-ups ............................................................................68
Fixing Up Those Data Entry Flub-Ups ............................................70
You really AutoCorrect that for me .................................................70
Cell editing etiquette ......................................................................71
Taking the Drudgery out of Data Entry ...........................................73
I’m just not complete without you ..................................................73
Fill ’er up with AutoFill ..................................................................75
Inserting special symbols ...............................................................80
Entries all around the block ...........................................................81
Data entry express .........................................................................82
How to Make Your Formulas Function Even Better ......................83
Inserting a function into a formula with the
   Function Wizard button ...............................................................84
   Editing a function with the Function Wizard button .....................87
   I’d be totally lost without AutoSum .............................................87
Making Sure That the Data Is Safe and Sound .............................90
The Save As dialog box in Windows Vista .....................................91
The Save As dialog box in Windows XP .........................................92
Changing the default file location ..................................................93
The difference between the XLSX and XLS file format .................94
Saving the Workbook as a PDF File ...............................................95
Document Recovery to the Rescue .................................................96

Part II: Editing Without Tears .....................................................97

Chapter 3: Making It All Look Pretty .........................................99
Choosing a Select Group of Cells .....................................................100
Point-and-click cell selections .......................................................100
Keyboard cell selections ...............................................................104
Having Fun with the Format as Table Gallery ..............................107
Cell Formatting from the Home Tab ..........................................................109
Formatting Cells Close to the Source with the Mini Toolbar...............113
Using the Format Cells Dialog Box.............................................................114
  Getting comfortable with the number formats ..............................114
  The values behind the formatting ....................................................119
  Make it a date! ...............................................................................121
  Ogling some of the other number formats ..................................122
Calibrating Columns ....................................................................................123
  Rambling rows ...........................................................................124
  Now you see it, now you don’t ....................................................125
Futzing with the Fonts .................................................................................126
  Altering the Alignment .......................................................................128
  Intent on indents ........................................................................130
  From top to bottom........................................................................130
  Tampering with how the text wraps ............................................131
  Reorienting cell entries ................................................................133
  Shrink to fit ..................................................................................134
  Bring on the borders!.................................................................135
  Applying fill colors, patterns, and gradient effects to cells ..........136
Do It in Styles................................................................................................138
  Creating a new style for the gallery .................................................138
  Copying custom styles from one workbook into another ............138
Fooling Around with the Format Painter ..................................................139

Chapter 4: Going through Changes ..............................................................141

Opening the Darned Thing Up for Editing .................................................142
  The Open dialog box in Excel 2007 running on Windows Vista ..........142
  The Open dialog box in Excel 2007 running on Windows XP ..........144
  Opening more than one workbook at a time ..................................146
  Opening recently edited workbooks .................................................146
  When you don’t know where to find them ....................................147
  Opening files with a twist .................................................................149
Much Ado about Undo ..................................................................................150
  Undo is Redo the second time around ............................................150
  What ya gonna do when you can’t Undo? .....................................151
Doing the Old Drag-and-Drop Thing ..........................................................151
  Copies, drag-and-drop style ..........................................................153
  Insertions courtesy of drag and drop ..............................................154
Formulas on AutoFill....................................................................................155
  Relatively speaking .......................................................................156
  Some things are absolutes! ...............................................................157
  Cut and paste, digital style .................................................................159
  Paste it again, Sam .................................................................160
  Keeping pace with the Paste Options ............................................160
  Paste it from the Clipboard task pane .............................................161
So what’s so special about Paste Special? ..............................................162
Let's Be Clear about Deleting Stuff.............................................................164
   Sounding the all clear! .................................................................164
     Get these cells outta here!...................................................165
Staying in Step with Insert .................................................................166
Stamping Out Your Spelling Errors ............................................................167
Stamping Out Errors with Text to Speech.................................................169

Chapter 5: Printing the Masterpiece ......................................................173
   Taking a Gander at the Pages in Page Layout View ................................174
   Checking the Printout with Print Preview .........................................175
   Printing the Worksheet..................................................................177
   Printing the Worksheet from the Print Dialog Box .........................178
     Printing particular parts of the workbook ..................................179
   Setting and clearing the Print Area ................................................181
   My Page Was Set Up! ......................................................................181
     Using the buttons in the Page Setup group..............................182
     Using the buttons in the Scale to Fit group...........................188
     Using the Print buttons in the Sheet Options group ..............188
   From Header to Footer ..................................................................189
     Adding an Auto Header or Auto Footer ..................................190
     Creating a custom header or footer .........................................192
   Solving Page Break Problems ......................................................196
   Letting Your Formulas All Hang Out ...........................................198

Part III: Getting Organized and Staying That Way .......201

Chapter 6: Maintaining the Worksheet .................................................203
   Zeroing In with Zoom....................................................................204
   Splitting the Difference................................................................206
   Fixed Headings Courtesy of Freeze Panes ....................................209
   Electronic Sticky Notes ................................................................212
     Adding a comment to a cell .....................................................212
     Comments in review...............................................................214
     Editing the comments in a worksheet ..................................215
     Getting your comments in print ............................................216
   The Cell Name Game ....................................................................216
     If I only had a name . . . .......................................................216
     Name that formula! ...............................................................217
     Naming constants ....................................................................218
   Seek and Ye Shall Find . . . ........................................................220
   You Can Be Replaced! ..............................................................223
   Do Your Research .....................................................................224
   You Can Be So Calculating .......................................................226
   Putting on the Protection ...........................................................227
Chapter 7: Maintaining Multiple Worksheets ......................... 231
  Juggling Worksheets ................................................................... 232
  Sliding between the sheets ....................................................... 232
  Editing en masse ...................................................................... 235
  Don’t Short-Sheet Me! ............................................................... 236
    A worksheet by any other name ........................................... 237
    A sheet tab by any other color ............................................. 238
  Getting your sheets in order .................................................... 239
  Opening Windows on Your Worksheets .................................... 240
  Comparing Two Worksheets Side by Side .................................. 245
  Moving and Copying Sheets to Other Workbooks .................... 246
  To Sum Up .............................................................................. 249

Part IV: Digging Data Analysis ............................................. 253

Chapter 8: Doing What-If Analysis ........................................ 255
  Playing what-if with Data Tables .......................................... 256
    Creating a one-variable data table ....................................... 256
    Creating a two-variable data table ....................................... 259
  Playing What-If with Goal Seeking ....................................... 261
  Examining Different Cases with Scenario Manager .................. 264
    Setting up the various scenarios ....................................... 264
    Producing a summary report ............................................. 266

Chapter 9: Playing with Pivot Tables ................................. 269
  Pivot Tables: The Ultimate Data Summary ............................ 269
  Producing a Pivot Table .......................................................... 270
  Formatting a Pivot Table .......................................................... 273
    Refining the Pivot Table style ......................................... 274
    Formatting the values in the pivot table ......................... 275
  Sorting and Filtering the Pivot Table Data ............................ 275
    Filtering the report .......................................................... 276
    Filtering individual Column and Row fields ................. 276
    Sorting the pivot table ...................................................... 278
  Modifying a Pivot Table .......................................................... 278
    Modifying the pivot table fields ..................................... 278
    Pivoting the table’s fields ................................................ 279
    Modifying the table’s summary function ....................... 280
  Get Smart with a Pivot Chart ................................................. 281
    Moving a pivot chart to its own sheet .......................... 282
    Filtering a pivot chart ...................................................... 283
    Formatting a pivot chart .................................................... 283
Part V: Life Beyond the Spreadsheet

Chapter 10: Charming Charts and Gorgeous Graphics

Making Professional-Looking Charts
Creating a new chart
Moving and resizing an embedded chart in a worksheet
Moving an embedded chart onto its own chart sheet
Customizing the chart type and style from the Design tab
Customizing chart elements from the Layout tab
Editing the titles in a chart
Formatting chart elements from the Format tab
Adding Great Looking Graphics
Telling all with a text box
The wonderful world of Clip Art
Inserting pictures from graphics files
Editing Clip Art and imported pictures
Formatting Clip Art and imported pictures
Adding preset graphic shapes
Working with WordArt
Make mine SmartArt
Theme for a day
Controlling How Graphic Objects Overlap
Reordering the layering of graphic objects
Grouping graphic objects
Hiding graphic objects
Printing Just the Charts

Chapter 11: Getting on the Data List

Creating a Data List
Adding records to a data list
Sorting Records in a Data List
Sorting records on a single field
Sorting records on multiple fields
Filtering the Records in a Data List
Using readymade number filters
Using readymade date filters
Getting creative with custom filtering
Importing External Data
Querying an Access database table
Performing a New Web query
Chapter 12: Hyperlinks and Macros .......................................................... 343
   Using Add-Ins in Excel 2007 .............................................................. 343
   Adding Hyperlinks to a Worksheet .................................................... 345
   Automating Commands with Macros ................................................. 348
      Recording new macros ................................................................. 348
      Running macros ........................................................................... 352
      Assigning macros to the Quick Access toolbar ......................... 353

Part VI: The Part of Tens ...................................................................... 355

Chapter 13: Top Ten New Features in Excel 2007  .............................. 357

Chapter 14: Top Ten Beginner Basics .................................................... 361

Chapter 15: The Ten Commandments of Excel 2007 .......................... 363

Index ................................................................................................... 365
Introduction

I’m very proud to present you with the completely revamped and almost totally brand new Excel 2007 For Dummies, the latest version of everybody’s favorite book on Microsoft Office Excel for readers with no intention whatsoever of becoming spreadsheet gurus. The dramatic changes evident in this version of the book reflect the striking, dare I say, revolutionary changes that Microsoft has brought to its ever-popular spreadsheet program. One look at the new Ribbon command structure and all those rich style galleries in Excel 2007 and you know you’re not in Kansas anymore ‘cause this is definitely not your mother’s Excel!

In keeping with Excel’s more graphical and colorful look and feel, Excel 2007 For Dummies has taken on some color of its own (just take a gander at those color plates in the mid-section of the book) and now starts off with a definitive introduction to the new user Ribbon interface. This chapter is written both for those of you for whom Excel is a completely new experience and those of you who have had some experience with the old pull-down menu and multi-toolbar Excel interface who are now faced with the seemingly daunting task of getting comfortable with a whole new user experience.

Excel 2007 For Dummies covers all the fundamental techniques you need to know in order to create, edit, format, and print your own worksheets. In addition to showing you around the worksheet, this book also exposes you to the basics of charting, creating data lists, and performing data analysis. Keep in mind, though, that this book just touches on the easiest ways to get a few things done with these features — I make no attempt to cover charting, data lists, or data analysis in the same definitive way as spreadsheets: This book concentrates on spreadsheets because spreadsheets are what most regular folks create with Excel.

About This Book

This book isn’t meant to be read cover to cover. Although its chapters are loosely organized in a logical order (progressing as you might when studying Excel in a classroom situation), each topic covered in a chapter is really meant to stand on its own.
Each discussion of a topic briefly addresses the question of what a particular feature is good for before launching into how to use it. In Excel, as with most other sophisticated programs, you usually have more than one way to do a task. For the sake of your sanity, I have purposely limited the choices by usually giving you only the most efficient ways to do a particular task. Later on, if you’re so tempted, you can experiment with alternative ways of doing a task. For now, just concentrate on performing the task as I describe.

As much as possible, I’ve tried to make it unnecessary for you to remember anything covered in another section of the book. From time to time, however, you will come across a cross-reference to another section or chapter in the book. For the most part, such cross-references are meant to help you get more complete information on a subject, should you have the time and interest. If you have neither, no problem; just ignore the cross-references as if they never existed.

How to Use This Book

This book is like a reference in which you start out by looking up the topic you need information about (in either the table of contents or the index), and then you refer directly to the section of interest. I explain most topics conversationally (as though you were sitting in the back of a classroom where you can safely nap). Sometimes, however, my regiment-commander mentality takes over, and I list the steps you need to take to accomplish a particular task in a particular section.

What You Can Safely Ignore

When you come across a section that contains the steps you take to get something done, you can safely ignore all text accompanying the steps (the text that isn’t in bold) if you have neither the time nor the inclination to wade through more material.

Whenever possible, I have also tried to separate background or footnote-type information from the essential facts by exiling this kind of junk to a sidebar (look for blocks of text on a gray background). These sections are often flagged with icons that let you know what type of information you will encounter there. You can easily disregard text marked this way. (I’ll scoop you on the icons I use in this book a little later.)
Foolish Assumptions

I’m going to make only one assumption about you (let’s see how close I get): You have access to a PC (at least some of the time) that is running either Windows Vista or Windows XP and on which Microsoft Office Excel 2007 is installed. However, having said that, I make no assumption that you’ve ever launched Excel 2007, let alone done anything with it.

This book is intended ONLY for users of Microsoft Office Excel 2007! If you’re using any previous version of Excel for Windows (from Excel 97 through 2003), the information in this book will only confuse and confound you as your version of Excel works nothing like the 2007 version this book describes.

If you are working on an earlier version of Excel, please put this book down slowly and instead pick up a copy of Excel 2003 For Dummies, published by Wiley Publishing.

How This Book Is Organized

This book is organized in six parts (which gives you a chance to see at least six of those great Rich Tennant cartoons!). Each part contains two or more chapters (to keep the editors happy) that more or less go together (to keep you happy). Each chapter is further divided into loosely related sections that cover the basics of the topic at hand. You should not, however, get too hung up on following along with the structure of the book; ultimately, it doesn’t matter at all if you find out how to edit the worksheet before you learn how to format it, or if you figure out printing before you learn editing. The important thing is that you find the information — and understand it when you find it — when you need to perform a particular task.

In case you’re interested, a synopsis of what you find in each part follows.

Part I: Getting In on the Ground Floor

As the name implies, in this part I cover such fundamentals as how to start the program, identify the parts of the screen, enter information in the worksheet, save a document, and so on. If you’re starting with absolutely no background in using spreadsheets, you definitely want to glance at the information in Chapter 1 to discover the secrets of the new Ribbon interface before you move on to how to create new worksheets in Chapter 2.
Part II: Editing Without Tears

In this part, I show how to edit spreadsheets to make them look good, as well as how to make major editing changes to them without courting disaster. Peruse Chapter 3 when you need information on formatting the data to improve the way it appears in the worksheet. See Chapter 4 for rearranging, deleting, or inserting new information in the worksheet. And read Chapter 5 for the skinny on printing out your finished product.

Part III: Getting Organized and Staying That Way

Here I give you all kinds of information on how to stay on top of the data that you’ve entered into your spreadsheets. Chapter 6 is full of good ideas on how to keep track of and organize the data in a single worksheet. Chapter 7 gives you the ins and outs of working with data in different worksheets in the same workbook and gives you information on transferring data between the sheets of different workbooks.

Part IV: Digging Data Analysis

This part consists of two chapters. Chapter 8 gives you an introduction to performing various types of what-if analysis in Excel, including setting up data tables with one and two inputs, performing goal seeking, and creating different cases with Scenario Manager. Chapter 9 introduces you to Excel’s vastly improved pivot table and pivot chart capabilities that enable you to summarize and filter vast amounts of data in a worksheet table or data list in a compact tabular or chart format.

Part V: Life Beyond the Spreadsheet

In Part V, I explore some of the other aspects of Excel besides the spreadsheet. In Chapter 10, you find out just how ridiculously easy it is to create a chart using the data in a worksheet. In Chapter 11, you discover just how useful Excel’s data list capabilities can be when you have to track and organize a large amount of information. In Chapter 12, you find out about using add-in programs to enhance Excel’s basic features, adding hyperlinks to jump to new places in a worksheet, to new documents, and even to Web pages, as well as how to record macros to automate your work.
Part VI: The Part of Tens

As is the tradition in For Dummies books, the last part contains lists of the top ten most useful and useless facts, tips, and suggestions. In this part, you find three chapters. Chapter 13 provides my top ten list of the best new features in Excel 2007 (and boy was it hard keeping it down to just ten). Chapter 14 gives you the top ten beginner basics you need to know as you start using this program. And Chapter 15 gives you the King James Version of the Ten Commandments of Excel 2007. With this chapter under your belt, how canst thou goest astray?

Conventions Used in This Book

The following information gives you the lowdown on how things look in this book — publishers call these items the book’s conventions (no campaigning, flag-waving, name-calling, or finger-pointing is involved, however).

Keyboard and mouse

Excel 2007 is a sophisticated program with a whole new and wonderful user interface, dubbed the Ribbon. In Chapter 1, I explain all about this new Ribbon interface and how to get comfortable with its new command structure. Throughout the book, you’ll find Ribbon command sequences using the shorthand developed by Microsoft whereby the name on the tab on the Ribbon and the command button you select are separated by vertical bars as in:

Home | Copy

This is shorthand for the Ribbon command that copies whatever cells or graphics are currently selected to the Windows Clipboard. It means that you click the Home tab on the Ribbon (if it’s not already displayed) and then click the Copy button (that sports the traditional side-by-side page icon).

Some of the Ribbon command sequences involve not only selecting a command button on a tab but then also selecting an item on a drop-down menu. In this case, the drop-down menu command follows the name of the tab and command button, all separated by vertical bars, as in:

Formulas | Calculation Options | Manual
This is shorthand for the Ribbon command sequence that turns on manual recalculation in Excel. It says that you click the Formulas tab (if it’s not already displayed) and then click the Calculation Options button followed by the Manual drop-down menu option.

Although you use the mouse and keyboard shortcut keys to move your way in, out, and around the Excel worksheet, you do have to take some time to enter the data so that you can eventually mouse around with it. Therefore, this book occasionally encourages you to type something specific into a specific cell in the worksheet. Of course, you can always choose not to follow the instructions. When I tell you to enter a specific function, the part you should type generally appears in **bold** type. For example, `=SUM(A2:B2)` means that you should type exactly what you see: an equal sign, the word **SUM**, a left parenthesis, the text **A2:B2** (complete with a colon between the letter-number combos), and a right parenthesis. You then, of course, have to press Enter to make the entry stick.

When Excel isn’t talking to you by popping up message boxes, it displays highly informative messages in the status bar at the bottom of the screen. This book renders messages that you see on-screen like this:

```
Calculate
```

This is the message that tells you that Excel is in manual recalculation mode (after using the earlier Ribbon command sequence) and that one or more of the formulas in your worksheet are not up-to-date and are in sore need of recalculation.

Occasionally I give you a *hot key combination* that you can press in order to choose a command from the keyboard rather than clicking buttons on the Ribbon with the mouse. Hot key combinations are written like this: Alt+FS or Ctrl+S (both of these hot key combos save workbook changes).

With the Alt key combos, you press the Alt key until the hot key letters appear in little squares all along the Ribbon. At that point, you can release the Alt key and start typing the hot key letters (by the way, you type all lowercase hot key letters — I only put them in caps to make them stand out in the text).

Hot key combos that use the Ctrl key are of an older vintage and work a little bit differently. You have to hold down the Ctrl key as you type the hot letter (though again, type only lowercase letters unless you see the Shift key in the sequence, as in Ctrl+Shift+C).
Excel 2007 uses only one pull-down menu (the File pull-down menu) and one toolbar (the Quick Access toolbar). You open the File pull-down menu by clicking the Office Button (the four-color round button in the upper-left corner of Excel program window) or pressing Alt+F. The Quick Access toolbar with its four buttons appears to the immediate right of the Office Button.

All earlier versions of this book use *command arrows* to lead you from the initial pull-down menu, to the submenu, and so on, to the command you ultimately want. For example, if you need to open the File pull-down menu to get to the Open command, that instruction would look like this: Choose File ➪ Open. This is the equivalent of Office Button | Open and Alt+FO. Commands using the older command arrow notation rather than the vertical bar notation occur only in the tables in Chapter 1 for people upgrading to Excel 2007 from older versions of Excel.

Finally, if you’re really observant, you may notice a discrepancy between the capitalization of the names of dialog box options (such as headings, option buttons, and check boxes) as they appear in text and how they actually appear in Excel on your computer screen. I intentionally use the convention of capitalizing the initial letters of all the main words of a dialog box option to help you differentiate the name of the option from the rest of the text describing its use.

**Special icons**

The following icons are strategically placed in the margins to point out stuff you may or may not want to read.

This icon alerts you to nerdy discussions that you may well want to skip (or read when no one else is around).

This icon alerts you to shortcuts or other valuable hints related to the topic at hand.

This icon alerts you to information to keep in mind if you want to meet with a modicum of success.

This icon alerts you to information to keep in mind if you want to avert complete disaster.
Where to Go from Here

If you’ve never worked with a computer spreadsheet, I suggest that, right after getting your chuckles with the cartoons, you first go to Chapter 1 and find out what you’re dealing with. And, if you’re someone with some experience with earlier versions of Excel, I want you to head directly to the section, “Migrating to Excel 2007 from Earlier Versions” in Chapter 1, where you find out how to stay calm as you become familiar and, yes, comfortable with the new Ribbon user interface.

Then, as specific needs arise (such as, “How do I copy a formula?” or “How do I print just a particular section of my worksheet?”), you can go to the table of contents or the index to find the appropriate section and go right to that section for answers.
Part I
Getting In on the Ground Floor

The 5th Wave  By Rich Tennant

“I’ve used several spreadsheet programs, but this is the best one for designing quilt patterns.”
In this part . . .

One look at the Excel 2007 screen with its new Microsoft Office Button, Quick Access toolbar, and Ribbon, and you realize how much stuff is going on here. Well, not to worry: In Chapter 1, I break down the parts of the Excel 2007 Ribbon user interface and make some sense out of the rash of tabs and command buttons that you’re going to be facing day after day after day.

Of course, it’s not enough to just sit back and have someone like me explain what’s what on the screen. To get any good out of Excel, you’ve got to start learning how to use all these bells and whistles (or buttons and boxes, in this case). That’s where Chapter 2 comes in, giving you the lowdown on how to use some of the screen’s more prominent buttons and boxes to get your spreadsheet data entered. From this humble beginning, it’s a quick trip to total screen mastery.
Chapter 1
The Excel 2007 User Experience

In This Chapter
- Getting familiar with the new Excel 2007 program window
- Selecting commands from the Ribbon
- Customizing the Quick Access Toolbar
- Methods for starting Excel 2007
- Surfing an Excel 2007 worksheet and workbook
- Getting some help with using this program
- Quick start guide for users migrating to Excel 2007 from earlier versions

The designers and engineers at Microsoft have really gone and done it this time — cooking up a brand new way to use everybody’s favorite electronic spreadsheet program. This new Excel 2007 user interface scraps its previous reliance on a series of pull-down menus, task panes, and multitudinous toolbars. Instead, it uses a single strip at the top of the worksheet called the Ribbon designed to put the bulk of the Excel commands you use at your fingertips at all times.

Add a single remaining Office pull-down menu and sole Quick Access toolbar along with a few remaining task panes (Clipboard, Clip Art, and Research) to the Ribbon and you end up with the easiest to use Excel ever. This version offers you the handiest way to crunch your numbers, produce and print polished financial reports, as well as organize and chart your data, in other words, to do all the wonderful things for which you rely on Excel.

And best of all, this new and improved Excel user interface includes all sorts of graphical improvements. First and foremost is Live Preview that shows you how your actual worksheet data would appear in a particular font, table formatting, and so on before you actually select it. In addition, Excel now supports an honest to goodness Page Layout View that displays rulers and margins along with headers and footers for every worksheet and has a zoom slider at the bottom of the screen that enables you to zoom in and out on the spreadsheet data instantly. Last but not least, Excel 2007 is full of pop-up galleries that make spreadsheet formatting and charting a real breeze, especially in tandem with Live Preview.
Excel’s Ribbon User Interface

When you first launch Excel 2007, the program opens up the first of three new worksheets (named Sheet1) in a new workbook file (named Book1) inside a program window like the one shown in Figure 1-1 and Color Plate 1.

The Excel program window containing this worksheet of the workbook is made up of the following components:

- **Office Button** that when clicked opens the Office pull-down menu containing all the file related commands including Save, Open, Print, and Exit as well as the Excel Options button that enables you to change Excel’s default settings
- **Quick Access toolbar** that contains buttons you can click to perform common tasks such as saving your work and undoing and redoing edits and which you can customize by adding command buttons
- **Ribbon** that contains the bulk of the Excel commands arranged into a series of tabs ranging from Home through View
- **Formula bar** that displays the address of the current cell along with the contents of that cell
- **Worksheet area** that contains all the cells of the current worksheet identified by column headings using letters along the top and row headings using numbers along the left edge with tabs for selecting new worksheets and a horizontal scroll bar to move left and right through the sheet on the bottom and a vertical scroll bar to move up and down through the sheet on the right edge
- **Status bar** that keeps you informed of the program’s current mode, any special keys you engage, and enables you to select a new worksheet view and to zoom in and out on the worksheet

**Manipulating the Office Button**

At the very top of the Excel 2007 program window, you find the Office Button (the round one with the Office four-color icon in the very upper-left corner of the screen) followed immediately by the Quick Access toolbar.

When you click the Office Button, a pull-down menu similar to the one shown in Figure 1-2 appears. This Office menu contains all the commands you need for working with Excel workbook files such as saving, opening, and closing files. In addition, this pull-down menu contains an Excel Options button that you can select to change the program’s settings and an Exit Excel button that you can select when you’re ready to shut down the program.
Figure 1-1: The Excel 2007 program window that appears immediately after launching the program.

Figure 1-2: Click the Office Button to access the commands on its pull-down menu, open a recent workbook, or change the Excel Options.
Bragging about the Ribbon

The Ribbon (shown in Figure 1-3) radically changes the way you work in Excel 2007. Instead of having to memorize (or guess) on which pull-down menu or toolbar Microsoft put the particular command you want to use, their designers and engineers came up with the Ribbon that always shows you all the most commonly used options needed to perform a particular Excel task.

The Ribbon is made up of the following components:

- **Tabs** for each of Excel’s main tasks that bring together and display all the commands commonly needed to perform that core task
- **Groups** that organize related command buttons into subtasks normally performed as part of the tab’s larger core task
- **Command buttons** within each group that you select to perform a particular action or to open a gallery from which you can click a particular thumbnail — note that many command buttons on certain tabs of the Excel Ribbon are organized into mini-toolbars with related settings
- **Dialog Box launcher** in the lower-right corner of certain groups that opens a dialog box containing a bunch of additional options you can select

To get more of the Worksheet area displayed in the program window, you can minimize the Ribbon so that only its tabs are displayed — simply click Minimize the Ribbon on the menu opened by clicking the Custom Quick Access Toolbar button, double-click any one of the Ribbon’s tabs or press Ctrl+F1. To redisplay the entire Ribbon, and keep all the command buttons on its tab displayed in the program window, click Minimize the Ribbon item on the Custom Quick Access Toolbar’s drop-down menu, double-click one of the tabs or press Ctrl+F1 a second time.
When you work in Excel with the Ribbon minimized, the Ribbon expands each time you click one of its tabs to show its command buttons but that tab stays open only until you select one of the command buttons. The moment you select a command button, Excel immediately minimizes the Ribbon again to just the display of its tabs.

**Keeping tabs on the Excel Ribbon**

The very first time you launch Excel 2007, its Ribbon contains the following seven tabs, going from left to right:

- **Home** tab with the command buttons normally used when creating, formatting, and editing a spreadsheet arranged into the Clipboard, Font, Alignment, Number, Styles, Cells, and Editing groups (see Color Plate 1)

- **Insert** tab with the command buttons normally used when adding particular elements (including graphics, PivotTables, charts, hyperlinks, and headers and footers) to a spreadsheet arranged into the Shapes, Tables, Illustrations, Charts, Links, and Text groups (see Color Plate 2)

- **Page Layout** tab with the command buttons normally used when preparing a spreadsheet for printing or re-ordering graphics on the sheet arranged into the Themes, Page Setup, Scale to Fit, Sheet Options, and Arrange groups (see Color Plate 3)

- **Formulas** tab with the command buttons normally used when adding formulas and functions to a spreadsheet or checking a worksheet for formula errors arranged into the Function Library, Defined Names, Formula Auditing, and Calculation groups (see Color Plate 4). Note that this tab also contains a Solutions group when you activate certain add-in programs such as Conditional Sum and Euro Currency Tools — see Chapter 12 for more on using Excel add-in programs.

- **Data** tab with the command buttons normally used when importing, querying, outlining, and subtotaling the data placed into a worksheet’s data list arranged into the Get External Data, Manage Connections, Sort & Filter, Data Tools, and Outline groups (see Color Plate 5). Note that this tab also contains an Analysis group if you activate add-ins such as the Analysis Toolpak and Solver Add-In — see Chapter 12 for more on Excel add-ins.

- **Review** tab with the command buttons normally used when proofing, protecting, and marking up a spreadsheet for review by others arranged into the Proofing, Comments, and Changes, groups (see Color Plate 6). Note that this tab also contains an Ink group with a sole Start Inking button if you’re running Office 2007 on a Tablet PC.

- **View** tab with the command buttons normally used when changing the display of the Worksheet area and the data it contains arranged into the Workbook Views, Show/Hide, Zoom, Window, and Macros groups (see Color Plate 7).
In addition to these seven standard tabs, Excel has an eighth, optional Developer tab that you can add to the Ribbon if you do a lot of work with macros and XML files — see Chapter 12 for more on the Developer tab.

Although these standard tabs are the ones you always see on the Ribbon when it’s displayed in Excel, they aren’t the only things that can appear in this area. In addition, Excel can display contextual tools when you’re working with a particular object that you select in the worksheet such as a graphic image you’ve added or a chart or PivotTable you’ve created. The name of the contextual tools for the selected object appears immediately above the tab or tabs associated with the tools.

For example, Figure 1-4 shows a worksheet after you click the embedded chart to select it. As you can see, doing this causes the contextual tool called Chart Tools to be added to the very end of the Ribbon. Chart Tools contextual tool has its own three tabs: Design (selected by default), Layout, and Format. Note too that the command buttons on the Design tab are arranged into their own groups: Type, Data, Chart Layouts, Chart Styles, and Location.

The moment you deselect the object (usually by clicking somewhere on the sheet outside of its boundaries), the contextual tool for that object and all of its tabs immediately disappears from the Ribbon, leaving only the regular tabs — Home, Insert, Page Layout, Formulas, Data, Review, and View — displayed.

![Chart Tools Contextual tab](image)
Selecting commands from the Ribbon

The most direct method for selecting commands on the Ribbon is to click the tab that contains the command button you want and then click that button in its group. For example, to insert a piece of Clip Art into your spreadsheet, you click the Insert tab and then click the Clip Art button to open the Clip Art task pane in the Worksheet area.

The easiest method for selecting commands on the Ribbon — if you know your keyboard at all well — is to press the Alt key and then type the sequence of letters designated as the hot keys for the desired tab and associated command buttons.

When you first press and release the Alt key, Excel displays the hot keys for all the tabs on the Ribbon. When you type one of the Ribbon tab hot keys to select it, all the command button hot keys appear next to their buttons along with the hot keys for the Dialog Box launchers in any group on that tab (see Figure 1-5). To select a command button or Dialog Box launcher, simply type its hot key letter.

Figure 1-5:
When you press Alt plus a tab hot key, Excel displays the hot keys for selecting all of its command buttons and Dialog Box launchers.

If you know the old Excel shortcut keys from versions Excel 97 through 2003, you can still use them. For example, instead of going through the rigmarole of pressing Alt+HC to copy a cell selection to the Windows Clipboard and then Alt+HV to paste it elsewhere in the sheet, you can still press Ctrl+C to copy the selection and then press Ctrl+V when you’re ready to paste it. Note, however, that when using a hot key combination with the Alt key, you don’t need to keep the Alt key depressed while typing the remaining letter(s) as you do when using a hot key combo with the Ctrl key.
Adapting the Quick Access toolbar

When you first start using Excel 2007, the Quick Access toolbar contains only the following few buttons:

- **Save** to save any changes made to the current workbook using the same filename, file format, and location
- **Undo** to undo the last editing, formatting, or layout change you made
- **Redo** to reapply the previous editing, formatting, or layout change that you just removed with the Undo button

The Quick Access toolbar is very customizable as Excel makes it really easy to add any Ribbon command to it. Moreover, you’re not restricted to adding buttons for just the commands on the Ribbon: you can add any Excel command you want to the toolbar, even the obscure ones that don’t rate an appearance on any of its tabs.

By default, the Quick Access toolbar appears above the Ribbon tabs immediately to the right of the Office Button. To display the toolbar beneath the Ribbon immediately above the Formula bar, click the Customize Quick Access Toolbar button (the drop-down button to the right of the toolbar with a horizontal bar above a down-pointing triangle) and then click Show Below the Ribbon on its drop-down menu. You will definitely want to make this change if you start adding more buttons to the toolbar so that the growing Quick Access toolbar doesn’t start crowding out the name of the current workbook that appears to the toolbar’s right.

Adding command buttons on the Customize Quick Access Toolbar’s drop-down menu

When you click the Customize Quick Access Toolbar button, a drop-down menu appears containing the following commands:

- **New** to open a new workbook
- **Open** to display the Open dialog box for opening an existing workbook
- **Save** to save changes to your current workbook
- **E-mail** to open your mail
- **Quick Print** to send the current worksheet to your default printer
- **Print Preview** to open the current worksheet in the Print Preview window
- **Spelling** to check the current worksheet for spelling errors
- **Undo** to undo your latest worksheet edit
Redo to reapply the last edit that you removed with Undo

Sort Ascending to sort the current cell selection or column in A to Z alphabetical, lowest to highest numerical, or oldest to newest date order

Sort Descending to sort the current cell selection or column Z to A alphabetical, highest to lowest numerical, or newest to oldest date order

When you first open this menu, only the Save, Undo, and Redo options are selected (indicated by the check marks in front of their names) and therefore theirs are the only buttons to appear on the Quick Access toolbar. To add any of the other commands on this menu to the toolbar, you simply click the option on the drop-down menu. Excel then adds a button for that command to the end of the Quick Access toolbar (and a check mark to its option on the drop-down menu).

To remove a command button that you add to the Quick Access toolbar in this manner, click the option a second time on the Customize Quick Access Toolbar button’s drop-down menu. Excel removes its command button from the toolbar and the check mark from its option on the drop-down menu.

Adding command buttons on the Ribbon

To add any Ribbon command to the Quick Access toolbar, simply right-click its command button on the Ribbon and then click Add to Quick Access Toolbar on its shortcut menu. Excel then immediately adds the command button to the very end of the Quick Access toolbar, immediately in front of the Customize Quick Access Toolbar button.

If you want to move the command button to a new location on the Quick Access toolbar or group with other buttons on the toolbar, you need to click the Customize Quick Access Toolbar button and then click the More Commands option near the bottom of its drop-down menu.

Excel then opens the Excel Options dialog box with the Customize tab selected (similar to the one shown in Figure 1-6). Here, Excel shows all the buttons currently added to the Quick Access toolbar with the order in which they appear from left to right on the toolbar corresponding to their top-down order in the list box on the right-hand side of the dialog box.

To reposition a particular button on the bar, click it in the list box on the right and then click either the Move Up button (the one with the black triangle pointing upward) or the Move Down button (the one with the black triangle pointing downward) until the button is promoted or demoted to the desired position on the toolbar.
You can add separators to the toolbar to group related buttons. To do this, click the <Separator> selection in the list box on the left and then click the Add button twice to add two. Then, click the Move Up or Move Down buttons to position one of the two separators at the beginning of the group and the other at the end.

To remove a button added from the Ribbon, right-click it on the Quick Access toolbar and then click the Remove from Quick Access Toolbar option on its shortcut menu.

**Adding non-Ribbon commands to the Quick Access toolbar**

You can also use the options on the Customize tab of the Excel Options dialog box (see Figure 1-6) to add a button for any Excel command even if it’s not one of those displayed on the tabs of the Ribbon:

1. **Click the type of command you want to add to the Quick Access toolbar in the Choose Commands From drop-down list box.**

   The types of commands include the File pull-down menu (the default) as well as each of the tabs that appear on the Ribbon. To display only the commands that are not displayed on the Ribbon, click Commands Not in the Ribbon near the bottom of the drop-down list. To display a complete list of all the Excel commands, click All Commands at the very bottom of the drop-down list.

2. **Click the command whose button you want to add to the Quick Access toolbar in the list box on the left.**
3. Click the Add button to add the command button to the bottom of the list box on the right.

4. (Optional) To reposition the newly added command button so that it’s not the last one on the toolbar, click the Move Up button until it’s in the desired position.

5. Click the OK button to close Excel Options dialog box.

If you’ve created favorite macros (see Chapter 12) that you routinely use and want to be able to run directly from the Quick Access toolbar, click Macros in the Choose Commands From drop-down list box in the Excel Options dialog box and then click the name of the macro to add followed by the Add button.

**Having fun with the Formula bar**

The Formula bar displays the cell address and the contents of the current cell. The address of this cell is determined by its column letter(s) followed immediately by the row number as in cell A1, the very first cell of each worksheet at the intersection of column A and row 1 or cell XFD1048576, the very last of each Excel 2007 worksheet, at the intersection of column XFD and row 1048576. The contents of the current cell are determined by the type of entry you make there: text or numbers if you just enter a heading or particular value and the nuts and bolts of a formula if you enter a calculation there.

The Formula bar is divided into three sections:

- **Name box:** The left-most section that displays the address of the current cell address
- **Formula bar buttons:** The second, middle section that appears as a rather nondescript button displaying only an indented circle on the left (used to narrow or widen the Name box) with the Function Wizard button (labeled fx) on the right until you start making or editing a cell entry at which time, its Cancel (an X) and its Enter (a check mark) buttons appear in between them
- **Cell contents:** The third, right-most white area to the immediate right of the Function Wizard button that takes up the rest of the bar and expands as necessary to display really, really long cell entries that won’t fit the normal area

The Cell contents section of the Formula bar is really important because it **always** shows you the contents of the cell even when the worksheet does not (when you’re dealing with a formula, Excel displays only the calculated result in the cell in the worksheet and not the formula by which that result is derived) and you can edit the contents of the cell in this area at anytime. By the same token, when the Contents area is blank, you know that the cell is empty as well.
What to do in the Worksheet area

The Worksheet area is where most of the Excel spreadsheet action takes place because it’s the place that displays the cells in different sections of the current worksheet and it’s right inside the cells that you do all your spreadsheet data entry and formatting, not to mention a great deal of your editing.

Keep in mind that in order for you to be able to enter or edit data in a cell, that cell must be current. Excel indicates that a cell is current in three ways:

- The cell cursor — the dark black border surrounding the cell’s entire perimeter — appears in the cell
- The address of the cell appears in the Name box of the Formula bar
- The cell’s column letter(s) and row number are shaded (in a kind of a beige color on most monitors) in the column headings and row headings that appear at the top and left of the Worksheet area, respectively

Moving around the worksheet

An Excel worksheet contains far too many columns and rows for all of a worksheet’s cells to be displayed at one time regardless of how large your personal computer monitor screen is or how high the screen resolution. (After all, we’re talking 17,179,869,184 cells total!) Excel therefore offers many methods for moving the cell cursor around the worksheet to the cell where you want to enter new data or edit existing data:

- Click the desired cell — assuming that the cell is displayed within the section of the sheet currently visible in the Worksheet area
- Click the Name box, type the address of the desired cell directly into this box and then press the Enter key

How you assign 26 letters to 16,384 columns

When it comes to labeling the 16,384 columns of an Excel 2007 worksheet, our alphabet with its measly 26 letters is simply not up to the task. To make up the difference, Excel first doubles the letters in the cell’s column reference so that column AA follows column Z (after which you find column AB, AC, and so on) and then triples them so that column AAA follows column ZZ (after which you get column AAB, AAC, and the like). At the end of this letter tripling, the 16,384th and last column of the worksheet ends up being XFD so that the last cell in the 1,048,576th row has the cell address XFD1048576.
Press F5 to open the Go To dialog box, type the address of the desired cell into its Reference text box and then click OK.

Use the cursor keys as shown in Table 1-1 to move the cell cursor to the desired cell.

Use the horizontal and vertical scroll bars at the bottom and right edge of the Worksheet area to move the part of the worksheet that contains the desired cell and then click the cell to put the cell cursor in it.

Keystroke shortcuts for moving the cell cursor
Excel offers a wide variety of keystrokes for moving the cell cursor to a new cell. When you use one of these keystrokes, the program automatically scrolls a new part of the worksheet into view, if this is required to move the cell pointer. In Table 1-1, I summarize these keystrokes and how far each one moves the cell pointer from its starting position.

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Where the Cell Cursor Moves</th>
</tr>
</thead>
<tbody>
<tr>
<td>→ or Tab</td>
<td>Cell to the immediate right.</td>
</tr>
<tr>
<td>← or Shift+Tab</td>
<td>Cell to the immediate left.</td>
</tr>
<tr>
<td>↑</td>
<td>Cell up one row.</td>
</tr>
<tr>
<td>↓</td>
<td>Cell down one row.</td>
</tr>
<tr>
<td>Home</td>
<td>Cell in Column A of the current row.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>First cell (A1) of the worksheet.</td>
</tr>
<tr>
<td>Ctrl+End or End, Home</td>
<td>Cell in the worksheet at the intersection of the last column that has any data in it and the last row that has any data in it (that is, the last cell of the so-called active area of the worksheet).</td>
</tr>
<tr>
<td>PgUp</td>
<td>Cell one full screen up in the same column.</td>
</tr>
<tr>
<td>PgDn</td>
<td>Cell one full screen down in the same column.</td>
</tr>
<tr>
<td>Ctrl+→ or End, →</td>
<td>First occupied cell to the right in the same row that is either preceded or followed by a blank cell. If no cell is occupied, the pointer goes to the cell at the very end of the row.</td>
</tr>
</tbody>
</table>
| Ctrl← or End, ←              | First occupied cell to the left in the same row that is either preceded or followed by a blank cell. If no cell is occupied, the pointer goes to the cell at the very beginning of the row.
Table 1-1 (continued)

<table>
<thead>
<tr>
<th>Keystroke</th>
<th>Where the Cell Cursor Moves</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+↑ or End, ↑</td>
<td>First occupied cell above in the same column that is either preceded or followed by a blank cell. If no cell is occupied, the pointer goes to the cell at the very top of the column.</td>
</tr>
<tr>
<td>Ctrl+↓ or End, ↓</td>
<td>First occupied cell below in the same column that is either preceded or followed by a blank cell. If no cell is occupied, the pointer goes to the cell at the very bottom of the column.</td>
</tr>
<tr>
<td>Ctrl+Page Down</td>
<td>Last occupied cell in the next worksheet of that workbook.</td>
</tr>
<tr>
<td>Ctrl+Page Up</td>
<td>Last occupied cell in the previous worksheet of that workbook.</td>
</tr>
</tbody>
</table>

*Note: In the case of those keystrokes that use arrow keys, you must either use the arrows on the cursor keypad or else have the Num Lock disengaged on the numeric keypad of your keyboard.*

The keystrokes that combine the Ctrl or End key with an arrow key listed in Table 1-1 are among the most helpful for moving quickly from one edge to the other in large tables of cell entries or in moving from table to table in a section of the worksheet that contains many blocks of cells.

When you use Ctrl and an arrow key to move from edge to edge in a table or between tables in a worksheet, you hold down Ctrl while you press one of the four arrow keys (indicated by the + symbol in keystrokes, such as Ctrl+→).

When you use End and an arrow-key alternative, you must press and then release the End key *before* you press the arrow key (indicated by the comma in keystrokes, such as End, →). Pressing and releasing the End key causes the End Mode indicator to appear on the status bar. This is your sign that Excel is ready for you to press one of the four arrow keys.

Because you can keep the Ctrl key depressed as you press the different arrow keys that you need to use, the Ctrl-plus-arrow-key method provides a more fluid method for navigating blocks of cells than the End-then-arrow-key method.

You can use the Scroll Lock key to “freeze” the position of the cell pointer in the worksheet so that you can scroll new areas of the worksheet in view with keystrokes such as PgUp (Page Up) and PgDn (Page Down) without changing the cell pointer’s original position (in essence, making these keystrokes work in the same manner as the scroll bars).
After engaging Scroll Lock, when you scroll the worksheet with the keyboard, Excel does not select a new cell while it brings a new section of the worksheet into view. To “unfreeze” the cell pointer when scrolling the worksheet via the keyboard, you just press the Scroll Lock key again.

**Tips on using the scroll bars**

To understand how scrolling works in Excel, imagine its humongous worksheet as a papyrus scroll attached to rollers on the left and right. To bring into view a new section of a papyrus worksheet that is hidden on the right, you crank the left roller until the section with the cells that you want to see appears. Likewise, to scroll into view a new section of the worksheet that is hidden on the left, you would crank the right roller until that section of cells appears.

You can use the horizontal scroll bar at the bottom of the Worksheet area to scroll back and forth through the columns of a worksheet and the vertical scroll bar to scroll up and down through its rows. To scroll a column or a row at a time in a particular direction, click the appropriate scroll arrow at the ends of the scroll bar. To jump immediately back to the originally displayed area of the worksheet after scrolling through single columns or rows in this fashion, simply click the black area in the scroll bar that now appears in front of or after the scroll bar.

Keep in mind that you can resize the horizontal scroll bar making it wider or narrower by dragging the button that appears to the immediate left of its left scroll arrow. Just keep in mind when working in a workbook that contains a whole bunch of worksheets that in widening the horizontal scroll bar you can end up hiding the display of the workbook’s later sheet tabs.

To scroll very quickly through columns or rows of the worksheet, hold down the Shift key and then drag the mouse pointer in the appropriate direction within the scroll bar until the columns or rows that you want to see appear on the screen in the Worksheet area. When you hold down the Shift key as you scroll, the scroll button within the scroll bar becomes real skinny and a ScreenTip appears next to the scroll bar, keeping you informed of the letter(s) of the columns or the numbers of the rows that you’re currently whizzing through.

If your mouse has a wheel, you can use it to scroll directly through the columns and rows of the worksheet without using the horizontal or vertical scroll bars. Simply position the white-cross mouse pointer in the center of the Worksheet area and then hold down the wheel button of the mouse. When the mouse pointer changes to a four-pointed arrow, drag the mouse pointer in the appropriate direction (left and right to scroll through columns or up and down to scroll through rows) until the desired column or row comes into view in the Worksheet area.
The only disadvantage to using the scroll bars to move around is that the scroll bars bring only new sections of the worksheet into view — they don’t actually change the position of the cell cursor. If you want to start making entries in the cells in a new area of the worksheet, you still have to remember to select the cell (by clicking it) or the group of cells (by dragging through them) where you want the data to appear before you begin entering the data.

**Surfing the sheets in a workbook**

Each new workbook you open in Excel 2007 contains three blank worksheets, each with its own 16,384 columns and 1,048,576 rows (giving you a truly staggering total of 51,539,607,552 blank cells!). But that’s not all, if ever you need more worksheets in your workbook; you can add them simply by clicking the Insert Worksheet button that appears to the immediate right of the last sheet tab (see Figure 1-7).

![Figure 1-7: The Sheet Tab scroll buttons, sheet tabs, and Insert Worksheet button enable you to activate your worksheets and add to them.](image)
On the left side of the bottom of the Worksheet area, the Sheet Tab scroll buttons appear followed by the actual tabs for the worksheets in your workbook and the Insert Worksheet button. To activate a worksheet for editing, you select it by clicking its sheet tab. Excel lets you know what sheet is active by displaying the sheet name in boldface type and making its tab appear on top of the others.

Don’t forget the Ctrl+Page Down and Ctrl+Page Up shortcut keys for selecting the next and previous sheet, respectively, in your workbook.

If your workbook contains too many sheets for all their tabs to be displayed at the bottom of the Worksheet area, use the Sheet Tab scroll buttons to bring new tabs into view (so that you can then click them to activate them). You click the Next Sheet button to scroll the next hidden sheet tab into view or the Last Sheet button to scroll the last group of completely or partially hidden tabs into view.

**One reason for adding extra sheets to a workbook**

You may wonder why on earth anyone would ever need more than three worksheets given just how many cells each individual sheet contains. The simple truth is that it’s all about how you choose to structure a particular spreadsheet rather than running out of places to put the data. For example, suppose that you need to create a workbook that contains budgets for all the various departments in your corporation, you may decide to devote an individual worksheet to each department (with the actual budget spreadsheet tables laid out in the same manner on each sheet) rather than placing all the tables in different sections of the same sheet. Using this kind of one-sheet-per-budget layout makes it much easier for you to find each budget, print each one as a separate page of a report, and, if ever necessary, to consolidate their data in a separate summary worksheet.

**Showing off the Status bar**

The Status bar is the last component at the very bottom of the Excel program window (see Figure 1-8). The Status bar contains the following areas:

- **Mode** button that indicates the current state of the Excel program (Ready, Edit, and so on) as well as any special keys that are engaged (Caps Lock, Num Lock, and Scroll Lock)

- **Macro Recording** button (the red dot) that opens the Record Macro dialog box where you can set the parameters for a new macro and begin recording it (see Chapter 12)
AutoCalculate indicator that displays the Average and Sum of all the numerical entries in the current cell selection along with the Count of every cell in selection

Layout selector that enables you to select between three layouts for the Worksheet area: Normal, the default view that shows only the worksheet cells with the column and row headings; Page Layout View that adds rulers, page margins, and shows page breaks for the worksheet; and Page Break Preview that enables you to adjust the paging of a report (see Chapter 5 for details)

Zoom slider that enables you to zoom in and out on the cells in the Worksheet area by dragging the slider to the right or left, respectively

The Num Lock indicator tells you that you can use the numbers on the numeric keypad for entering values in the worksheet. This keypad will most often be separate from the regular keyboard on the right side if you’re using a separate keyboard and embedded in keys on the right side of the regular keyboard on almost all laptop computers where the keyboard is built right into the computer.
Starting and Exiting Excel

Excel 2007 runs under both the older Windows XP operating system and the brand new Windows Vista operating system. Because of changes made to the Start menu in Windows Vista, the procedure for starting Excel from this version of Windows is a bit different from Windows XP.

Starting Excel from the Windows Vista Start menu

You can use the Start Search box at the bottom of the Windows Vista Start menu to locate Excel on your computer and launch the program in no time at all:

1. Click the Start button on the Windows taskbar to open the Windows Start menu.
2. Click the Start Search text box and type the two letters ex to have Vista locate Microsoft Office Excel 2007 on your computer.
3. Click the Microsoft Office Excel 2007 option that now appears in the left Programs column on the Start menu.

If you have more time on your hands, you can also launch Excel from the Vista Start menu by going through the rigmarole of clicking Start➪All Programs➪Microsoft Office➪Microsoft Office Excel 2007.

Starting Excel from the Windows XP Start menu

When starting Excel 2007 from the Windows XP Start menu, you follow these simple steps:

1. Click the Start button on the Windows taskbar to open the Windows Start menu.
2. With the mouse, highlight All Programs on the Start menu and then Microsoft Office on the Start continuation menu before clicking the Microsoft Office Excel 2007 option on the Microsoft Office continuation menu.
Pinning Excel to the Start menu

If you use Excel all the time, you may want to make its program option a permanent part of the Windows Start menu. To do this, you pin the program option to the Start menu (and the steps for doing this are the same in Windows XP as they are in Windows Vista):

1. **Start Excel from the Windows Start menu.**

   In launching Excel, use the appropriate method for your version of Windows as outlined in the “Starting Excel from the Windows Vista Start menu” or the “Starting Excel from the Windows XP Start menu” section earlier in this chapter.

   After launching Excel, Windows adds Microsoft Office 2007 to the recently used portion on the left side of the Windows Start menu.

2. **Click the Start menu and then right-click Microsoft Excel 2007 on the Start menu to open its shortcut menu.**

3. **Click Pin to Start menu on the shortcut menu.**

After pinning Excel in this manner, the Microsoft Office Excel 2007 option always appears in the upper section of the left-hand column of the Start menu and you can then launch Excel simply by clicking the Start button and then click this option.

Creating an Excel desktop shortcut for Windows Vista

Some people prefer having the Excel Program icon appear on the Windows desktop so that they can launch the program from the desktop by double-clicking this program icon. To create an Excel program shortcut for Windows Vista, you follow these steps:

1. **Click the Start button on the Windows taskbar.**

   The Start menu opens where you click the Start Search text box.

2. **Click the Start Search text box and type excel.exe.**

   Excel.exe is the name of the executable program file that runs Excel. After finding this file on your hard disk, you can create a desktop shortcut from it that launches the program.
3. Right-click the file icon for the `excel.exe` file at the top of the Start menu and then highlight Send To on the pop-up menu and click Desktop (Create Shortcut) on its continuation menu.

   A shortcut named EXCEL -Shortcut appears to your desktop. You should probably rename the shortcut to something a little more friendly, such as Excel 2007.

4. Right-click the EXCEL - Shortcut icon on the Vista desktop and then click Rename on the pop-up menu.

5. Replace the current name by typing a new shortcut name, such as Excel 2007 and then click anywhere on the desktop.

Creating an Excel desktop shortcut for Windows XP

If you're running Excel 2007 on Windows XP, you use the following steps to create a program shortcut for your Windows XP desktop:

1. Click the Start button on the Windows taskbar.

   The Start menu opens the Search item.

2. Click Search in the lower-right corner of the Start menu.

   The Search Results dialog box appears.

3. Click the All Files and Folders link in the panel on the left side of the Search Results dialog box.

   The Search Companion pane appears on the left side of the Search Results dialog box.

4. Type `excel.exe` in the All or Part of the File Name text box.

   `Excel.exe` is the name of the executable program file that runs Excel. After finding this file on your hard disk, you can create a desktop shortcut from it that launches the program.

5. Click the Search button.

   Windows now searches your hard disk for the Excel program file. After locating this file, its name appears on the right side of the Search Results dialog box. When this filename appears, you can click the Stop button in the left panel to halt the search.

6. Right-click the file icon for the `excel.exe` file and then highlight Send To on the pop-up menu and click Desktop (Create Shortcut) on its continuation menu.

   A shortcut named Shortcut to excel.exe appears on your desktop.
7. Click the Close button in the upper-right corner of the Search Results dialog box.

After closing the Search Results dialog box, you should see the icon named Shortcut to excel.exe on the desktop. You should probably rename the shortcut to something a little more friendly, such as Excel 2007.

8. Right-click the Shortcut to excel.exe icon and then click Rename on the pop-up menu.

9. Replace the current name by typing a new shortcut name, such as Excel 2007 and then click anywhere on the desktop.

After you create an Excel desktop shortcut on the Windows XP desktop you can launch Excel by double-clicking the shortcut icon.

**Adding the Excel desktop shortcut to the Quick Launch toolbar**

If you want to be able to launch Excel 2007 by clicking a single button, drag the icon for your Excel Windows Vista or XP desktop shortcut to the Quick Launch toolbar to the immediate right of the Start button at the beginning of the Windows taskbar. When you position the icon on this toolbar, Windows indicates where the new Excel button will appear by drawing a black, vertical I-beam in front of or between the existing buttons on this bar. As soon as you release the mouse button, Windows adds an Excel 2007 button to the Quick Launch toolbar that enables you to launch the program by a single-click of its icon.

**Exiting Excel**

When you’re ready to call it a day and quit Excel, you have several choices for shutting down the program:

- Click the Office Button followed by the Exit Excel button
- Press Alt+FX or Alt+F4
- Click the Close button in the upper-right corner of the Excel program window (the X)

If you try to exit Excel after working on a workbook and you haven’t saved your latest changes, the program beeps at you and displays an alert box querying whether you want to save your changes. To save your changes
before exiting, click the Yes command button. (For detailed information on saving documents, see Chapter 2.) If you’ve just been playing around in the worksheet and don’t want to save your changes, you can abandon the document by clicking the No button.

**Help Is on the Way**

You can get online help with Excel 2007 anytime that you need it while using the program. Simply click the Help button with the question mark icon on the right side of the program window opposite the tabs on the Ribbon or press F1 to open a separate Excel Help window (see Figure 1-9).

![Figure 1-9: The Microsoft Office Excel Help window automatically connects you to the Internet when you open it.](image)

When the Help window first opens, Excel attempts to use your Internet connection to update its topics. The opening Help window contains a bunch of links that you can click to get information on what’s new in the program to quizzes that test your knowledge of Excel.

To get help with a particular command or function, use the Search text box at the top of the Excel Help window. Type keywords or a phrase describing your topic (such as “print preview” or “printing worksheets”) in this text box and then press Enter or click the Search button. The Excel Help window then presents a list of links to related help topics that you can click to display their information.
To print the help topic currently displayed in the Excel Help window, click the Print button (with the printer icon) on its toolbar. Excel then opens a Print dialog box where you can select the printer and options to use in printing the information.

To display a table of contents with all the main categories and subtopics arranged hierarchically, click the Show Table of Contents button (with the book icon) on the toolbar.

**Migrating to Excel 2007 from Earlier Versions**

If you’re a brand new Excel user, you’re going to take to the program’s new Ribbon User Interface like a duck to water. However, if you’re coming to Excel 2007 as a dedicated user of any of the earlier Excel versions (from Excel 97 all the way through Excel 2003), the first time you launch Excel 2007 and take a gander at the Ribbon, you’re probably going to feel more like someone just threw you into the deep end of the pool without a life preserver.

Don’t panic! Simply use this section of the chapter as your Excel 2007 life preserver. It’s intended to get you oriented, keep your head above water, and have you swimming with the new interface in no time at all. Just give me five minutes of your precious time and I promise I’ll have you up and running with Excel 2007 and, maybe even smiling again. Now, take a deep breath, and here we go. . . .

First, the bad news: there is *no* Classic mode in Excel 2007 that will magically turn that fat, screen-real estate stealing Ribbon back into those sleek and tried and true pull-down menus (thanks Microsoft, I needed that)! After the wonderful designers and engineers at Microsoft got through dumping all the pull-down menus and toolbars that you worked so diligently to master and on which you relied every Excel workday of your life, there was just nothing left for them to hang a Classic mode onto.

Now, for the good news: you really don’t need a Classic mode — you just need to find out where those scoundrel engineers went and put all the stuff you used to do so effortlessly in versions of Excel before the Ribbon User Interface. After all, you already know what most of those pull-down menu items and toolbar buttons do; all you have to do is locate them.
Cutting the Ribbon down to size

First thing to do is to get that busy Ribbon out of your face. At this point, it’s just taking up valuable work space and probably making you crazy. So, please double-click any one of the tabs or press Ctrl+F1 right now to cut the Ribbon display down to only its tabs. Single-clicking a tab then temporarily redisplays the Ribbon until you select one of its command buttons, whereas pressing Ctrl+F1 a second time redisplays the Ribbon and keeps it open in all its glory.

When only the tabs — Home through View — are showing at the top of the Excel program window, you should feel a whole lot more comfortable with the screen. The Excel 2007 screen is then as clean and uncluttered, if not more, as the earlier version of Excel that you were using with only the Quick Access toolbar, Ribbon tabs, and Formula bar displayed above the Worksheet area.

Now, you’re probably wondering where those Microsoft engineers moved the most important and commonly-used pull-down menu commands. Table 1-2 shows the Excel 2007 equivalents for the menu commands you probably used most often in doing your work in the earlier version of Excel.

When a particular command is assigned to one of the tabs on the Ribbon, Table 1-2 lists only the tab and command button name without naming the group since the group name plays no part in selecting the command. So, for example, the table lists the tab+command button equivalent of the View | Header and Footer command as Insert | Header & Footer without regard to the fact that the Header & Footer button is part of the Text group on the Insert tab.

### Table 1-2: Excel 2007 Equivalents for Common Pull-Down Menu Commands in Excel 2003

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Menu</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>File</td>
<td>New</td>
<td>Office Button</td>
<td>New</td>
</tr>
<tr>
<td>File</td>
<td>Open</td>
<td>Office Button</td>
<td>Open</td>
</tr>
<tr>
<td>File</td>
<td>Save</td>
<td>Office Button</td>
<td>Save or Save button on the Quick Access Toolbar</td>
</tr>
</tbody>
</table>

(continued)
Table 1-2 (continued)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>File: Save As</td>
<td>Office Button</td>
<td>Save As</td>
<td>F12</td>
</tr>
<tr>
<td>File: Print</td>
<td>Office Button</td>
<td>Print</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>File: Send To: Mail Recipient</td>
<td>Office Button</td>
<td>Send</td>
<td>Email</td>
</tr>
<tr>
<td>File: Send To: Recipient Using Internet Fax Service</td>
<td>Office Button</td>
<td>Send</td>
<td>Internet Fax</td>
</tr>
<tr>
<td>File: Close</td>
<td>Office Button</td>
<td>Close</td>
<td>Ctrl+W</td>
</tr>
</tbody>
</table>

**Edit Menu**

<table>
<thead>
<tr>
<th>Edit: Office Clipboard</th>
<th>Home</th>
<th>Dialog Box launcher in the Clipboard group</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit: Clear: All</td>
<td>Home</td>
<td>Clear (eraser icon)</td>
<td>Clear All</td>
</tr>
<tr>
<td>Edit: Clear: Formats</td>
<td>Home</td>
<td>Clear (eraser icon)</td>
<td>Clear Formats</td>
</tr>
<tr>
<td>Edit: Clear: Contents</td>
<td>Home</td>
<td>Clear (eraser icon)</td>
<td>Clear Contents</td>
</tr>
<tr>
<td>Edit: Clear: Comments</td>
<td>Home</td>
<td>Clear (eraser icon)</td>
<td>Clear Comments</td>
</tr>
<tr>
<td>Edit: Delete</td>
<td>Home</td>
<td>Delete</td>
<td></td>
</tr>
<tr>
<td>Edit: Move or Copy Sheet</td>
<td>Home</td>
<td>Format</td>
<td>Move or Copy Sheet</td>
</tr>
<tr>
<td>Edit: Find</td>
<td>Home</td>
<td>Find &amp; Select</td>
<td>Find</td>
</tr>
<tr>
<td>Edit: Replace</td>
<td>Home</td>
<td>Find &amp; Select</td>
<td>Replace</td>
</tr>
</tbody>
</table>

**View Menu**

<table>
<thead>
<tr>
<th>View: Header and Footer</th>
<th>Insert</th>
<th>Header &amp; Footer</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>View: Full Screen</td>
<td>View</td>
<td>Full Screen</td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------</td>
<td>----------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td><strong>Insert Menu</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert➪Cells</td>
<td>Home</td>
<td>Insert</td>
<td>Insert Cells</td>
</tr>
<tr>
<td>Insert➪Rows</td>
<td>Home</td>
<td>Insert</td>
<td>Insert Sheet Rows</td>
</tr>
<tr>
<td>Insert➪Columns</td>
<td>Home</td>
<td>Insert</td>
<td>Insert Sheet Columns</td>
</tr>
<tr>
<td>Insert➪Worksheets</td>
<td>Home</td>
<td>Insert</td>
<td>Insert Sheet</td>
</tr>
<tr>
<td>Insert➪Symbol</td>
<td>Insert</td>
<td>Symbol</td>
<td></td>
</tr>
<tr>
<td>Insert➪Page Break</td>
<td>Page Layout</td>
<td>Page Breaks</td>
<td>Insert Page Break</td>
</tr>
<tr>
<td>Insert➪Name Define</td>
<td>Formulas</td>
<td>Define Name</td>
<td>Define Name</td>
</tr>
<tr>
<td>Insert➪Name Paste</td>
<td>Formulas</td>
<td>Use in Formula</td>
<td></td>
</tr>
<tr>
<td>Insert➪Name Create</td>
<td>Formulas</td>
<td>Create from Selection</td>
<td></td>
</tr>
<tr>
<td>Insert➪Name Label</td>
<td>Formulas</td>
<td>Name Manager</td>
<td></td>
</tr>
<tr>
<td>Insert➪Comment</td>
<td>Review</td>
<td>New Comment</td>
<td></td>
</tr>
<tr>
<td>Insert➪Picture</td>
<td>Insert</td>
<td>Picture</td>
<td></td>
</tr>
<tr>
<td>Insert➪Hyperlink</td>
<td>Insert</td>
<td>Hyperlink</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td><strong>Format Menu</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Format➪Cells</td>
<td>Home</td>
<td>Format</td>
<td>Cells</td>
</tr>
<tr>
<td>Format➪Row Height</td>
<td>Home</td>
<td>Format</td>
<td>Row Height</td>
</tr>
<tr>
<td>Format➪AutoFit</td>
<td>Home</td>
<td>Format</td>
<td>AutoFit Row Height</td>
</tr>
<tr>
<td>Format➪Row Hide/Unhide</td>
<td>Home</td>
<td>Format</td>
<td>Hide &amp; Unhide</td>
</tr>
</tbody>
</table>

(continued)
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Format Column Width</td>
<td>Home</td>
<td>Format</td>
<td>Column Width</td>
</tr>
</tbody>
</table>
| Format Column Hide/Unhide | Home | Format | Hide & Unhide | Alt+HOU/
|                         | Home | Format | Hide Columns/ Unhide Columns | Alt+HOUL |
| Format Column Standard Width | Home | Format | Default Width | Alt+HOD |
| Format Sheet Rename | Home | Format | Rename Sheet | Alt+HOR |
| Format Sheet Hide/Unhide | Home | Format | Hide & Unhide | Alt+HOU/
|                         | Home | Format | Hide Sheet/ Unhide Sheet | Alt+HOUH |
| Format Sheet Background | Page Layout | Background | Alt+PG |
| Format Sheet Tab Color | Home | Format | Tab Color | Alt+HOT |
| Format AutoFormat | Home | Format as Table | Alt+HT |
| Format Conditional Formatting | Home | Conditional Formatting | Alt+HL |
| Format Style | Home | Cell Styles | Alt+HJ |

**Tools Menu**

<table>
<thead>
<tr>
<th>Tools Spelling</th>
<th>Review</th>
<th>Spelling</th>
<th>F7</th>
<th>Alt+RS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools Research</td>
<td>Review</td>
<td>Research</td>
<td>Alt+RR</td>
<td></td>
</tr>
<tr>
<td>Tools Error Checking</td>
<td>Formulas</td>
<td>Error Checking</td>
<td>Alt+MK</td>
<td></td>
</tr>
</tbody>
</table>
| Tools Speech Show Text to Speech Toolbar | Available only as custom
Speaks Cells, Speak Cells - Stop Speak Cells, Speak Cells by Columns, Speak Cells by Rows and Speak Cells on Enter buttons added to Quick Access toolbar | | | |
--- | --- | --- | ---
Tools ›› Track Changes | Review | Track Changes | Alt+RG
Tools ›› Protection ›› Protect Sheet | Review | Protect Sheet | Alt+RPS
Tools ›› Protection ›› Allow Users to Edit Ranges | Review | Allow Users to Edit Ranges | Alt+RU
Tools ›› Protection ›› Protect Workbook | Review | Protect Workbook | Alt+RPW
Tools ›› Protection ›› Protect and Share Workbook | Review | Protect Sharing | Alt+RO
Tools ›› Macro | View | Macros | Alt+F8 | Alt+WM
Tools ›› Add-Ins | Office Button | Excel Options | Alt+FIAA and Alt+G
Tools ›› AutoCorrect Options | Office Button | Excel Options | Alt+FIPP and Alt+A
Tools ›› Options | Office Button | Excel Options | Alt+FI

### Data Menu

| Data ›› Sort | Data | Sort or Home | Sort & Filter | Custom Sort | Alt+AS or Alt+HSU
| --- | --- | --- | --- | --- | ---
| Data ›› Filter | Data | Filter | Alt+AT
| Data ›› Filter | Data | Advanced | Alt+AQ
| Data ›› Form | Available only as a custom Form button added to Quick Access toolbar |
### Table 1-2 (continued)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Data ▮ Subtotals</td>
<td>Data ▮ Subtotal</td>
<td></td>
<td>Alt+AB</td>
</tr>
<tr>
<td>Data ▮ Validation</td>
<td>Data ▮ Data Validation</td>
<td></td>
<td>Alt+AVV</td>
</tr>
<tr>
<td>Data ▮ Table</td>
<td>Data ▮ What-If Analysis</td>
<td></td>
<td>Alt+AWT</td>
</tr>
<tr>
<td>Data ▮ Text to Columns</td>
<td></td>
<td></td>
<td>Alt+AE</td>
</tr>
<tr>
<td>Data ▮ Consolidate</td>
<td>Data ▮ Consolidate</td>
<td></td>
<td>Alt+AN</td>
</tr>
<tr>
<td>Data ▮ Group and Outline</td>
<td></td>
<td></td>
<td>Alt+AG/Alt+AU</td>
</tr>
<tr>
<td>Data ▮ Pivot Table and Pivot Chart Report</td>
<td>Insert ▮ Pivot Table ▮ Pivot Table/Pivot Chart</td>
<td></td>
<td>Alt+NVT/Alt+NVC</td>
</tr>
<tr>
<td>Data ▮ Import External Data</td>
<td>Data ▮ From Other Sources</td>
<td></td>
<td>Alt+AFO</td>
</tr>
</tbody>
</table>

### Window Menu

<table>
<thead>
<tr>
<th>Window ▮ New Window</th>
<th>View ▮ New Window</th>
<th>Alt+WN</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window ▮ Arrange</td>
<td>View ▮ Arrange</td>
<td>Alt+WA</td>
</tr>
<tr>
<td>Window ▮ Compare Side by Side</td>
<td>View ▮ View Side by Side (two-page icon in Window group)</td>
<td></td>
</tr>
<tr>
<td>Window ▮ Hide, Unhide</td>
<td>View ▮ Hide/Unhide</td>
<td>Alt+WU Alt+WH/</td>
</tr>
<tr>
<td>Window ▮ Split</td>
<td>View ▮ Split</td>
<td>Alt+WS</td>
</tr>
<tr>
<td>Window ▮ Freeze Panes</td>
<td>View ▮ Freeze Panes</td>
<td></td>
</tr>
</tbody>
</table>
For the most part, the pull-down menu commands listed in Table 1-2 are logically located. The ones that take the most getting used to are the Header and Footer and PivotTable/Chart commands that are located on the Insert tab rather than the View tab and Data tab as might be expected given they inhabited, respectively, the View and Data pull-down menus in earlier Excel versions. In addition, the worksheet background command ended up all by its lonesome on the Page Layout tab rather than going to the Home tab with all its fellow formatting commands.

Finding the Standard Toolbar buttons equivalents

If you’re like me, you came to rely heavily on the buttons of the Standard toolbar in doing all sorts of everyday tasks in earlier versions of Excel. Table 1-3 shows you the Excel 2007 equivalents for the buttons on the Standard toolbar in Excel 2003. As you can see from this table, most of these Standard toolbar buttons are regulated to one of the places in Excel 2007:

- **Office pull-down menu** activated by clicking the Office Button or pressing Alt+F (New, Open, Save, Print Preview)
- **Quick Access toolbar** (Save, Undo, and Redo)
- **Home tab** in the Clipboard group (Cut, Copy, Paste, and Format Painter) and Editing group (AutoSum, Sort Ascending, and Sort Descending)

<table>
<thead>
<tr>
<th>Table 1-3: Excel 2007 Equivalents for the Standard Toolbar Buttons in Excel 2003</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Toolbar button</strong></td>
</tr>
<tr>
<td>New</td>
</tr>
<tr>
<td>Open</td>
</tr>
<tr>
<td>Save</td>
</tr>
<tr>
<td>Permission</td>
</tr>
</tbody>
</table>

(continued)
### Table 1-3 (continued)

<table>
<thead>
<tr>
<th>Toolbar button</th>
<th>Excel 2007 Equivalent</th>
<th>Common Shortcut Keys</th>
<th>Excel 2007 Shortcut Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail</td>
<td>Office Button</td>
<td>Send</td>
<td>Email</td>
</tr>
<tr>
<td>Print</td>
<td>Quick Print button on Quick Access toolbar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Preview</td>
<td>Office Button</td>
<td>Print</td>
<td>Print Preview</td>
</tr>
<tr>
<td>Spelling</td>
<td>Review</td>
<td>Spelling</td>
<td>F7</td>
</tr>
<tr>
<td>Research</td>
<td>Review</td>
<td>Research</td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>Home</td>
<td>Cut (scissors icon in Clipboard group)</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Home</td>
<td>Copy (double-sheet icon in Clipboard group)</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Home</td>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Format Painter</td>
<td>Home</td>
<td>Format Painter (brush icon in Clipboard group)</td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undo button on Quick Access toolbar</td>
<td>Ctrl+Z</td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>Redo button on Quick Access toolbar</td>
<td>Ctrl+Y</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Toolbar button</th>
<th>Excel 2007 Equivalent</th>
<th>Common Shortcut Keys</th>
<th>Excel 2007 Shortcut Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Ink Annotations</td>
<td>Review</td>
<td>Start Inking</td>
<td></td>
</tr>
<tr>
<td>Insert Hyperlink</td>
<td>Insert</td>
<td>Hyperlink</td>
<td>Ctrl+K</td>
</tr>
<tr>
<td>AutoSum</td>
<td>Home</td>
<td>Sum (( \Sigma ) icon)</td>
<td>Alt+HU</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Home</td>
<td>Sort &amp; Filter</td>
<td>Sort A to Z</td>
</tr>
</tbody>
</table>
### Toolbar button equivalents

<table>
<thead>
<tr>
<th>Toolbar button</th>
<th>Excel 2007 Equivalent</th>
<th>Common Shortcut Keys</th>
<th>Excel 2007 Shortcut Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort Descending</td>
<td>Home</td>
<td>Sort &amp; Filter</td>
<td>Sort Z to A</td>
</tr>
<tr>
<td>ChartWizard</td>
<td>Not available except as specific chart type command buttons in the Charts group on the Insert tab</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drawing</td>
<td>Not available except as command buttons in the Shapes, Illustrations, and Text groups on the Insert tab and as custom buttons added to Quick Access toolbar</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom</td>
<td>View</td>
<td>View</td>
<td>Alt+WQ</td>
</tr>
<tr>
<td>Microsoft Excel Help</td>
<td>Microsoft Office Excel Help button to the right of the Ribbon tabs</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Because Excel 2007 supports only a single toolbar, the Quick Access toolbar, the Drawing toolbar disappears completely from Excel 2007 and thus the Drawing button on the Standard toolbar has no equivalent. Most of its main features, including Clip Art, inserting graphics files, and creating diagrams and WordArt are now found on the Insert tab. Also, keep in mind that Excel 2007 doesn’t have an equivalent to the ChartWizard button on the Standard toolbar because you can create a chart in a split-second by clicking the Column, Line, Pie, Bar, Area, XY (Scatter), or Other Charts command buttons on the Insert tab (see Chapter 8).

### Finding the Formatting Toolbar buttons equivalents

Finding the Excel 2007 equivalents for the buttons on the Formatting toolbar in earlier versions of Excel couldn’t be easier: Every one of the buttons on the Formatting toolbar is prominently displayed on the Home tab of the Excel 2007 toolbar.
Ribbon. They’re all easy to identify as they use the same icons as before and are located in the Font, Alignment, or Number group on the Home tab (refer to Figure 1-3).

In addition to the Font, Font Size, Bold, Italic, Underline, Borders, Fill Color, and Font Color buttons from the Formatting toolbar, the Font group also contains the following two buttons:

- **Increase Font** button that bumps up the current font size a point
- **Decrease Font** button that reduces the current font size by a point

In addition to the Left Align, Center, Right Align, Decrease Indent, Increase Indent, and Merge and Center buttons, the Alignment group also contains the following buttons:

- **Top Align** button that vertically aligns the data entered into the current cell selection with the top edge of the cell
- **Middle Align** button that vertically centers the data entered into the current cell selection
- **Bottom Align** button that aligns the data entered in the current cell selection with the bottom edge of the cell
- **Orientation** button that opens a pop-menu of orientation options that enable you to change the direction of the text entered into the current cell selection by angling it up or down, converting it to vertical text, rotating it up or down as well as opening the Alignment tab of the Format Cells dialog box
- **Wrap Text** button that applies the wrap text function to the current cell selection so that Excel expands the row heights as needed to fit all of its text within the current column widths

In addition to the Percent Style, Comma, Increase Decimal, and Decrease Decimal buttons from the Formatting toolbar, the Numbers group contains the following buttons:

- **Accounting Number Format** button that enables you to select among several different currency formats from U.S. dollars to Swiss Francs as well as to open the Number tab of the Format Cells dialog box with the Accounting number format selected
- **Number Format** button that opens a pop-up menu of different number options from General through Text as well as opens the Number tab in the Format Cells dialog box when you select its More Number Formats option
**Putting the Quick Access toolbar to excellent use**

Figure 1-10 shows you the Excel 2007 program window with the Ribbon minimized and a completely customized Quick Access toolbar that’s moved down so that it appears under the tabs and immediately above the Formula bar. This completely custom version of Quick Access toolbar should seem very familiar to you: It contains every button from the Standard and Formatting toolbar in Excel 2003 with the exception of the Permission, Zoom and Help buttons in the original order in which they appear on their respective toolbars. The Permission button is so esoteric and seldom used that I didn’t bother to add it and neither the Zoom button nor the Help button is really needed as the Zoom slider that enables you to quickly select a new screen magnification percentage is always displayed in the lower-right corner of the Excel 2007 Status bar and the Help button is always displayed on the right side of the bar containing the Ribbon tabs.
To customize your Quick Access toolbar so that it matches the one shown in Figure 1-10 with every button from the Standard and Formatting toolbars except the Permission, Zoom, and Help buttons, follow these steps:

1. **Click the Customize Quick Access Toolbar button at the end of the Quick Access toolbar and then click the Show Below the Ribbon option.**
   
   When filling the Quick Access toolbar with buttons, you need to place the bar beneath the Ribbon so that it won’t crowd out name of the current workbook file.

2. **Click the Customize Quick Access Toolbar button again and this time click the More Commands option.**
   
   Excel opens the Excel Options dialog box with the Customize tab selected. The Customize Quick Access Toolbar list box on the right side of this dialog box shows all three of the default buttons in the order in which they now appear on the toolbar.

3. **Click the New option in the Popular Commands list followed by the Add button.**
   
   Excel adds the New command button at the end of the toolbar indicated by the appearance of the New button at the bottom of the list in the Customize Quick Access Toolbar list box on the right.

4. **Click the Move Up button (with the triangle pointing upward) three times to move the New button to the top of the Customize Quick Access Toolbar list box and the first position on the Quick Access toolbar.**
   
   Note that the New button is now in front of the Save button on the toolbar.

5. **Click the Open option in the Popular Commands list box on the left and then click the Add button.**
   
   Excel inserts the Open button in the Customize Quick Access Toolbar list box in between the New and Save button, which is exactly where it appears on the Standard toolbar.

6. **Click the Save button in the Customize Quick Access Toolbar list box on the right to select this button. Then, click the Quick Print option in the Popular Commands list box on the left and click the Add button.**
   
   Excel inserts the Quick Print button after the Save button.

7. **Click the Print Preview button near the bottom of the Popular Commands list box and then click the Add button.**
   
   Excel inserts the Print Preview button after the Quick Print button in the Customize Quick Access Toolbar list box.

Now, you need to add the Spelling and Research buttons. They are located on the Review tab in Excel 2007. Before you can add their buttons to the Quick Access toolbar, you need to replace Popular Commands with Review Tab by selecting this option on the Choose Commands From drop-down list.
8. Click the Choose Commands From drop-down button and then click Review Tab in the drop-down list.

   Excel now displays all the command buttons on the Review tab of the Ribbon in the list box below.

9. Add the Spelling and Research buttons from the Review Tab list box to the Customize Quick Access Toolbar list box and position them so that they appear one after the other following the Print Preview button.

   Next you need to add the Cut, Copy, Paste, and Format Painter buttons to the Quick Access toolbar. These command buttons are on the Home tab.

10. Click the Home Tab option in the Choose Commands From drop-down list and then add the Cut, Copy, Paste, and Format Painter buttons to the Customize Quick Access Toolbar in this order in front of the Undo button.

   Note when adding the Paste button that Choose Commands From displays two Paste buttons. The first is the regular Paste button that was on the Standard toolbar. The second is a Paste button with a drop-down button that, when clicked, opens a drop-down menu with all the special Paste options. You can add either one, although the second Paste button with the drop-down menu is much more versatile.

11. Click the Format Painter option in the Insert Tab list box and then click the Add button.

   Excel adds the Format Painter button after the Paste button in the Customize Quick Access Toolbar list box on the right.

12. Click the Redo button in the Customize Quick Access Toolbar list box to select its icon and then click the Insert Tab on the Choose Commands From drop-down list and add the Insert Hyperlink button from to the Quick Access toolbar.

13. Add the remaining Standard toolbar buttons, AutoSum, Sort Ascending, Sort Descending, and Create Chart, to the Quick Access toolbar.

   The AutoSum, Sort Ascending, and Sort Descending buttons are available in the Home Tab and the Create Chart button (the closest thing to the Chart Wizard in Excel 2007) is on the Insert Tab list box.

14. Add the buttons on the Formatting toolbar to the Quick Access toolbar in the order in which they appear.

   The Formatting toolbar contains these tools all found on the Home tab:

   - Font
   - Font Size
   - Bold
   - Italic
15. Click the OK button to close the Excel Options dialog box and return to the Excel program window.

Your Quick Access toolbar should now have the same buttons as the one shown in Figure 1-10.

After adding all the buttons on the Standard and the Formatting toolbar (with the exception of the Permission button that almost nobody uses, the Drawing button that has no equivalent in Excel 2007, and the Zoom and Help buttons that are always available in the Excel 2007 program window), the Quick Access toolbar fills the entire width of the screen on many monitors. Keep in mind that if you need to add extra buttons that can no longer be displayed on the single row above the Formula bar, Excel automatically adds a More Controls button to the end of the Quick Access toolbar. You then click this More Controls button to display a pop-up menu containing all the buttons that can no longer be displayed on the toolbar.

To add vertical bar separators to divide the buttons into groups as you see in the original Standard and Formatting toolbars and shown in Figure 1-8, click the <Separator> option located at the top of each Choose Commands From list box followed by the Add button.
Getting good to go with Excel 2007

The version of the Excel 2007 program window shown in Figure 1-10 with the Ribbon minimized to just tabs and the Quick Access toolbar displayed above the Formula bar with all but a few of the buttons from the Standard and Formatting toolbars is as close as I can get you to any sort of Excel 2003 Classic mode.

Combine this simplified screen layout with the common shortcut keys (see Table 1-2) that you already know and you should be pretty much good to go with Excel 2007. Of course, you need to keep in mind that in the course of using the program, the Ribbon can’t always stay reduced to just its tabs. As you find out as you explore the features covered in the remaining chapters of this book, there’ll be times when you need the tools (especially in the form of those fantastic galleries) that a particular tab has to offer.

The only other issues that should be of any concern to you right now are the new Excel 2007 file formats and running all those Excel macros on which you’ve come to rely.

Dealing with the new Excel file formats

Yes, it’s true that Excel 2007 introduces yet another new native file format in which to save its workbook files (although Microsoft insists that this one is a truly “open” XML file format and not at all proprietary like all the previous ones).

Fortunately, Excel 2007 has no trouble opening any workbook files saved in the good old .XLS file format used by versions 97 through 2003. More importantly, the program automatically saves all editing changes you make to these files in this original file format.

This means you don’t have a worry in the world when it comes to making simple edits to existing spreadsheets with Excel 2007. Simply, open the workbook file and then make all the necessary changes. When you finish, click the Save button on the Quick Access toolbar to save your changes in the good old .XLS file format that everybody in the office who is still using a previous version of Excel can still open, edit, and print. Excel also warns you should you ever add a new 2007 element to the existing workbook that’s not supported by its earlier versions.

The challenge comes when you need to use Excel 2007 to create a brand new spreadsheet. The program automatically wants to save all new workbooks in its fancy new .XLSX file format (see Chapter 2 for a complete rundown on this new workbook file format and the pros and cons of using it). If you don’t want to save your workbook in this format, you need to remember to click the Save as Type drop-down button and then click the Excel 97-2003 Workbook (*.xls) option on its drop-down menu before you click Save.
If you’re working an office environment where all the workbooks you produce with Excel 2007 must be saved in the old 97-2003 file format for compatibility sake, you can change the program’s default Save setting so that the program always saves all new workbooks in the old file format. To do this, open the Save tab of the Excel Options dialog box (Office Button | Excel Options or Alt+FIS) and then click Excel 97-2003 Workbook in the Save Files in This Format drop-down list box before you click OK.

**Using your macros**

The good news is that Excel 2007 supports the creating and running of macros, using the same Microsoft Visual Basic for Applications of earlier versions. It even enables you to edit these macros in a version of VBA Editor, if you’re sufficiently skilled to do so.

The biggest problem with macros comes about if you have a tendency, like I do, to map your global macros (the ones you save in the PERSONAL.XLSB workbook so that they’re available when working in any Excel workbook) onto custom pull-down menus and toolbars. Because Excel 2007 retains only the single pull-down File menu and Quick Access toolbar, none of the custom menus and toolbars to which you’ve assigned macros comes over to Excel 2007. This means, that although the macros are still a part of their respective workbooks and continue to run, you must now run all macros either using keyboard shortcuts you assigned to them or via the Macro dialog box (click View | Macros | View Macros or press Alt+WMV or Alt+F8).

You can assign macros to buttons on the Quick Access toolbar and then run them by clicking their buttons. The only problem is that all macros you assign to this toolbar use the same generic macro button icon so that the only way to differentiate the macros is through the ToolTip that appears when you position the mouse over the macro button.

To assign a macro to a generic macro on the Quick Access toolbar, open the Customize tab of the Excel Options dialog box (Office Button | Excel Options or Alt+FIC) and then select Macros in the Choose Commands From drop-down list box. Excel then displays the names of all the macros in the current workbook (including all global macros saved in the PERSONAL.XLSB workbook) in the Choose Commands From list box. To assign a macro to a macro button, click its name in this list box and then click the Add button. You can then move the macro button to the desired position on the Quick Access toolbar with the Move Up and Move Down buttons and, if you so desire, make it part of a separate section on the toolbar by adding a <Separator> before and after its button.
Chapter 2

Creating a Spreadsheet from Scratch

In This Chapter

► Starting a new workbook
► Entering the three different types of data in a worksheet
► Creating simple formulas by hand
► Fixing your data-entry boo-boos
► Using the AutoCorrect feature
► Using the AutoFill feature to complete a series of entries
► Entering and editing formulas containing built-in functions
► Totaling columns and rows of numbers with the AutoSum button
► Saving your precious work and recovering workbooks after a computer crash

After you know how to launch Excel 2007, it’s time to find out how not to get yourself into trouble when actually using it! In this chapter, you find out how to put all kinds of information into all those little, blank worksheet cells I describe in Chapter 1. Here you find out about the Excel AutoCorrect and AutoComplete features and how they can help cut down on errors and speed up your work. You also get some basic pointers on other smart ways to minimize the drudgery of data entry, such as filling out a series of entries with the AutoFill feature and entering the same thing in a bunch of cells all at the same time.

And after discovering how to fill up a worksheet with all this raw data, you find out what has to be the most important lesson of all — how to save all that information on disk so that you don’t ever have to enter the stuff again!
So What Ya Gonna Put in That New Workbook of Yours?

When you start Excel without specifying a document to open — which is what happens when you start the program from the Windows Vista or XP Start menu (refer to Chapter 1) — you get a blank workbook in a new workbook window. This workbook, temporarily named Book1, contains three blank worksheets (Sheet1, Sheet2, and Sheet3). To begin to work on a new spreadsheet, you simply start entering information in the first sheet of the Book1 workbook window.

The ins and outs of data entry

Here are a few simple guidelines (a kind of data-entry etiquette, if you will) that you should keep in mind when you start creating a spreadsheet in Sheet1 of your new workbook:

✔ Whenever you can, organize your information in tables of data that use adjacent (neighboring) columns and rows. Start the tables in the upper-left corner of the worksheet and work your way down the sheet, rather than across the sheet, whenever possible. When it’s practical, separate each table by no more than a single column or row.

✔ When you set up these tables, don’t skip columns and rows just to “space out” the information. In Chapter 3, you see how to place as much white space as you want between information in adjacent columns and rows by widening columns, heightening rows, and changing the alignment.

✔ Reserve a single column at the left edge of the table for the table’s row headings.

✔ Reserve a single row at the top of the table for the table’s column headings.

✔ If your table requires a title, put the title in the row above the column headings. Put the title in the same column as the row headings. You can get information on how to center this title across the columns of the entire table in Chapter 3.

In Chapter 1, I make a really big deal about how big each of the worksheets in a workbook is. You may wonder why I’m now on your case about not using that space to spread out the data that you enter into it. After all, given all the real estate that comes with each and every Excel worksheet, you’d think conserving space would be one of the last things you’d have to worry about.
And you’d be 100 percent correct . . . except for one little, itty-bitty thing: Space conservation in the worksheet equals memory conservation. You see, as a table of data grows and expands into columns and rows in new areas of the worksheet, Excel decides that it had better reserve a certain amount of computer memory and hold it open just in case you might go crazy and fill that area full of cell entries. This means that if you skip columns and rows that you really don’t need to skip (just to cut down on all that cluttered data), you end up wasting computer memory that could otherwise be used to store more information in the worksheet.

**You must remember this . . .**

So now you know: It’s the amount of computer memory available to Excel that determines the ultimate size of the spreadsheet you can build, not the total number of cells in the worksheets of your workbook. When you run out of memory, you’ve effectively run out of space — no matter how many columns and rows are still left to fill. To maximize the information you can get into a single worksheet, always adopt the “covered wagon” approach to worksheet design by keeping your data close together.

**Doing the Data-Entry Thing**

Begin by reciting (in unison) the basic rule of worksheet data entry. All together now:

**To enter data in a worksheet, position the cell pointer in the cell where you want the data, and then begin typing the entry.**

Note that before you can position the cell pointer in the cell where you want the entry, Excel must be in Ready mode (look for Ready as the Program indicator at the beginning of the Status bar). When you start typing the entry, however, Excel goes through a mode change from Ready to Enter mode (and *Enter* replaces *Ready* as the Program indicator).

If you’re not in Ready mode, try pressing Esc.

As soon as you begin typing in Enter mode, the characters that you type in a cell in the worksheet area simultaneously appear on the formula bar near the top of the screen. Starting to type something that’s ultimately destined to go into the current cell also triggers a change to the Formula bar because two new boxes, Cancel and Enter, appear in between the Name Box drop-down button and the Function Wizard button.
As you continue to type, Excel displays your progress both on the formula bar and in the active cell in the worksheet (see Figure 2-1). However, the insertion point (the flashing vertical bar that acts as your cursor) is displayed only at the end of the characters displayed in the cell.

After you finish typing your cell entry, you still have to get it into the cell so that it stays put. When you do this, you also change the program from Enter mode back to Ready mode so that you can move the cell pointer to another cell and, perhaps, enter or edit the data there.

**Figure 2-1:** What you type appears both in the current cell and on the Formula bar.
To complete your cell entry and, at the same time, get Excel out of Enter mode and back into Ready mode, you can click the Enter box on the Formula bar, press the Enter key, or press one of the arrow keys (↓, ↑, →, or ←) to move to another cell. You can also press the Tab or Shift+Tab keys to complete a cell entry.

Now, even though each of these alternatives gets your text into the cell, each does something a little different afterward, so please take note:

- If you click the Enter box (the one with the check mark) on the Formula bar, the text goes into the cell, and the cell pointer just stays in the cell containing the brand-new entry.
- If you press the Enter key on your keyboard, the text goes into the cell, and the cell pointer moves down to the cell below in the next row.
- If you press one of the arrow keys, the text goes into the cell, and the cell pointer moves to the next cell in the direction of the arrow. Press ↓, and the cell pointer moves below in the next row just as when you finish off a cell entry with the Enter key. Press → to move the cell pointer right to the cell in the next column; press ← to move the cell pointer left to the cell in the previous column; and or press ↑ to move the cell pointer up to the cell in the next row above.
- If you press Tab, the text goes into the cell, and the cell pointer moves to the adjacent cell in the column on the immediate right (the same as pressing the → key). If you press Shift+Tab, the cell pointer moves to the adjacent cell in the column on the immediate left (the same as pressing the ← key) after putting in the text.

No matter which of the methods you choose when putting an entry in its place, as soon as you complete your entry in the current cell, Excel deactivates the Formula bar by removing the Cancel and Enter boxes. Thereafter, the data you entered continues to appear in the cell in the worksheet (with certain exceptions that I discuss later in this chapter), and every time you put the cell pointer into that cell, the data will reappear on the Formula bar as well.

If, while still typing an entry or after finishing typing but prior to completing the entry, you realize that you’re just about to stick it in the wrong cell, you can clear and deactivate the Formula bar by clicking the Cancel box (the one with the X in it) or by pressing Esc. If, however, you don’t realize that you had the wrong cell current until after you’ve entered your data there, you have to either move the entry to the correct cell (something you find out how to do in Chapter 4) or delete the entry (see Chapter 4) and then reenter the data in the correct cell.
It Takes All Types

Unbeknownst to you as you go about happily entering data in your spreadsheet, Excel constantly analyzes the stuff you type and classifies it into one of three possible data types: a piece of text, a value, or a formula.

If Excel finds that the entry is a formula, the program automatically calculates the formula and displays the computed result in the worksheet cell (you continue to see the formula itself, however, on the Formula bar). If Excel is satisfied that the entry does not qualify as a formula (I give you the qualifications for an honest-to-goodness formula a little later in this chapter), the program then determines whether the entry should be classified as text or as a value.

Excel makes this distinction between text and values so that it knows how to align the entry in the worksheet. It aligns text entries with the left edge of the cell and values with the right edge. Also, because most formulas work properly only when they are fed values, by differentiating text from values, the program knows which will and will not work in the formulas that you build. Suffice to say that you can foul up your formulas but good if they refer to any cells containing text where Excel expects values to be.

The telltale signs of text

A text entry is simply an entry that Excel can’t pigeonhole as either a formula or value. This makes text the catchall category of Excel data types. As a practical rule, most text entries (also known as labels) are a combination of letters and punctuation or letters and numbers. Text is used mostly for titles, headings, and notes in the worksheet.

You can tell right away whether Excel has accepted a cell entry as text because text entries are automatically aligned at the left edge of their cells. If the text entry is wider than the cell can display, the data spills over into the neighboring cell or cells on the right, as long as those cells remain blank (see Figure 2-2).

To Excel, text is nothing but a big zero

Use the AutoCalculate indicator to prove to yourself that Excel gives all text entries the value of 0 (zero). As an example, enter the number 10 in one cell and then some stupid piece of text, such as Excel is like a box of chocolates, in the cell directly below. Then drag up so that both cells (the one with 10 and the one with the text) are highlighted. Take a gander at the AutoCalculate indicator on the Status bar, and you see that it reads Average: 10, Count: 2, and Sum: 10, proving that the text adds nothing to the total value of these two cells.
If, sometime later, you enter information in a cell that contains spillover text from a cell to its left, Excel cuts off the spillover of the long text entry (see Figure 2-3). Not to worry: Excel doesn’t actually lop these characters off the cell entry — it simply shaves the display to make room for the new entry. To redisplay the seemingly missing portion of the long text entry, you have to widen the column that contains the cell where the text is entered. (To find out how to do this, skip ahead to Chapter 3.)
How Excel evaluates its values

Values are the building blocks of most of the formulas that you create in Excel. As such, values come in two flavors: numbers that represent quantities (14 stores or $140,000 dollars) and numbers that represent dates (July 30, 1995) or times (2 pm).

You can tell whether Excel has accepted your entry as a value because values are aligned at the right edge of their cells. If the value that you enter is wider than the column containing the cell can display, Excel automatically converts the value to (of all things) scientific notation. For example, 6E+08 indicates that the 6 is followed by eight zeros for a grand total of 600 million! To restore a value that’s been converted into that weird scientific notation stuff back to a regular number, simply widen the column for that cell. (Read how in Chapter 3.)

Making sure that Excel’s got your number

When building a new worksheet, you’ll probably spend a lot of your time entering numbers, representing all types of quantities from money that you made (or lost) to the percentage of the office budget that went to coffee and donuts. (You mean you don’t get donuts?)

To enter a numeric value that represents a positive quantity, like the amount of money you made last year, just select a cell, type the numbers — for example, 459600 — and complete the entry in the cell by clicking the Enter box, pressing the Enter key, and so on. To enter a numeric value that represents a negative quantity, like the amount of money the office spent on coffee and donuts last year, begin the entry with the minus sign or hyphen (–) before typing the numbers — for example, –175 (that’s not too much to spend on coffee and donuts when you just made $459,600) — and then complete the entry.

If you’re trained in accounting, you can enclose the negative number (that’s expense to you) in parentheses. You’d enter it like this: (175). Just note that if you go to all the trouble to use parentheses for your negatives (expenses), Excel goes ahead and automatically converts the number so that it begins with a minus sign; if you enter (175) in the Coffee and Donut expense cell, Excel spits back –175. (Relax, you can find out how to get your beloved parentheses back for the expenses in your spreadsheet in Chapter 3.)

With numeric values that represent dollar amounts, like the amount of money you made last year, you can include dollar signs ($) and commas (,) just as they appear in the printed or handwritten numbers you’re working from. Just be aware that when you enter a number with commas, Excel assigns a number format to the value that matches your use of commas. (For more information on number formats and how they are used, see Chapter 3.)

Likewise, when you preface a financial figure with a dollar sign, Excel assigns an appropriate dollar-number format to the value (one that automatically inserts commas between the thousands).
When entering numeric values with decimal places, use the period as the
decimal point. When you enter decimal values, the program automatically
adds a zero before the decimal point (Excel inserts 0.34 in a cell when you
enter .34) and drops trailing zeros entered after the decimal point (Excel
inserts 12.5 in a cell when you enter 12.50).

If you don’t know the decimal equivalent for a value that contains a fraction,
you can just go ahead and enter the value with its fraction. For example, if
you don’t know that 2.1875 is the decimal equivalent for 2\(\frac{3}{16}\), just type 2\(\frac{3}{16}\)
(making sure to add a space between the 2 and 3) in the cell. After complet-
ing the entry, when you put the cell pointer in that cell, you see 2\(\frac{3}{16}\) in the cell
of the worksheet, but 2.1875 appears on the formula bar. As you see in
Chapter 3, it’s then a simple trick to format the display of 2\(\frac{3}{16}\) in the
cell so that it matches the 2.1875 on the Formula bar.

If you need to enter simple fractions, such as \(\frac{3}{4}\) or \(\frac{5}{8}\), you must enter them
as a mixed number preceded by zero; for example, enter 0\(\frac{3}{4}\) or 0\(\frac{5}{8}\) (be sure
to include a space between the zero and the fraction). Otherwise, Excel
gets mixed up and thinks that you’re entering the dates March 4 (3/4) and
May 8 (5/8).

When entering in a cell a numeric value that represents a percentage (so
much out of a hundred), you have this choice:

✔ You can either divide the number by 100 and enter the decimal equiva-
   lent (by moving the decimal point two places to the left like your teacher
taught you; for example, enter .12 for 12 percent).

✔ You can enter the number with the percent sign (for example, enter 12%)

Either way, Excel stores the decimal value in the cell (0.12 in this example).
If you use the percent sign, Excel assigns a percentage-number format to the
value in the worksheet so that it appears as 12%.

**How to fix your decimal places (when you don’t even know they’re broken)**

If you find that you need to enter a whole slew of numbers that use the same
number of decimal places, you can turn on Excel’s Fixed Decimal setting and
have the program enter the decimals for you. This feature really comes in
handy when you have to enter hundreds of financial figures that all use two
decimal places (for example, for the number of cents).

To fix the number of decimal places in a numeric entry, follow these steps:

1. **Click Office Button** | **Excel Options** | **Advanced** or press Alt+FIA.

   The Advanced tab of the Excel Options dialog box opens.
2. **Click the Automatically Insert a Decimal Point check box in the Editing Options section to fill it with a check mark.**

   By default, Excel fixes the decimal place two places to the left of the last number you type. To change the default Places setting, go to Step 3; otherwise move to Step 4.

3. **(Optional) Type a new number in the Places text box or use the spinner buttons to change the value.**

   For example, you could change the Places setting to 3 to enter numbers with the following decimal placement: 00.000.

4. **Click OK or press Enter.**

   Excel displays the Fixed Decimal status indicator on the Status bar to let you know that the Fixed Decimal feature is now active.

After fixing the decimal place in numeric values, Excel automatically adds a decimal point to any numeric value that you enter using the number of places you selected — all you do is type the digits and complete the entry in the cell. For example, to enter the numeric value 100.99 in a cell after fixing the decimal point to two places, type the digits **10099** without adding any period for a decimal point. When you complete the cell entry, Excel automatically inserts a decimal point two places from the right in the number you typed, leaving 100.99 in the cell.

When you’re ready to return to normal data entry for numerical values (where you enter any decimal points yourself), open the Advanced tab of the Excel Options dialog box (Alt+FIA) and then click the Fixed Decimal check box again, this time to clear it, and then click OK or press Enter. Excel removes the Fixed Decimal indicator from the Status bar.

---

**Don’t get in a fix over your decimal places!**

While the Fixed Decimal setting is turned on, Excel adds a decimal point to all the numeric values that you enter. However, if you want to enter a number without a decimal point, or one with a decimal point in a position different from the one called for by this feature, you have to remember to type the decimal point (period) yourself. For example, to enter the number 1099 instead of 10.99 when the decimal point is fixed at two places, type **1099** followed immediately by a period (.) in the cell.

And, for heaven’s sake, please don’t forget to turn off the Fixed Decimal feature before you start work on another worksheet or exit Excel. Otherwise, when you intend to enter values, such as 20, you’ll end up with 0.2 instead, and you won’t have a clue what’s going on!
Tapping on the old ten-key

You can make the Fixed Decimal feature work even better by selecting the block of the cells where you want to enter the numbers (see “Entries all around the block,” later in this chapter) and then pressing Num Lock so that you can do all the data entry for this cell selection from the numeric keypad (à la ten-key adding machine).

Using this approach, all you have to do to enter the range of values in each cell is type the number’s digits and press Enter on the numeric keypad — Excel inserts the decimal point in the proper place as it moves the cell pointer down to the next cell. Even better, when you finish entering the last value in a column, pressing Enter automatically moves the cell pointer to the cell at the top of the next column in the selection.

Look at Figures 2-4 and 2-5 to see how you can make the ten-key method work for you. In Figure 2-4, the Fixed Decimal feature is turned on (using the default of two decimal places), and the block of cells from B3 through D9 are selected. You also see that six entries have already been made in cells B3 through B8 and a seventh, 30834.63, is about to be completed in cell B9. To make this entry when the Fixed Decimal feature is turned on, you simply type 3083463 from the numeric keypad.

In Figure 2-5, check out what happens when you press Enter (either on the regular keyboard or the numeric keypad). Not only does Excel automatically add the decimal point to the value in cell B9, but it also moves the cell pointer up and over to cell C3 where you can continue entering the values for this column.
Entering dates with no debate

At first look, it may strike you as a bit odd that dates and times are entered as values in the cells of a worksheet rather than as text. The reason for this is simple, really: Dates and times entered as values can be used in formula calculations, whereas dates and times entered as text cannot. For example, if you enter two dates as values, you can then set up a formula that subtracts the more recent date from the older date and returns the number of days between them. This kind of thing just couldn’t happen if you were to enter the two dates as text entries.

Excel determines whether the date or time that you type is entered as a value or as text by the format you follow. If you follow one of Excel’s built-in date and time formats, the program recognizes the date or time as a value. If you don’t follow one of the built-in formats, the program enters the date or time as a text entry — it’s as simple as that.

Excel recognizes the following time formats:

- 3 AM or 3 PM
- 3 A or 3 P (upper- or lowercase a or p — Excel inserts 3:00 AM or 3:00 PM)
- 3:21 AM or 3:21 PM (upper- or lowercase am or pm)
- 3:21:04 AM or 3:21:04 PM (upper- or lowercase am or pm)
- 15:21
- 15:21:04
Excel isn’t fussy so that you can enter the AM or PM designation in the date in any case — all upper- or lowercase letters or even a mix of the two.

Excel knows the following date formats. (Note that month abbreviations always use the first three letters of the name of the month: Jan, Feb, Mar, and so forth.)

- November 6, 2008 or November 6, 08 (appear in cell as 6-Nov-08)
- 11/6/08 or 11-6-08 (appear in cell as 11/6/2008)
- 6-Nov-08 or 6/Nov/08 or even 6Nov08 (all appear in cell as 6-Nov-08)
- 11/6 or 6-Nov or 6/Nov or 6Nov (all appear in cell as 6-Nov)
- Nov-06 or Nov/06 or Nov06 (all appear in cell as 6-Nov)

**Make it a date in the 21st Century**

Contrary to what you might think, when entering dates in the 21st Century, you need to enter only the last two digits of the year. So, for example, to enter the date January 6, 2008, in a worksheet, I enter 1/6/08 in the target cell. Likewise, to put the date February 15, 2010, in a worksheet, I enter 2/15/10 in the target cell.

Note that this system of having to put in only the last two digits of dates in the 21st Century works only for dates in the first three decades of the new century (2000 through 2029). To enter dates for the years 2030 on, you need to input all four digits of the year.

This also means, however, that to put in dates in the first three decades of the 20th Century (1900 through 1929), you must enter all four digits of the year. For example, to put in the date July 21, 1925, you have to enter 7/21/1925 in the target cell. Otherwise, if you enter just the last two digits (25) for the year part of the date, Excel enters a date for the year 2025 and not 1925!

**The dating game**

Dates are stored as serial numbers that indicate how many days have elapsed from a particular starting date; times are stored as decimal fractions indicating the elapsed part of the 24-hour period. Excel supports two date systems: the 1900 date system used by Excel in Windows, where January 1, 1900 is the starting date (serial number 1) and the 1904 system used by Excel for the Macintosh, where January 2, 1904 is the starting date.

If you ever get a hold of a workbook created with Excel for the Macintosh that contains dates that seem all screwed up when you open the file, you can rectify this problem by opening the Advanced tab of the Excel Options dialog box (Office Button | Excel Options | Advanced or Alt+F1A), and then clicking the Use 1904 Date System check box in the When Calculating This Workbook section before you click OK.
Excel 2007 always displays all four digits of the year in the cell and on the Formula bar even when you only enter the last two. So, for example, if you enter 11/06/08 in a cell, Excel automatically displays 11/06/2008 in the worksheet cell (and on the Formula bar when that cell is current).

Therefore, by looking at the Formula bar, you can always tell when you’ve entered a 20th rather than a 21st Century date in a cell even if you can’t keep straight the rules for when to enter just the last two digits rather than all four. (Read through Chapter 3 for information on how to format your date entries so that only the last digits are displayed in the worksheet.)

For information on how to perform simple arithmetic operations between the dates and time you enter in a worksheet and have the results make sense, see the information about dates in Chapter 3.

**Fabricating those fabulous formulas!**

As entries go in Excel, formulas are the real workhorses of the worksheet. If you set up a formula properly, it computes the right answer when you first enter it into a cell. From then on, it keeps itself up to date, recalculating the results whenever you change any of the values that the formula uses.

You let Excel know that you’re about to enter a formula (rather than some text or a value), in the current cell by starting the formula with the equal sign (=). Most simple formulas follow the equal sign with a built-in function such as SUM or AVERAGE. (See the section “Inserting a function into a formula with the Function Wizard button,” later in this chapter, for more information on using functions in formulas.) Other simple formulas use a series of values or cell references that contain values separated by one or more of the following mathematical operators:

+ (plus sign) for addition
- (minus sign or hyphen) for subtraction
* (asterisk) for multiplication
/ (slash) for division
^ (caret) for raising a number to an exponential power

For example, to create a formula in cell C2 that multiplies a value entered in cell A2 by a value in cell B2, enter the following formula in cell C2: =A2*B2.
To enter this formula in cell C2, follow these steps:

1. Select cell C2.
2. Type the entire formula =A2*B2 in the cell.
3. Press Enter.

Or

1. Select Cell C2.
2. Type = (equal sign).
3. Select cell A2 in the worksheet by using the mouse or the keyboard.
   This action places the cell reference A2 in the formula in the cell (as shown in Figure 2-6).
4. Type * (Shift+8 on the top row of the keyboard).
   The asterisk is used for multiplication rather than the x symbol you used in school.
5. Select cell B2 in the worksheet by using the mouse or the keyboard.
   This action places the cell reference B2 in the formula (as shown in Figure 2-7).
6. Click the Enter box to complete the formula entry, while at the same time keeping the cell pointer in cell C2.
   Excel displays the calculated answer in cell C2 and the formula =A2*B2 in the Formula bar (as shown in Figure 2-8).

Figure 2-6: To start the formula, type = and then select cell A2.
When you finish entering the formula \(=A2*B2\) in cell C2 of the worksheet, Excel displays the calculated result, depending on the values currently entered in cells A2 and B2. The major strength of the electronic spreadsheet is the capability of formulas to automatically change their calculated results to match changes in the cells referenced by the formulas.
Now comes the fun part: After creating a formula like the preceding one that refers to the values in certain cells (rather than containing those values itself), you can change the values in those cells, and Excel automatically recalculates the formula, using these new values and displaying the updated answer in the worksheet! Using the example shown in Figure 2-8, suppose that you change the value in cell B2 from 100 to 50. The moment that you complete this change in cell B2, Excel recalculates the formula and displays the new answer, 1000, in cell C2.

If you want it, just point it out

The method of selecting the cells you use in a formula, rather than typing their cell references, is known as pointing. Pointing is not only quicker than typing cell references, it also reduces the risk that you might type the wrong cell reference. When you type a cell reference, you can easily type the wrong column letter or row number and not realize your mistake just by looking at the calculated result returned in the cell.

If you select the cell you want to use in a formula, either by clicking it or moving the cell pointer to it, you have less chance of entering the wrong cell reference.

Altering the natural order of operations

Many formulas that you create perform more than one mathematical operation. Excel performs each operation, moving from left to right, according to a strict pecking order (the natural order of arithmetic operations). In this order, multiplication and division pull more weight than addition and subtraction and, therefore, are performed first, even if these operations don’t come first in the formula (when reading from left to right).

Consider the series of operations in the following formula:

=\( A2 + B2 \times C2 \)

If cell A2 contains the number 5, B2 contains the number 10, and C2 contains the number 2, Excel evaluates the following formula:

=\( 5 + 10 \times 2 \)

In this formula, Excel multiplies 10 times 2 to equal 20 and then adds this result to 5 to produce the result 25.
If you want Excel to perform the addition between the values in cells A2 and B2 before the program multiplies the result by the value in cell C2, enclose the addition operation in parentheses as follows:

\[(A2+B2)\times C2\]

The parentheses around the addition tell Excel that you want this operation performed before the multiplication. If cell A2 contains the number 5, B2 contains the number 10, and C2 contains the number 2, Excel adds 5 and 10 to equal 15 and then multiplies this result by 2 to produce the result 30.

In fancier formulas, you may need to add more than one set of parentheses, one within another (like the wooden Russian dolls that nest within each other) to indicate the order in which you want the calculations to take place. When nesting parentheses, Excel first performs the calculation contained in the most inside pair of parentheses and then uses that result in further calculations as the program works its way outward. For example, consider the following formula:

\[(A4+(B4–C4))\times D4\]

Excel first subtracts the value in cell C4 from the value in cell B4, adds the difference to the value in cell A4, and then finally multiplies that sum by the value in D4.

Without the additions of the two sets of nested parentheses, left to its own devices, Excel would first multiply the value in cell C4 by that in D4, add the value in A4 to that in B4, and then perform the subtraction.

Don’t worry too much when nesting parentheses in a formula if you don’t pair them properly so that you have a right parenthesis for every left parenthesis in the formula. If you do not include a right parenthesis for every left one, Excel displays an alert dialog box that suggests the correction that needs to be made to balance the pairs. If you agree with the program’s suggested correction, you simply click the Yes button. However, be sure that you only use parentheses: ( ). Excel balks at the use of brackets — [ ] — or braces — { } — in a formula by giving you an Error alert box.

**Formula flub-ups**

Under certain circumstances, even the best formulas can appear to have freaked out after you get them in your worksheet. You can tell right away that a formula’s gone haywire because instead of the nice calculated value you expected to see in the cell, you get a strange, incomprehensible message in all uppercase letters beginning with the number sign (#) and ending with an exclamation point (!) or, in one case, a question mark (?). This weirdness is
known, in the parlance of spreadsheets, as an *error value*. Its purpose is to let you know that some element — either in the formula itself or in a cell referred to by the formula — is preventing Excel from returning the anticipated calculated value.

When one of your formulas returns one of these error values, an alert indicator (in the form of an exclamation point in a diamond) appears to the left of the cell when it contains the cell pointer, and the upper-left corner of cell contains a tiny green triangle. When you position the mouse pointer on this alert indicator, Excel displays a brief description of the formula error and adds a drop-down button to the immediate right of its box. When you click this button, a pop-up menu appears with a number of related options. To access online help on this formula error, including suggestions on how to get rid of the error, click the Help on This Error item on this pop-up menu.

The worst thing about error values is that they can contaminate other formulas in the worksheet. If a formula returns an error value to a cell and a second formula in another cell refers to the value calculated by the first formula, the second formula returns the same error value, and so on down the line.

After an error value shows up in a cell, you have to discover what caused the error and edit the formula in the worksheet. In Table 2-1, I list some error values that you might run into in a worksheet and then explain the most common causes.

<table>
<thead>
<tr>
<th>Table 2-1 Error Values That You Can Encounter from Faulty Formulas</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>What Shows Up in the Cell</strong></td>
</tr>
<tr>
<td>#DIV/0!</td>
</tr>
<tr>
<td>#NAME?</td>
</tr>
<tr>
<td>#NULL!</td>
</tr>
</tbody>
</table>
Table 2-1 (continued)

<table>
<thead>
<tr>
<th>What Shows Up in the Cell</th>
<th>What's Going On Here?</th>
</tr>
</thead>
<tbody>
<tr>
<td>#NUM!</td>
<td>Appears when Excel encounters a problem with a number in the formula, such as the wrong type of argument in an Excel function or a calculation that produces a number too large or too small to be represented in the worksheet.</td>
</tr>
<tr>
<td>#REF!</td>
<td>Appears when Excel encounters an invalid cell reference, such as when you delete a cell referred to in a formula or paste cells over the cells referred to in a formula.</td>
</tr>
<tr>
<td>#VALUE!</td>
<td>Appears when you use the wrong type of argument or operator in a function, or when you call for a mathematical operation that refers to cells that contain text entries.</td>
</tr>
</tbody>
</table>

Fixing Up Those Data Entry Flub-Ups

We all wish we were perfect, but alas, because so few of us are, we are best off preparing for those inevitable times when we mess up. When entering vast quantities of data, it's really easy for those nasty little typos to creep into your work. In your pursuit of the perfect spreadsheet, here are things you can do. First, get Excel to automatically correct certain data entry typos right as they happen with its AutoCorrect feature. Second, manually correct any disgusting little errors that get through, either while you're still in the process of making the entry in the cell or after the entry has gone in.

You really AutoCorrect that for me

The AutoCorrect feature is a godsend for those of us who tend to make the same stupid typos over and over again. With AutoCorrect, you can alert Excel 2007 to your own particular typing gaffes and tell the program how it should automatically fix them for you.

When you first install Excel, the AutoCorrect feature already knows to automatically correct two initial capital letters in an entry (by lowercasing the second capital letter), to capitalize the name of the days of the week, and to replace a set number of text entries and typos with particular substitute text.
You can add to the list of text replacements at any time when using Excel. These text replacements can be of two types: typos that you routinely make along with the correct spellings, and abbreviations or acronyms that you type all the time along with their full forms.

To add to the replacements:

1. Click Office Button | Excel Options | Proofing or press Alt+FIP and then click the AutoCorrect Options button or press Alt+A to open the AutoCorrect dialog box.
2. On the AutoCorrect tab in this dialog box, enter the typo or abbreviation in the Replace text box.
3. Enter the correction or full form in the With text box.
4. Click the Add button or press Enter to add the new typo or abbreviation to the AutoCorrect list.
5. Click the OK button to close the AutoCorrect dialog box.

**Cell editing etiquette**

Despite the help of AutoCorrect, some mistakes are bound to get you. How you correct them really depends upon whether you notice before or after you complete the cell entry.

- ✔️ If you catch the mistake before you complete an entry, you can delete it by pressing your Backspace key until you remove all the incorrect characters from the cell. Then you can retype the rest of the entry or the formula before you complete the entry in the cell.

- ✔️ If you don’t discover the mistake until after you’ve completed the cell entry, you have a choice of replacing the whole thing or editing just the mistakes.

- ✔️ When dealing with short entries, you’ll probably want to take the replacement route. To replace a cell entry, you have only to position the cell pointer in that cell, type your replacement entry, and then complete the replacement entry by clicking the Enter box or pressing Enter or one of the arrow keys.

- ✔️ When the error in an entry is relatively easy to fix and the entry is on the long side, you’ll probably want to edit the cell entry rather than replace it. To edit the entry in the cell, simply double-click the cell or select the cell and then press F2.
Doing either one reactivates the Formula bar by once again displaying the Enter and Cancel boxes, while at the same time placing the insertion point in the cell entry in the worksheet. (If you double-click, the insertion point positions itself wherever you click; press F2, and the insertion point positions itself after the last character in the entry.) Notice also that the mode indicator changes to Edit. While in this mode, you can use the mouse or the arrow keys to position the insertion point at the place in the cell entry that needs fixing.

In Table 2-2, I list the keystrokes that you can use to reposition the insertion point in the cell entry and delete unwanted characters. If you want to insert new characters at the insertion point, simply start typing. If you want to delete existing characters at the insertion point as you type new ones, press the Insert key on your keyboard to switch from the normal insert mode to overwrite mode. To return to normal insert mode, press Insert a second time. When you finish making corrections to the cell entry, you must complete the edits by pressing Enter before Excel updates the contents of the cell.

While Excel is in Edit mode, you must reenter the edited cell contents by either clicking the Enter box or pressing Enter. You can use the arrow keys as a way to complete an entry only when the program is in Enter mode. When the program is in Edit mode, the arrow keys move the insertion point only through the entry that you’re editing, not to a new cell.

| Table 2-2 Keystrokes for Fixing Those Cell Entry Flub-Ups |
|-----------------|-----------------------------------------------------|
| **Keystroke**   | **What the Keystroke Does**                          |
| Delete          | Deletes the character to the right of the insertion point |
| Backspace       | Deletes the character to the left of the insertion point |
| →               | Positions the insertion point one character to the right |
| ←               | Positions the insertion point one character to the left |
| ↑               | Positions the insertion point, when it is at the end of the cell entry, to its preceding position to the left |
| End or ↓        | Moves the insertion point after the last character in the cell entry |
| Home            | Moves the insertion point in front of the first character of the cell entry |
| Ctrl+→          | Positions the insertion point in front of the next word in the cell entry |
| Ctrl+←          | Positions the insertion point in front of the preceding word in the cell entry |
| Insert          | Switches between insert and overwrite mode |
Taking the Drudgery out of Data Entry

Before leaving the topic of data entry, I feel duty-bound to cover some of the shortcuts that really help to cut down on the drudgery of this task. These data-entry tips include AutoComplete and AutoFill features as well as doing data entry in a preselected block of cells and making the same entry in a bunch of cells all at the same time.

I’m just not complete without you

The AutoComplete feature in Excel 2007 is not something you can do anything about, just something to be aware of as you enter your data. In an attempt to cut down on your typing load, our friendly software engineers at Microsoft came up with the AutoComplete feature.

AutoComplete is kinda like a moronic mind reader who anticipates what you might want to enter next based upon what you just entered. This feature comes into play only when you’re entering a column of text entries. (It does not come into play when entering values or formulas or when entering a row of text entries.) When entering a column of text entries, AutoComplete looks at the kinds of entries that you make in that column and automatically duplicates them in subsequent rows whenever you start a new entry that begins with the same letter as an existing entry.

The Tale of Two Edits: Cell versus Formula bar editing

Excel gives you a choice between editing a cell’s contents either in the cell or on the Formula bar. Whereas most of the time, editing right in the cell is just fine, when dealing with really, really long entries (like humongous formulas that seem to go on forever or text entries that take up paragraphs and paragraphs), you may prefer to do your editing on the Formula bar. This is because Excel 2007 automatically adds up and down scroll arrow buttons to the end of the Formula bar when a cell entry is too long to be completely displayed on a single row. These scroll arrow buttons enable you to display each line of the cell’s long entry without expanding the Formula bar (as in earlier versions of Excel) and thereby obscuring the top part of the Worksheet area.

To edit the contents in the Formula bar rather than in the cell itself, click the appropriate scroll arrow button to display the line with the contents that needs editing and then click the I-beam mouse pointer at the place in the text or numbers that requires modification to set the insertion cursor.
For example, suppose that I enter **Jack Sprat Diet Centers** (one of the companies owned and operated by Mother Goose Enterprises) in cell A3 and then move the cell pointer down to cell A4 in the row below and press J (lowercase or uppercase, it doesn’t matter). AutoComplete immediately inserts the remainder of the familiar entry — **ack Sprat Diet Centers** — in this cell after the J, as shown in Figure 2-9.

Now this is great if I happen to need Jack Sprat Diet Centers as the row heading in both cells A3 and A4. Anticipating that I might be typing a different entry that just happens to start with the same letter as the one above, AutoComplete automatically selects everything after the first letter in the duplicated entry it inserted (from **ack** on, in this example). This enables me to replace the duplicate supplied by AutoComplete just by continuing to type. This is what I did after capturing the Excel screen that you see in Figure 2-9 because I needed to enter Jack and Jill Trauma Centers — another of Mother’s companies — in cell A4.

If you override a duplicate supplied by AutoComplete in a column by typing one of your own (as in my example with changing Jack Sprat Diet Centers to Jack and Jill Trauma Centers in cell A4), you effectively shut down its ability to supply any more duplicates for that particular letter. So, for instance, in my example, after changing Jack Sprat Diet Centers to Jack and Jill Trauma Centers in cell A4, AutoComplete doesn’t do anything if I then type J in cell A5. In other words, you’re on your own if you don’t continue to accept AutoComplete’s typing suggestions.
If you find that the AutoComplete feature is really making it hard for you to enter a series of cell entries that all start with the same letter but are otherwise not alike, you can turn off the AutoComplete feature. Click Office Button | Excel Options | Advanced or press Alt+FIA to select the Advanced tab of the Excel Options dialog box. Then, select the Enable AutoComplete for Cell Values check box in the Editing Options section to remove its check mark before clicking OK.

**Fill ‘er up with AutoFill**

Many of the worksheets that you create with Excel require the entry of a series of sequential dates or numbers. For example, a worksheet may require you to title the columns with the 12 months, from January through December or to number the rows from 1 to 100.

Excel’s AutoFill feature makes short work of this kind of repetitive task. All you have to enter is the starting value for the series. In most cases, AutoFill is smart enough to figure out how to fill out the series for you when you drag the fill handle to the right (to take the series across columns to the right) or down (to extend the series to the rows below).

Remember that the AutoFill handle looks like this — + — and appears only when you position the mouse pointer on the lower-right corner of the cell (or the last cell, when you’ve selected a block of cells). Keep in mind that if you drag a cell selection with the white-cross mouse pointer rather than the AutoFill handle, Excel simply extends the cell selection to those cells you drag through (see Chapter 3). If you drag a cell selection with the arrowhead pointer, Excel moves the cell selection (see Chapter 4).

When creating a series with the fill handle, you can drag in only one direction at a time. For example, you can fill the series or copy the entry to the range to the left or right of the cell that contains the initial values, or you can fill the series or copy to the range above or below the cell that contains the initial values. You can’t, however, fill or copy the series to two directions at the same time (such as down and to the right by dragging the fill handle diagonally).

As you drag the mouse, the program keeps you informed of whatever entry would be entered into the last cell selected in the range by displaying that entry next to the mouse pointer (as a kind of AutoFill tips, if you will). When you release the mouse button after extending the range with the fill handle, Excel either creates a series in all of the cells that you select or copies the entire range with the initial value. To the right of the last entry in the filled or copied series, Excel also displays a drop-down button that contains a shortcut menu of options. You can use this shortcut menu to override
Excel's default filling or copying. For example, when you use the fill handle, Excel copies an initial value into a range of cells. But, if you want a sequential series, you could do this by selecting the Fill Series command on the AutoFill Options shortcut menu.

In Figures 2-10 and 2-11, I illustrate how to use AutoFill to enter a row of months, starting with January in cell B2 and ending with June in cell G2. To do this, you simply enter January in cell B2 and then position the mouse pointer on the fill handle in the lower-right corner of this cell before you drag through to cell G2 on the right (as shown in Figure 2-10). When you release the mouse button, Excel fills in the names of the rest of the months (February through June) in the selected cells (as shown in Figure 2-11). Note that Excel keeps the cells with the series of months selected, giving you another chance to modify the series. (If you went too far, you can drag the fill handle to the left to cut back on the list of months; if you didn’t go far enough, you can drag it to the right to extend the list of months further.)
Also, you can use the options on the AutoFill Options drop-down menu (opened by clicking the drop-down button that appears on the fill handle to the right of June) to override the series created by default. To have Excel copy January into each of the selected cells, choose Copy Cells on this menu. To have the program fill the selected cells with the formatting used in cell B2 (in this case, the cell has had bold and italics applied to it — see Chapter 3 for details on formatting cells), you select Fill Formatting Only on this menu. To have Excel fill in the series of months in the selected cells without copying the formatting used in cell B2, you select the Fill Without Formatting command from this shortcut menu.

See Table 2-3 in the following section to see some of the different initial values that AutoFill can use and the types of series that Excel can create from them.

**Working with a spaced series**

AutoFill uses the initial value that you select (date, time, day, year, and so on) to design the series. All the sample series I show in Table 2-3 change by a factor of one (one day, one month, or one number). You can tell AutoFill to create a series that changes by some other value: Enter two sample values in neighboring cells that describe the amount of change you want between each value in the series. Make these two values the initial selection that you extend with the fill handle.

For example, to start a series with Saturday and enter every other day across a row, enter **Saturday** in the first cell and **Monday** in the cell next door. After selecting both cells, drag the fill handle across the cells to the right as far you need to fill out a series based on these two initial values. When you release the mouse button, Excel follows the example set in the first two cells by entering every other day (Wednesday to the right of Monday, Friday to the right of Wednesday, and so on).

<table>
<thead>
<tr>
<th><strong>Value Entered in First Cell</strong></th>
<th><strong>Extended Series Created by AutoFill in the Next Three Cells</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>June</td>
<td>July, August, September</td>
</tr>
<tr>
<td>Jun</td>
<td>Jul, Aug, Sep</td>
</tr>
<tr>
<td>Tuesday</td>
<td>Wednesday, Thursday, Friday</td>
</tr>
<tr>
<td>Tue</td>
<td>Wed, Thu, Fri</td>
</tr>
</tbody>
</table>

(continued)
### Table 2-3 (continued)

<table>
<thead>
<tr>
<th>Value Entered in First Cell</th>
<th>Extended Series Created by AutoFill in the Next Three Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan-00</td>
<td>Feb-00, Mar-00, Apr-00</td>
</tr>
<tr>
<td>15-Feb</td>
<td>16-Feb, 17-Feb, 18-Feb</td>
</tr>
<tr>
<td>10:00 PM</td>
<td>11:00 PM, 12:00 AM, 1:00 AM</td>
</tr>
<tr>
<td>8:01</td>
<td>9:01, 10:01, 11:01</td>
</tr>
<tr>
<td>Quarter 1</td>
<td>Quarter 2, Quarter 3, Quarter 4</td>
</tr>
<tr>
<td>Qtr2</td>
<td>Qtr3, Qtr4, Qtr1</td>
</tr>
<tr>
<td>Q3</td>
<td>Q4, Q1, Q2</td>
</tr>
<tr>
<td>Product 1</td>
<td>Product 2, Product 3, Product 4</td>
</tr>
<tr>
<td>1st Product</td>
<td>2nd Product, 3rd Product, 4th Product</td>
</tr>
</tbody>
</table>

**Copying with AutoFill**

You can use AutoFill to copy a text entry throughout a cell range (rather than fill in a series of related entries). To copy a text entry to a cell range, hold down the Ctrl key as you click and drag the Fill handle. When you hold down the Ctrl key as you click the fill handle, a plus sign appears to the right of the Fill handle — your sign that AutoFill will *copy* the entry in the active cell instead of creating a series using it. You can also tell because the entry that appears as the AutoFill tip next to the mouse pointer as you drag contains the same text as the original cell. If you decide, after copying an initial label or value to a range, that you should have used it to fill in a series, all you have to do is click the drop-down button that appears on the fill handle at cell with the last copied entry and select the Fill Series command on the AutoFill Options shortcut menu that then appears.

Although holding down Ctrl as you drag the fill handle copies a text entry, just the opposite is true when it comes to values! Suppose that you enter the number 17 in a cell and then drag the fill handle across the row — Excel just copies the number 17 in all the cells that you select. If, however, you hold down Ctrl as you drag the fill handle, Excel then fills out the series (17, 18, 19, and so on). If you forget and create a series of numbers when you only need the value copied, rectify this situation by selecting the Copy Cells command on the AutoFill Options shortcut menu.
Creating custom lists for AutoFill

In addition to varying the increment in a series created with AutoFill, you can also create your own custom series. For example, say your company has offices in the following locations and you get tired of typing out the sequence in each new spreadsheet that requires them:

- New York
- Chicago
- Atlanta
- Seattle
- San Francisco
- San Diego

After creating a custom list with these locations, you can enter the entire sequence of cities simply by entering New York in the first cell and then dragging the Fill handle to the blank cells where the rest of the companies should appear.

To create this kind of custom series, follow these steps:

1. Click Office Button | Excel Options | Popular or press Alt+FI and then click the Edit Custom Lists button in the Top Options for Working with Excel section to open the Custom Lists dialog box (as shown in Figure 2-12).

If you’ve already gone to the time and trouble of typing the custom list in a range of cells, go to Step 2. If you haven’t yet typed the series in an open worksheet, go to Step 5 instead.
2. Click inside the Import List from Cells text box and click the Minimize Dialog Box button (the one with the picture of the tiny grid to the right of the Import List from Cells text box) so that you can see your list and drag through the range of cells to select them (see Chapter 3 for details).

3. After selecting the cells in the worksheet, click the Maximize Dialog box button.

   This button automatically replaces the Minimize Dialog box button to the right of the Import List from Cells text box.

4. Then click the Import button to copy this list into the List Entries list box.

   Skip to Step 7.

5. Click inside the List Entries list box and then type each entry (in the desired order), being sure to press Enter after typing each one.

   When all the entries in the custom list appear in the List Entries list box in the order you want them, proceed to Step 7.

6. Click the Add button to add the list of entries to the Custom lists box.

   Finish creating all the custom lists you need, using the preceding steps. When you are done, move on to Step 7.

7. Click OK twice, the first time to close the Custom Lists dialog box and the second to close the Excel Options dialog box and return to the current worksheet in the active workbook.

After adding a custom list to Excel, from then on you need only enter the first entry in a cell and then use the fill handle to extend it to the cells below or to the right.

If you don’t even want to bother with typing the first entry, use the AutoCorrect feature — refer to the section “You really AutoCorrect that for me,” earlier in this chapter — to create an entry that will fill in as soon as you type your favorite acronym for it (such as ny for New York).

**Inserting special symbols**

Excel makes it easy to enter special symbols, such as foreign currency indicators, as well as special characters, such as the trademark and copyright symbols, into your cell entries. To add a special symbol or character to a cell entry you’re making or editing, click Insert | Symbol on the Ribbon or press Alt+NU to open the Symbol dialog box (similar to the one shown in Figure 2-13).
The Symbol dialog box contains two tabs: Symbols and Special Characters. To insert a mathematical or foreign currency symbol on the Symbols tab, click its symbol in the list box and then click the Insert button. (You can also do this by double-clicking the symbol.) To insert characters, such as foreign language or accented characters from other character sets, click the Subset drop-down button, then click the name of the set in the drop-down list, and then click the desired characters in the list box below. You can also insert commonly used currency and mathematical symbols, such as the Pound or plus-or-minus symbol, by clicking them in the Recently Used Symbols section at the bottom of this tab of the Symbol dialog box.

To insert special characters, such as the registered trademark, paragraph symbol, and ellipsis, click the Special Characters tab of the Symbol dialog box, locate the symbol in the scrolling list, click it, and then click the Insert button. (You can also insert one of these special characters by double-clicking as well.)

When you finish inserting special symbols and characters, close the Symbol dialog box by clicking its Close button in its upper-right corner.

**Entries all around the block**

When you want to enter a table of information in a new worksheet, you can simplify the job of entering the data if you select all the empty cells in which you want to make entries before you begin entering any information. Just position the cell pointer in the first cell of what is to become the data table and then select all the cells in the subsequent columns and rows. (For information on the ways to select a range of cells, see Chapter 3.) After you select the block of cells, you can begin entering the first entry.
When you select a block of cells (also known as a range) before you start entering information, Excel restricts data entry to that range as follows:

- The program automatically advances the cell pointer to the next cell in the range when you click the Enter box or press Enter to complete each cell entry.

- In a cell range that contains several different rows and columns, Excel advances the cell pointer down each row of the column as you make your entries. When the cell pointer reaches the cell in the last row of the column, the cell pointer advances to the first selected row in the next column to the right. If the cell range uses only one row, Excel advances the cell pointer from left to right across the row.

- When you finish entering information in the last cell in the selected range, Excel positions the cell pointer in the first cell of the now-completed data table. To deselect the cell range, click the mouse pointer on one of the cells in the worksheet (inside or outside the selected range — it doesn’t matter) or press one of the arrow keys.

Be sure that you don’t press one of the arrow keys to complete a cell entry within a preselected cell range instead of clicking the Enter box or pressing Enter. Pressing an arrow key deselects the range of cells when Excel moves the cell pointer. To move the cell pointer around a cell range without deselecting the range, try these methods:

- Press Enter to advance to the next cell down each row and then across each column in the range. Press Shift+Enter to move up to the previous cell.

- Press Tab to advance to the next cell in the column on the right and then down each row of the range. Press Shift+Tab to move left to the previous cell.

- Press Ctrl+. (period) to move from one corner of the range to another.

**Data entry express**

You can save a lot of time and energy when you want the same entry (text, value, or formula) to appear in many cells of the worksheet; you can enter the information in all the cells in one operation. You first select the cell ranges to hold the information. (Excel lets you select more than one cell range for this kind of thing — see Chapter 3 for details.) Then you construct the entry on the formula bar and press Ctrl-Enter to put the entry into all the selected ranges.
The key to making this operation a success is to hold the Ctrl key as you press Enter so that Excel inserts the entry on the formula bar into all the selected cells. If you forget to hold Ctrl and you just press Enter, Excel places the entry in the first cell only of the selected cell range.

You can also speed up data entry in a list that includes formulas by making sure that the Extend Data Range Formats and Formulas check box is selected in the Editing Options section of the Advanced tab in the Excel Options dialog box. (click Microsoft Office | Excel Options | Advanced or press Alt+FIA.) When this check box is selected, Excel automatically formats new data that you type in the last row of a list to match that of like data in earlier rows and copies down formulas that appear in the preceding rows. Note, however, that for this new feature to kick in, you must manually enter the formulas and format the data entries in at least three rows preceding the new row.

How to Make Your Formulas Function Even Better

Earlier in this chapter, I show you how to create formulas that perform a series of simple mathematical operations, such as addition, subtraction, multiplication, and division. (See the section “Fabricating those fabulous formulas!”) Instead of creating more complex formulas from scratch out of an intricate combination of these operations, you can find an Excel function to get the job done.

A function is a predefined formula that performs a particular type of computation. All you have to do to use a function is supply the values that the function uses when performing its calculations. (In the parlance of the Spreadsheet Guru, such values are known as the arguments of the function.) As with simple formulas, you can enter the arguments for most functions either as a numerical value (for example, 22 or –4.56) or, as is more common, as a cell reference (B10) or as a cell range (C3:F3).

Just as with a formula you build yourself, each function you use must start with an equal sign (=) so that Excel knows to enter the function as a formula rather than as text. Following the equal sign, you enter the name of the function (in uppercase or lowercase — it doesn’t matter, as long as you don’t misspell the name). Following the name of the function, you enter the arguments required to perform the calculations. All function arguments are enclosed in a pair of parentheses.
If you type the function directly in a cell, remember not to insert spaces between the equal sign, function name, and the arguments enclosed in parentheses. Some functions use more than one value when performing their designated calculations. When this is the case, you separate each function with a comma (not a space).

After you type the equal sign and begin typing the first few letters of the name of the function you want to use, a drop-down list showing all the functions that begin with the letters you’ve typed appears immediately beneath the cell. When you see the name of the function you want to use on this list, double-click it and Excel will finish entering the function name in the cell and on the Formula bar as well as add the left parenthesis (‘(’) that marks the beginning of the arguments for the function.

Excel then displays all the arguments that the function takes beneath the cell and you can indicate any cell or cell range that you want to use as the first argument either by pointing to it or typing its cell or range references. When the function uses more than one argument, you can point to the cells or cell ranges or enter the addresses for the second argument right after you enter a comma (’,’) to complete the first argument.

After you finish entering the last argument, you need to close off the function by typing a right parenthesis (‘)’) to mark the end of the argument list. The display of the function name along with its arguments that appeared beneath the cell when you first selected the function from the drop-down list then disappears. Click the Enter box or press Enter or the appropriate arrow key to then insert the function into the cell and have Excel calculate the answer.

**Inserting a function into a formula with the Function Wizard button**

Although you can enter a function by typing it directly in a cell, Excel provides a Function Wizard button on the Formula bar you can use to select any of Excel’s functions. When you click this button, Excel opens the Insert Function dialog box (shown in Figure 2-14) where you can select the function you want to use. After you select your function, Excel opens the Function Arguments dialog box. In this dialog box, you can specify the function arguments. The real boon comes when you’re fooling with an unfamiliar function or one that’s kind of complex (some of these puppies can be really hairy). You can get loads of help in completing the argument text boxes in the Function Arguments dialog box by clicking the Help on this Function hyperlink in the lower-left corner of this dialog box.
The Insert Function dialog box contains three boxes: a Search for a Function text box, a Select a Category drop-down list box, and a Select a Function list box. When you open the Insert Function dialog box, Excel automatically selects Most Recently Used as the category in the Select a Category drop-down list box and displays the functions you usually use in the Select a Function list box.

If your function isn't among the most recently used, you must then select the appropriate category of your function in the Select a Category drop-down list box. If you don’t know the category, you must search for the function by typing a description of its purpose in the Search for a Function text box and then press Enter or click the Go button. For example, to locate all the Excel functions that total values, you enter the word total in the Search for Function list box and click the Go button. Excel then displays its list of Recommended functions for calculating totals in the Select a Function list box. You can peruse the recommended functions by selecting each one. As you select each function in this list, the Insert Function dialog box shows you the required arguments followed by a description, at the bottom of the dialog box, of what the function does.

After you locate and select the function you want to use, click the OK button to insert the function into the current cell and open the Function Arguments dialog box. This dialog box displays the required arguments for the function along with any that are optional. For example, suppose that you select the SUM function (the crown jewel of the Most Recently Used function category) in the Select a Function list box and then click OK. As soon as you do, the program inserts

\[
\text{SUM}() \quad \text{Figure 2-14: Select the function you want to use in Insert Function dialog box.}
\]
in the current cell and on the Formula bar (following the equal sign), and the Function Arguments dialog box showing the SUM arguments appears on the screen (as shown in Figure 2-15). This is where you add the arguments for the Sum function.

As you can read in the Function Arguments dialog box shown in Figure 2-15, you can select up to 255 numbers to be summed. What’s not obvious, however (there’s always some trick, huh?), is that these numbers don’t have to be in single cells. In fact, most of the time you’ll be selecting a whole slew of numbers in nearby cells (in a multiple cell selection — that range thing) that you want to total.

To select your first number argument in the dialog box, you click the cell (or drag through the block of cells) in the worksheet while the insertion point is in the Number1 text box. Excel then displays the cell address (or range address) in the Number1 text box while, at the same time, showing the value in the cell (or values, if you select a bunch of cells) in the box to the right. Excel displays the total so far near the bottom of the Function Arguments dialog box after the words Formula result=.

Keep in mind that when selecting cells, you can minimize this arguments dialog box down to just the contents of the Number1 text box by clicking the Minimize Dialog box button on the right of the Number1 text box. After minimizing the arguments dialog box so that you can select the cells to be used as the first argument, you can expand it again by clicking the Maximize Dialog box button (the only button displayed on the far right) or by pressing the Esc key. Instead of minimizing the dialog box, you can also temporarily move it out of the way by clicking on any part and then dragging the dialog box to its new destination on the screen.

If you’re adding more than one cell (or bunch of cells) in a worksheet, press the Tab key or click the Number2 text box to move the insertion point that text box. (Excel responds by extending the argument list with a Number3 text box.) Here is where you specify the second cell (or cell range) that is to be added to the one now showing in the Number1 text box. After you click the cell or drag
through the second cell range, the program displays the cell address(es), with
the numbers in the cell(s) to the right and the running total near the bottom of
the Function Arguments dialog box after the words Formula result= (as
shown in Figure 2-15). Note that you can minimize the entire Arguments dialog
box down to just the contents of the argument text box you’re dealing with
(Number2, Number3, and so on) by clicking its particular Minimize Dialog box
button if the dialog box obscures the cells that you need to select.

When you finish pointing out the cells or bunches of cells to be summed,
click the OK button to close the Function Arguments dialog box and put the
SUM function in the current cell.

**Editing a function with the Function Wizard button**

Use the Excel Function Wizard button to edit formulas that contain functions
right from the Formula bar. Select the cell with the formula with the function
to be edited before you click the Function Wizard button (the one sporting
the fx that appears immediately in front of the current cell entry on the
Formula bar).

As soon as you click the Function Wizard button, Excel opens the Function
Arguments dialog box where you can edit its arguments. To edit just the argu-
ments of a function, select the cell references in the appropriate argument’s
text box (marked Number1, Number2, Number3, and so on) and then make
whatever changes are required to the cell addresses or select a new range of
cells. Keep in mind that Excel automatically adds any cell or cell range that
you highlight in the worksheet to the current argument. If you want to
replace the current argument, you need to highlight it and then get rid of its
cell addresses by pressing the Delete key before you highlight the new cell or
cell range to be used as the argument. (Remember that you can always mini-
mize this dialog box or move it to a new location if it obscures the cells you
need to select.)

When you finish editing the function, press Enter or click the OK button in
the Function Arguments dialog box to put it away and update the formula in
the worksheet.

**I’d be totally lost without AutoSum**

Before leaving this fascinating discussion on entering functions, I want you to
get to the AutoSum tool in the Editing group on the Home tab of the Ribbon.
Look for the Greek sigma (Σ) symbol. This little tool is worth its weight in
gold. In addition to entering the SUM, AVERAGE, COUNT, MAX, or MIN func-
tions, it also selects the most likely range of cells in the current column or
row that you want to use as the function’s argument and then automatically enters them as the function’s argument. And nine times out of ten, Excel selects (with the marquee or moving dotted line) the correct cell range to be totaled, averaged, counted, and so forth. For that tenth case, you can manually correct the range by simply dragging the cell pointer through the block of cells that need to be summed.

Simply click the AutoSum button on the Home tab when you want to insert the Sum function into the current cell. If you want to use this button to insert another function, such as Average, Count, Max, or Min, you need to click its drop-down button and select the name of the desired function on its pop-up menu (click Count Numbers on the menu to insert the COUNT function). Note that if you select the More Functions command on this menu, Excel opens the Insert Function dialog box as though you had clicked the fx button on the Formula bar.

In Figure 2-16, check out how to use the AutoSum tool to total the sales of Jack Sprat Diet Centers in row 3. Position the cell pointer in cell E3 where the first-quarter total is to appear and click the AutoSum tool. Excel inserts SUM (equal sign and all) onto the Formula bar; places a marquee around the cells B3, C3, and D3; and uses the cell range B3:D3 as the argument of Sum function.

Now look at the worksheet after you insert the function in cell E3 (see Figure 2-17). The calculated total appears in cell E3 while the following Sum function formula appears in the Formula bar:

```
=SUM(B3:D3)
```
After entering the function to total the sales of Jack Sprat Diet Centers, you can copy this formula to total sales for the rest of the companies by dragging the fill handle down column E until the cell range E3:E9 is highlighted.

Look at Figure 2-18 to see how you can use the AutoSum tool to total the January sales for all the Mother Goose Enterprises in column B. Position the cell pointer in cell B10 where you want the total to appear. Click the AutoSum tool, and Excel places the marquee around cells B3 through B9 and correctly enters the cell range B3:B9 as the argument of the SUM function.

In Figure 2-19, you see the worksheet after inserting the function in cell B10 and using the AutoFill feature to copy the formula to cells C10, D10, and E10 to the right. (To use AutoFill, drag the fill handle through the cells to the right until you reach cell E10. Release the mouse button.)
Making Sure That the Data Is Safe and Sound

All the work you do in any of the worksheets in your workbook is at risk until you save the workbook as a disk file normally on your computer’s hard drive. Should you lose power or should your computer crash for any reason before you save the workbook, you’re out of luck. You have to re-create each and every keystroke — a painful task, made all the worse because it’s so unnecessary. To avoid this unpleasantness altogether, adopt this motto: Save your work any time you enter more information than you could possibly bear to lose.

To encourage frequent saving on your part, Excel even provides you with a Save button on the Quick Access toolbar (the one with the picture of a 3½” floppy disk, the very first on the toolbar). You don’t even have to take the time and trouble to choose the Save command from the File pull-down menu (opened by clicking the Office Button) or even press Ctrl+S; you can simply click this tool whenever you want to save new work on disk.

When you click the Save button, press Ctrl+S, or click Office Button | Save for the first time you, Excel displays the Save As dialog box. Use this dialog box to replace the temporary document name (Book1, Book2, and so forth) with a more descriptive filename in the File Name text box, select a new file format in the Save As Type drop-down list box, and to select a new drive and folder before you save the workbook as a disk file.

When you finish making changes in the Save As dialog box, click the Save button or press Enter to have Excel 2007 save your work. When Excel saves your workbook file, the program saves all the information in every worksheet in your workbook (including the last position of the cell cursor) in the designated folder and drive.
You don’t have to fool with the Save As dialog box again unless you want to rename the workbook or save a copy of it in a different directory. If you want to do either of these things, you must click Office Button | Save AS or press Alt+FA to choose the Save As command rather than click the Save button on the Quick Access toolbar or press Ctrl+S.

The Save As dialog box in Windows Vista

Figure 2-20 shows you the Save As dialog box as it appears in Excel 2007 when running the program under Windows Vista. Here, you can replace the temporary filename (Book1, Book2, and so on) with a more descriptive name by clicking the File Name text box and typing in the new name (up to 255 characters total including spaces).

To select a new folder in which to save the new workbook file, follow these steps:

1. Click the Browse Folders button (with the triangle pointing downward) to expand the Save As dialog box.

When you expand the Save As dialog box, the dialog box displays the Navigation Pane where you can select folders listed in the Favorite Links or Folders sections.

2. In the Navigation Pane, click the name of the Favorites link containing the folder in which you want to save the file or click the Folders button (with the upward-pointing triangle) and then click the name of this folder.
3. (Optional) If you want to save the workbook file inside a new subfolder within the folder currently open in the Save As dialog box, click the New Folder button on the toolbar and then replace the suggested New Folder name by typing the actual name of the folder and press Enter.

4. Click the Save button to save the file in the selected folder.

When the Save As dialog box is expanded, you can add a title, subject, and tags to the new workbook file by clicking the Add a Title, Specify the Subject, or Add a Tag links. You can then use any or all of these pieces of information you add to the file when later searching for the workbook (see Chapter 4 for details on searching).

**The Save As dialog box in Windows XP**

Figure 2-21 shows you the Save As dialog box as it appears in Excel 2007 when running the program under Windows XP.

The Windows XP version of the Save As dialog box contains a bunch of large buttons that appear on the left side of the dialog box: My Recent Documents, Desktop, My Documents, My Computer, and My Network Places. Use these buttons to select the following folders in which to save your new workbook file:

- Click the My Recent Documents button to save your workbook in the Recent folder. The Recent folder resides in this hierarchy: Windows folder (on your hard drive)\Application Data folder\Microsoft folder\Office folder\Recent folder.
- Click the Desktop button to save your workbook on your computer’s desktop.
- Click the My Documents button to save your workbook in the My Documents folder.
- Click the My Computer button to save your workbook on one of the disks on your computer or in your own or a shared documents folder on your hard drive.
- Click the My Network Places button to save your workbook in one of the folders on your company’s network.

To save your workbook in a new subfolder within the folder open in the Save As dialog box, click the Create New Folder button on the toolbar (or press Alt+4) and then type the name for the folder in the New Folder dialog box before you click OK.
Changing the default file location

Whenever you open the Save As dialog box to save a new workbook file, Excel 2007 automatically selects the folder listed in the Default File Location text box on the Save tab of the Excel Options dialog box (Office Button | Excel Options | Save or Alt+FIS).

When you first start using Excel, the default folder is either the My Documents (Windows XP) or the Documents folder (Windows Vista) under your user name on your hard drive. So, for example, the directory path of the default folder where Excel 2007 automatically saves new workbook files on my computer running Windows XP is

C:\Documents and Settings\Greg\My Documents

However, the directory path of the default folder where Excel 2007 automatically saves new workbook files on my other computer running Windows Vista is

C:\Users\Greg\Documents

The very generic My Documents or Documents folder may not be the places on your hard drive where you want all the new workbooks you create automatically saved. To change the default file location to another folder on your computer, follow these steps:

1. Click Office Button | Excel Options | Save or press Alt+FIS to open the Save tab of the Excel Options dialog box.

   The Default File Location text box displays the directory path to the current default folder.
2. Click the Default File Location text box to select the current directory path.

When you click the Default File Location text box, Excel selects the entire directory path so that if you begin typing, the characters you type replace the entire path. To edit part of the path (such as the My Documents or Documents folder name after your user name), click the mouse pointer at that place in the path to set the Insertion point.

3. Edit the existing path or replace it with the path to another existing folder in which you want all future workbooks to automatically be saved.

4. Click OK to close the Excel Options dialog box.

The difference between the XLSX and XLS file format

Excel 2007 supports the use of a new XML-based file format (which Microsoft officially calls the Microsoft Office Open XML format), which is touted as being more efficient in saving data resulting in smaller file size and offering superior integration with external data sources (especially, when these resources are Web-based ones supporting XML files). This XML-based file format carries the filename extension .xlsx and the file format in which Excel automatically saves any new workbook you create.

The only problem with that this newfangled XML-based file format is that it’s not one that earlier versions of Excel can open. This means that if everybody who needs to work with the workbook you’ve just created hasn’t yet upgraded to Excel 2007, you need to save the new workbook in the earlier file format used in versions 97 through 2003 with the old .xls filename extension. To do this, click the File As Type drop-down button and then click Excel 97-2003 Workbook (*.xls) on the drop-down menu. (If you work in an office where all workbooks must be backwardly compatible with earlier versions, see “Dealing with the new Excel file formats” in Chapter 1 for a tip on making the Excel 97-2003 workbook file format the new default for Excel 2007.)

Keep in mind that filename extensions such as .xlsx and .xls do not appear as part of the filename (even though they are appended) in the File Name text box in the Save As dialog box unless you’ve removed the check mark from the Hide Extensions for Known File Types check box found on the View tab of the Folder Options dialog box (Tools → Options) in any Windows Explorer window such as My Documents in Windows XP or Documents in Windows Vista.
Excel 2007 also supports a new binary file format called Office Excel 2007 Binary or BIFF12 for short that carries the .xlsb filename extension. Select this binary format for really huge spreadsheets that you create that have to be backwardly compatible with earlier versions of Excel.

**Saving the Workbook as a PDF File**

The PDF (Portable Document File) file format developed by Adobe Systems Incorporated enables people to open up and print documents without access to the original programs with which the documents were created.

For the first time ever, Excel enables you to save your workbook files directly in this special PDF file format. This means that you can readily share your Excel 2007 workbooks with users who don’t have Excel installed on their computers by saving them as PDF files. All they have to have installed in order to open and print the PDF copy of workbook file is the free Adobe Reader software (which can be downloaded from the Adobe Web site at [www.adobe.com](http://www.adobe.com)).

Before you can save files in the PDF file format, you must download and install the Excel Microsoft Save as PDF or XPS Add-in program from the Microsoft Web site. To do this, open the Excel Help window and then search for “PDF and XPS” in the Search text box. Then, click the Enable Support for Other File Formats, Such as PDF and XPS link in the Help window. Locate the Microsoft Save as PDF or XPS Add-in for 2007 Microsoft Office Programs link the help screen describing PDF and XPS file formats. Finally, follow the online instructions for downloading and installing this add-in program on the Microsoft Downloads Web site.

To save a workbook as a PDF file, click the Office Button and then position the mouse over the continuation button attached to the Save As button (the triangle pointing to the right) and click the PDF or XPS option on the continuation menu (or simply press Alt+FFP) to open the Publish as PDF or XPS dialog box. If you don’t need to edit the filename (Excel automatically appends .pdf to the current filename) or the folder location, simply click the Publish button, and Excel will save the workbook in a PDF file and automatically open it up for your inspection in Adobe Reader.

If you create an Excel 2007 workbook that incorporates new features not supported in earlier versions of Excel, instead of saving the workbook as an .xls file, thereby losing all of its 2007 enhancements, consider saving it as a PDF file so that co-workers still using pre-2007 Excel versions can still have access to the data in all its glory via the Adobe Reader.
Document Recovery to the Rescue

Excel 2007 offers a document recovery feature that can help you in the event of a computer crash because of a power failure or some sort of operating system freeze or shutdown. The AutoRecover feature saves your workbooks at regular intervals. In the event of a computer crash, Excel displays a Document Recovery task pane the next time you start Excel after rebooting the computer.

When you first start using Excel 2007, the AutoRecover feature is set to automatically save changes to your workbook (provided that the file has already been saved) every ten minutes. You can shorten or lengthen this interval as you see fit. Click Office Button | Excel Options | Save or press Alt+FIS to open the Excel Options dialog box with the Save tab selected. Use the spinner buttons or enter a new automatic save interval into the text box marked Save AutoRecover Information Every 10 Minutes before clicking OK.

The Document Recovery task pane shows the available versions of the workbook files that were open at the time of the computer crash. It identifies the original version of the workbook file and when it was saved along with the recovered version of the file and when it was saved. To open the recovered version of a workbook (to see how much of the work it contains that was unsaved at the time of the crash), position the mouse pointer over the AutoRecover version. Then click its drop-down menu button and click Open on its pop-up menu. After you open the recovered version, you can (if you choose) then save its changes by clicking the Save button on the Quick Access toolbar or by clicking Office Button | Save.

To save the recovered version of a workbook without bothering to first open it up, place your mouse over the recovered version, click its drop-down button, and choose the Save As option on the pop-up menu. To permanently abandon the recovered version (leaving you with only the data in the original version), click the Close button at the bottom of the Document Recovery task pane. When you click the Close button, an alert dialog box appears, giving you the chance to retain the recovered versions of the file for later viewing. To retain the files for later viewing, select the Yes (I want to view these files later) radio button before clicking OK. To retain only the original versions of the files shown in the task pane, select the No (remove these files. I have saved the files I need) radio button instead.

Note that the AutoRecover features only works on Excel workbooks that you have saved at least one time (as explained in the earlier section “Making Sure That the Data Is Safe and Sound”). In other words, if you build a new workbook and don’t bother to save and rename it prior to experiencing a computer crash, the AutoRecover feature will not bring back any part of it. For this reason, it is very, very important that you get into the habit of saving new workbooks with the Save button on the Quick Access toolbar very shortly after beginning to work on one its worksheets. Or you can use the trusty keyboard shortcut Ctrl+S.
Part II

Editing
Without Tears

The 5th Wave

By Rich Tennant

“Well, shoot! This eggplant chart is just as confusing as the butternut squash chart and the gourd chart. Can’t you just make a pie chart like everyone else?”
In this part . . .

The business world wouldn’t be half bad if it weren’t for the fact that right around the time you master your job, somebody goes and changes it on you. When your life must always be flexible, changing gears and “going with the flow” can really grate on a person! The sad truth is that a big part of the work you do with Excel 2007 is changing the stuff you slaved so hard to enter into the spreadsheet in the first place.

In Part II, I break this editing stuff down into three phases: formatting the raw data; rearranging the formatting data or in some cases deleting it; and, finally, spitting out the final formatted and edited data in printed form. Take it from me, after you know your way around editing your spreadsheets (as presented in this part of the book), you’re more than halfway home with Excel 2007.
In spreadsheet programs like Excel, you normally don’t worry about how the stuff looks until after you enter all the data in the worksheets of your workbook and save it all safe and sound (see Chapters 1 and 2). Only then do you pretty up the information so that it’s clearer and easy to read.

After you decide on the types of formatting that you want to apply to a portion of the worksheet, select all the cells to be beautified and then click the appropriate tool or choose the menu command to apply those formats to the cells. But before you discover all the fabulous formatting features you can use to dress up cells, you first need to know how to pick out the group of cells that you want to apply the formatting to — selecting the cells or, alternatively, making a cell selection.

Be aware, also, that entering data into a cell and formatting that data are two completely different things in Excel. Because they’re separate, you can change the entry in a formatted cell, and new entries assume the cell’s formatting. This enables you to format blank cells in a worksheet, knowing that when you get around to making entries in those cells, those entries automatically assume the formatting you assign to those cells.
Choosing a Select Group of Cells

Given the monotonously rectangular nature of the worksheet and its components, it shouldn’t come as a surprise to find that all the cell selections you make in the worksheet have the same kind of cubist feel to them. After all, worksheets are just blocks of cells of varying numbers of columns and rows.

A cell selection (or cell range) is whatever collection of neighboring cells you choose to format or edit. The smallest possible cell selection in a worksheet is just one cell: the so-called active cell. The cell with the cell cursor is really just a single cell selection. The largest possible cell selection in a worksheet is all the cells in that worksheet (the whole enchilada, so to speak). Most of the cell selections you need for formatting a worksheet will probably fall somewhere in between, consisting of cells in several adjacent columns and rows.

Excel shows a cell selection in the worksheet by highlighting in color the entire block of cells within the extended cell cursor except for the active cell that keeps its original color. (Look at Figure 3-1 to see several cell selections of different sizes and shapes.)

In Excel, you can select more than one cell range at a time (a phenomenon somewhat ingloriously called a noncontiguous or nonadjacent selection). In fact, although Figure 3-1 appears to contain several cell selections, it’s really just one big, nonadjacent cell selection with cell D12 (the active one) as the cell that was selected last.

Point-and-click cell selections

The mouse is a natural for selecting a range of cells. Just position the mouse pointer (in its thick, white-cross form) on the first cell and drag in the direction that you want to extend the selection.
To extend the cell selection to columns to the right, drag your mouse to the right, highlighting neighboring cells as you go.

To extend the selection to rows to the bottom, drag your mouse down.

To extend the selection down and to the right at the same time, drag your mouse diagonally toward the cell in the lower-right corner of the block you’re highlighting.

**Shifty cell selections**

To speed up the old cell-selection procedure, you can use the old Shift+click method, which goes as follows:

1. **Click the first cell in the selection.**
   
   This selects that cell.

2. **Position the mouse pointer in the last cell in the selection.**
   
   This is kitty-corner from the first cell in your selected rectangular block.

3. **Press the Shift key and hold it down while you click the mouse button again.**
   
   When you click the mouse button the second time, Excel selects all the cells in the columns and rows between the first cell and last cell.

The Shift key works with the mouse like an extend key to extend a selection from the first object you select through to, and including, the second object you select. See the section “Extend that cell selection,” later in this chapter. Using the Shift key enables you to select the first and last cells, as well as all the intervening cells in a worksheet or all the document names in a dialog list box.

If, when making a cell selection with the mouse, you notice that you include the wrong cells before you release the mouse button, you can deselect the cells and resize the selection by moving the pointer in the opposite direction. If you already released the mouse button, click the first cell in the highlighted range to select just that cell (and deselect all the others) and then start the whole selection process again.

**Nonadjacent cell selections**

To select a nonadjacent cell selection made up of more than one noncontiguous (that is, not touching) block of cells, drag through the first cell range and then hold down the Ctrl key while you click the first cell of the second range and drag the pointer through the cells in this range. As long as you hold down Ctrl while you select the subsequent ranges, Excel doesn’t deselect any of the previously selected cell ranges.
The Ctrl key works with the mouse like an add key to include non-neighboring objects in Excel. See the section “Nonadjacent cell selections with the keyboard,” later in this chapter. By using the Ctrl key, you can add to the selection of cells in a worksheet or to the document names in a dialog list box without having to deselect those already selected.

**Going for the “big” cell selections**

You can select the cells in entire columns or rows or even all the cells in the worksheet by applying the following clicking-and-dragging techniques to the worksheet frame:

- To select every single cell in a particular column, click its column letter on the frame at the top of the worksheet document window.
- To select every cell in a particular row, click its row number on the frame at the left edge of the document window.
- To select a range of entire columns or rows, drag through the column letters or row numbers on the frame surrounding the workbook.
- To select more than entire columns or rows that are not right next to each other (that old noncontiguous stuff, again), press and hold down the Ctrl key while you click the column letters or row numbers of the columns and rows that you want to add to the selection.
- To select each and every cell in the worksheet, press Ctrl-A or click the Select All button, which is the button with the triangle pointing downward on the diagonal, in the upper-left corner of the workbook frame, formed by the intersection of the row with the column letters and the column with the row numbers.

**Selecting the cells in a table of data, courtesy of AutoSelect**

Excel provides a really quick way (called AutoSelect) to select all the cells in a table of data entered as a solid block. To use AutoSelect, simply follow these steps:

1. **Click the first cell of the table to select it.**
   This is the cell in the table’s upper-left corner.

2. **Hold down the Shift key while you double-click either the right or bottom edge of the selected cell with the arrowhead mouse pointer. (See Figure 3-2.)**

   Double-clicking the bottom edge of the cell causes the cell selection to expand to the cell in the last row of the first column (as shown in Figure 3-3). If you double-click the right edge of the cell, the cell selection expands to the cell in the last column of the first row.
3a. Double-click somewhere on the right edge of the cell selection (refer to Figure 3-3) if the cell selection now consists of the first column of the table.

This selects all the remaining rows of the table of data (as shown in Figure 3-4).

3b. Double-click somewhere on the bottom edge of the current cell selection if the cell selection now consists of the first row of the table.

This selects all the remaining rows in the table.
Although the preceding steps may lead you to believe that you have to select the first cell of the table when you use AutoSelect, you can actually select any of the cells in the four corners of the table. Then when expanding the cell selection in the table with the Shift key depressed, you can choose whatever direction you like (left, by clicking the left edge; right, by clicking the right edge; up, by clicking the top edge; or down, by clicking the bottom edge) to select either the first or last row of the table or the first or last column. After expanding the cell selection to include either the first or last row or first or last column, you need to click whichever edge of that current cell selection that will expand it so that it includes all the remaining table rows or columns.

**Keyboard cell selections**

If you’re not really keen on using the mouse, you can use the keyboard to select the cells you want. Sticking with the Shift+click method of selecting cells, the easiest way to select cells with the keyboard is to combine the Shift key with other keystrokes that move the cell cursor. (I list these keystrokes in Chapter 1.)

Start by positioning the cell cursor in the first cell of the selection and then holding the Shift key while you press the appropriate cell-pointer movement keys. When you hold the Shift key as you press direction keys — such as the arrow keys (↑, →, ↓, ←), PgUp, or PgDn — Excel anchors the selection on the current cell, moves the cell cursor, and also highlights cells as it goes.
When making a cell selection this way, you can continue to alter the size and shape of the cell range with the cell-pointer movement keys as long as you don’t release the Shift key. After you release the Shift key, pressing any of the cell-pointer movement keys immediately collapses the selection, reducing it to just the cell with the cell cursor.

**Extend that cell selection**

If holding the Shift key as you move the cell cursor is too tiring, you can place Excel in Extend mode by pressing (and promptly releasing) F8 before you press any cell-pointer movement key. Excel displays the Extend Selection indicator on the left side of the Status bar — when you see this, the program will select all the cells that you move the cell cursor through (just as though you were holding down the Shift key).

After you highlight all the cells you want in the cell range, press F8 again (or Esc) to turn off Extend mode. The Extend Selection indicator disappears from the status bar, and then you can once again move the cell cursor with the keyboard without highlighting everything in your path. In fact, when you first move the pointer, all previously selected cells are deselected.

**AutoSelect keyboard style**

For the keyboard equivalent of AutoSelect with the mouse (read this chapter’s section “Selecting the cells in a table of data, courtesy of AutoSelect”), you combine the use of the F8 (Extend key) or the Shift key with the Ctrl+arrow keys or End+arrow keys to zip the cell cursor from one end of a block to the other, merrily selecting all the cells in its path as it goes.

To select an entire table of data with a keyboard version of AutoSelect, follow these steps:

1. **Position the cell cursor in the first cell.**
   
   That’s the cell in the upper-left corner of the table.

2. **Press F8 (or hold the Shift key) and then press Ctrl+→ to extend the cell selection to the cells in the columns on the right.**

3. **Then press Ctrl+↓ to extend the selection to the cells in the rows below.**

Keep in mind that the directions in the preceding steps are somewhat arbitrary — you can just as well press Ctrl+↓ before you press Ctrl+→. Just be sure (if you’re using the Shift key instead of F8) that you don’t let up on the Shift key until after you finish performing these two directional maneuvers. Also, if you press F8 to get the program into Extend mode, don’t forget to press this key again to get out of Extend mode after the table cells are all selected, or you’ll end up selecting cells that you don’t want included when you next move the cell cursor.
Nonadjacent cell selections with the keyboard

Selecting more than one cell range is a little more complicated with the keyboard than it is with the mouse. When using the keyboard, you alternate between anchoring the cell cursor and moving the cell cursor to select the cell range and unanchoring the cell cursor and repositioning it at the beginning of the next range. To unanchor the cell cursor so that you can move it into position for selecting another range, press Shift+F8. This puts you in Add to Selection mode, in which you can move to the first cell of the next range without selecting any more cells. Excel lets you know that the cell cursor is unanchored by displaying the Add to Selection indicator on the left side of the Status bar.

To select more than one cell range by using the keyboard, follow these general steps:

1. Move the cell cursor to the first cell of the first cell range that you want to select.
2. Press F8 to get into Extend Selection mode.
   Move the cell cursor to select all the cells in the first cell range. Alternatively, hold the Shift key as you move the cell cursor.
3. Press Shift+F8 to switch from Extend Selection mode to Add to Selection mode.
   The Add to Selection indicator appears in the Status bar.
4. Move the cell cursor to the first cell of the next nonadjacent range that you want to select.
5. Press F8 again to get back into Extend Selection mode and then move the cell cursor to select all the cells in this new range.
6. If you still have other nonadjacent ranges to select, repeat Steps 3, 4, and 5 until you select and add all the cell ranges that you want to use.

Cell selections à la Go To

If you want to select a really big cell range that would take a long time to select by pressing various cell-pointer movement keys, use the Go To feature to extend the range to a far distant cell. All you gotta do is follow this pair of steps:

1. Position the cell cursor in the first cell of the range; then press F8 to anchor the cell cursor and get Excel into Extend Selection mode.
2. Press F5 or Ctrl+G to open the Go To dialog box, type the address of the last cell in the range (the cell kitty-corner from the first cell), and then click OK or press Enter.
Because Excel is in Extend Selection mode at the time you use Go To to jump to another cell, the program not only moves the cell cursor to the designated cell address but selects all the intervening cells as well. After selecting the range of cells with the Go To feature, don’t forget to press F8 (the Extend Selection key) again to prevent the program from messing up your selection by adding on more cells the next time you move the cell cursor.

Having Fun with the Format as Table Gallery

Here’s a formatting technique that doesn’t require you to do any prior cell selecting. (Kinda figures, doesn’t it?) In fact, the Format as Table feature is so automatic that to use it, the cell cursor just has to be somewhere within the table of data prior to your clicking the Format as Table command button in the Styles group on the Home tab. Clicking the Format as Table command button opens its rather extensive Table gallery with the formatting thumbnails divided into three sections — Light, Medium, and Dark — each of which describes the intensity of the colors used by its various formats (see Color Plate 11).

As soon as you click one of the table formatting thumbnails in this Table gallery, Excel makes its best guess as to the cell range of the data table to apply it to (indicated by the marquee around its perimeter) and the Format As Table dialog box similar to the one shown in Figure 3-5 appears.
This dialog box contains a Where Is the Data for Your Table text box that shows the address of the cell range currently selected by the marquee and a My Table Has Headers check box (selected by default).

If Excel does not correctly guess the range of the data table you want to format, drag through the cell range to adjust the marquee and the range address in the Where Is the Data for Your Table text box. If your data table doesn’t use column headers or, if the table has them, but you still don’t want Excel to add Filter drop-down buttons to each column heading, click the My Table Has Headers check box before you click the OK button.

Keep in mind that the table formats in the Table gallery are not available if you select multiple nonadjacent cells before you click the Format as Table command button on the Home tab.

After you click the OK button in the Format As Table dialog box, Excel applies the format of the thumbnail you clicked in the gallery to the data table and the Design tab under the Table Tools contextual tab shown in Figure 3-6 appears at the end of the Ribbon.

The Design tab enables you to use Live Preview to see how your table would appear. Simply position the mouse pointer over any of the format thumbnails in the Table Style group to see the data in your table appear in that table format. Click the button with the triangle pointing downward to scroll up new rows of table formats in the Table Styles group and the button with the triangle pointing upward to scroll down rows without opening the Table gallery and possibly obscuring the actual data table in the Worksheet area. Click the More button (the one with the horizontal bar above the downward pointing triangle) to redisplay the Table gallery and then mouse over the thumbnails in the Light, Medium, and Dark sections to have Live Preview apply them to the table.
In addition to enabling you to select a new format from the Table gallery in the Table Styles group, the Design tab contains a Table Styles Options group containing a bunch of check boxes that enable you to customize the look of the selected table format even further:

- **Header Row** to add Filter buttons to each of the column headings in the first row of the table
- **Totals Row** to have Excel add a Totals row to the bottom of the table that displays the sums of each column that contains values — to apply another Statistical function to the values in a particular column, click the cell in that column’s Totals row to display a drop-down list button and then the function to use the drop-down menu of functions, Average, Count, Count Numbers, Max, Min, Sum, StdDev (Standard Deviation), or Var (Variation) that appears when you click its drop-down button
- **First Column** to have Excel display the row headings in the first column of the table in bold
- **Last Column** to have Excel display the row headings in the last column of the table in bold
- **Banded Rows** to have Excel apply shading to every other row in the table
- **Banded Columns** to have Excel apply shading to every other column in the table

Keep in mind that whenever you assign a format in the Table gallery to one of the data tables in your workbook, Excel automatically assigns that table a generic range name (Table1, Table2, and so on). You can use the Table Name text box in the Properties group on the Design tab to rename the data table by giving it a more descriptive range name (see Chapter 6 for all you need to know about naming cell ranges).

When you finish selecting and/or customizing the formatting of your data table, click a cell outside of the table to remove the Design contextual tab from the Ribbon. If you later decide that you want to further experiment with the table’s formatting, click any of the table’s cells to redisplay the Design contextual tab at the end of the Ribbon.

### Cell Formatting from the Home Tab

Some spreadsheet tables require a lighter touch than the Format as Table command button offers. For example, you may have a data table where the only emphasis you want to add is to make the column headings bold at the top of the table and to underline the row of totals at the bottom (done by drawing a borderline along the bottom of the cells).
The formatting buttons that appear in the Font, Alignment, and Number groups on the Home tab enable you to accomplish just this kind of targeted cell formatting. Figure 3-7 shows you the Home tab with all the buttons in these three groups identified. See Table 3-1 for a complete rundown on how to use each of these formatting buttons.

Table 3-1 The Formatting Command Buttons in the Font, Alignment, and Number Groups on the Home Tab

<table>
<thead>
<tr>
<th>Group</th>
<th>Button Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font</td>
<td>Font</td>
<td>Displays a Font drop-down menu from which you can select a new font for your cell selection</td>
</tr>
<tr>
<td>Font Size</td>
<td>Font Size</td>
<td>Displays a Font Size drop-down menu from which you can select a new font size for your cell selection — click the Font Size text box and enter the desired point size if it doesn’t appear on the drop-down menu</td>
</tr>
<tr>
<td>Increase</td>
<td>Increase Font Size</td>
<td>Increases the size of the font in the cell selection by one point</td>
</tr>
<tr>
<td>Decrease</td>
<td>Decrease Font Size</td>
<td>Decreases the size of the font in the cell selection by one point</td>
</tr>
<tr>
<td>Bold</td>
<td>Bold</td>
<td>Applies boldface to the entries in the cell selection</td>
</tr>
<tr>
<td>Italic</td>
<td>Italic</td>
<td>Italicizes the entries in the cell selection</td>
</tr>
<tr>
<td><strong>Group</strong></td>
<td><strong>Button Name</strong></td>
<td><strong>Function</strong></td>
</tr>
<tr>
<td>-----------</td>
<td>----------------</td>
<td>--------------</td>
</tr>
<tr>
<td></td>
<td>Underline</td>
<td>Underlines the entries in the cell selection</td>
</tr>
<tr>
<td></td>
<td>Borders</td>
<td>Displays a Borders drop-down menu from which you can select a border style for the cell selection</td>
</tr>
<tr>
<td></td>
<td>Fill Color</td>
<td>Displays a Color drop-down palette from which you can select a new background color for the cell selection</td>
</tr>
<tr>
<td></td>
<td>Font Color</td>
<td>Displays a Color drop-down palette from which you can select a new font color for the cell selection</td>
</tr>
<tr>
<td><strong>Alignment</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Align Left</td>
<td>Aligns all the entries in the cell selection with the left edge of their cells</td>
</tr>
<tr>
<td></td>
<td>Center</td>
<td>Centers all the entries in the cell selection within their cells</td>
</tr>
<tr>
<td></td>
<td>Align Right</td>
<td>Aligns all the entries in the cell selection with the right edge of their cells</td>
</tr>
<tr>
<td></td>
<td>Decrease Indent</td>
<td>Decreases the margin between entries in the cell selection and their left cell borders by one tab stop</td>
</tr>
<tr>
<td></td>
<td>Increase Indent</td>
<td>Increases the margin between the entries in the cell selection and their left cell borders by one tab stop</td>
</tr>
<tr>
<td></td>
<td>Top Align</td>
<td>Aligns the entries in the cell selection with the top border of their cells</td>
</tr>
<tr>
<td></td>
<td>Middle Align</td>
<td>Vertically centers the entries in the cell selection between the top and bottom borders of their cells</td>
</tr>
<tr>
<td></td>
<td>Bottom Align</td>
<td>Aligns the entries in the cell selection with the bottom border of their cells</td>
</tr>
<tr>
<td></td>
<td>Orientation</td>
<td>Displays a drop-down menu with options for changing the angle and direction of the entries in the cell selection</td>
</tr>
<tr>
<td></td>
<td>Wrap Text</td>
<td>Wraps the entries in the cell selection that spill over their right borders onto multiple lines within the current column width</td>
</tr>
</tbody>
</table>

(continued)
Table 3-1 *(continued)*

<table>
<thead>
<tr>
<th>Group</th>
<th>Button Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merge and Center</td>
<td>Merges the cell selection into a single cell and the centers the entry in the first cell between its new left and right border — click the Merge and Center drop-down button to display a menu of options that enable to merge the cell selection into a single cell without centering the entries as well as to split up a merged cell back into its original individual cells</td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>Number Format</td>
<td>Displays the number format applied to active cell in the cell selection — click its drop-down button to display a menu showing the active cell in cell selection formatted with all of Excel's major Number formats</td>
</tr>
<tr>
<td>Accounting</td>
<td>Accounting Number Format</td>
<td>Formats the cell selection using Accounting Number format that adds a dollar sign, uses commas to separate thousands, displays two decimal places, and encloses negative values in a closed pair of parentheses — click the Accounting Number Format drop-down button to display a menu of other major currency number formats from which you can choose</td>
</tr>
<tr>
<td>Percent Style</td>
<td>Formats the cell selection using the Percent Style Number format that multiplies the values by 100 and adds a percent sign with no decimal places</td>
<td></td>
</tr>
<tr>
<td>Comma Style</td>
<td>Formats the cell selection with the Comma Style Number format that uses commas to separate thousands, displays two decimal places, and encloses negative values in a closed pair of parentheses</td>
<td></td>
</tr>
<tr>
<td>Increase Decimal</td>
<td>Adds a decimal place to the values in the cell selection</td>
<td></td>
</tr>
<tr>
<td>Decrease Decimal</td>
<td>Removes a decimal place from the values in the cell selection</td>
<td></td>
</tr>
</tbody>
</table>

Don’t forget about the shortcut keys: Ctrl+B for toggling on and off bold in the cell selection, Ctrl+I for toggling on and off italics, and Ctrl+U for toggling on and off underlining for quickly adding or removing these attributes from the entries in the cell selection.
Formatting Cells Close to the Source with the Mini Toolbar

Excel 2007 makes it easy to apply common formatting changes to a cell selection right within the Worksheet area thanks to its new mini toolbar feature (nicknamed the mini-bar — makes me thirsty just thinking about it!).

To display the mini-bar, select the cells that need formatting and then right-click somewhere in the cell selection. The mini toolbar then appears immediately above the cell selection’s shortcut menu (see Figure 3-8).

As you can see in this figure, the mini-bar contains most of the buttons from the Font group of the Home tab (with the exception of the Underline button). It also contains the Center and Merge and Center buttons from the Alignment group (see “Altering the Alignment” later in this chapter) and the Accounting Number Format, Percent Style, Comma Style, Increase Decimal and Decrease Decimal buttons from the Number group (see “Getting comfortable with the number formats” later in this chapter). Simply click these buttons to apply their formatting to the current cell selection.

In addition, the mini-bar contains the Format Painter button from the Clipboard group of the Home tab that you can use to copy the formatting in the active cell to a cell selection you make (see “Fooling Around with the Format Painter” later in this chapter for details).
Using the Format Cells Dialog Box

Although the command buttons in the Font, Alignment, and Number groups on the Home tab give you immediate access to the most commonly used formatting commands, they do not represent all of Excel’s formatting commands by any stretch of the imagination.

To have access to all the formatting commands, you need to open the Format Cells dialog box by doing any of the following:

- Click the More option at the very bottom of the drop-down menu attached to the Number Format button
- Click the Dialog Box launcher button in the lower-right of the Number group
- Press Ctrl+1

The Format Cells dialog box that this command calls up contains six tabs: Number, Alignment, Font, Border, Fill, and Protection. In this chapter, I show you how to use them all except the Protection tab; for information on that tab, see Chapter 6.

The keystroke shortcut that opens the Format Cells dialog box — Ctrl+1 — is one worth knowing. Just keep in mind that the keyboard shortcut is pressing the Ctrl key plus the number 1 key, and not the function key F1.

Getting comfortable with the number formats

As I explain in Chapter 2, how you enter values into a worksheet determines the type of number format that they get. Here are some examples:

- If you enter a financial value complete with the dollar sign and two decimal places, Excel assigns a Currency number format to the cell along with the entry.
- If you enter a value representing a percentage as a whole number followed by the percent sign without any decimal places, Excel assigns to the cell the Percentage number format that follows this pattern along with the entry.
- If you enter a date (dates are values, too) that follows one of the built-in Excel number formats, such as 11/06/02 or 06-Nov-02, the program assigns a Date number format that follows the pattern of the date along with a special value representing the date.
Although you can format values in this manner as you go along (which is necessary in the case of dates), you don’t have to do it this way. You can always assign a number format to a group of values before or after you enter them. And, in fact, formatting numbers after you enter them is often the most efficient way to go because it’s just a two-step procedure:

1. Select all the cells containing the values that need dressing up.
2. Select the number format that you want to use either from the formatting command buttons on the Home tab or the options available on the Number tab in the Format Cells dialog box.

Even if you’re a really, really good typist and prefer to enter each value exactly as you want it to appear in the worksheet, you still have to resort to using number formats to make the values that are calculated by formulas match the others you enter. This is because Excel applies a General number format (which the Format Cells dialog box defines: “General format cells have no specific number format.”) to all the values it calculates as well as any you enter that don’t exactly follow one of the other Excel number formats. The biggest problem with the General format is that it has the nasty habit of dropping all leading and trailing zeros from the entries. This makes it very hard to line up numbers in a column on their decimal points.

You can view this sad state of affairs in Figure 3-9, which is a sample worksheet with the first-quarter 2008 sales figures for Mother Goose Enterprises before any of the values have been formatted. Notice how the numbers in the monthly sales figures columns zig and zag because they don’t align according to decimal place. This is the fault of Excel’s General number format; the only cure is to format the values with another more uniform number format.

![Figure 3-9: Numbers with decimals don’t align when you choose General formatting.](image-url)
Accenting your cells with the Accounting Number format

Given the financial nature of most worksheets, you probably use the Accounting Number format more than any other. This is a really easy format to apply because you can assign it to the cell selection simply by clicking the Accounting Number Format button on the Home tab.

Remember that the Accounting Number format adds a dollar sign, commas between thousands of dollars, and two decimal places to any values in a selected range. If any of the values in the cell selection are negative, this number format displays them in parentheses (the way accountants like them). If you want a minus sign in front of your negative financial values rather enclose them in parentheses, select the Currency format on the Number Format drop-down menu or on the Number tab of the Format Cells dialog box.

You can see in Figure 3-10 only the cells containing totals are selected (cell ranges E3:E10 and B10:D10). This cell selection was then formatted with the Accounting Number Format by simply clicking its command button (the one with the $ icon, naturally) in the Number group on the Ribbon’s Home tab.

Although you could put all the figures in the table into the Accounting Number Format to line up the decimal points, this would result in a superabundance of dollar signs in a fairly small table. In this example, I only formatted the monthly and quarterly totals à la Accounting Number format.
“Look, Ma, no more format overflow!”

When I apply the Accounting Number format to the selection in the cell ranges of E3:E10 and B10:D10 in the sales table shown in Figure 3-10, Excel not only adds dollar signs, commas between the thousands, a decimal point, and two decimal places to the highlighted values, but also, at the same time, automatically widens columns B, C, D, and E just enough to display all this new formatting. In versions of Excel earlier than Excel 2003, you’d have had to widen these columns yourself, and instead of the perfectly aligned numbers, you would have been confronted with columns of #######s in cell ranges E3:E10 and B10:D10. Such pound signs (where nicely formatted dollar totals should be) serve as overflow indicators, declaring that whatever formatting you added to the value in that cell has added so much to the value’s display that Excel can no longer display it within the current column width.

Fortunately, Excel eliminates the format overflow indicators when you’re formatting the values in your cells by automatically widening their columns. The only time you’ll ever run across these dreaded #######s in your cells is when you take it upon yourself to manually narrow a worksheet column (see the section “Calibrating Columns,” later in this chapter) to such an extent that Excel can no longer display all the characters in its cells with formatted values.

Currying your cells with the Comma Style

The Comma Style format offers a good alternative to the Currency Style format. Like Currency, the Comma format inserts commas in larger numbers to separate thousands, hundred thousands, millions, and . . . well, you get the idea.

This format also displays two decimal places and puts negative values in parentheses. What it doesn’t display is dollar signs. This makes it perfect for formatting tables where it’s obvious that you’re dealing with dollars and cents or for larger values that have nothing to do with money.

The Comma Style format also works well for the bulk of the values in the sample first-quarter sales worksheet. Check out Figure 3-11 to see this table after I format the cells containing the monthly sales for each Mother Goose company with the Comma Style format. To do this, select the cell range B3:D9 and click the Comma Style button — the one with the comma icon (,) — in the Number group on the Home tab.

Note how, in Figure 3-11, that the Comma Style format takes care of the earlier decimal alignment problem in the quarterly sales figures. Moreover, Comma Style-formatted monthly sales figures align perfectly with the Currency style-formatted monthly totals in row 10. If you look really closely (you may need a magnifying glass for this one), you see that these formatted
values no longer abut the right edges of their cells; they’ve moved slightly to the left. The gap on the right between the last digit and the cell border accommodates the right parenthesis in negative values, ensuring that they, too, align precisely on the decimal point.

---

**Playing around with the Percent Style**

Many worksheets use percentages in the form of interest rates, growth rates, inflation rates, and so on. To insert a percentage in a cell, type the percent sign (%) after the number. To indicate an interest rate of 12 percent, for example, you enter **12%** in the cell. When you do this, Excel assigns a Percent Style number format and, at the same time, divides the value by 100 (that’s what makes it a percentage) and places the result in the cell (0.12 in this example).

Not all percentages in a worksheet are entered by hand in this manner. Some may be calculated by a formula and returned to their cells as raw decimal values. In such cases, you should add a Percent format to convert the calculated decimal values to percentages (done by multiplying the decimal value by 100 and adding a percent sign).

The sample first-quarter-sales worksheet just happens to have some percentages calculated by formulas in row 12 that need formatting (these formulas indicate what percentage each monthly total is of the first-quarter total in cell E10). In Figure 3-12, these values reflect Percent Style formatting. To accomplish this feat, you simply select the cells and click the Percent Style button in the Number group on the Home tab. (Need I point out that it’s the button with the % symbol?)
Deciding how many decimal places

You can increase or decrease the number of decimal places used in a number entered with the Accounting Number Format, Comma Style, or Percent Style button in the Number group of the Home tab simply by clicking the Increase Decimal tool or the Decrease Decimal button in this group.

Each time you click the Increase Decimal button (the one with the arrow pointing left), Excel adds another decimal place to the number format you apply. Percentages appear in the cell range B12:D12 (see Figure 3-13) after I increase the number of decimal places in the Percent format from none to two. (Note that the Percent Style doesn’t use any decimal places.) I accomplish this by clicking the Increase Decimal button twice.

The values behind the formatting

Make no mistake about it — all that these fancy number formats do is spiff up the presentation of the values in the worksheet. Like a good illusionist, a particular number format sometimes appears to magically transform some entries; but in reality, the entries are the same old numbers you started with. For example, suppose that a formula returns the following value:

25.6456
Now suppose that you format the cell containing this value with the Accounting Number Format button on the Home tab. The value now appears as follows:

$25.65

This change may lead you to believe that Excel rounded the value up to two decimal places. In fact, the program has rounded up only the display of the calculated value — the cell still contains the same old value of 25.6456. If you use this cell in another worksheet formula, keep in mind that Excel uses the behind-the-scenes value in its calculation, not the spiffed-up one shown in the cell.

But what if you want the values to match their formatted appearance in the worksheet? Well, Excel can do that in a single step. Be forewarned, however, that this is a one-way trip. You can convert all underlying values to the way they are displayed by selecting a single check box, but you can’t return them to their previous state by deselecting this check box.

Well, because you insist on knowing this little trick anyway, here goes (just don’t write and try to tell me that you weren’t warned):

1. **Make sure that you format all the values in your worksheet with the right number of decimal places.**

   You must do this step before you convert the precision of all values in the worksheet to their displayed form.
2. Click Microsoft Office Button | Excel Options | Advanced or press Alt+FIA to open the Advanced tab of Excel Options dialog box.

3. In the When Calculating This Workbook section, click the Set Precision as Displayed check box (to fill it with a check mark) and click OK.

Excel displays the Data Will Permanently Lose Accuracy alert dialog box.

4. Go ahead (live dangerously) and click the OK button or press Enter to convert all values to match their display.

Save the workbook with the calculated values. Then, after converting all the values in a worksheet by selecting the Set Precision as Displayed check box, open the Save As dialog box (click Office Button | Save As or press Alt+FA) and edit the filename in the File Name text box (maybe by appending as Displayed to the current filename) before you click the Save button or press Enter. That way, you’ll have two copies: the original workbook file with the values as entered and calculated by Excel and the new as Displayed version.

**Make it a date!**

In Chapter 2, I mention that you can easily create formulas that calculate the differences between the dates and times that you enter in your worksheets. The only problem is that when Excel subtracts one date from another date or one time from another time, the program automatically formats the calculated result in a corresponding date or time number format as well. So, for example, if you enter 8-15-08 in cell B4 and 4/15/08 in cell C4 and in cell E4 enter the following formula for finding the number of elapsed days between the two dates:

\[
\text{=B4-C4}
\]

Excel returns the result of 122 disguised as 5/1/1900 in cell E4. To reformat the result, you need to assign the General number format to the cell — you can do this quickly by selecting the cell and then pressing Ctrl-Shift+- (tilde) or not so quickly by clicking General on the Number Format drop-down list on the Home tab. When you assign the General format to this cell, the value 122 replaces 5/1/1900, indicating that 122 days have elapsed between the two dates.

Likewise, when dealing with formulas that calculate the difference between two times in a worksheet, you also have to reformat the result that appears in a corresponding time format into the General format. For example, suppose
that you enter 8:00 AM in cell C8 and 4:00 PM in cell D8 and then create in cell E8 the following formula for calculating the difference in hours between the two times:

\[=D8-C8\]

You still have to convert the result in cell E8 — that automatically appears as 8:00 AM — to the General format. When you do this, the fraction 0.333333 — representing its fraction of the total 24-hour period — replaces 8:00 AM in cell E8. You can then convert this fraction of a total day into the corresponding number of hours by multiplying this cell by 24.

**Ogling some of the other number formats**

Excel supports many more number formats than just the Accounting Number, Comma Style, and Percent Style formats. To use them, select the cell range (or ranges) you want to format and select Format Cells on the cell shortcut menu (right-click somewhere in the cell selection to activate this menu) or just press Ctrl+1 to open the Format Cells dialog box.

After the Format Cells dialog box opens, click the Number tab and select the desired format from the Category list box. Some Number format categories — such as Date, Time, Fraction, and Special — give you further formatting choices in a Type list box. Other number formats, such as Number and Currency, have their own particular boxes that give you options for refining their formats. When you click the different formats in these list boxes, Excel shows what effect this would have on the first of the values in the current cell selection in the Sample area above. When the sample has the format that you want to apply to the current cell selection, you just click OK or press Enter to apply the new number format.

Excel contains a nifty category of number formats called Special. The Special category contains the following four number formats that may interest you:

- **Zip Code**: Retains any leading zeros in the value (important for zip codes and of absolutely no importance in arithmetic computations). Example: 00123.

- **Zip Code + 4**: Automatically separates the last four digits from the first five digits and retains any leading zeros. Example: 00123-5555.

- **Phone Number**: Automatically encloses the first three digits of the number in parentheses and separates the last four digits from the previous three with a dash. Example: (999) 555-1111.
Social Security Number: Automatically puts dashes in the value to separate its digits into groups of three, two, and four. Example: 666-00-9999.

These Special number formats really come in handy when creating databases in Excel, which often deal with stuff like zip codes, telephone numbers, and sometimes even Social Security Numbers (see Chapter 9 for more on creating databases).

Calibrating Columns

For those times when Excel 2007 doesn’t automatically adjust the width of your columns to your complete satisfaction, the program makes your changing the column widths a breeze. The easiest way to adjust a column is to do a best-fit, using the AutoFit feature. With this method, Excel automatically determines how much to widen or narrow the column to fit the longest entry currently in the column.

Here’s how to use AutoFit to get the best-fit for a column:

1. Position the mouse pointer on the right border of the worksheet frame with the column letter at the top of the worksheet.
   The mouse pointer changes to a double-headed arrow pointing left and right.

2. Double-click the mouse button.
   Excel widens or narrows the column width to suit the longest entry.

You can apply a best-fit to more than one column at a time. Simply select all the columns that need adjusting (if the columns neighbor one another, drag through their column letters on the frame; if they don’t, hold down the Ctrl key while you click the individual column letters). After you select the columns, double-click any of the right borders on the frame.

Best-fit à la AutoFit doesn’t always produce the expected results. A long title that spills into several columns to the right produces an awfully wide column when you use best-fit.

When AutoFit’s best-fit won’t do, drag the right border of the column (on the frame) until it’s the size you need instead of double-clicking it. This manual technique for calibrating the column width also works when more than one column is selected. Just be aware that all selected columns assume whatever size you make the one that you’re actually dragging.
You can also set the widths of columns from the Format button’s drop-down list in the Cells group on the Home tab. When you click this drop-down button, the Cell Size section of this drop-down menu contains the following width options:

- **Column Width** to open the Column Width dialog box you enter the number of characters that you want for the column width before you click OK
- **AutoFit Column Width** to have Excel apply best-fit to the columns based on the widest entries in the current cell selection
- **Default Width** to open the Standard Width dialog box containing the standard column width of 8.43 characters that you can apply to the columns in the cell selection

**Rambling rows**

The story with adjusting the heights of rows is pretty much the same as that with adjusting columns except that you do a lot less row adjusting than you do column adjusting. That’s because Excel automatically changes the height of the rows to accommodate changes to their entries, such as selecting a larger font size or wrapping text in a cell. I discuss both of these techniques in the upcoming section “Altering the Alignment.” Most row-height adjustments come about when you want to increase the amount of space between a table title and the table or between a row of column headings and the table of information without actually adding a blank row. (See the section “From top to bottom,” later in this chapter, for details.)

To increase the height of a row, drag the bottom border of the row frame down until the row is high enough and then release the mouse button. To shorten a row, reverse this process and drag the bottom row-frame border up. To use AutoFit to create a best-fit for the entries in a row, you double-click the bottom row frame border.

As with columns, you can also adjust the height of selected rows using row options in the Cells section on the Format button’s drop-down menu on the Home tab:

- **Row Height** to open the Row Height dialog box where you enter the number of characters in the Row Height text box and click OK
- **AutoFit Row Height** to return the height of selected rows to the best fit
Now you see it, now you don’t

A funny thing about narrowing columns and rows: You can get too carried away and make a column so narrow or a row so short that it actually disappears from the worksheet! This can come in handy for those times when you don’t want part of the worksheet visible. For example, suppose you have a worksheet that contains a column listing employee salaries — you need these figures to calculate the departmental budget figures, but you would prefer to leave sensitive info off most printed reports. Rather than waste time moving the column of salary figures outside the area to be printed, you can just hide the column until after you print the report.

Hiding worksheet columns

Although you can hide worksheet columns and rows by just adjusting them out of existence, Excel does offer an easier method of hiding them, via the Hide & Unhide option on the Format button’s drop-down menu (located in the Cells group of the Home tab). Suppose that you need to hide column B in the worksheet because it contains some irrelevant or sensitive information that you don’t want printed. To hide this column, you could follow these steps:

1. Click anywhere in column B to select the column.
2. Click the drop-down button attached to the Format button in the Cells group on the Home tab.
   Excel opens the Format button’s drop-down menu.
3. Click Hide & Unhide | Hide Columns on the drop-down menu.
   That’s all there is to it — column B goes poof! All the information in the column disappears from the worksheet. When you hide column B, notice that the row of column letters in the frame now reads A, C, D, E, F, and so forth.

You could just as well have hidden column B by clicking its column letter on the frame with the secondary mouse button and then clicking the Hide command on the column’s shortcut menu.

So now, suppose that you’ve printed the worksheet and need to make a change to one of the entries in column B. To unhide the column, follow these steps:

1. Position the mouse pointer on column letter A in the frame and drag the pointer right to select both columns A and C.
   You must drag from A to C to include hidden column B as part of the column selection — don’t click while holding down the Ctrl key or you won’t get B.
2. Click the drop-down button attached to the Format button in the Cells group on the Home tab.

3. Click Hide & Unhide | Unhide Columns on the drop-down menu.

Excel brings back the hidden B column, and all three columns (A, B, and C) are selected. You can then click the mouse pointer on any cell in the worksheet to deselect the columns.

You could also unhide column B by selecting columns A and C, clicking either one of them with the secondary mouse button, and then clicking the Unhide command on the column shortcut menu.

**Hiding worksheet rows**

The procedure for hiding and unhiding rows of the worksheet is essentially the same as for hiding and unhiding columns. The only difference is that after selecting the rows to hide, you click Hide & Unhide | Hide Rows on the Format button’s drop-down menu and Hide & Unhide | Unhide Rows to bring them back.

Don’t forget that you can use the Hide and Unhide options on the rows’ shortcut menu to make selected rows disappear and then reappear in the worksheet.

**Futzing with the Fonts**

When you start a new worksheet, Excel 2007 assigns a uniform font and type size to all the cell entries you make. The default font varies according to the version of Windows under which you’re running Excel. When you run Excel on Windows Vista, Excel uses its new Calibri font (the so-called Body Font) in 11-point size, and when running Excel under Windows XP, it uses its standard Arial font in a 10-point size. Although these two fonts may be fine for normal entries, you may want to use something with a little more zing for titles and headings in the worksheet.

If you don’t especially care for the standard font that Excel uses on your version of Windows, modify it by from the Personalize tab of the Excel Options dialog box (click Office Button | Excel Options | Popular or press Alt+FIP). Look for the Use This Font drop-down list box in the When Creating New Workbooks section and then click the new standard font you want from its drop-down list. If you want a different type size, choose the Font Size drop-down list box and click a new point size on its drop-down menu or enter the new point size for the standard font directly into the Font Size text box.

Using the buttons in the Font group on the Home tab, you can make most font changes (including selecting a new font style or new font size) without
having to resort to changing the settings on the Font tab in the Format Cells
dialog box (Ctrl+1):

✔ To select a new font for a cell selection, click the drop-down button next
to the Font combo box and then select the name of the font you want to
use from the list box — note that Excel displays the name of each font
that appears in this list box in the actual font named (so that the font
name becomes an example of what the font looks like — on-screen
anyway)

✔ To change the font size, click the drop-down button next to the Font Size
combo box; then select the new font size or click the Font Size text box,
type the new size, and press Enter

You can also add the attributes of bold, italics, underlining, or strikethrough
to the font you use. The Font group of the Home tab contains the Bold, Italic,
and Underline buttons, which not only add these attributes to a cell selection
but remove them as well. After you click any of these attribute tools, notice
that the tool becomes shaded whenever you position the cell cursor in the cell
or cells that contain that attribute. When you click an outlined format button to
remove an attribute, Excel no longer shades the attribute button when you
select the cell.

Although you’ll probably make most font changes with the toolbars, on rare
occasions you may find it more convenient to make these changes from the
Font tab in the Format Cells dialog box (Ctrl+1).

As you can see in Figure 3-14, this Font tab in the Format Cells dialog box brings
together under one roof fonts, font styles (bold and italics), effects (underlining
and strikethrough), and color changes. When you want to make a lot of font-
related changes to a cell selection, working in the Font tab may be your best
bet. One of the nice things about using this tab is that it contains a Preview box
that shows you how your font changes appear (on-screen at least).
To change the color of the entries in a cell selection, click the Font Color button’s drop-down menu in the Font group on the Home tab and then select the color you want the text to appear in the drop-down palette. Keep in mind that you can use Live Preview to see what the entries in the cell selection look like in a particular font color by moving the mouse pointer over the color swatches in the palette before you select one by clicking it (assuming, of course, that the palette doesn’t cover the cells).

If you change font colors and then print the worksheet with a black-and-white printer, Excel renders the colors as shades of gray. The Automatic option at the top of the Font button’s drop-down menu picks up the color assigned in Windows as the window text color. This color is black unless you change it on the Advanced Appearance tab of the Display Properties dialog box in Windows Vista and XP. (For help on this subject, please see Microsoft Windows XP For Dummies or Microsoft Windows Vista For Dummies both by Andy Rathbone, from Wiley Publishing, Inc. — and be sure to tell Andy that Greg sent ya!)

**Altering the Alignment**

The horizontal alignment assigned to cell entries when you first make them is simply a function of the type of entry it is: All text entries are left-aligned, and all values are right-aligned with the borders of their cells. You can, however, alter this standard arrangement anytime it suits you.

The Alignment group of the Home tab contains three normal horizontal alignment tools: the Align Left, Center, and Align Right buttons. These buttons align the current cell selection exactly as you expect them to. On the right side of the Alignment group, you usually find the special alignment button called Merge and Center.

Despite its rather strange name, you’ll want to get to know this button. You can use it to center a worksheet title across the entire width of a table in seconds (or faster, depending upon your machine). I show you in Figures 3-15 and 3-16 how you can use this tool. In Figure 3-15, notice that the worksheet title Mother Goose Enterprises – 2008 Sales is in cell A1. Because it’s a long text entry, it spills over to the empty cell to the right (B1). To center this title over the table (which extends from column A through E), select the cell range A1:E1 (the width of the table) and then click the Merge and Center button in the Alignment group on the Ribbon’s Home tab.
Look at Figure 3-16 to see the result: The cells in row 1 of columns A through E are merged into one cell, and now the title is properly centered in this supercell and consequently over the entire table.
If you ever need to split up a supercell that you’ve merged with the Merge and Center back into its original, individual cells, select the cell, and then simply click the Merge and Center button in the Alignment group on the Home tab again. You can also do this by clicking the drop-down button attached to the Merge and Center button on the Home tab and then clicking Unmerge Cells on this drop-down menu (a few more steps, I’d say!).

**Intent on indents**

In Excel 2007, you can indent the entries in a cell selection by clicking the Increase Indent button on the Formatting toolbar. The Increase Indent button in the Alignment group of the Home tab sports a picture of an arrow pushing the lines of text to the right. Each time you click this button, Excel indents the entries in the current cell selection to the right by one character width of the standard font. (See the section “Futzing with the Fonts,” earlier in this chapter, if you don’t know what a standard font is or how to change it.)

You can remove an indent by clicking the Decrease Indent button (to the immediate left of the Increase Indent button) on the Home tab with the picture of the arrow pushing the lines of text to the left. Also, you can change how many characters an entry is indented with the Increase Indent button or outdented with the Decrease Indent button. Open the Format Cells dialog box (Ctrl+1). Select the Alignment tab, and then alter the value in the Indent text box (by typing a new value in this text box or by dialing up a new value with its spinner buttons).

**From top to bottom**

*Left, right,* and *center* alignment all refer to the horizontal positioning of a text entry in relation to the left and right cell borders (that is, horizontally). You can also align entries in relation to the top and bottom borders of their cells (that is, vertically). Normally, all entries are vertically aligned with the bottom of the cells (as though they were resting on the very bottom of the cell). You can also vertically center an entry in its cell or align it with the top of its cell.

To change the vertical alignment of a cell range that you’ve selected, click the appropriate button (Top Align, Middle Align, or Bottom Align) in the Alignment group on the Home tab.
Figure 3-17 shows the title for the 2008 Mother Goose Enterprises sales worksheet after centering it vertically in its cell by clicking the Middle Align button on the Home tab. (This text entry was previously centered across the cell range A1:E1; the height of row 1 is increased from the normal 12.75 characters to 36 characters.)

**Tampering with how the text wraps**

Traditionally, column headings in worksheet tables have been a problem — you either had to keep them really short or abbreviate them if you wanted to avoid widening all the columns more than the data warranted. You can avoid this problem in Excel by using the Wrap Text button in the Alignment group on the Home tab (the one to the immediate right of the Increase Indent button). In Figure 3-18, I show a new worksheet in which the column headings containing the various Mother Goose companies use the Wrap Text feature to avoid widening the columns as much as these long company names would otherwise require.

To create the effect shown in Figure 3-18, select the cells with the column headings (the cell range B2:H2) and then click the Wrap Text button in the Alignment group on the Home tab.
Selecting Wrap Text breaks up the long text entries in the selection (that either spill over or are cut off) into separate lines. To accommodate more than one line in a cell, the program automatically expands the row height so that the entire wrapped-text entry is visible.

When you select Wrap Text, Excel continues to use the horizontal and vertical alignment you specify for the cell. Note that you can use any of the Horizontal alignment options found on the Alignment tab of the Format Cells dialog box (Ctrl+1), including Left (Indent), Center, Right (Indent), Justify, or Center Across Selection. You can’t, however, use the Fill option or Distributed (Indent) option. Select the Fill option on the Horizontal drop-down list box only when you want Excel to repeat the entry across the entire width of the cell.

If you want to wrap a text entry in its cell and have Excel justify the text with both the left and right borders of the cell, select the Justify option from the Horizontal pop-up menu in the Alignment tab in the Format Cells dialog box.

You can break a long text entry into separate lines by positioning the insertion point in the cell entry (or on the Formula bar) at the place where you want the new line to start and pressing Alt+Enter. Excel expands the row containing the cell (and the Formula bar above) when it starts a new line. When you press Enter to complete the entry or edit, Excel automatically wraps the text in the cell, according to the cell’s column width and the position of the line break.
Reorienting cell entries

Instead of wrapping text entries in cells, you may find it more beneficial to change the orientation of the text by rotating the text up (in a counterclockwise direction) or down (in a clockwise direction). Peruse Figure 3-19 for a situation where changing the orientation of the wrapped column headings works much better than just wrapping them in their normal orientation in the cells.

This example shows the same column headings for the sample order form I introduce in Figure 3-19 after rotating them 90 degrees counterclockwise. Notice that switching to this orientation allows their columns to be narrower than when displayed in the normal orientation.

To make this switch, first select the cell range B2:H2. Next, click the drop-down button attached to the Orientation button in the Alignment group on the Home tab and then click the Rotate Text Up option on this drop-down menu.

Figure 3-20 shows the same headings rotated up at a 45-degree angle. To create what you see in this figure, you click the Angle Counterclockwise option on the Orientation button’s drop-down menu after making the same cell selection, B2:H2.

If you need to set the rotation of the entries in a spreadsheet at angles other than 45 and 90 degrees (up or down), you need to click the Format Cell Selection option on the Orientation button’s drop-down menu to open the Alignment tab of the Format Cells dialog box (or press Ctrl+1 and click the Alignment tab) and then use the controls in the Orientation section to set the angle and number of degrees.
To set a new angle, enter the number of degrees in the Degrees text box, click the appropriate place on the semicircular diagram, or drag the line extending from the word Text in the diagram to the desired angle.

To angle text up using the Degrees text box, enter a positive number between 1 and 45 in the text box. To angle the text down, enter a negative number between -1 and -45.

To set the text vertically so that each letter is above the other in a single column, click the Vertical Text option on the Orientation button’s drop-down menu on the Home tab.

**Shrink to fit**

For those times when you need to prevent Excel from widening the column to fit its cell entries (as might be the case when you need to display an entire table of data on a single screen or printed page), use the Shrink to Fit text control.

Click the Alignment tab of the Format Cells dialog box (Ctrl+1) and then click the Shrink to Fit check box in Text Control section. Excel reduces the font size of the entries to the selected cells so that they don’t require changing the current column width. Just be aware when using this Text Control option that, depending the length of the entries and width of the column, you can end up with some text entries so small that they’re completely illegible!
**Bring on the borders!**

The gridlines you normally see in the worksheet to separate the columns and rows are just guidelines to help you keep your place as you build your spreadsheet. You can choose to print them with your data or not (by checking or clearing the Print check box in the Gridlines section on the Page Layout tab).

To emphasize sections of the worksheet or parts of a particular table, you can add borderlines or shading to certain cells. Don’t confuse the borderlines that you add to accent a particular cell selection with the gridlines normally used to define cell borders in the worksheet — borders that you add are printed whether or not you print the worksheet gridlines.

To better see the borders that you add to the cells in a worksheet, remove the gridlines normally displayed in the worksheet by clearing the View check box in the Gridlines section on the Page Layout tab.

To add borders to a cell selection, click the drop-down button attached to the Borders button in the Font group on the Home tab. Doing this displays a drop-down menu with all the border options you can apply to the cell selection (see Figure 3-21) where you click the type of line you want to apply to all its cells.

![Figure 3-21: Select borders for a cell selection with the Border tab on the Format Cells dialog box.](image-url)
When selecting options on this drop-down menu determining where you want the borderlines drawn, keep these things in mind:

- To have Excel draw borders only around the outside edges of the entire cell selection (in other words, following the path of the expanded cell cursor), click the Outside Borders or the Thick Box Border option button on this menu.
- If you want borderlines to appear around all four edges of each cell in the cell selection (like a paned window), select the All Borders option on this drop-down menu.

To change the type of line or line thickness or color of the borders you apply to a cell selection, you must open the Format Cells dialog box and use the options on its Border tab (click More Borders at the bottom of the Borders button’s drop-down menu or press Ctrl+1 and then click the Border tab).

To select a new line thickness or line style for a border you’re applying, click its example in the Style section. To change the color of the border you want to apply, click the color sample on the Color drop-down palette. After you select a new line style and/or color, apply the border to the cell selection by clicking the appropriate line in either the Presets or Border section of the Border tab before you click OK.

To get rid of existing borders in a worksheet, you must select the cell or cells that presently contain them and then click the No Border option at the top of the second section on the Borders button’s drop-down menu.

**Applying fill colors, patterns, and gradient effects to cells**

You can also add emphasis to particular sections of the worksheet or one of its tables by changing the fill color of the cell selection and/or applying a pattern or gradient to it.

If you’re using a black-and-white printer, you will want to restrict your color choices to light gray in the color palette. Also, you will want to restrict your use of pattern styles to the very open ones with few dots when enhancing a cell selection that contains any kind of entries (otherwise, the entries will be almost impossible to read when printed).
To just choose a new fill color for the background of a cell selection, you can click the Fill Color button’s drop-down menu in the Font group on the Home tab and then select the color you want to use in the drop-down palette. Remember that you can use Live Preview to see what the cell selection looks like in a particular fill color by moving the mouse pointer over the color swatches. Click one to select it.

To choose a new pattern for a cell selection, you must open the Format Cells dialog box (Ctrl+1), and then click the Fill tab (see Figure 3-22). To change the pattern of the cell selection, click a pattern swatch from the Pattern Style button’s pattern palette. To add a fill color to the pattern you select, click its color swatch in the Background Color section of the Fill tab.

If you want to add a gradient effect to the cell selection that goes from one color to another in a certain direction, click the Fill Effects button on the Fill tab to open the Fill Effects dialog box (see Figure 3-22). This dialog box contains a Gradient tab with controls that enable you to determine the two colors to use as well as shading style and variant.

After you select the colors and styles of the gradient, check the Sample swatch in the Fill Effects dialog box. When you’ve got it the way you want it, click OK to close the Fill Effects dialog box and return to the Format Cells dialog box. The selected gradient effect then appears in its Sample area on the Fill tab in the Format Cells dialog box. Unfortunately, this is one area where Live Preview doesn’t work, so you’re just going to have to click its OK button to apply the gradient to the cell selection to see how it actually looks in the worksheet.
Although you can’t select new patterns or gradients (only colors) with the Fill Color button on the Home tab, you can remove fill colors, patterns, and gradients assigned to a cell selection by clicking the No Fill option on the Fill Color button’s drop-down menu.

**Do It in Styles**

In Excel 2007, cell styles really come alive in the form of the new Cell Styles gallery (see Color Plate12) that you open by clicking the Cells Styles button in the Style group on the Home tab.

The Cell Styles gallery contains loads of readymade styles you can immediately apply to the current cell selection. Simply click the desired style sample in the gallery after using the Live Preview feature to determine which style looks best on your data.

**Creating a new style for the gallery**

To create a new style for the gallery by example, manually format a single cell with all the attributes you want (font, font size, font color, bold, italic, underlining, fill color, pattern, borders, orientation, and so on) and then click Cell Styles button on the Home tab followed by the New Cell Style at the bottom of the gallery. Excel then opens a Style dialog box where you replace the generic style name (Style 1, Style 2, and so on) with your own descriptive name. Click OK.

Excel then adds a sample of your new style — the style name formatted, with the new style’s attributes — to a Custom section at the top of the Cell Style gallery. To then apply this custom style to a cell selection, you only have to click its sample in the Custom section of the Cells Styles gallery.

The custom cell styles you create don’t become part the current workbook until the next time you save the workbook so you need to remember to click the Save button on the Quick Access toolbar or press Ctrl+S to save your changes after creating a new cell style if want that style to remain part of the workbook’s Cell Styles gallery the next time you open the workbook in Excel.

**Copying custom styles from one workbook into another**

Excel makes it easy to copy custom cell styles that you’ve saved as part one workbook into the workbook you’re currently working on. To copy custom styles from workbook to another, follow these steps:
1. Open the workbook that needs the custom styles added to it from another existing workbook.

   This can be a brand new workbook or one that you’ve opened for editing (see Chapter 4).

2. Open the workbook which has the custom styles you want to copy saved as part of it.

   See the previous section, “Creating a new style for the gallery” for tips on how to create and save cell styles.

3. Switch back to the workbook into which you want to copy the saved custom styles.

   You can do this by clicking the workbook’s button on the Windows Vista or XP taskbar or using the Flip feature by pressing Alt+Tab until you select the workbook’s thumbnail in the center of the desktop.

4. Click the Cell Styles button on the Home tab followed by Merge Styles in the Cell Styles gallery or press Alt+HY2M to open the Merge Styles dialog box.

5. Click the name of the open workbook file that contains the custom styles to copy in the Merge Styles From list box and then click OK.

After you close the Merge Styles dialog box, Excel adds all the custom styles from the designated workbook into the current workbook adding it to the Custom section of its Cell Styles gallery. To retain the custom styles you just imported, save the current workbook (Save button on the Quick Access toolbar or Ctrl+S). Then, you can switch back to the workbook containing the original custom styles you just copied and close its file (Alt+FC).

**Fooling Around with the Format Painter**

Using cell styles to format ranges of worksheet cells is certainly the way to go when you have to apply the same formatting over and over again in the workbooks you create. However, there may be times when you simply want to reuse a particular cell format and apply it to particular groups of cells in a single workbook without ever bothering to open the Cells Styles Gallery.

For those occasions when you feel the urge to format on the fly (so to speak), use the Format Painter button (the paintbrush icon) in the Clipboard group on the Home tab. This wonderful little tool enables you to take the formatting from a particular cell that you fancy up and apply its formatting to other cells in the worksheet simply by selecting those cells.
To use the Format Painter to copy a cell’s formatting to other worksheet cells, just follow these easy steps:

1. **Format an example cell or cell range in your workbook, selecting whatever fonts, alignment, borders, patterns, and color you want it to have.**

2. **With the cell cursor in one of the cells you just fancied up, click the Format Painter button in the Clipboard group on the Home tab.**
   
The mouse pointer changes from the standard thick, white cross to a thick, white cross with an animated paintbrush by its side, and you see a marquee around the selected cell with the formatting to be used by the Format Painter.

3. **Drag the white-cross-plus-animated-paintbrush pointer (the Format Painter pointer) through all the cells you want to format in the same manner as the example cell you first selected.**
   
   As soon as you release the mouse button, Excel applies all the formatting used in the example cell to all the cells you just selected!

To keep the Format Painter selected so that you can format a bunch of different cell ranges with the Format Painter pointer, double-click the Format Painter button on the Home tab after you select the sample cell with the desired formatting. To stop formatting cells with the Format Painter pointer, you simply click the Format Painter button on the Home tab (it remains selected when you double-click it) again to restore the button to its unselected state and return the mouse pointer to its normal thick, white-cross shape.

Note that you can use the Format Painter to restore a cell range that you gussied all up back to its boring default (General) cell format. To do this, click an empty, previously unformatted cell in the worksheet before you click the Format Painter button and then use the Format Painter pointer to drag through the cells you want returned to the default General format.
Chapter 4
Going through Changes

In This Chapter

- Opening workbook files for editing
- Undoing your boo-boos
- Moving and copying with drag and drop
- Copying formulas
- Moving and copying with Cut, Copy, and Paste
- Deleting cell entries
- Deleting and inserting columns and rows
- Spell-checking the worksheet
- Corroborating cell entries in a worksheet with the Text to Speech feature

Picture this: You just finished creating, formatting, and printing a major project with Excel — a workbook with your department’s budget for the next fiscal year. Because you finally understand a little bit about how the Excel thing works, you finish the job in crack time. You’re actually ahead of schedule.

You turn the workbook over to your boss so that she can check the numbers. With plenty of time for making those inevitable last-minute corrections, you’re feeling on top of this situation.

Then comes the reality check — your boss brings the document back, and she’s plainly agitated. “We forgot to include the estimates for the temps and our overtime hours. They’ve got to go right here. While you’re adding them, can you move these rows of figures up and those columns over?”

As she continues to suggest improvements, your heart begins to sink. These modifications are in a different league than, “Let’s change these column headings from bold to italics and add shading to that row of totals.” Clearly, you’re looking at a lot more work on this baby than you had contemplated. Even worse, you’re looking at making structural changes that threaten to unravel the very fabric of your beautiful worksheet.
As the preceding fable points out, editing a worksheet in a workbook can occur on different levels:

- You can make changes that affect the contents of the cells, such as copying a row of column headings or moving a table to a new area in a particular worksheet.
- You can make changes that affect the structure of a worksheet itself, such as inserting new columns or rows (so that you can enter new data originally left out) or deleting unnecessary columns or rows from an existing table so that you don’t leave any gaps.
- You can even make changes to the number of worksheets in a workbook (either by adding or deleting sheets).

In this chapter, you discover how to safely make all these types of changes to a workbook. As you see, the mechanics of copying and moving data or inserting and deleting rows are simple to master. It’s the impact that such actions have on the worksheet that takes a little more effort to understand. Not to worry! You always have the Undo feature to fall back on for those (hopefully rare) times when you make a little tiny change that throws an entire worksheet into complete and utter chaos.

In the final section of this chapter (“Stamping Out Errors with Text to Speech”), find out how to use the Text to Speech feature to check out and confirm the accuracy of the data entries you make in your worksheets. With Text to Speech, you can listen as your computer reads back a series of cell entries as you visually corroborate their accuracy from the original source document. Text to Speech can make this sort of routine and otherwise labor-intensive editing much easier and greatly increase the accuracy of your spreadsheets.

Opening the Darned Thing Up for Editing

Before you can do any damage — I mean, make any changes — in a workbook, you have to open it up in Excel. To open a workbook, you can click Office Button | Open or press Alt+FO or use the old standby keyboard shortcuts Ctrl+O or Ctrl+F12.

The Open dialog box in Excel 2007 running on Windows Vista

If you’re running Excel 2007 under Windows Vista, an Open dialog box very much like the one in Figure 4-1 appears. This dialog box is divided into panes:
the Navigation Pane on the left where you can select a new folder to open and the main pane on the right showing the icons for all the subfolders in the current folder as well as the documents that Excel can open.

![Image of Open dialog box]

This current folder whose contents is displayed in the Open dialog box is either the one designated as the Default File Location on the Save tab of the Excel Options dialog box or the folder you last opened during your current Excel work session.

To open a workbook in another folder, click its link in the Favorite Links section of the Navigation pane or click the Expand Folders button (the one with the triangle pointing upward) and click its folder in this list.

If you open a new folder and it appears empty of all files (and you know that it’s not an empty folder), this just means the folder doesn’t contain any of the types of files that Excel can open directly (such as workbooks, template files, and macro sheets). To display all the files whether or not Excel can open them directly (meaning without some sort of conversion), click the drop-down button that appears next to the drop-down list box that currently contains Microsoft Office Excel Files and click All Files on its drop-down menu.

When the icon for the workbook file you want to work with appears in the Open dialog box, you can then open it either by clicking its file icon and then clicking the Open button or, if you’re handy with the mouse, by just double-clicking the file icon.

You can use the slider attached to the Views drop-down list button in the Open dialog box to change the way folder and file icons appear in the dialog box. When you select Large Icons or Extra Large Icons on this slider (or anywhere in between), the Excel workbook icons actually show a preview of the
data in the upper-left corner of the first worksheet when the file is saved with
the preview picture option turned on:

✔ To enable the preview feature when saving workbooks in Excel 2007,
select the Save Thumbnails check box in the Save As dialog box before
saving the file for the first time.

✔ To enable the preview feature when saving workbooks in Excel 97
through 2003, click the Save Preview Picture check box on the Summary
tab of the workbook's Properties dialog box selected (File ➤ Properties)
before saving the file for the first time.

This preview of part of the first sheet can help you quickly identify the work-
book you want to open for editing or printing.

The Open dialog box in Excel 2007
running on Windows XP

Figure 4-2 shows you the Open dialog box that appears when you run Excel
2007 under Windows XP. This dialog box is divided into two sections: a My
Places panel on the left and a folder and file list box on the right.

Figure 4-2:
Use the
Open dialog
box to find
and open a
workbook
for editing.
When you can’t find the filename you’re looking for in the list box, the first thing you need to do is check to make sure that you’re looking in the right folder — because if you’re not, you’re never going to find the missing file. To tell which folder is currently open, check the Look In drop-down list box at the top of the Open dialog box (refer to Figure 4-2).

If the folder that is currently open is not the one that has the workbook file you need to use, you then need to open the folder that does contain the file. In Excel, you can use the Up One Level button (refer to Figure 4-2) in the Open dialog box to change levels until you see the folder you want to open in the list box. To open the new folder, click its icon in the list box and then click the Open button or press Enter (or you can just double-click its icon).

If the workbook file you want is on another drive, click the Up One Level button until the C: drive icon appears in the Look In drop-down list box. You can then switch drives by clicking the drive icon in the list box and then choosing the Open button or pressing Enter (or you can just double-click the drive icon).

When you locate the file you want to use in the list box in the Open dialog box, open it by clicking its file icon and then clicking the Open button or pressing Enter (or by double-clicking the file icon).

Use the buttons displayed in the My Places panel on the left side of the Open dialog box (My Recent Documents, Desktop, My Documents, My Computer, and My Network Places) to easily open any folders associated with these buttons that contain workbook files:

- **My Recent Documents**: Click this button to open workbook files you save in the Recent folder (located inside the Office folder within the Microsoft folder).

- **Desktop**: Click this folder to open workbook files you save directly on the desktop of your computer.

- **My Documents**: Click this button to open workbook files you save in the Personal folder inside the Windows folder. (In fact, on some computers, the My Documents button in the Excel 200X Open dialog box appears as the Personal button.)

- **My Computer**: Click this button to open workbook files you save in folders on the local disks on your computer.

- **My Network Places**: Click this button to open workbook files you save in folders on the disks attached to your company’s network.
You can select Preview on the Views button’s drop-down menu to display a preview pane on the right side of the Open dialog box. This pane shows data in the upper-left corner of the first worksheet for all workbooks saved when the preview picture option is enabled as described in the Remember tip in the previous section.

**Opening more than one workbook at a time**

If you know that you’re going to edit more than one of the workbook files’ sheets shown in the list box of the Open dialog box, you can select multiple files in the list box and Excel will then open all of them (in the order they’re listed) when you click the Open button or press Enter.

Remember that in order to select multiple files that appear sequentially in the Open dialog box, you click the first filename and then hold down the Shift key while you click the last filename. To select files that are not listed sequentially, you need to hold down the Ctrl key while you click the various filenames.

After the workbook files are open in Excel, you can then switch documents by selecting their filename buttons on the Window taskbar or by using the Flip feature (Alt+Tab) to select the workbook’s thumbnail. (See Chapter 7 for detailed information on working on more than one worksheet at a time.)

**Opening recently edited workbooks**

If you know that the workbook you now need to edit is one of those that you had open recently, you don’t even have to fool around with the Open dialog box. Just click Office Button to open the File pull-down menu and then click the link to the workbook file in the Recent Documents list displayed in the column on the right side.

Excel 2007 keeps a running list of the last nine files you opened in the Recent Documents list on the Office pull-down menu. If the workbook you want to work with is one of those shown on this list, you can open its file by clicking its filename in the list or typing its number (1, 2, 3, and so on).

If you want, you can have Excel list more or fewer files in the Recent Documents list on the Office pull-down menu. To change the number of recently opened files listed, follow these simple steps:

1. Click **Office Button | Excel Options | Advanced** or press **Alt+FIA** to open the Advanced tab of the Excel Options dialog box.
2. Type a new entry (between 1 and 50) in the Show This Number of Recent Documents or use the spinner buttons to increase or decrease this number.

3. Click OK or press Enter to close the Options dialog box.

Tip

Note that if you don’t want any files displayed in the Recent Documents list on the Office pull-down menu, enter 0 in the Show This Number of Recent Documents text box or select it with the spinner buttons.

When you don’t know where to find them

The only problem you can encounter in opening a document from the Open dialog box is locating the filename. Everything’s hunky-dory as long as you can see the workbook filename listed in Open dialog box or know which folder to open in order to display it. But what about those times when a file seems to have mysteriously migrated and is now nowhere to be found on your computer?

Searching for workbooks when running Excel on Windows Vista

When you run Excel 2007 under Windows Vista, the new operating system adds a Search text box to the Open dialog box (see Figure 4-3) that enables you to search for missing notebooks right from within the dialog box.

To use Vista’s Search feature to find a workbook, click the Search text box in the upper-right corner of the Open dialog box and then begin typing search characters used in the workbook’s filename or contained in the workbook itself.
As Vista finds any matches for the characters you type, the names of the workbook files (and other Excel files such as templates and macros sheets as well) appear in the Open dialog box. As soon as the workbook you want to open is listed, you can open it by clicking its icon and filename followed by the Open button or by double-clicking it.

**Searching for workbooks when running Excel on Windows XP**

Unfortunately, the Open dialog box in Excel 2007 when running under Windows XP does not have a search feature built into it. This means that to search for missing workbooks, you have to do it outside of Excel by using the Windows XP’s search feature.

To use the Windows search feature to find an Excel workbook, follow these steps:

1. **Click the Start button on the Windows XP taskbar and then click Search in the right column of the Search menu.**
   
   Windows opens a Search Results dialog box.

2. **Click the Documents (Word Processing, Spreadsheets, Etc.) link in the left panel of the Search Results dialog box.**

3. (Optional) **If you know the last time the workbook file was modified, click the appropriate option button (Within Last Week, Past Month, or Within the Past Year).**

   If you haven’t the slightest idea the last time the workbook was edited, leave the Don’t Remember option button selected.

4. **Click the All or Part of the Document Name text box and then type the filename or the part of the name that you’re sure of (see Figure 4-4).**

   Type an asterisk (*) for multiple missing characters and a question mark (?) for single missing characters that you can’t supply in the workbook filename such as **Budget*.xls?**, for which Budget 1-2005.xlsx and Budget 2-2005.xls are both matches.

5. (Optional) **To search for the workbook on a particular hard drive or folder or by a phrase or name entered in the spreadsheets in the file, click the Use Advanced Search Options link and then enter contents to search for in the workbook in the Word or Phrase in the Workbook text, change the location to search Look In as well as any other of the advanced options that help narrow the search.**

   Note that if you don’t know the workbook filename but you do know the size, a key phrase or name it contains, just enter the appropriate advanced search criteria, leaving the All or Part of the Document Name text box blank.

6. **After you finish specifying all your search criteria, click the Search button to have Windows XP begin searching for the workbook file.**
After you click Search, Windows displays all the workbook files that match your search criteria in the list box on the right side of the Search Results dialog box. When you locate the workbook file you want to edit in Excel, right-click its file icon and filename and then click Open on the shortcut menu or simply double-click it.

**Opening files with a twist**

The pop-up menu attached to the Open button in the Open dialog box enables you to open the selected workbook file(s) in special ways. These ways include:

- **Open Read-Only**: This command opens the files you select in the Open dialog box’s list box in a read-only state, which means that you can look but you can’t touch. (Actually, you can touch; you just can’t save your changes.) To save changes in a read-only file, you must use the File ➪ Save As command from the Excel menu bar and give the workbook file a new filename. (Refer to Chapter 2.)

- **Open as Copy**: This command opens a copy of the files you select in the Open dialog box. Use this method of file-opening as a safety net: If you mess up the copies, you always have the originals to fall back on.

- **Open in Browser**: This command opens workbook files you save as Web pages (as I describe in Chapter 10) in your favorite Web browser (which would normally be the Microsoft Internet Explorer). Note that this command is not available unless the program identifies that the selected file or files were saved as Web pages rather than plain old Excel worksheet files.
Open and Repair: This command attempts to repair corrupted workbook files before opening them in Excel. When you select this command, a dialog box appears giving you a choice between attempting to repair the corrupted file or opening the recovered version, extracting data out of the corrupted file, and placing it in a new workbook (which you can save with the Save command). Click the Repair button to attempt to recover and open the file. Click the Extract Data button if you previously tried unsuccessfully to have Excel repair the file.

Much Ado about Undo

Before you start tearing into the workbook that you just opened, get to know the Undo feature and how it can put right many of the things that you could inadvertently mess up. The Undo command button on the Quick Access toolbar is a regular chameleon button. When you delete the cell selection by pressing the Delete key, the Undo button’s ToolTip says Undo Clear (Ctrl+Z). If you move some entries to a new part of the worksheet by dragging it, the Undo command button ToolTip changes to Undo Drag and Drop.

In addition to clicking the Undo command button (in whatever guise it appears), you can also choose this command by pressing Ctrl+Z (perhaps for unZap).

The Undo command button on Quick Access toolbar changes in response to whatever action you just took; it keeps changing after each action. If you forget to strike when the iron is hot, so to speak — by using the Undo feature to restore the worksheet to its previous state before you choose another command — you then need to consult the drop-down menu on the Undo button by clicking its drop-down button that appears to the right of the Undo icon (the curved arrow pointing to the left). After the Undo drop-down menu is open, click the action on this menu that you want undone. Excel will then undo this action and all actions that precede it in the list (which are automatically selected).

Undo is Redo the second time around

After using the Undo command button on the Quick Access toolbar, Excel 2007 activates the Redo command button to its immediate right. If you delete an entry from a cell by pressing the Delete key and then click the Undo command button or press Ctrl+Z, the ToolTip that appears when you position the mouse over the Redo command button appears as:

Redo Clear Ctrl+Y
When you click the Redo command button or press Ctrl+Y, Excel redoes the thing you just undid. Actually, this sounds more complicated than it is. It simply means that you use Undo to switch back and forth between the result of an action and the state of the worksheet just before that action until you decide how you want the worksheet (or until the cleaning crew turns off the lights and locks up the building).

**What ya gonna do when you can’t Undo?**

Just when you think it is safe to begin gutting the company’s most important workbook, I really feel that I’ve got to tell you that (yikes!) Undo doesn’t work all the time! Although you can undo your latest erroneous cell deletion, bad move, or unwise copy, you can’t undo your latest imprudent save. (You know, like when you meant to choose Save As from the File pull-down menu to save the edited worksheet under a different document name but instead chose Save and ended up saving the changes as part of the current document.)

Unfortunately, Excel doesn’t let you know when you are about to take a step from which there is no return — until it’s too late. After you’ve gone and done the un-undoable and you click the Undo button where you expect its ToolTip to say Undo blah, blah, it now reads Can’t Undo.

One exception to this rule is when the program gives you advance warning (which you should heed). When you choose a command that is normally undoable but currently — because you’re low on memory, or the change will affect so much of the worksheet, or both — Excel knows that it can’t undo the change if it goes through with it, the program displays an alert box telling you that there isn’t enough memory to undo this action and asking whether you want to go ahead anyway. If you click the Yes button and complete the edit, just realize that you do so without any possibility of pardon. If you find out, too late, that you deleted a row of essential formulas (that you forgot about because you couldn’t see them), you can’t bring them back with Undo. In such a case, you would have to close the file (Office Button | Close) and NOT save your changes.

**Doing the Old Drag-and-Drop Thing**

The first editing technique you need to learn is called *drag and drop*. As the name implies, it’s a mouse technique that you can use to pick up a cell selection and drop it into a new place on the worksheet. Although drag and drop is primarily a technique for moving cell entries around a worksheet, you can adapt it to copy a cell selection, as well.
To use drag and drop to move a range of cell entries (you can only move one cell range at a time), follow these steps:

1. **Select a cell range.**

2. **Position the mouse pointer on one edge of the extended cell cursor that now surrounds the entire cell range.**

   Your signal that you can start dragging the cell range to its new position in the worksheet is when the pointer changes to the arrowhead.

3. **Drag your selection to its destination.**

   Drag your selection by depressing and holding down the primary mouse button — usually the left one — while moving the mouse.

   While you drag your selection, you actually move only the outline of the cell range, and Excel keeps you informed of what the new cell range address would be (as a kind of drag-and-drop tool tip) if you were to release the mouse button at that location.

   Drag the outline until it’s positioned on the new cells in the worksheet where you want the entries to appear (as evidenced by the cell range in the drag-and-drop tool tip).

4. **Release the mouse button.**

   The cell entries within that range reappear in the new location as soon as you release the mouse button.

In Figures 4-5 and 4-6, I show how you can drag and drop to move a cell range. In Figure 4-5, I select the cell range A10:E10 (containing the quarterly totals) to move it to row 12 to make room for sales figures for two new companies (Simple Simon Pie Shoppes and Jack Be Nimble Candlesticks, which hadn’t been acquired when this workbook was first created). In Figure 4-6, you see the Mother Goose Enterprises 2008 sales worksheet right after completing this move.
The arguments for the `SUM` functions in cell range B12: E12 do not keep pace with the change in row — it continues to sum only the values in rows 3 through 9 right after the move. When, however, you enter the sales figures for these new enterprises in columns B through C in rows 10 and 11, Excel shows off its smarts by automatically updating the formulas in row 12 to include the new entries. So, for example, the `SUM(B3:B9)` formula in B12 magically becomes `SUM(B3:B11)`.

### Copies, drag-and-drop style

What if you want to copy a cell range instead of dragging and dropping one? Suppose that you need to start a new table in rows further down the worksheet, and you want to copy the cell range with the formatted title and column headings for the new table. To copy the formatted title range in the sample worksheet, follow these steps:

1. **Select the cell range.**
   In the case of Figures 4-5 and 4-6, that’s cell range B2:E2.
2. **Hold the Ctrl key down while you position the mouse pointer on an edge of the selection (that is, the expanded cell cursor).**
   The pointer changes from a thick, shaded cross to an arrowhead with a `+` (plus sign) to the right of it with the drag-and-drop screen tips right beside it. Keep in mind that the plus sign next to the pointer is your signal that drag and drop will *copy* the selection rather than *move* it.
3. **Drag the cell-selection outline to the place where you want the copy to appear and release the mouse button.**
If, when using drag and drop to move or copy cells, you position the outline of the selection so that it overlaps any part of cells that already contain entries, Excel displays an alert box with the following question: Do you want to replace contents of the destination cells?

To avoid replacing existing entries and to abort the entire drag-and-drop mission, click the Cancel button in this alert box. To go ahead and exterminate the little darlings, click OK or press Enter.

**Insertions courtesy of drag and drop**

Like the Klingons of *Star Trek* fame, spreadsheets, such as Excel, never take prisoners. When you place or move a new entry into an occupied cell, the new entry completely replaces the old as though the old entry never existed in that cell.

To insert the cell range you’re moving or copying within a populated region of the worksheet without wiping out existing entries, hold down the Shift key while you drag the selection. (If you’re copying, you have to get really ambitious and hold down both the Shift and Ctrl keys at the same time!).

With the Shift key depressed as you drag, instead of a rectangular outline of the cell range, you get an I-beam shape that shows where the selection will be inserted along with the address of the cell range (as a kind of Insertion screen tip) indicating where it would be inserted if you release the mouse button. As you move the I-beam shape, notice that it wants to attach itself to the column and row borders as you move it. When you position the I-beam shape at the column or row border where you want the cell range to be inserted, release the mouse button. Excel inserts the cell range, moving the existing entries to neighboring blank cells (out of harm’s way).

**But I held down the Shift key just like you said . . .**

Drag and drop in Insert mode is one of Excel’s most finicky features. Sometimes you can do everything just right and still get the alert box warning you that Excel is about to replace existing entries instead of pushing them aside. When you see this alert box, always click the Cancel button! Fortunately, you can insert things with the Insert commands without worrying about which way the I-beam selection goes (see “In Step with Insert” later in this chapter).
When inserting cells with drag and drop, it may be helpful to think of the I-beam shape as a pry bar that pulls apart the columns or rows along the axis of the I. Also, keep in mind that sometimes after moving a range to a new place in the worksheet, instead of the data appearing, you see only #######s in the cells. (Excel 2007 doesn’t automatically widen the new columns for the incoming data as it does when formatting the data.) Remember that the way to get rid of the #######s in the cells is by widening those troublesome columns enough to display all the data-plus-formatting, and the easiest way to do this kind of widening is by double-clicking the right border of the column.

**Formulas on AutoFill**

Copying with drag and drop (by holding down the Ctrl key) is useful when you need to copy a bunch of neighboring cells to a new part of the worksheet. Frequently, however, you just need to copy a single formula that you just created to a bunch of neighboring cells that need to perform the same type of calculation (such as totaling columns of figures). This type of formula copy, although quite common, can’t be done with drag and drop. Instead, use the AutoFill feature (read about this in Chapter 2) or the Copy and Paste commands. (See the section “Cut and paste, digital style” later in this chapter.)

Here’s how you can use AutoFill to copy one formula to a range of cells. In Figure 4-7, you can see the Mother Goose Enterprises – 2008 Sales worksheet with all the companies but this time without the monthly totals in row 12.

![Figure 4-7: Copying a formula to a cell range with AutoFill.](image)
Figure 4-7 shows the worksheet after dragging the fill handle in cell B12 and dragging it to select the cell range C12:E12 (where this formula should be copied).

**Relatively speaking**

Figure 4-8 shows the worksheet after the formula in a cell is copied to the cell range C12:E12 and cell C12 is active. Notice how Excel handles the copying of formulas. The original formula in cell B12 is as follows:

\[ =\text{SUM}(B3:B11) \]

When the original formula is copied next door to cell C12, Excel changes the formula slightly so that it looks like this:

\[ =\text{SUM}(C3:C11) \]

Excel adjusts the column reference, changing it from B to C, because I copied from left to right across the rows.

When you copy a formula to a cell range that extends down the rows, Excel adjusts the row numbers in the copied formulas rather than the column letters to suit the position of each copy. For example, cell E3 in the Mother Goose Enterprises – 2008 Sales worksheet contains the following formula:

\[ =\text{SUM}(B3:D3) \]

When you copy this formula down to cell E4, Excel changes the copy of the formula to the following:

\[ =\text{SUM}(B4:D4) \]
Excel adjusts the row reference to keep current with the new row 4 position. Because Excel adjusts the cell references in copies of a formula relative to the direction of the copying, the cell references are known as relative cell references.

**Some things are absolutes!**

All new formulas you create naturally contain relative cell references unless you say otherwise. Because most copies you make of formulas require adjustments of their cell references, you rarely have to give this arrangement a second thought. Then, every once in a while, you come across an exception that calls for limiting when and how cell references are adjusted in copies.

One of the most common of these exceptions is when you want to compare a range of different values with a single value. This happens most often when you want to compute what percentage each part is to the total. For example, in the Mother Goose Enterprises – 2008 Sales worksheet, you encounter this situation in creating and copying a formula that calculates what percentage each monthly total (in the cell range B14:D14) is of the quarterly total in cell E12.

Suppose that you want to enter these formulas in row 14 of the Mother Goose Enterprises – 2008 Sales worksheet, starting in cell B14. The formula in cell B14 for calculating the percentage of the January-sales-to-first-quarter-total is very straightforward:

\[ \frac{B12}{E12} \]

This formula divides the January sales total in cell B12 by the quarterly total in E12 (what could be easier?). Look, however, at what would happen if you dragged the fill handle one cell to the right to copy this formula to cell C14:

\[ \frac{C12}{F12} \]

The adjustment of the first cell reference from B12 to C12 is just what the doctor ordered. However, the adjustment of the second cell reference from E12 to F12 is a disaster. Not only do you not calculate what percentage the February sales in cell C12 are of the first quarter sales in E12, but you also end up with one of those horrible #DIV/0! error things in cell C14.

To stop Excel from adjusting a cell reference in a formula in any copies you make, convert the cell reference from relative to absolute. You do this by pressing the function key F4. Excel indicates that you make the cell reference absolute by placing dollar signs in front of the column letter and row number. For example, look at Figure 4-9. Cell B14 in this figure contains the correct formula to copy to the cell range C14:D14:

\[ \frac{B12}{E12} \]
Look at the worksheet after this formula is copied to the range C14:D14 with the fill handle and cell C14 selected (see Figure 4-10). Notice that the formula bar shows that this cell contains the following formula:

\[ \frac{C12}{E12} \]

Because E12 was changed to $E12 in the original formula, all the copies have this same absolute (nonchanging) reference.
If you goof up and copy a formula where one or more of the cell references should have been absolute but you left them all relative, edit the original formula as follows:

1. Double-click the cell with the formula or press F2 to edit it.
2. Position the insertion point somewhere on the reference you want to convert to absolute.
4. When you finish editing, click the Enter button on the Formula bar and then copy the formula to the messed-up cell range with the fill handle.

Be sure to press F4 only to change a cell reference to completely absolute as I describe earlier. If you press the F4 function key a second time, you end up with a so-called mixed reference, where only the row part is absolute and the column part is relative (as in E$12). If you then press F4 again, Excel comes up with another type of mixed reference, where the column part is absolute and the row part is relative (as in $E12). If you go on and press F4 yet again, Excel changes the cell reference back to completely relative (as in E12). After you’re back where you started, you can continue to use F4 to cycle through this same set of cell reference changes all over again.

**Cut and paste, digital style**

Instead of using drag and drop or AutoFill, you can use the old standby Cut, Copy, and Paste commands to move or copy information in a worksheet. These commands use the Office Clipboard as a kind of electronic halfway house where the information you cut or copy remains until you decide to paste it somewhere. Because of this Clipboard arrangement, you can use these commands to move or copy information to any other worksheet open in Excel or even to other programs running in Windows (such as a Word document).

To move a cell selection with Cut and Paste, follow these steps:

1. Select the cells you want to move.
2. Click the Cut command button in the Clipboard group on the Home tab (the button with the scissors icon).
   
   Or, if you prefer, you can choose Cut by pressing Ctrl+X.

   Whenever you choose the Cut command in Excel, the program surrounds the cell selection with a *marquee* (a dotted line that travels around the cells’ outline) and displays the following message on the Status bar:

   Select destination and press ENTER or choose Paste
3. Move the cell cursor to, or click the cell in the upper-left corner of the new range to which you want the information moved.

4. Press Enter to complete the move operation.

Or, if you’re feeling really ambitious, click the Paste command button in the Clipboard group on the Home tab or press Ctrl+V.

Notice that when you indicate the destination range, you don’t have to select a range of blank cells that matches the shape and size of the cell selection you’re moving. Excel only needs to know the location of the cell in the upper-left corner of the destination range to figure out where to put the rest of the cells.

Copying a cell selection with the Copy and Paste commands follows an identical procedure to the one you use with the Cut and Paste commands. After selecting the range to copy, you have even more choices about how to get the information into the Clipboard. Instead of clicking the Copy button on the Home tab on the Ribbon or choosing Copy from the cell shortcut menu after right-clicking it, you can press Ctrl+C.

**Paste it again, Sam . . .**

An advantage to copying a selection with the Copy and Paste commands and the Clipboard is that you can paste the information multiple times. Just make sure that, instead of pressing Enter to complete the first copy operation, you click the Paste button on the Home tab in the Ribbon or press Ctrl+V.

When you use the Paste command to complete a copy operation, Excel copies the selection to the range you designate without removing the marquee from the original selection. This is your signal that you can select another destination range (either in the same or a different document).

After you select the first cell of the next range where you want the selection copied, choose the Paste command again. You can continue in this manner, pasting the same selection to your heart’s content. When you make the last copy, press Enter instead of choosing the Paste command button or pressing Ctrl+V. If you forget and choose Paste, get rid of the marquee around the original cell range by pressing the Esc key.

**Keeping pace with the Paste Options**

Right after you click the Paste button on the Home tab of the Ribbon or press Ctrl+V to paste cell entries that you copy (not cut) to the Clipboard, Excel displays a Paste Options button with its own drop-down button at the end of the pasted range. You can use the options available when you click the drop-down button to modify the paste operation in the following ways:
Keep Source Formatting: Excel copies the formatting from the original cells and pastes this into the destination cells (along with the copied entries).

Use Destination Theme: Excel formats the copied entries according the cell style applied to the destination cell range.

Match Destination Formatting: Excel formats the copied entries according to the formatting assigned to the destination cell range.

Values Only: Excel copies only the calculated results of any formulas in the source cell range.

Values and Number Formatting: Excel copies the calculated results of any formulas along with all the formatting assigned to the labels, values, and formulas in the source cell range to the destination range. This means that all the labels and values in the destination range appear formatted just like the source range even though all the original formulas are lost and only the calculated values are retained.

Values and Source Formatting: Excel copies the calculated results of any formulas along with all formatting assigned to source cell range.

Keep Source Column Widths: Excel makes the width of the columns in the destination range the same as those in the source range when it copies their cell entries.

Formatting Only: Excel copies only the formatting (and not the entries) from the source cell range to the destination range.

Link Cells: Excel creates linking formulas in the destination range so that any changes that you make to the entries in cells in the source range are immediately brought forward and reflected in the corresponding cells of the destination range.

Paste it from the Clipboard task pane

The Office Clipboard can store multiple cuts and copies from any program running under Windows not just Excel. In Excel, this means that you can continue to paste stuff from the Office Clipboard into a workbook even after finishing a move or copy operation (even when you do so by pressing the Enter key rather than using the Paste command).

To open the Office Clipboard in its own task pane to the immediate left of the Worksheet area (see Figure 4-11), click the Dialog Box launcher button in the right-hand corner of the Clipboard group on the Ribbon’s Home tab.

To paste an item from the Office Clipboard into a worksheet other than the one with the data last cut or copied onto it, click the item in the Clipboard task pane to paste it into the worksheet starting at the current position of the cell cursor.
Note that you can paste all the items stored in the Office Clipboard into the current worksheet by clicking the Paste All button at the top of the Clipboard task pane. To clear the Office Clipboard of all the current items, click the Clear All button. To delete only a particular item from the Office Clipboard, position the mouse pointer over the item in the Clipboard task pane until its drop-down button appears. Click this drop-down button, and then choose Delete from the pop-up menu.

To have the Office Clipboard task pane appear automatically after making two cuts or copies to the Clipboard in an Excel workbook, click the Show Office Clipboard Automatically option on the Options button pop-up menu. To be able to open the Office Clipboard task pane in the Excel program window by pressing Ctrl+CC, click Show Office Clipboard When Ctrl+C Pressed Twice on the Options button’s pop-up menu. Note that this option only opens the task pane by pressing Ctrl+CC: you still have to click the Close button on the Office Clipboard to close the task pane.

**So what’s so special about Paste Special?**

Normally, unless you fool around with the Paste Options (see the section “Keeping pace with the Paste Options” earlier in this chapter), Excel copies all the information in the range of cells you selected: formatting, as well the formulas, text, and other values you enter. If you want, use the Paste Special command to specify that only the entries be copied (without the formatting) or that just the formatting be copied (without the entries).
To paste particular parts of a cell selection while discarding others, click the drop-down button that appears at the bottom of the Paste command button on the Ribbon’s Home tab. Then, click Paste Special on its drop-down menu to open the Paste Special dialog box. Here you can specify which parts of the current cell selection to use by selecting the appropriate Paste Special radio button or check box as follows:

- **All** to paste all the stuff in the cell selection (formulas, formatting, you name it).
- **Formulas** to paste all the text, numbers, and formulas in the current cell selection without their formatting.
- **Values** to convert formulas in the current cell selection to their calculated values.
- **Formats** to paste only the formatting from the current cell selection, leaving the cell entries in the dust.
- **Comments** to paste only the notes that you attach to their cells (kinda like electronic self-stick notes — see Chapter 6 for details).
- **Validation** to paste only the data validation rules into the cell range that you set up with the Data Validation command (which enables you to set what value or range of values is allowed in a particular cell or cell range).
- **All Using Source Theme** to paste all the information plus the cell styles applied to the cells.
- **All Except Borders** to paste all the stuff in the cell selection without copying any borders you use there.
- **Column Widths** to apply the column widths of the cells copied to the Clipboard to the columns where the cells are pasted.
- **Formulas and Number Formats** to include the number formats assigned to the pasted values and formulas.
- **Values and Number Formats** to convert formulas to their calculated values and include the number formats you assign to all the pasted values.
- **None** to have Excel perform no operation between the data entries you cut or copy to the Clipboard and the data entries in the cell range where you paste.
- **Add** to add the data you cut or copy to the Clipboard and the data entries in the cell range where you paste.
- **Subtract** to subtract the data you cut or copy to the Clipboard from the data entries in the cell range where you paste.
- **Multiply** to multiply the data you cut or copy to the Clipboard by the data entries in the cell range where you paste.
Divide to divide the data you cut or copy to the Clipboard by the data entries in the cell range where you paste.

Skip Blanks check box when you want Excel to paste everywhere except for any empty cells in the incoming range. In other words, a blank cell cannot overwrite your current cell entries.

Transpose check box when you want Excel to change the orientation of the pasted entries. For example, if the original cells’ entries run down the rows of a single column of the worksheet, the transposed pasted entries will run across the columns of a single row.

Paste Link button when you’re copying cell entries and you want to establish a link between copies you’re pasting and the original entries. That way, changes to the original cells automatically update in the pasted copies.

You can alternatively select the Formulas, Paste Values, No Borders, Transpose, and Paste Link paste options directly from the drop-down menu attached to the Paste button in the Clipboard group on the Home tab of the Ribbon without having to open the Paste Special dialog box. (Note that the No Borders option on the Paste button’s drop-down menu is the same as the All Except Borders option in the Paste Special dialog box.)

Let’s Be Clear about Deleting Stuff

No discussion about editing in Excel would be complete without a section on getting rid of the stuff you put into cells. You can perform two kinds of deletions in a worksheet:

Clearing a cell: Clearing just deletes or empties the cell’s contents without removing the cell from the worksheet, which would alter the layout of the surrounding cells.

Deleting a cell: Deleting gets rid of the whole kit and caboodle — cell structure along with all its contents and formatting. When you delete a cell, Excel has to shuffle the position of entries in the surrounding cells to plug up any gaps made by the demise.

Sounding the all clear!

To get rid of just the contents of a cell selection rather than delete the cells along with their contents, select the range of cells to be cleared, simply press the Delete key.
If you want to get rid of more than just the contents of a cell selection, click the Clear button (the one with the eraser) in the Editing group on the Ribbon’s Home tab and then click one of the following options on its drop-down menu:

- **Clear All**: Gets rid of all formatting and notes, as well as entries in the cell selection (Alt+HEA).
- **Clear Formats**: Deletes only the formatting from the cell selection without touching anything else (Alt+HEF).
- **Clear Contents**: Deletes only the entries in the cell selection just like pressing the Delete key (Alt+HEC).
- **Clear Comments**: Removes the notes in the cell selection but leaves everything else behind (Alt+HEM).

**Get these cells outta here!**

To delete the cell selection rather than just clear out its contents, select the cell range, and then click the drop-down button attached to the Delete command button in the Cells group of the Home tab and click Delete Cells on the drop-down menu (or press Alt+HDD). The Delete dialog box opens, showing options for filling in the gaps created when the cells currently selected are blotted out of existence with those left behind:

- **Shift Cells Left**: This default option moves entries from neighboring columns on the right to the left to fill in gaps created when you delete the cell selection by clicking OK or pressing Enter.
- **Shift Cells Up**: Select this to move entries up from neighboring rows below.
- **Entire Row**: Select this to remove all the rows in the current cell selection.
- **Entire Columns**: Select this to delete all the columns in the current cell selection.

If you know that you want to shift the remaining cells to the right after deleting the cells in the current selection, you can simply click the Delete command button on the Home tab of the Ribbon (this is the same thing as opening the Delete dialog box and then clicking OK when the default Shift Cells Left option button is selected).

To delete an entire column or row from the worksheet, you can select the column or row on the workbook window frame, then right-click the selection and click Delete from the column’s or row’s shortcut menu.
You can also delete entire columns and rows selected in the worksheet by clicking the drop-down button attached to the Delete command button on the Ribbon’s Home tab and then clicking the Delete Sheet Columns (Alt+HDC) or Delete Sheet Rows option (Alt+HDR) on the drop-down menu.

Deleting entire columns and rows from a worksheet is risky business unless you are sure that the columns and rows in question contain nothing of value. Remember, when you delete an entire row from the worksheet, you delete all information from column A through XFD in that row (and you can see only a very few columns in this row). Likewise, when you delete an entire column from the worksheet, you delete all information from row 1 through 1,048,576 in that column.

Staying in Step with Insert

For those inevitable times when you need to squeeze new entries into an already populated region of the worksheet, you can insert new cells in the area rather than go through all the trouble of moving and rearranging several individual cell ranges. To insert a new cell range, select the cells (many of which are already occupied) where you want the new cells to appear and then click the drop-down attached to the Insert command button in the Cells group of the Home tab and then click Insert Cells on the drop-down menu (or press Alt+HII). The Insert dialog box opens with the following options buttons:

- **Shift Cells Right**: Select this to shift existing cells to the right to make room for the ones you want to add before clicking OK or pressing Enter.
- **Shift Cells Down**: Use this default to instruct the program to shift existing entries down instead before clicking OK or pressing Enter.
- **Entire Row** or **Entire Column**: As when you delete cells, when you insert cells with the Insert dialog box, you can insert complete rows or columns in the cell range by selecting either of these radio buttons. You can also select the row number or column letter on the frame before you choose the Insert command.

If you know that you want to shift the existing cells to the right to make room for the newly inserted cells, you can simply click the Insert command button on the Ribbon’s Home tab (this is the same thing as opening the Insert dialog box and then clicking OK when the Shift Cells Right option button is selected).
Remember that you can also insert entire columns and rows in a worksheet by right-clicking the selection and then clicking Insert on the Column’s or Row’s shortcut menu.

Keep in mind that just like when you delete whole columns and rows, inserting entire columns and rows affects the entire worksheet, not just the part you see. If you don’t know what’s out in the hinterlands of the worksheet, you can’t be sure how the insertion will impact — perhaps even sabotage — stuff (especially formulas) in the other unseen areas. I suggest that you scroll all the way out in both directions to make sure that nothing’s out there.

**Stamping Out Your Spelling Errors**

If you’re as good a speller as I am, you’ll be really relieved to know that Excel 2007 has a built-in spell checker that can catch and get rid of all those embarrassing little spelling errors. With this in mind, you no longer have any excuse for putting out worksheets with typos in the titles or headings.

To check the spelling in a worksheet, you have the following options:

- Click the Spelling command button on the Ribbon’s Review tab
- Press Alt+Rs
- Press F7

Any way you do it, Excel begins checking the spelling of all text entries in the worksheet. When the program comes across an unknown word, it displays the Spelling dialog box, similar to the one shown in Figure 4-12.

![Figure 4-12: Check your spelling from the Spelling dialog box.](image-url)
Excel suggests replacements for the unknown word shown in the Not in Dictionary text box with a likely replacement in the Suggestions list box of the Spelling dialog box. If that replacement is incorrect, you can scroll through the Suggestions list and click the correct replacement. Use the Spelling dialog box options as follows:

- **Ignore Once and Ignore All:** When Excel’s spell check comes across a word its dictionary finds suspicious but you know is viable, click the Ignore Once button. If you don’t want the spell checker to bother querying you about this word again, click the Ignore All button.

- **Add to Dictionary:** Click this button to add the unknown (to Excel) word — such as your name — to a custom dictionary so that Excel won’t flag it again when you check the spelling in the worksheet later on.

- **Change:** Click this button to replace the word listed in the Not in Dictionary text box with the word Excel offers in the Suggestions list box.

- **Change All:** Click this button to change all occurrences of this misspelled word in the worksheet to the word Excel displays in the Suggestions list box.

- **AutoCorrect:** Click this button to have Excel automatically correct this spelling error with the suggestion displayed in the Suggestions list box (by adding the misspelling and suggestion to the AutoCorrect dialog box; for more, read through Chapter 2).

- **Dictionary Language:** To switch to another dictionary (such as a United Kingdom English dictionary, or a French dictionary when checking French terms in a multilingual worksheet), click this drop-down button and then select the name of the desired language in the pop-up list.

Notice that the Excel spell checker not only flags words not found in its built-in or custom dictionary but also flags occurrences of double words in a cell entry (such as total total) and words with unusual capitalization (such as NEW York instead of New York). By default, the spell checker ignores all words with numbers and all Internet addresses. If you want it to ignore all words in uppercase letters as well, click the Options button at the bottom of the Spelling dialog box, and then select the Ignore Words in UPPERCASE check box before clicking OK.
Keep in mind that you can check the spelling of just a particular group of entries by selecting the cells before you click the Spelling command button on the Review tab of the Ribbon or press F7.

**Stamping Out Errors with Text to Speech**

The good news is that Excel 2007 still supports the Text to Speech feature first introduced in Excel 2003. This feature enables your computer to read aloud any series of cell entries in the worksheet. By using Text to Speech, you can check your printed source as the computer reads out loud the values and labels that you’ve actually entered — a real nifty way to catch and correct errors that may otherwise escape unnoticed.

The Text to Speech translation feature requires no prior training or special microphones: All that’s required is a pair of speakers or headphones connected to your computer.

Now for the bad news: Text to Speech is not available from any of the tabs on the Ribbon. The only way to access Text to Speech is by adding its various Speak Cells command buttons as custom button on the Quick Access toolbar as follows:

1. **Click Office Button | Excel Options | Customize or press Alt+FIC.**

   The Customize tab of the Excel Options dialog box opens.

2. **Click Commands Not in the Ribbon on the Choose Commands From drop-down menu.**

   The Text to Speech command buttons include Speak Cells, Speak Cells – Stop Speaking Cells, Speak Cells by Column, Speak Cells by Row, and Speak Cells on Enter.

3. **Click the Speak Cells button in Choose Commands From list box on the left and then click the Add button to add it to the bottom of the Customize Quick Access Toolbar list box on the right.**

4. **Repeat Step 3 until you’ve added the remaining Text to Speech buttons to the Quick Access toolbar: Speak Cells – Stop Speaking Cells, Speak Cells by Column, Speak Cells by Row, and Speak Cells on Enter.**

If you want to reposition the Text to Speech buttons on the Quick Access toolbar, select each button in the Customize Quick Access Toolbar and then move it left on the bar by clicking the Move Up button or right by
clicking Move Down. If you want to set off the Text to Speech buttons as a separate group on the Quick Access toolbar, add a <Separator> icon ahead of the Speak Cells command button (and following the Speak Cells on Enter button if you have buttons not related to the Text to Speech function that follow on the Quick Access toolbar).

5. Click the OK button to close the Excel Options dialog box.

Figure 4-13 shows the Quick Access toolbar in my Excel 2007 program window after I moved the toolbar down so that it appears below the Ribbon and after I added all the Speak Cells command buttons to it and grouped them together with a <Separator> icon.

After adding the Text to Speech commands as custom Speak Cells buttons on the Quick Access toolbar, you can use them to corroborate spreadsheet entries and catch those hard-to-spot errors as follows:

1. Select the cells in the worksheet whose contents you want read aloud by Text to Speech.

2. Click the Speak Cells custom button on the Quick Access toolbar to have the computer begin reading back the entries in the selected cells.

By default, the Text to Speech feature reads the contents of each cell in the cell selection by first reading down each column and then across the rows. If you want Text to Speech to read across the rows and then down the columns, click the Speak Cells by Rows button on the Quick Access toolbar (the button with the two opposing horizontal arrows).
3. To have the Text to Speech feature read back each cell entry as you press the Enter key (at which point the cell cursor moves down to the next cell in the selection), click the Speak Cells on Enter custom button (the button with the curved arrow Enter symbol) on the Quick Access toolbar.

As soon as you click the Speak Cells on Enter button, the computer tells you, “Cells will now be spoken on Enter.” After selecting this option, you need to press Enter each time that you want to hear an entry read back to you.

4. To pause the Text to Speech feature when you’re not using the Speak Cells on Enter option (Step 3) and you locate a discrepancy between what you’re reading and what you’re hearing, click the Speak Cells - Stop Speaking Cells button (the Speak Cells button with the x).

Keep in mind that after you click the Speak Cells on Enter button on the Quick Access toolbar, the computer only speaks each new cell entry that you complete by pressing the Enter key (which moves the cell cursor down one row) and not by some other method, such as clicking the Enter button on the Formula bar or pressing the ↓ key in order to have the Text to Speech feature read what you just entered.
Chapter 5
Printing the Masterpiece

In This Chapter
► Previewing pages in Page Layout view and Print Preview
► Quick Printing from the Quick Access toolbar
► Printing all the worksheets in a workbook
► Printing just some of the cells in a worksheet
► Changing page orientation
► Printing the whole worksheet on a single page
► Changing margins for a report
► Adding a header and footer to a report
► Printing column and row headings as print titles on every page of a report
► Inserting page breaks in a report
► Printing the formulas in your worksheet

For most people, getting the data down on paper is really what spreadsheets are all about (all the talk about a so-called paperless office to the contrary). Everything — all the data entry, all the formatting, all the formula checking, all the things you do to get a spreadsheet ready — is really just preparation for printing its information.

In this chapter, you find out just how easy it is to print reports with Excel 2007. Thanks to the program’s new Page Layout worksheet view and handy Page Layout tab on the Ribbon, you discover how to produce top-notch reports the first time you send the document to the printer (instead of the second or even the third time around).

The only trick to printing a worksheet is getting used to the paging scheme and learning how to control it. Many of the worksheets you create with Excel are not only longer than one printed page but also wider. Word processors, such as Word 2007, page the document only vertically; they won’t let you create a document wider than the page size you’re using. Spreadsheet programs like Excel 2007, however, often have to break up pages both vertically and horizontally to print a worksheet document (a kind of tiling of the print job, if you will).
When breaking a worksheet into pages, Excel first pages the document vertically down the rows in the first columns of the print area (just like a word processor). After paging the first columns, the program pages down the rows of the second set of columns in the print area. Excel pages down and then over until the entire document included in the current print area (which can include the entire worksheet or just sections) is paged.

When paging the worksheet, keep in mind that Excel does not break up the information within a row or column. If all the information in a row won’t fit at the bottom of the page, the program moves the entire row to the following page. If all the information in a column won’t fit at the right edge of the page, the program moves the entire column to a new page. (Because Excel pages down and then over, the column may not appear on the next page of the report.)

You can deal with such paging problems in several ways — and, in this chapter, you see all of them! After you have these page problems under control, printing is a proverbial piece of cake.

**Taking a Gander at the Pages in Page Layout View**

Excel 2007’s new Page Layout view gives you instant access to the paging of the current worksheet. Activate this feature by clicking the Page Layout View button (the center one) to the immediate left of the Zoom slider on the Status bar or the Page Layout View command button on the Ribbon’s View tab (Alt+WP). As you can see in Figure 5-1, when you switch to Page Layout view, Excel adds horizontal and vertical rulers to the column letter and row number headings. In the Worksheet area, this view shows the margins for each printed page with any headers and footers defined for the report along with the breaks between each (often you have to use the Zoom slider to reduce the screen magnification to display the page breaks on the screen).

To see all the pages required to print the active worksheet, drag the slider button in the Zoom slider on the Status bar to the left until you decrease the screen magnification sufficiently to display all the pages of data.

Excel displays rulers using the default units for computer (inches on a U.S. computer and centimeters on a European machine). To change the units, open the Advanced tab of the Excel Options dialog box (Office Button | Excel Options | Advanced or Alt+FIA) and then select the appropriate unit on the Ruler Units drop-down menu in the Display section (Inches, Centimeters, or Millimeters) in the Display section.

Note that the Ruler command button acts as a toggle switch so that the first time you click this button, Excel removes the rulers from the Page Layout view and the second time the program adds them back again.
Checking the Printout with Print Preview

Save wasted paper and your sanity by using the Print Preview feature before you print any worksheet, section of worksheet, or entire workbook. Because of the peculiarities in paging worksheet data, check the page breaks for any report that requires more than one page. Print Preview shows you exactly how the worksheet data will be paged when printed and you can make last minute changes to the page settings before sending the report on to the printer when everything looks okay.

To switch to Print Preview, click the Office Button and then highlight the button to the right of the Print option (and not before you click by Print Preview on the submenu that appears) or press Alt+FWV. Excel displays the first page of the report in a separate window with its own Print Preview contextual tab. When positioned over the spreadsheet, the mouse pointer becomes a magnifying glass. Look at Figure 5-2 to see the first page of a four-page report in Print Preview.

When Excel displays a full page in the Print Preview window, you can barely read its contents; increase the view to actual size if you need to verify some of the information. Zoom up to 100 percent by clicking the previewed page with the magnifying-glass mouse pointer or by clicking the Zoom button in the Print Preview tab on the Ribbon. Check out the difference in Figure 5-3 — here you can see what the first page of the four-page report looks like after I zoom in by clicking the Zoom pointer (with the magnifying-glass icon) on the top central portion of the page.
After you enlarge a page to actual size, use the scroll bars to bring new parts of the page into view in the Print Preview window. If you prefer to use the keyboard, press the ↑ and ↓ keys or PgUp and PgDn to scroll up or down the page, respectively; press ← and → or Ctrl+PgUp and Ctrl+PgDn to scroll left and right, respectively.
To return to the full-page view, click the mouse pointer (in its arrowhead form) anywhere on the page or click the Zoom command button on the Print Preview tab on the Ribbon.

Excel indicates the number of pages in a report on the Status bar of the Print Preview window (at the far-left bottom of your Excel screen). If your report has more than one page, view pages that follow by clicking the Next Page button in the Preview group of the Print Preview tab on the Ribbon. To review a page you’ve already seen, back up a page by clicking the Previous Page button immediately below it. (The Previous button is grayed out if you’re on the first page.) You can also advance to the next page by pressing the PgDn or ↓ key or move back to the previous page by pressing the PgUp or ↑ key when the page view is full-page rather than actual size.

When you finish previewing the report, the Print Preview tab offers you following options:

- **Print** command button in the Print group to display the Print dialog box and print the report from the normal worksheet view. (See the section “Printing the Worksheet,” later in this chapter.)

- **Page Setup** command button in the Print group to open the Page Setup dialog box where you can take care of paging problems by choosing a new paper size, page order, orientation, or margins, or if you notice a problem with the header or footer (the text you enter in the top or bottom margin of the pages). For more on what printing parameters you can set here, see the section “My Page Was Set Up!” later in this chapter.

- **Show Margins** check box in the Preview group to display markers for the current top, bottom, left, and right margins that you can then adjust by dragging them. (See “Massaging the margins,” later in this chapter, for details.)

- **Close Print Preview** command button in the Preview group to close the Print Preview window and return to the previous worksheet view.

**Printing the Worksheet**

As long as you want to use Excel’s default print settings to print all the cells in the current worksheet, printing in Excel 2007 is a breeze. Simply add the Quick Print button to the Quick Access toolbar (by clicking Customize Quick Access Toolbar button and then clicking Quick Print on its drop-down menu).

After adding the Quick Print button to the Quick Access toolbar, you can use this button to print a single copy of all the information in the current worksheet, including any charts and graphics — but not including comments you
add to cells. (See Chapter 6 for details about adding comments to your worksheet and Chapter 8 for details about charts and graphics.)

When you click the Quick Print button, Excel routes the print job to the Windows print queue, which acts like a middleman to send the job to the printer. While Excel sends the print job to the print queue, Excel displays a Printing dialog box to inform of its progress (displaying such updates as Printing Page 2 of 3). After this dialog box disappears, you are free to go back to work in Excel. To stop the printing while the job is still in the process of being sent to the print queue, click the Cancel button in the Printing dialog box.

If you don’t realize that you want to cancel the print job until after Excel finishes shipping it to the print queue (that is, while the Printing dialog box appears on-screen), you must open the dialog box for your printer by clicking and cancel printing from there:

1. **Click the printer icon in the Notification area at the far right of the Windows Vista or XP taskbar (to the immediate left of the current time) with the secondary mouse button to open its shortcut menu.**

   This printer icon displays the screen tip 1 document(s) pending for so-and-so. For example, when I’m printing, this message reads 1 document(s) pending for Greg when I position the mouse pointer over the printer icon.

2. **Right-click the printer icon and then select the Open Active Printers command from its shortcut menu.**

   This opens the dialog box for the printer with the Excel print job in its queue (as described under the Document heading in the list box).

3. **Select the Excel print job that you want to cancel in the list box of your printer’s dialog box.**

4. **Choose Document:→Cancel from the menu bar.**

5. **Wait for the print job to disappear from the queue in the printer’s dialog box and then click the Close button to get rid of it and return to Excel.**

---

**Printing the Worksheet from the Print Dialog Box**

Printing with the Quick Print button on the Quick Access toolbar is fine provided that all you want is a single copy of all the information in the current worksheet. If you want more copies, more or less data (such as all the worksheets in the workbook or just a cell selection within a particular worksheet), then you need to print from the Print dialog box (shown in Figure 5-4).
Excel provides a number of ways to open the Print dialog box:

- Press Ctrl+P.
- Click Office Button | Print.
- Press Alt+FP
- Press Ctrl+Shift+F12.

**Printing particular parts of the workbook**

Within the Print dialog box are the Print Range and Print What sections (from which you can select how much of the information is printed), and the Copies section, from which you can change the number of copies printed. Here’s what’s in these areas and how you use their options:

- **All:** When the All option button is selected, all the pages in your document will print. Because this is the default choice, you would only need to select it if you previously printed a portion of the document by selecting the Page(s) option button.

- **Page(s):** Normally, Excel prints all the pages required to produce the information in the areas of the workbook that you want printed. Sometimes, however, you may need to reprint only a page or range of pages that you’ve modified within this section. To reprint a single page, enter its page number in both the From and To text boxes here or select these page numbers with the spinner buttons. To reprint a range of pages, put the first page number in the From text box and the last page number in the To text box. Excel automatically deselects the All option button and selects the Page(s) option button in the Page Range section as soon as you start typing in the From or To text boxes.
Selection: Select this option button to have Excel print just the cells that are currently selected in your workbook. (Yes, you must remember to select these cells before opening the Print dialog box and choosing this printing option).

Active Sheet(s): Excel automatically displays and selects this option button and prints all the information in whatever worksheets are selected in your workbook. Normally, this means printing just the data in the current worksheet. To print other worksheets in the workbook when this option button is selected, hold down Ctrl while you click the sheet’s tab. To include all the sheets between two sheet tabs, click the first one and then hold Shift while you click the second tab (Excel selects all the tabs in between).

Entire Workbook: Select this option button to have Excel print all the data in each of the worksheets in your workbook.

Table: Select this option button to have Excel print only the data range that you formatted as a table (see Chapter 3 for details). Note this option button remains grayed out and unavailable if your worksheet doesn’t contain any tables.

Ignore Print Areas: Click this check box to put a check mark in it when you want one of the other Print What options (Selection, Active Sheet(s), or Entire Workbook) that you selected to be used in the printing rather than the Print Area you defined (see “Setting and clearing the Print Area” section later in this chapter for details).

Number of Copies: To print more than one copy of the report, enter the number of copies you want to print in the Number of Copies text box in the Copies section — or use the spinner buttons to select the required number.

Collate: When you collate pages, you simply make separate stacks of each complete report, rather than print all copies of page one, and then all copies of page two, and so on. To have Excel collate each copy of the report for you, select the Collate check box in the Copies section to put a check mark in it.

After you finish choosing new print options, you can send the job to the printer by clicking OK or pressing Enter. To use another printer that’s been installed for Windows (Excel lists the current printer in the Name text box and all printers installed for Windows on the Name pop-up list), select the new printer on the Name drop-down menu in the Printer section at the top of the dialog box before you start printing.

To open the report in the Print Preview window for last-minute checking before sending it to the printer, click the Preview button (see “Checking the Printout with Print Preview” earlier in this chapter).
Setting and clearing the Print Area

Excel includes a special printing feature called the Print Area. You click Print Area | Set Print Area on the Ribbon’s Page Layout tab or press Alt+PRS to define any cell selection on a worksheet as the Print Area. After you define the Print Area, Excel then prints this cell selection anytime you print the worksheet (either with the Quick Print button, if you’ve added it to the Quick Access toolbar or by using the Office Button | Print command or one of its shortcuts).

Whenever you fool with the Print Area, you need to keep in mind that after you define it, its cell range is the only one you can print (regardless of what other Print What options you select in the Print dialog box) unless you click the Ignore Print Areas check box and until you clear the Print Area.

To clear the Print Area (and therefore go back to the printing defaults Excel establishes in the Print dialog box — see the preceding section, “Printing particular parts of the workbook”) you just have to click Print Area | Clear Print File on the Page Layout tab or simply press Alt+PRC.

You can also define and clear the Print Area from the Sheet tab of the Page Setup dialog box opened by clicking the Dialog Box launcher in the Page Setup group on in the Ribbon’s Page Layout tab. To define the Print Area from this dialog box, click the Print Area text box on the Sheet tab to insert the cursor and then select the cell range or ranges in the worksheet (remembering that you can reduce the Page Setup dialog box to just this text box by clicking its minimize box). To clear the Print Area from this dialog box, select the cell addresses in the Print Area text box and press the Delete key.

My Page Was Set Up!

About the only thing the slightest bit complex in printing a worksheet is figuring out how to get the pages right. Fortunately, the command buttons in the Page Setup group on the Page Layout tab of the Ribbon give you a great deal of control over what goes on which page.

Three groups of buttons on the Page Layout tab help you get your page settings exactly as you want them: the Page Setup group, the Scale to Fit group, and the Sheet Options group, all described in the following sections.

To see the effect of changes you make to the page setup settings in the Worksheet area, put the worksheet into Page Layout view by clicking the Page Layout button on the Status bar as you work with the command buttons in Page Setup, Scale to Fit, and Sheet Options groups on the Page Layout tab of the Ribbon.
Using the buttons in the Page Setup group

The Page Setup group of the Page Layout tab contains the following important command buttons:

- **Margins** button to select one of three preset margins for the report or to set custom margins on the Margins tab of the Page Setup dialog box. (See “Massaging the margins” that follows in this chapter.)

- **Orientation** button to switch between Portrait and Landscape mode for the printing (see “Getting the lay of the landscape” later in this chapter).

- **Size** button to select one of the preset paper sizes or to set a custom size or to change the printing resolution or page number on the Page tab of the Page Setup dialog box.

- **Print Area** button to set and clear the Print Area. (See “Setting and clearing the Print Area” earlier in this chapter.)

- **Breaks** button to insert or remove page breaks. (See “Solving Page Break Problems” later in this chapter.)

- **Background** button to open the Sheet Background dialog box where you can select a new graphic image or photo to be used as a background for all the worksheets in the workbook. (Note that this button changes to Delete Background as soon as you select a background image.)

- **Print Titles** button to open up the Sheet tab of the Page Setup dialog box where you can define rows of the worksheet to repeat at the top and columns at the left as print titles for the report. (See “Putting out the print titles” later in this chapter.)

Massaging the margins

The Normal margin settings that Excel applies to a new report uses standard top, bottom, left, and right margins of \( \frac{3}{4} \) inch with just over a \( \frac{1}{4} \) inch separating the header and footer from the top and bottom margin, respectively.

In addition to the Normal margin settings, the program enables you to select two other standard margins from the Margins button’s drop-down menu:

- **Wide** margins with 1-inch top, bottom, left, and right margins and \( \frac{1}{2} \) inch separating the header and footer from the top and bottom margin, respectively.

- **Narrow** margins with a top and bottom margin of \( \frac{3}{4} \) inch and a left and right margin of \( \frac{1}{4} \) inch, and \( \frac{1}{2} \) inch separating the header and footer from the top and bottom margin, respectively.

Frequently, you find yourself with a report that takes up a full printed page and then just enough also to spill over onto a second, mostly empty, page.
To squeeze the last column or the last few rows of the worksheet data onto page 1, try selecting Narrow on the Margins button’s drop-down menu.

If that doesn’t do it, you can try manually adjusting the margins for the report either from the Margins tab of the Page Setup dialog box or by dragging the margin markers in the Print Preview window. To get more columns on a page, try reducing the left and right margins. To get more rows on a page, try reducing the top and bottom margins.

To open the Margins tab of the Page Setup dialog box (shown in Figure 5-5), click Custom Margins on the Margins button’s drop-down menu. There, enter the new settings in the Top, Bottom, Left, and Right text boxes — or select the new margin settings with their respective spinner buttons.

Select one or both Center on Page options in the Margins tab of the Page Setup dialog box (refer to Figure 5-5) to center a selection of data (that takes up less than a full page) between the current margin settings. In the Center on the Page section, select the Horizontally check box to center the data between the left and right margins. Select the Vertically check box to center the data between the top and bottom margins.

When you select the Show Margins check box on the Print Preview tab in the Print Preview window (Alt+FWV) to change the margin settings, you can modify the column widths as well as the margins. (See Figure 5-6.) To change one of the margins, position the mouse pointer on the desired margin marker (the pointer shape changes to a double-headed arrow) and drag the marker with your mouse in the appropriate direction. When you release the mouse button, Excel redraws the page, using the new margin setting. You may gain or lose columns or rows, depending on what kind of adjustment you make. Changing the column widths is the same story: Drag the column marker to the left or right to decrease or increase the width of a particular column.
Getting the lay of the landscape

The drop-down menu attached to the Orientation button in the Page Setup group of the Ribbon’s Page Layout tab contains two options:

- **Portrait** (the default) where the printing runs parallel to the short edge of the paper
- **Landscape** where the printing runs parallel to the long edge of the paper

Because many worksheets are far wider than they are tall (such as budgets or sales tables that track expenditures over all 12 months), you may find that their worksheets page better if you switch the orientation from the normal portrait mode (which accommodates fewer columns on a page because the printing runs parallel to the short edge of the page) to landscape mode.
In Figure 5-7, you can see the Print Preview window with the first page of a report in landscape mode in the Page Layout view. For this report, Excel can fit three more columns of information on this page in landscape mode than it can in portrait mode. However, because this page orientation accommodates fewer rows, the total page count for this report increases from two pages in portrait mode to four pages in landscape mode.

Putting out the print titles
Excel’s Print Titles enable you to print particular row and column headings on each page of the report. Print titles are important in multi-page reports where the columns and rows of related data spill over to other pages that no longer show the row and column headings on the first page.

Don’t confuse print titles with the header of a report (see “From Header to Footer” later in this chapter). Even though both are printed on each page, header information prints in the top margin of the report; print titles always appear in the body of the report — at the top, in the case of rows used as print titles, and on the left, in the case of columns.
To designate rows and/or columns as the print titles for a report, follow these steps:

1. **Click the Print Titles button on the Page Layout tab on the Ribbon or press Alt+PI.**

   The Page Setup dialog box appears with Sheet tab selected (refer to Figure 5-8).

   To designate worksheet rows as print titles, go to Step 2a. To designate worksheet columns as print titles, go to Step 2b.

2a. **Select the Rows to Repeat at Top text box and then drag through the rows with information you want to appear at the top of each page in the worksheet below. If necessary, reduce the Page Setup dialog box to just the Rows to Repeat at Top text box by clicking the text box’s Collapse/Expand dialog button.**

   In the example I show you in Figure 5-8, I click the minimize button associated with the Rows to Repeat at Top text box and then drag through rows 1 and 2 in column A of the Bo Peep Pet Detectives – Client List worksheet, and the program entered the row range $1:$2 in the Rows to Repeat at Top text box.

   Note that Excel indicates the print-title rows in the worksheet by placing a dotted line (that moves like a marquee) on the border between the titles and the information in the body of the report.

2b. **Select the Columns to Repeat at Left text box and then drag through the range of columns with the information you want to appear at the left edge of each page of the printed report in the worksheet below. If necessary, reduce the Page Setup dialog box to just the Columns to Repeat at Left text box by clicking its Collapse/Expand dialog button.**

   Note that Excel indicates the print-title columns in the worksheet by placing a dotted line (that moves like a marquee) on the border between the titles and the information in the body of the report.

3. **Click OK or press Enter to close the Page Setup dialog box.**

   The dotted line showing the border of the row and/or column titles disappears from the worksheet.

In Figure 5-8, rows 1 and 2 containing the worksheet title and column headings for the Bo Peep Pet Detectives client database are designated as the print titles for the report. In Figure 5-9, you can see the Print Preview window with the second page of the report. Note how these print titles appear on all pages of the report.
To clear print titles from a report if you no longer need them, open the Sheet tab of the Page Setup dialog box and then delete the row and column ranges from the Rows to Repeat at Top and the Columns to Repeat at Left text boxes. Click OK or press Enter.
Using the buttons in the Scale to Fit group

If your printer supports scaling options, you’re in luck. You can always get a worksheet to fit on a single page simply by selecting the 1 Page option on the Width and Height drop-down menus attached to their command buttons in the Scale to Fit group on the Ribbon’s Layout Page. When you select these options, Excel figures out how much to reduce the size of the information you’re printing to fit it all on one page.

If you preview this one page in the Print Preview window (Alt+FWV) and find that the printing is just too small to read comfortably, click the Page Setup button on the Print Preview tab to reopen the Page tab of the Page Setup dialog box and try changing the number of pages in the Page(s) Wide By and Tall text boxes (to the immediate right of the Fit To option button).

Instead of trying to stuff everything on one page, check out how your worksheet looks if you fit it on two pages across. Try this: Select 2 Pages on the Width button’s drop-down menu on the Page Layout tab and leave 1 Page selected in the Height drop-down list button. Alternately, see how the worksheet looks on two pages down: Select 1 Page on the Width button’s drop-down menu and 2 Pages on the Height button’s drop-down menu.

After using the Width and Height Scale to Fit options, you may find that you don’t want to scale the printing. Cancel scaling by selecting Automatic on both the Width and Height drop-down menus and then entering 100 in the Scale text (or select 100 with its spinner buttons).

Using the Print buttons in the Sheet Options group

The Sheet Options group contains two very useful Print check boxes (neither of which is automatically selected), the first in the Gridlines column and the second in the Headings column:

✔ Select the Print check box in the Gridlines column to print the column and row gridlines on each page of the report.
✔ Select the Print check box in the Headings column to print the row headings with the row numbers and the column headings with the column letters on each page of the report.
Select both check boxes (by clicking them to put check marks in them) when you want the printed version of your spreadsheet data to match as closely as their on-screen appearance. This is useful when you need to use the cell references on the printout to help you later locate the cells in the actual worksheet that need editing.

**From Header to Footer**

Headers and footers are simply standard text that appears on every page of the report. A header is printed in the top margin of the page, and a footer is printed — you guessed it — in the bottom margin. Both are centered vertically in the margins. Unless you specify otherwise, Excel does not automatically add either a header or footer to a new workbook.

Use headers and footers in a report to identify the document used to produce the report and display the page numbers and the date and time of printing.

The place to add a header or footer to a report is in Page Layout view. You can switch to this view by clicking the Page Layout View button on the Status bar or by clicking the Page Layout View button on the Ribbon’s View tab, or by just pressing Alt+WP.

When the worksheet’s displayed in Page Layout Preview, position the mouse pointer over the section in the top margin of the first page marked Click to Add Header or in the bottom margin of the first page marked Click to Add Footer.

To create a centered header or footer, highlight the center section of this header/footer area and then click the mouse pointer to set the insertion point in the middle of the section. To add a left-aligned header or footer, highlight and then click to set the insertion point flush with the left edge of the left-hand section or to add a right-aligned header or footer, highlight and click to set the insertion point flush with the right edge of the right-hand section.

Immediately after setting the insertion point in the left, center, or right section of the header/footer area, Excel adds a Header & Footer Tools contextual tab with its own Design tab (see Figure 5-10). The Design tab is divided into Auto Header & Footer, Header & Footer Elements, Navigation, and Options groups.
Adding an Auto Header or Auto Footer

The Header and Footer command buttons on the Design tab of the Header & Footer Tools contextual tab enable you to add stock headers and footers in an instant. Simply click the appropriate command button and then click the header or footer example you want to use on the Header or Footer drop-down menu that appears.

To create the centered header and footer for the report shown in Figure 5-11, I first selected

Client List, Confidential, Page 1

on the Header command button’s drop-down menu. Client List is the name of the worksheet; Confidential is stock text; and Page 1 is, of course, the current page number).

To set up the footer, I chose

Page 1 of ?
in the Footer command button’s drop-down menu (which puts in the current page number, along with the total number of pages, in the report). You can select this paging option on either the Header or Footer button’s drop-down menu.

Check out the results in Figure 5-11, which is the first page of the report in Page Layout view. Here you can see the header and footer as they will print. You can also see how choosing Page 1 of ? works in the footer: On the first page, you see the centered footer: Page 1 of 4; on the second page, you would see the centered footer Page 2 of 4.

If, after selecting some stock header or footer info, you decide that you no longer need either the header or footer printed in your report, you can remove it. Simply click the click the (None) option at the top of the Header button’s or Footer button’s drop-down menus. (Remember that the Design tab with the Header and Footer command buttons under the Header & Footer Tools contextual tab is automatically selected on the Ribbon the moment you click the header or footer in Page Layout view.)
Creating a custom header or footer

Most of the time, the stock headers and footers available on the Header button’s and Footer button’s drop-down menus are sufficient for your report printing needs. Every once in a while, however, you may want to insert information not available in these list boxes or in an arrangement Excel doesn’t offer in the readymade headers and footers.

For those times, you need to use the command buttons that appear in the Header & Footer Elements group of Design tab under the Header & Footer Tools contextual tab. These command buttons enable you to blend your own information with that generated by Excel into different sections of the custom header or footer you’re creating.

The command buttons in the Header & Footer Elements group include

- **Page Number**: Click this button to insert the & [Page] code that puts in the current page number.
- **Number of Pages**: Click this button to insert the & [Pages] code that puts in the total number of pages.
- **Current Date**: Click this button to insert the & [Date] code that puts in the current date.
- **Current Time**: Click this button to insert the & [Time] code that puts in the current time.
- **File Path**: Click this button to insert the & [Path] & [Filename] codes that put in the directory path along with the name of the workbook file.
- **File Name**: Click this button to insert the & [Filen] code that puts in the name of the workbook file.
- **Sheet Name**: Click this button to insert the & [Tab] code that puts in the name of the worksheet as shown on the sheet tab.
- **Picture**: Click this button to insert the & [Picture] code that inserts the image that you select from the Insert Picture dialog box (that shows the contents of the My Pictures folder on your computer by default).
- **Format Picture**: Click this button to apply the formatting that you choose from the Format Picture dialog box to the & [Picture] code that you enter with the Insert Picture button without adding any code of its own.

To use these command buttons in the Header & Footer Elements group to create a custom header or footer, follow these steps:
1. Put your worksheet into Page Layout view by clicking the Page Layout View button on the Status bar or by clicking View | Page Layout View on the Ribbon or pressing Alt+WP.

In Page Layout view, the text, Click to Add Header, appears centered in the top margin of the first page and the text, Click to Add Footer, appears centered in the bottom margin.

2. Position the mouse pointer in the top margin to create a custom header or the bottom margin to create a custom footer and then click the pointer in the left, center, or right section of the header or footer to set the insertion and left-align, center, or right-align the text.

When Excel sets the insertion point, the text, Click to Add Header and Click to Add Footer, disappears and the Design tab on the Header & Footer Tools contextual tab becomes active on the Ribbon.

3. To add program generated information to your custom header or footer (such as the filename, worksheet name, current date, and so forth) click its command button in the Header & Footer Elements group.

Excel inserts the appropriate header/footer code preceded by an ampersand (&) into the header or footer. These codes are replaced by the actual information (filename, worksheet name, graphic image, and the like) as soon as you click another section of the header or footer or finish the header or footer by clicking the mouse pointer outside of it.

4. (Optional) To add your own text to the custom header or footer, type it at the insertion point.

When joining program-generated information indicated by a header/footer code with your own text, be sure to insert the appropriate spaces and punctuation. For example, to have Excel display the Page 1 of 4 in a custom header or footer, you do the following:

1. Type the word Page and press the spacebar.

2. Click the Page Number command button and press the spacebar again.

3. Type the word of and press the spacebar a third time.

4. Click the Number of Pages command button.

This inserts Page &[Page] of &[Pages] in the custom header (or footer).

5. (Optional) To modify the font, font size, or some other font attribute of your custom header or footer, drag through its codes and text and then click the Home tab and then click appropriate command button in the Font group.
In addition to selecting a new font and font size for the custom header or footer, you can add bold, italics, underlining, and a new font color to its text with the Bold, Italic, Underline, and Font Color command buttons on the Home tab.

6. After you finish defining and formatting the codes and text for your custom header or footer, click a cell in the Worksheet area to deselect the header or footer area.

Excel replaces the header/footer codes in the custom header or footer with the actual information, while at the same time removing the Header & Footer Tools contextual tab from the Ribbon.

Figure 5-12 shows you a custom footer I added to a spreadsheet in Page Layout view. This custom footer blends my own text, Preliminary, with program-generated sheet name and date, and time information and uses all three sections: left-aligned page information, centered Preliminary warning, and right aligned current date and time. Note the different font and bold formatting for Preliminary warning in the center section.

Figure 5-12: Spreadsheet in Page Layout view showing the custom footer.
Creating unique first-page headers and footers

For the first time in Excel history, you can now define a header or footer for the first page that’s different from all the rest of the pages. Simply, click the Different First Page check box to put a check mark in it. (This check box is part of the Options group of the Design tab on the Header & Footer Tools contextual tab that appears when you’re defining or editing a header or footer in Page Layout view.)

After selecting the Different First Page check box, go ahead and define the unique header and/or footer for just the first page (now marked First Page Header or First Page Footer) and then, on the second page of the report, define the header and/or footer (marked simply Header or Footer) for the remaining pages of the report (see “Adding an Auto Header or Auto Footer” and “Creating a custom header or footer” earlier in the chapter for details).

Use this feature when your spreadsheet report has a cover page that needs no header or footer. For example, suppose that you have a report that needs the current page number and total pages centered at the bottom of all pages except the cover page. To do this, select Different First Page check box on the Design tab of Header & Footer Tools contextual tab on the Ribbon and then define a centered Auto Footer that displays the current page number and total pages (Page 1 of ?) on the second page of the report, leaving the Click to Add Footer text intact on the first page.

Excel will correctly number both the total number of pages in the report and the current page number without printing this information on the first page. So if your report has a total of six pages (including the cover page), the second page footer will read Page 2 of 6; the third page, Page 3 of 6; and so on, even as the first printed page has no footer at all.

Creating different even and odd page headers and footers

If you plan to do two-sided printing or copying of your spreadsheet report, you may want to define a one header or footer for even the pages and another for odd pages of the report. That way, the header or footer information (such as the report name or current page) alternates from being right-aligned on the odd pages (printed on the front side of the page) to being left-aligned on even pages (printed on the back side of the page).

To create an alternating header or footer for a report, you click the Different Odd & Even Pages check box to put a check mark in it. (This check box is found in the Options group of the Design tab on the Header & Footer Tools contextual tab that appears when you’re defining or editing a header or footer in Page Layout view.)
After that, create a header or footer on the first page of the report (now marked Odd Page Header or Odd Page Footer) in the third, right-aligned section header or footer area and then recreate this header or footer on the second page (now marked Even Page Header or Even Page Footer), this time in the first, left-aligned section.

**Solving Page Break Problems**

The Page Break preview feature in Excel enables you to spot and fix page break problems in an instant, such as when the program wants to split information across different pages that you know should always be printed together on the same page.

Figure 5-13 shows a worksheet in Page Break Preview with an example of a bad vertical page break that you can remedy by adjusting the location of the page break on Page 1 and 3. Given the page size, orientation, and margin settings for this report, Excel breaks the page between columns K and L. This break separates the Paid column (L) from all the others in the client list, effectively putting this information on its own page 3 and page 4 (not shown in Figure 5-13).
To prevent the data in the Paid column from being printed alone on its own pages, you need to move the page break to a column on the left. In this case, I choose to move the page break back between columns G (with the Zip code data) and H (containing the account Status information) so that the name and address information stays together on Page 1 and 2 and the other client data is printed together on Page 3 and 4. Figure 5-13 shows how you can create the vertical page break in Page Break Preview mode by following these steps:

1. Click the Page Break Preview button (the third one in the cluster of three to the left of the Zoom slider) on the Status bar or click View | Page Break Preview on the Ribbon or press Alt+W1.

   This takes you into a page break preview mode that shows your worksheet data at a reduced magnification (60 percent of normal in Figure 5-13) with the page numbers displayed in large light type and the page breaks shown by heavy lines between the columns and rows of the worksheet.

   The first time you choose this command, Excel displays a Welcome to Page Break Preview dialog box (shown in Figure 5-13). To prevent this dialog box from reappearing each time you use Page Break Preview, click the Do Not Show This Dialog Again check box before you close the Welcome to Page Break Preview alert dialog box.

2. Click OK or press Enter to get rid of the Welcome to Page Break Preview alert dialog box.

3. Position the mouse pointer somewhere on the page break indicator (one of the heavy lines surrounding the representation of the page) that you need to adjust; when the pointer changes to a double-headed arrow, drag the page indicator to the desired column or row and release the mouse button.

   For the example shown in Figure 5-13, I dragged the page break indicator between Page 1 and 3 to the left so that it’s between columns G and H. Excel then moved the page break back to this point, which puts all the name and address information together on pages 1 and 2. This new page break then causes all the other columns of client data to print together on pages 3 and 4.

   In Figure 5-14, you can see Page 1 of the report as it then appears in the Print Preview window.

4. After you finish adjusting the page breaks in Page Break Preview (and, presumably, printing the report), click the Normal button (the first one in the cluster of three to the left of the Zoom slider) on the Status bar or click View | Normal on the Ribbon or press Alt+W1 to return the worksheet to its regular view of the data.
You can also insert your own manual page breaks at the cell cursor’s position by clicking Insert Page Break on the Break button’s drop-down menu on the Page Layout tab (Alt+PBI) and remove them by clicking Remove Page Break on this menu (Alt+PBR). To remove all manual page breaks that you’ve inserted into a report, click Reset All Page Breaks on the Break button’s drop-down menu (Alt+PBA).

**Letting Your Formulas All Hang Out**

One more basic printing technique you may need every once in a while is how to print the formulas in a worksheet instead of printing the calculated results of the formulas. You can check over a printout of the formulas in your worksheet to make sure that you haven’t done anything stupid (like replace a formula with a number or use the wrong cell references in a formula) before you distribute the worksheet companywide.

Before you can print a worksheet’s formulas, you have to display the formulas, rather than their results, in the cells by clicking the Show Formulas button (the one with the icon that looks like a page of a calendar with a tiny 15 above an fx) in the Formula Auditing group on the Ribbon’s Formulas tab (Alt+MH).
Excel then displays the contents of each cell in the worksheet as they normally appear only in the Formula bar or when you’re editing them in the cell. Notice that value entries lose their number formatting, formulas appear in their cells (Excel widens the columns with best-fit so that the formulas appear in their entirety), and long text entries no longer spill over into neighboring blank cells.

Tip

Excel allows you to toggle between the normal cell display and the formula cell display by pressing Ctrl+`. (That is, press Ctrl and the key with the tilde on top.) This key — usually found in the upper-left corner of your keyboard — does double-duty as a tilde and as a weird backward accent mark: ` (Don’t confuse that backward accent mark with the apostrophe that appears on a key below the quotation mark!)

After Excel displays the formulas in the worksheet, you are ready to print it as you would any other report. You can include the worksheet column letters and row numbers as headings in the printout so that if you do spot an error, you can pinpoint the cell reference right away.

Remember

To include the row and column headings in the printout, put a check mark in the Print check box in the Headings column on the Sheet Options group of the Page Layout tab of the Ribbon before you send the report to the printer.

After you print the worksheet with the formulas, return the worksheet to normal by clicking the Show Formulas button on the Formulas tab of the Ribbon or by pressing Ctrl+`. 
Part III

Getting Organized and Staying That Way

The 5th Wave  By Rich Tennant

"Unless there's a corrupt cell in our spreadsheet analysis concerning the importance of trunk space, this should be a big seller next year."
In today’s business world, we all know how vital it is to stay organized — as well as how difficult that can be. Keeping straight the spreadsheets that you create in Excel 2007 is no less important and, in some cases, no less arduous.

In this part, I help you tackle this conundrum by giving you the inside track on how to keep on top of all the stuff in every single worksheet that you create or edit. Not only do you discover in Chapter 6 how to keep track of the information in one worksheet, but also, in Chapter 7, how to juggle the information from one worksheet to another and even from one workbook to another.
Chapter 6
Maintaining the Worksheet

In This Chapter
- Zooming in and out on a worksheet
- Splitting up the workbook window into two or four panes
- Freezing columns and rows on-screen for worksheet titles
- Attaching comments to cells
- Naming your cells
- Finding and replacing stuff in your worksheet
- Looking up stuff using online resources in the Research Task pane
- Controlling when you recalculate a worksheet
- Protecting your worksheets

Each worksheet in Excel 2007 offers an immense place in which to store information (and each workbook you open offers you three of these babies). But because your computer monitor lets you see only a tiny bit of any of the worksheets in a workbook at a time, the issue of keeping on top of information is not a small one (pun intended).

Although the Excel worksheet employs a coherent cell-coordinate system that you can use to get anywhere in the great big worksheet, you have to admit that this A1, B2 stuff — although highly logical — remains fairly alien to human thinking. (I mean, saying, “Go to cell IV88,” just doesn’t have anywhere near the same impact as saying, “Go to the corner of Hollywood and Vine.”) Consider for a moment the difficulty of coming up with a meaningful association between the 2008 depreciation schedule and its location in the cell range AC50:AN75 so that you can remember where to find it.

In this chapter, I show you some of the more effective techniques for maintaining and keeping on top of information. You find out how to change the perspective on a worksheet by zooming in and out on the information, how to split the document window into separate panes so that you can display different sections of the worksheet at the same time, and how to keep particular rows and columns on the screen at all times.
And, as if that weren’t enough, you also see how to add comments to cells, assign descriptive, English-type names to cell ranges (like Hollywood_and_Vine!), and use the Find and Replace commands to locate and, if necessary, replace entries anywhere in the worksheet. Finally, you see how to control when Excel recalculates the worksheet and how to limit where changes can be made.

**Zeroing In with Zoom**

So what are you gonna do now that the boss won’t spring for that 21-inch monitor for your computer? All day long, it seems that you’re either straining your eyes to read all the information in those little, tiny cells, or you’re scrolling like mad trying to locate a table you can’t seem to find. Never fear, the Zoom feature is here in the form of the Zoom slider on the Status bar. You can use the Zoom slider to quickly increase the magnification of part of the worksheet or shrink it down to the tiniest size.

You can use the Zoom slider on the Status bar of the Excel window in either of two ways:

- Drag the Zoom slider button to the left or the right on the slider to decrease or increase the magnification percentage (with 10% magnification the lowest percentage when you drag all the way to the left on the slider and 400% magnification the highest percentage when you drag all the way to the right).
- Click the Zoom Out (with the minus sign) or the Zoom In button (with the plus sign) at either end of the slider to decrease or increase the magnification percentage by 10 percent.

In Figure 6-1, you can see a blowup of the worksheet after increasing it to 200-percent magnification (twice normal size). To blow up a worksheet like this, drag the Zoom slider button to the right until 200% appears on the Status bar to the left of the slider. (You can also do this by clicking View | Zoom and then clicking the 200% option button in the Zoom dialog box, if you really want to go to all that trouble.) One thing’s for sure: You don’t have to go after your glasses to read the names in those enlarged cells! The only problem with 200-percent magnification is that you can see only a few cells at one time.

In Figure 6-2, check out the same worksheet, this time at 25-percent magnification (roughly one-quarter normal size). To reduce the display to this magnification, you drag the Zoom slider button to the left until 25% appears on the Status bar in front of the slider (unless you’re just dying to open the Zoom dialog box so that you can accomplish this via its 25% option button).
**Figure 6-1:**
Zooming in: A sample worksheet at 200% magnification.

**Figure 6-2:**
Zooming out: A sample worksheet at 25% magnification.
Whew! At 25 percent of normal screen size, the only thing you can be sure of is that you can't read a thing! However, notice that with this bird's-eye view, you can see at a glance how far over and down the data in this worksheet extends and how much empty space there is in the worksheet.

The Zoom dialog box (View | Zoom or Alt+WQ) offers five precise magnification settings — 200%, 100% (normal screen magnification), 75%, 50%, and 25%. To use other percentages besides those, you have the following options:

- If you want to use other precise percentages in between the five preset percentages (such as 150% or 85%) or settings greater or less than the highest or lowest (such as 400% or 10%), click within the Custom button’s text box in the Zoom dialog box, type the new percentage, and press Enter.

- If you don’t know what percentage to enter in order to display a particular cell range on the screen, select the range, click View | Zoom to Selection on the Ribbon or press Alt-WG. Excel figures out the percentage necessary to fill up your screen with just the selected cell range.

To quickly return to 100% (normal) magnification in the worksheet after selecting any another percentage, all you have to do is to click the bar in the center of the Zoom slider on the Status bar.

You can use the Zoom feature to locate and move to a new cell range in the worksheet. First, select a small magnification, such as 50%. Then locate the cell range you want to move to and select one of its cells. Finally, use the Zoom feature to return the screen magnification to 100%. When Excel returns the display to normal size, the cell you select and its surrounding range appear on-screen.

**Splitting the Difference**

Although zooming in and out on the worksheet can help you get your bearings, it can’t bring together two separate sections so that you can compare their data on the screen (at least not at a normal size where you can actually read the information). To manage this kind of trick, split the Worksheet area into separate panes and then scroll the worksheet in each pane so that they display the parts you want to compare.

Splitting the window is easy. Look at Figure 6-3 to see an Income Analysis worksheet after splitting its worksheet window horizontally into two panes and scrolling up rows 34 through 46 in the lower pane. Each pane has its own vertical scroll bar, which enables you to scroll different parts of the worksheet into view.
To split a worksheet into two (upper and lower) horizontal panes, you can drag the split bar, located right above the scroll arrow at the very top of the vertical scroll bar, down until the window divides as you want it. Use the following steps:

1. **Click the vertical split bar and hold down the primary mouse button.**
   The mouse pointer changes to a double-headed arrow with a split in its middle (like the one used to display hidden rows).

2. **Drag downward until you reach the row at which you want the document window divided.**
   A gray dividing line appears in the workbook document window as you drag down, indicating where the document window will be split.

3. **Release the mouse button.**
   Excel divides the window into horizontal panes at the pointer’s location and adds a vertical scroll bar to the new pane.

You can also split the document window into two vertical (left and right) panes by following these steps:
1. Click the split bar located at the right edge of the horizontal scroll bar.
2. Drag to the left until you reach the column at which you want the document window divided.
3. Release the mouse button.
   Excel splits the window at that column and adds a second horizontal scroll bar to the new pane.

Don’t confuse the tab split bar to the left of the horizontal scroll bar with the horizontal split bar at its right. You drag the *tab split bar* to increase or decrease the number of sheet tabs displayed at the bottom of the workbook window; you use the *horizontal split bar* to divide the workbook window into two vertical panes.

Note that you can make the panes in a workbook window disappear by double-clicking anywhere on the split bar that divides the window rather than having to drag the split bar all the way to one of the edges of the window to get rid of it.

Instead of dragging split bars, you can divide a document window by clicking the Split button on the Ribbon’s View tab (Alt+WS). When you click this command button, Excel uses the position of the cell cursor to determine where to split the window into panes. The program splits the window vertically at the left edge of the pointer and horizontally along the top edge.

If you want the workbook window split into just two horizontal panes, do this: Using the top of the cell cursor as the dividing line, position the cell cursor in the first column of the desired row that is displayed on your screen. If you want the workbook window split into just two vertical windows, do this: Using the left edge of the cell cursor as the dividing line, position the cell cursor in the first row of the desired column that’s displayed on your screen.

If you position the cell cursor somewhere in the midst of the cells displayed on-screen when you click View | Split or press Alt+WS, Excel splits the window into four panes along the top and left edge of the cell cursor. For example, if you position the cell cursor in cell B10 of the sample Income Analysis worksheet and then click View | Split, the window splits into four panes: A horizontal split occurs between rows 9 and 10, and a vertical split occurs between columns A and B (as shown in Figure 6-4).

Excel divides whatever portion of the worksheet is displayed on-screen given its current magnification into four equal panes when the cell cursor is in cell A1 at the time you click View | Split or press Alt+WS.
After you split the window into panes, you can move the cell cursor into a particular pane either by clicking one of its cells. To remove the panes from a worksheet window, click View | Split on the Ribbon or press Alt+WS another time.

Fixed Headings Courtesy of Freeze Panes

Window panes are great for viewing different parts of the same worksheet that normally can’t be seen together. You can also use window panes to freeze headings in the top rows and first columns so that the headings stay in view at all times, no matter how you scroll through the worksheet. Frozen headings are especially helpful when you work with a table that contains information that extends beyond the rows and columns shown on-screen.

In Figure 6-5, you can see just such a table. The Income Analysis worksheet contains more rows and columns than you can see at one time (unless you decrease the magnification to 25% with Zoom, which makes the data too small to read). As a matter of fact, this worksheet continues down to row 52 and over to column P.
By splitting the document window into four panes between rows 2 and 3 and columns A and B and then freezing them on the screen, you can keep the column headings in row 2 that identify each column of information on the screen as you scroll the worksheet up and down to review information on different employees. And you can keep the row headings in column A on the screen as you scroll the worksheet to the right.

Refer to Figure 6-5 to see the worksheet right after splitting the window into four panes and freezing them. To create and freeze these panes, follow these steps:

1. **Position the cell cursor in cell B3.**
2. **Click View | Freeze Panes on the Ribbon and then click Freeze Panes on the drop-down menu or press Alt+WFF.**

   In this example, Excel freezes the top and left window pane above row 3 and left of column B.

When Excel sets up the frozen panes, the borders of frozen panes are represented by a single line rather than a thin bar, as is the case with unfrozen panes.
See what happens when you scroll the worksheet up after freezing the window panes (shown in Figure 6-6). In this figure, I scrolled the worksheet up so that rows 12 through 38 appear under rows 1 and 2. Because the vertical pane with the worksheet title and column headings is frozen, it remains on-screen. (Normally, rows 1 and 2 would have been the first to disappear as you scroll the worksheet up.)

Look to Figure 6-7 to see what happens when you scroll the worksheet to the left. In this figure, I scroll the worksheet so that the data in columns K through P appear after the data in column A. Because the first column is frozen, it remains on-screen, helping you identify the various categories of income and expenses for each month.

Click the Freeze Top Row or Freeze First Column on the Freeze Panes button’s drop-down menu to freeze the column headings in the top row of the worksheet or the row headings in the first column of the worksheet regardless of where the cell cursor is located in the worksheet.

To unfreeze the window panes in a worksheet, click View | Freeze Panes on the Ribbon and then click Unfreeze Panes on the Freeze Panes button’s drop-down menu or press Alt-WFF. Choosing this option removes the window panes, indicating that Excel has unfrozen them.
Electronic Sticky Notes

You can add text comments to particular cells in an Excel worksheet. *Comments* act kind of like electronic pop-up versions of sticky notes. For example, you can add a comment to yourself to verify a particular figure before printing the worksheet or to remind yourself that a particular value is only an estimate (or even to remind yourself that it’s your anniversary and to pick up a little something special for your spouse on the way home!).

In addition to using notes to remind yourself of something you’ve done or that still remains to be done, you can also use a comment to mark your current place in a large worksheet. You can then use the comment’s location to quickly find your starting place the next time you work with that worksheet.

### Adding a comment to a cell

To add a comment to a cell, follow these steps:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Regional Income</strong></td>
<td><strong>Aug</strong></td>
<td><strong>Sep</strong></td>
<td><strong>Oct</strong></td>
<td><strong>Nov</strong></td>
<td><strong>Dec</strong></td>
<td><strong>TOTAL</strong></td>
</tr>
<tr>
<td>Northern</td>
<td>18,486</td>
<td>20,629</td>
<td>22,860</td>
<td>24,481</td>
<td>26,883</td>
<td>$286,078</td>
</tr>
<tr>
<td>Southern</td>
<td>11,986</td>
<td>13,081</td>
<td>14,317</td>
<td>15,497</td>
<td>16,891</td>
<td>$180,089</td>
</tr>
<tr>
<td>Central</td>
<td>385,981</td>
<td>403,498</td>
<td>421,806</td>
<td>439,787</td>
<td>457,673</td>
<td>$4,972,810</td>
</tr>
<tr>
<td>Western</td>
<td>116,534</td>
<td>127,458</td>
<td>138,892</td>
<td>151,433</td>
<td>165,062</td>
<td>$1,789,587</td>
</tr>
<tr>
<td>International</td>
<td>112,185</td>
<td>122,398</td>
<td>132,608</td>
<td>142,818</td>
<td>153,028</td>
<td>$1,882,018</td>
</tr>
<tr>
<td><strong>Total Cost of Goods Sold</strong></td>
<td>$600,091</td>
<td>$610,591</td>
<td>$621,092</td>
<td>$631,593</td>
<td>$642,094</td>
<td>$6,582,182</td>
</tr>
<tr>
<td>Southern</td>
<td>25,008</td>
<td>22,099</td>
<td>20,190</td>
<td>18,280</td>
<td>16,370</td>
<td>$189,100</td>
</tr>
<tr>
<td>Central</td>
<td>44,268</td>
<td>42,349</td>
<td>40,430</td>
<td>38,520</td>
<td>36,610</td>
<td>$460,900</td>
</tr>
<tr>
<td>Western</td>
<td>26,001</td>
<td>24,092</td>
<td>22,183</td>
<td>20,274</td>
<td>18,365</td>
<td>$240,123</td>
</tr>
<tr>
<td>International</td>
<td>55,095</td>
<td>53,186</td>
<td>51,277</td>
<td>49,368</td>
<td>47,459</td>
<td>$501,753</td>
</tr>
<tr>
<td><strong>Total Operating Expenses</strong></td>
<td>$182,388</td>
<td>$170,638</td>
<td>$158,888</td>
<td>$147,138</td>
<td>$135,388</td>
<td>$1,782,739</td>
</tr>
<tr>
<td>Northern</td>
<td>56,642</td>
<td>57,832</td>
<td>59,022</td>
<td>60,212</td>
<td>61,402</td>
<td>$685,533</td>
</tr>
<tr>
<td>Southern</td>
<td>5,007</td>
<td>5,007</td>
<td>5,007</td>
<td>5,007</td>
<td>5,007</td>
<td>$55,070</td>
</tr>
<tr>
<td>Central</td>
<td>92,038</td>
<td>93,238</td>
<td>94,438</td>
<td>95,638</td>
<td>96,838</td>
<td>$1,069,333</td>
</tr>
<tr>
<td>Western</td>
<td>51,366</td>
<td>52,556</td>
<td>53,746</td>
<td>54,936</td>
<td>56,126</td>
<td>$550,666</td>
</tr>
<tr>
<td>International</td>
<td>82,521</td>
<td>83,721</td>
<td>84,921</td>
<td>86,121</td>
<td>87,321</td>
<td>$869,851</td>
</tr>
<tr>
<td><strong>Total Net Income</strong></td>
<td>$201,373</td>
<td>$194,150</td>
<td>$186,928</td>
<td>$179,706</td>
<td>$172,484</td>
<td>$2,082,173</td>
</tr>
</tbody>
</table>

Figure 6-7: The Income Analysis worksheet after scrolling the columns left to display the last group of columns in this table.
1. Move the cell cursor to or click the cell to which you want to add the comment.

2. Click the New Comment command button on the Ribbon’s Review tab or press Alt+RC.

A new text box appears (similar to the one shown in Figure 6-8). This text box contains the name of the user as it appears in the User name text box on the Personalize tab of the Excel Options dialog box (Alt+FIP) and the insertion point located at the beginning of a new line right below the user name.

3. Type the text of your comment in the text box that appears.

4. When you finish entering the comment text, click somewhere on the worksheet outside of the text box.

Excel marks the location of a comment in a cell by adding a tiny triangle in the upper-right corner of the cell. (This triangular note indicator appears in red on a color monitor.)

5. To display the comment in a cell, position the thick white-cross mouse pointer somewhere in the cell with the note indicator.
Comments in review

When you have a workbook with sheets that contain a bunch of different comments, you probably won’t want to take the time to position the mouse pointer over each of its cells in order to be able to read each one. For those times, you need to click the Show All Comments command button on the Ribbon’s Review tab or press Alt+RA. When you click Show All Comments, Excel displays all the comments in the workbook while at the same time displaying the Reviewing toolbar (as shown in Figure 6-9).

With the Reviewing tab selected in the Ribbon, you can then move back and forth from comment to comment by clicking its Next and Previous command buttons in Comment group (Alt+RN and Alt+RV, respectively). When you reach the last comment in the workbook, you receive an alert box asking you whether you want to continue reviewing the comments from the beginning (which you can do by simply clicking OK). After you’re finished reviewing the comments in your workbook, you can hide their display by clicking the Show All Comments command button on the Review tab of the Ribbon or pressing Alt+RA a second time.
**Editing the comments in a worksheet**

To edit the contents of a comment, select it by clicking the Next or Previous command button in the Comments group of the Review toolbar and then click the Edit Comment button (which replaces New Comment) or right-click the cell with the comment and select Edit Command from the cell's shortcut menu.

To change the placement of a comment in relation to its cell, you select the comment by clicking somewhere on it and then positioning the mouse pointer on one of the edges of its text box. When a four-headed arrow appears at the tip of the mouse pointer, you can drag the text box to a new place in the worksheet. Note that when you release the mouse button, Excel redraws the arrow connecting the comment's text box to the note indicator in the upper-right corner of the cell.

To change the size of a comment's text box, you select the comment, position the mouse pointer on one of its sizing handles, and then drag in the appropriate direction (away from the center of the box to increase its size or toward the center to decrease its size). When you release the mouse button, Excel redraws the comment’s text box with the new shape and size. When you change the size and shape of a comment’s text box, Excel automatically wraps the text to fit in the new shape and size.

To change the font of the comment text, select the text of the comment (by selecting the comment for editing and then dragging through the text), then right-click the text box and click Format Comment on its shortcut menu to open the Font tab of the Format Cells dialog box (or you can press Ctrl+1 like you do to open this dialog box). You can then use the options on the Font tab to change the font, font style, font size, or color of the text displayed in the selected comment.

To delete a comment, select the cell with the comment in the worksheet or click the Next or Previous command buttons on the Review tab of the Ribbon until the comment is selected and then click the Delete command button on in the Comments group (Alt+RD). Excel removes the comment along with the note indicator from the selected cell.

You can also delete all comments by selecting Clear Comments from the Clear button's drop-down menu (the one with the eraser icon in the Editing group) on the Home tab of the Ribbon (Alt+HEM).
Getting your comments in print

When printing a worksheet, you can print comments along with worksheet data by selecting either the At End of Sheet or the As Displayed on Sheet option on Comments pop-up menu in the Sheet tab of the Page Setup dialog box. Open this dialog box by clicking the Dialog Box launcher button in the lower-right corner of the Page Setup group on the Ribbon’s Page Layout tab (Alt+PSP).

The Cell Name Game

By assigning descriptive names to cells and cell ranges, you can go a long way toward keeping on top of the location of important information in a worksheet. Rather than try to associate random cell coordinates with specific information, you just have to remember a name. You can also use range names to designate the cell selection that you want to print or use in other Office 2007 programs, such as Microsoft Office Word or Access. And, best of all, after you name a cell or cell range, you can use this name with the Go To feature.

If I only had a name . . .

When assigning range names to a cell or cell range, you need to follow a few guidelines:

✔ Range names must begin with a letter of the alphabet, not a number.
   
   For example, instead of 01Profit, use Profit01.

✔ Range names cannot contain spaces.

   Instead of a space, use the underscore (Shift-hyphen) to tie the parts of the name together. For example, instead of Profit 01, use Profit_01.

✔ Range names cannot correspond to cell coordinates in the worksheet.

   For example, you can’t name a cell Q1 because this is a valid cell coordinate. Instead, use something like Q1_sales.

To name a cell or cell range in a worksheet, follow these steps:

1. Select the cell or cell range that you want to name.

2. Click the cell address for the current cell that appears in the Name Box on the far left of the Formula bar.

   Excel selects the cell address in the Name Box.
3. Type the name for the selected cell or cell range in the Name Box.

When typing the range name, you must follow Excel’s naming conventions: Refer to the bulleted list of cell-name do’s and don’ts earlier in this section for details.

4. Press Enter.

To select a named cell or range in a worksheet, click the range name on the Name Box drop-down list. To open this list, click the drop-down arrow button that appears to the right of the cell address on the Formula bar.

Note that you can also accomplish the same thing by clicking Home | Find & Select & Select | Go To or by pressing F5, Ctrl+G, or Alt+HFDG to open the Go To dialog box (see Figure 6-10). Double-click the desired range name in the Go To list box (alternatively, select the name and click OK or press Enter). Excel moves the cell cursor directly to the named cell. If you selected a cell range, all the cells in that range are selected.

**Figure 6-10:** Select the named cell range to go to and select in a workbook.

---

**Name that formula!**

Cell names are not only a great way to identify and find cells and cell ranges in your spreadsheet, but they’re also a great way to make out the purpose of your formulas. For example, suppose that you have a simple formula in cell K3 that calculates the total due to you by multiplying the hours you work for a client (in cell I3) by the client’s hourly rate (in cell J3). Normally, you would enter this formula in cell K3 as

\[=I3\times J3\]

However, if you assign the name *Hours* to cell I3 and the name *Rate* to cell J3, you could then enter the formula as

\[=\text{Hours}\times\text{Rate}\]

in cell K3. I don’t think there’s anyone who would dispute that the formula \[=\text{Hours}\times\text{Rate}\] is much easier to understand than \[=I3\times J3\].
To enter a formula using cell names rather than cell references, follow these steps (see Chapter 2 to brush up on how to create formulas):

1. **Assign range names to the individual cells as I describe earlier in this section.**
   
   For this example, give the name *Hours* to cell I3 and the name *Rate* to cell J3.

2. **Place the cell cursor in the cell where the formula is to appear.**
   
   For this example, put the cell cursor in cell K3.

3. **Type = (equal sign) to start the formula.**

4. **Select the first cell referenced in the formula by selecting its cell (either by clicking or moving the cell cursor into it).**
   
   For this example, you select the Hours cell by selecting cell I3.

5. **Type the arithmetic operator you use in the formula.**
   
   For this example, you would type * (asterisk) for multiplication. (Refer to Chapter 2 for a list of the other arithmetic operators.)

6. **Select the second cell referenced in the formula by selecting its cell either by clicking or moving the cell cursor as before in Step 4.**
   
   For this example, you select the Rate cell by selecting cell J3.

7. **Click the Enter box or press Enter to complete the formula.**
   
   In this example, Excel enters the formula =Hours*Rate in cell K3.

You can’t use the fill handle to copy a formula that uses cell names, rather than cell addresses, to other cells in a column or row that perform the same function (see Chapter 4). When you copy an original formula that uses names rather than addresses, Excel copies the original formula without adjusting the cell references to the new rows and columns. See the section “Naming constants,” next in this chapter, to find out a way to use your column and row headings to identify the cell references in the copies, as well as the original formula from which the copies are made.

**Naming constants**

Certain formulas use constant values, such as a 7.5% tax rate or a 10% discount rate. If you don’t want to have to enter these constants into a cell of the worksheet in order to use the formulas, you create range names that hold their values and then use their range names in the formulas you create.
For example, to create a constant called *tax_rate* of 7.5%, you follow these steps:

1. Click the Define Name button on the Ribbon’s Formulas tab or press Alt+MMD to open the New Name dialog box.

2. In the New Name dialog box, type the range name (*tax_rate* in this example) into the Name text box.
   
   Be sure to adhere to the cell range naming conventions when entering this new name.

3. (Optional) To have the range name defined for just the active worksheet instead of the entire workbook, click the name of the sheet on the Scope drop-down list.
   
   Normally, you’re safer sticking with the default selection of Workbook in the Scope option so that you can use your constant in a formula on any of its sheets. Only change the scope to a particular worksheet when you’re sure that you’ll use it only in formulas on that worksheet.

4. Click in the Refers To text box after the equal to sign (=) and replace (enter) the current cell address with the constant value (7.5% in this example) or a formula that calculates the constant.

5. Click OK to close the New Name dialog box.

After you assign a constant to a range name by using this method, you can apply it to the formulas that you create in the worksheet in one of two ways:

- Type the range name to which you assign the constant at the place in the formula where its value is required.
- Click the Use in Formula command button on the Formulas tab (or press Alt+MS) and then click the constant’s range name on the drop-down menu that appears.

When you copy a formula that uses a range name containing a constant, its values remain unchanged in all copies of the formula that you create with the Fill handle. (In other words, range names in formulas act like absolute cell addresses in copied formulas — see Chapter 4 for more on copying formulas.)

Also, note that when you update the constant by changing its value in the Edit Name dialog box — opened by clicking the range name in the Name Manager dialog box (Alt+MN) and then clicking its Edit button — all of the formulas that use that constant (by referring to the range name) are automatically updated (recalculated) to reflect this change.
Seek and Ye Shall Find . . .

When all else fails, you can use Excel’s Find feature to locate specific information in the worksheet. Click Home | Find & Select | Find on the Ribbon or press Ctrl+F, Shift+F5, or even Alt+HFDF to open the Find and Replace dialog box.

In the Find What combo box of this dialog box, enter the text or values you want to locate and then click the Find Next button or press Enter to start the search. Choose the Options button in the Find and Replace dialog box to expand the search options (as shown in Figure 6-11).

![Figure 6-11: Use options in the Find and Replace dialog box to locate cell entries.](image)

When you search for a text entry with the Find and Replace feature, be mindful of whether the text or number you enter in the Find What text box is separate in its cell or occurs as part of another word or value. For example, if you enter the characters ca in the Find What text box and you don’t select the Match Entire Cell Contents check box Excel finds:

- The field name Ca in Case No cell A2
- The state code CA (for California) in cells F8, F9, and F11
- The ca that occurs in Rebecca in cell C31

If you select the Match Entire Cell Contents check box in the Find and Replace dialog box before starting the search, Excel would not consider the Ca in Case No or the ca in Rebecca to be a match because both of these cases have other text surrounding the text you’re searching for.

When you search for text, you can also specify whether or not you want Excel to match the case you use (uppercase or lowercase) when entering the search text in the Find What text box. By default, Excel ignores case differences between text in cells of your worksheet and the search text you enter in the Find What text box. To conduct a case-sensitive search, you need to select the Match Case check box (available when you click the Options button to expand the Find and Replace dialog box, shown in Figure 6-12).
If the text or values that you want to locate in the worksheet have special formatting, you can specify the formatting to match when conducting the search.

To have Excel match the formatting assigned to a particular cell in the worksheet, follow these steps:

1. Click the drop-down button on the right of the Format button and choose the Choose Format From Cell option on the pop-up menu.
   The Find and Replace dialog box temporarily disappears, and Excel adds an ink dropper icon to the normal white-cross mouse pointer.
2. Click this mouse pointer in the cell in the worksheet that contains the formatting you want to match.
   The Find and Replace dialog box reappears, and the Find and Replace feature picks up cell’s formatting.

To select the formatting to match in the search from the options on the Find Format dialog box (which are identical to those of the Format Cells dialog box), follow these steps:

1. Click the Format button or click its drop-down button and choose Format from its pop-up menu.
2. Then, select the formatting options to match from the various tabs (refer to Chapter 3 for help on selecting these options) and click OK.

When you use either of these methods to select the kinds of formatting to match in your search, the No Format Set button (located between the Find What text box and the Format button) changes to a Preview button. The word Preview in this button appears in whatever font and attributes Excel picks up from the sample cell or through your selections on the Font tab of the Find Format dialog box.

When you search for values in the worksheet, be mindful of the difference between formulas and values. For example, cell K24 of the Bo Peep Client List (refer to Figure 6-7) contains the value $15,000. If you type 15000 in the Find What text box and press Enter to search for this value, however, Excel displays an alert box with the following message

Microsoft Office Excel cannot find the data you’re searching for

instead of finding the value 15000 in cell K24. This is because the value in this cell is calculated by the following formula,

=I24*J24
and nowhere in that formula does the value 15000 show up. To have Excel find any entry matching 15000 in the cells of the worksheet, you need to choose Values in the Look In drop-down menu of the Find and Replace dialog box in place of the normally-used Formulas option.

To restrict the search to just the text or values in the text of the comments in the worksheet, choose the Comments option from the Look In pop-up menu.

If you don’t know the exact spelling of the word or name or the precise value or formula you’re searching for, you can use wildcards, which are symbols that stand for missing or unknown text. Use the question mark (?) to stand for a single unknown character; use the asterisk (*) to stand for any number of missing characters. Suppose that you enter the following in the Find What text box and choose the Values option in the Look In pop-up menu:

```
7*4
```

Excel stops at cells that contain the values 74, 704, and 7,5234, and even finds the text entry 782 4th Street.

If you actually want to search for an asterisk in the worksheet rather than use the asterisk as a wildcard, precede it with a tilde (~), as follows:

```
~*4
```

This arrangement enables you to search the formulas in the worksheet for one that multiplies by the number 4 (remember that Excel uses the asterisk as the multiplication sign).

The following entry in the Find What text box finds cells that contain Jan, January, June, Janet, and so on.

```
J?n*
```

Normally, Excel searches only the current worksheet for the search text you enter. If you want the program to search all the worksheets in the workbook, you must select the Workbook option from the Within pop-up menu.

When Excel locates a cell in the worksheet that contains the text or values you’re searching for, it selects that cell while at the same time leaving the Find and Replace dialog box open. (Remember that you can move the Find and Replace dialog box if it obscures your view of the cell.) To search for the next occurrence of the text or value, click the Find Next button or press Enter.
Excel normally searches down the worksheet by rows. To search across the columns first, choose the By Columns option in the Search pop-up menu. To reverse the search direction and revisit previous occurrences of matching cell entries, press the Shift key while you click the Find Next button in the Find and Replace dialog box.

**You Can Be Replaced!**

If your purpose for finding a cell with a particular entry is so that you can change it, you can automate this process by using the Replace tab on the Find and Replace dialog box. If you click Home | Find & Select | Replace on the Ribbon or press Ctrl+H or Alt+HFDR, Excel opens the Find and Replace dialog box with the Replace tab (rather than the Find tab) selected. On the Replace tab, enter the text or value you want to replace in the Find What text box, and then enter the replacement the text or value in the Replace With text box.

When you enter replacement text, enter it exactly as you want it to appear in the cell. In other words, if you replace all occurrences of *Jan* in the worksheet with *January*, enter the following in the Replace With text box:

```
January
```

Make sure that you use the capital J in the Replace With text box, even though you can enter the following in the Find What text box (providing you don’t check the Match Case check box that appears only when you choose the Options button to expand the Search and Replace dialog box options):

```
jan
```

After specifying what to replace and what to replace it with (as shown in Figure 6-12), you can have Excel replace occurrences in the worksheet on a case-by-case basis or globally. To replace all occurrences in a single operation, click the Replace All button.
Be careful with global search-and-replace operations; they can really mess up a worksheet in a hurry if you inadvertently replace values, parts of formulas, or characters in titles and headings that you hadn’t intended to change. With this in mind, always follow one rule:

Never undertake a global search-and-replace operation on an unsaved worksheet.

Also, verify whether or not the Match Entire Cell Contents check box (displayed only when you click the Options >> button) is selected before you begin. You can end up with a lot of unwanted replacements if you leave this check box unselected when you really only want to replace entire cell entries (rather than matching parts in cell entries).

If you do make a mess, immediately click the Undo button on the Quick Access toolbar or press Ctrl+Z to restore the worksheet.

To see each occurrence before you replace it, click the Find Next button or press Enter. Excel selects the next cell with the text or value you enter in the Find What text box. To have the program replace the selected text, click the Replace button. To skip this occurrence, click the Find Next button to continue the search. When you finish replacing occurrences, click the Close button to close the Find and Replace dialog box.

Do Your Research

Excel 2007 includes the Research task pane that you can use to search for information using online resources, such as the Encarta World Dictionary, Thesaurus, Stock Quotes, and Encyclopedia. Note that because all of these resources are online, to make use of the Research task pane, you must have Internet access available.

To open the Research task pane (similar to the one shown in Figure 6-13), click the Research command button on the Ribbon’s Review tab or press Alt+RR.

To then look up something in the Research pane, you enter the word or phrase you want to locate in the online resources in the Search For text box at the top of the Research pane. Then click the type of online reference to be searched on the Show Results From drop-down menu:

✔ All Reference Books to search for the word or phrase in any of the online reference books such as the Encarta Dictionary: English (North America, Thesaurus: English (U.S.), and so on
All Research Sites to look up the word or phrase in any online resource or any Web site such as Encarta Encyclopedia: English (North America), Factiva iWorks, HighBeam Research, and MSN Search

All Business and Financial Sites to look up the word or phrase in MSN Money Stock Quotes and Thomson Gale Company Profiles

To start the online search, click the Start Searching button to the immediate right of the Search For text box. Excel then connects you to the designated online resources and displays the search results in the list box below. Figure 6-13, for example, shows the various stock quote figures for Microsoft Corporation for the day and time I did the search.

When you include Web sites in your search, you can visit particular sites by clicking their links in the Research task pane. When you do, Windows then launches your default Web browser (such as Internet Explorer 7) and connects you to the linked page. To return to Excel after visiting a particular Web page, simply click the Close box in the upper-right corner of your Web browser’s window.

You can modify which online services are available for use in a search by clicking the Research Options link that appears at the very bottom of the Research task pane. When you click this link, Excel opens a Research Options dialog box that enables you to add or remove particular reference books and sites by selecting their check boxes.
You Can Be So Calculating

Locating information in a worksheet — although admittedly extremely important — is only a part of the story of keeping on top of the information in a worksheet. In really large workbooks that contain many completed worksheets, you may want to switch to manual recalculation so that you can control when the formulas in the worksheet are calculated. You need this kind of control when you find that Excel’s recalculation of formulas each time you enter or change information in cells has slowed the program’s response to a crawl. By holding off recalculations until you are ready to save or print the workbook, you find that you can work with Excel’s worksheets without interminable delays.

To put the workbook into manual recalculation, click the Calculation Options button in the Calculation group on the Ribbon’s Formulas tab and then click the Manual option on the drop-down menu or simply press Alt+MXM. After switching to manual recalculation, Excel displays the message

Calculate

on the status bar whenever you make a change to the worksheet that somehow affects the current values of its formulas. Whenever you see Calculate on the status bar, this is the signal that you need to bring the formulas up to date before saving the workbook (as you would before printing its worksheets).

To recalculate the formulas in a workbook when calculation is on manual, press F9 or Ctrl+= (equal sign) or click the Calculate Now (F9) button (the one with picture of a calculator in the upper-right corner of the Calculation group) on the Formulas tab (Alt+MB).

Excel then recalculates the formulas in all the worksheets in your workbook. If you made changes to only the current worksheet and don’t want to wait around for Excel to recalculate every other worksheet in the workbook, you can restrict the recalculation to the current worksheet by pressing Shift+F9 or clicking the Calculate Sheet (Shift+F9) button (the one with picture of a calculator on top of the worksheet in the lower-right corner of the Calculation group) on the Formulas tab (Alt+MJ).

If your worksheet contains data tables that perform different what-if scenarios (see Chapter 8 for details), you can have Excel automatically recalculate all parts of the worksheet except for those data tables by clicking Automatic Except Data Tables on the Calculation Options button’s drop-down menu on the Formulas tab (Alt+MXE).

To return a workbook to fully automatic recalculation, click the Automatic option on the Options button’s drop-down menu on the Formulas tab (Alt+MXA).
Putting on the Protection

After you more or less finalize a worksheet by checking out its formulas and proofing its text, you often want to guard against any unplanned changes by protecting the document.

Each cell in the worksheet can be locked or unlocked. By default, Excel locks all the cells in a worksheet so that, when you follow these steps, Excel locks the whole thing up tighter than a drum.

1. Click the Protect Sheet command button in the Changes group on the Ribbon’s Review tab or press Alt+RPS.

Excel opens the Protect Sheet dialog box (see Figure 6-14) in which you select the check box options you want to be available when the protection is turned on in the worksheet. By default, Excel selects the Protect Worksheet and Contents of Locked Cells check box at the top of the Protect Sheet dialog box. In addition, the program selects both the Select Locked Cells and Select Unlocked Cells check boxes in the Allow All Users of This Worksheet To list box below.

2. (Optional) Click any of the check box options in the Allow All Users of This Worksheet To list box (such as Format Cells or Insert Columns) that you still want to be functional when the worksheet protection is operational.

3. If you want to assign a password that must be supplied before you can remove the protection from the worksheet, type the password in the Password to Unprotect Sheet text box.

4. Click OK or press Enter.

If you type a password in the Password to Unprotect Sheet text box, Excel opens the Confirm Password dialog box. Re-enter the password in the Reenter Password to Proceed text box exactly as you type it in the Password to Unprotect Sheet text box and then click OK or press Enter.
If you want to go a step further and protect the layout of the worksheets in the workbook, you protect the entire workbook as follows:

1. **Click the Protect Workbook command button in the Changes group on the Ribbon’s Review tab and then click Protect Structure and Windows option on its drop-down menu or press Alt+RPWW.**

   Excel opens the Protect Structure and Windows dialog box, where the Structure check box is selected and the Windows check box is not selected. With the Structure check box selected, Excel won’t let you mess around with the sheets in the workbook (by deleting them or rearranging them). If you want to protect any windows that you set up (as I describe in Chapter 7), you need to select the Windows check box as well.

2. **To assign a password that must be supplied before you can remove the protection from the worksheet, type the password in the Password (optional) text box.**

3. **Click OK or press Enter.**

   If you type a password in the Password (optional) text box, Excel opens the Confirm Password dialog box. Re-enter the password in the Reenter Password to Proceed text box exactly as you type it into the Password (optional) text box in the Protect Sheet dialog box, and then click OK or press Enter.

Selecting the Protect Sheet command makes it impossible to make further changes to the contents of any of the locked cells in that worksheet except for those options that you specifically exempt in the Allow All Users of This Worksheet To list box. (See Step 2 in the first set of steps in this section.) Selecting the Protect Workbook command makes it impossible to make further changes to the layout of the worksheets in that workbook.

Excel displays an alert dialog box with the following message when you try to edit or replace an entry in a locked cell:

```
The cell or chart you are trying to change is protected and therefore read-only.
To modify a protected cell or chart, first remove protection using the Unprotect Sheet command (Review tab, Changes group). You may be prompted for a password.
```

Usually, your intention in protecting a worksheet or an entire workbook is not to prevent all changes but to prevent changes in certain areas of the worksheet. For example, in a budget worksheet, you may want to protect all the cells that contain headings and formulas but allow changes in all the cells where you enter the budgeted amounts. That way, you can’t inadvertently wipe out a title or formula in the worksheet simply by entering a value in the wrong column or row (not an uncommon occurrence).
To protect and share . . .

If you create a workbook with contents to be updated by several different users on your network, you can use the Protect Sharing command button in the Changes group of the Ribbon’s Review tab (Alt+RO) to ensure that Excel tracks all the changes made and that no user can intentionally or inadvertently remove Excel’s tracking of changes made to the file. To do this, simply select the Sharing with Tracked Changes check box in the Protect Shared Workbook dialog box that appears after you choose the command button. After you select this check box, you can add a password in the Password (optional) text box below that each user must supply before he or she can open the workbook to make any changes.

To leave certain cells unlocked so that you can still change them after protecting the worksheet or workbook, select all the cells as the cell selection, open the Format Cells dialog box (Ctrl+1), and then click the Locked check box on the Protection tab to remove its check mark. Then, after unlocking the cells you still want to be able to change, protect the worksheet as described earlier.

To remove protection from the current worksheet or workbook document so that you can again make changes to its cells (whether locked or unlocked), click the Unprotect Sheet or the Unprotect Workbook command button in the Changes group on the Ribbon’s Review tab (or press Alt-RPS and Alt-RPWW, respectively). If you assign a password when protecting the worksheet or workbook, you must then reproduce the password exactly as you assign it (including any case differences) in the Password text box of the Unprotect Sheet or Unprotect Workbook dialog box.
Chapter 7
Maintaining Multiple Worksheets

In This Chapter
- Moving from sheet to sheet in your workbook
- Adding and deleting sheets in a workbook
- Selecting sheets for group editing
- Naming sheet tabs descriptively
- Rearranging sheets in a workbook
- Displaying parts of different sheets
- Comparing two worksheets side by side
- Copying or moving sheets from one workbook to another
- Creating formulas that span different worksheets

When you’re brand new to spreadsheets, you have enough trouble keeping track of a single worksheet — let alone three worksheets — and the very thought of working with more than one may be a little more than you can take. However, after you get a little experience under your belt, you’ll find that working with more than one worksheet in a workbook is no more taxing than working with just a single worksheet.

Don’t confuse the term workbook with worksheet. The workbook forms the document (file) that you open and save as you work. Each workbook (file) normally contains three blank worksheets. These worksheets are like the loose-leaf pages in a notebook binder from which you can delete or to which you can add as you need. To help you keep track of the worksheets in your workbook and navigate between them, Excel provides sheet tabs (Sheet1 through Sheet3) that are kinda like tab dividers in a loose-leaf notebook.
You need to see how to work with more than one worksheet in a workbook, but it’s also important to know why you’d want to do such a crazy thing in the first place. The most common situation is, of course, when you have a bunch of worksheets that are somehow related to each other and, therefore, naturally belong together in the same workbook. For example, consider the case of Mother Goose Enterprises with its different companies: Jack Sprat Diet Centers, Jack and Jill Trauma Centers, Mother Hubbard Dog Goodies; Rub-a-Dub-Dub Hot Tubs and Spas; Georgie Porgie Pudding Pies; Hickory, Dickory, Dock Clock Repair; Little Bo Peep Pet Detectives; Simple Simon Pie Shoppes; and Jack Be Nimble Candlesticks. To keep track of the annual sales for all these companies, you could create a workbook containing a worksheet for each of the nine different companies.

By keeping the sales figures for each company in a different sheet of the same workbook, you gain all of the following benefits:

- You can enter the stuff that’s needed in all the sales worksheets (if you select those sheet tabs) just by typing it once into the first worksheet (see the section “Editing en masse,” later in this chapter).
- In order to help you build the worksheet for the first company’s sales, you can attach macros to the current workbook so that they are readily available when you create the worksheets for the other companies. (A macro is a sequence of frequently performed, repetitive tasks and calculations that you record for easy playback — see Chapter 12 for details.)
- You can quickly compare the sales of one company with the sales of another (see the section “Opening Windows on Your Worksheets,” later in this chapter).
- You can print all the sales information for each company as a single report in one printing operation. (Read through Chapter 5 for specifics on printing an entire workbook or particular worksheets in a workbook.)
- You can easily create charts that compare certain sales data from different worksheets (see Chapter 10 for details).
- You can easily set up a summary worksheet with formulas that total the quarterly and annual sales for all nine companies (see the section “To Sum Up . . .” later in this chapter).

### Sliding between the sheets

Each workbook that you create contains three worksheets, rather predictably named Sheet1 through Sheet3. In typical Excel fashion, these names appear on tabs at the bottom of the workbook window. To go from one worksheet to
another, you simply click the tab that contains the name of the sheet you want to see. Excel then brings that worksheet to the top of the stack, displaying its information in the current workbook window. You can always tell which worksheet is current because its name is displayed in bold type on the tab and its tab appears without any dividing line as an extension of the current worksheet.

The only problem with moving to a new sheet by clicking its sheet tab occurs when you add so many worksheets to a workbook (as I describe later in this chapter in the section “Don’t Short-Sheet Me!”) that not all the sheet tabs are visible at any one time, and the sheet tab you want to click is not visible in the workbook. To deal with this problem, Excel provides Tab scrolling buttons (shown in the lower-left corner of Figure 7-1) that you can use to bring new sheet tabs into view.
Click the Next tab scroll button (with the triangle pointing right) to bring the next unseen tab of the sheet on the right into view. Hold down the Shift key while you click this button to scroll several tabs at a time.

Click the Previous tab scroll button (with the triangle pointing left) to bring the next unseen tab of the sheet on the left into view. Hold down the Shift key while you click this button to scroll several tabs at a time.

Click the Last tab scroll button (with the triangle pointing right to the vertical bar) to bring the last group of sheet tabs, including the very last tab, into view.

Click the First tab scroll button (with the triangle pointing left to the vertical bar) to bring the first group of sheet tabs, including the very first tab, into view.

Just don’t forget that scrolling the sheet tab that you want into view is not the same thing as selecting it: You still need to click the tab for the desired sheet to bring it to the front of the stack.

To make it easier to find the sheet tab you want to select without having to do an inordinate amount of tab scrolling, drag the Tab split bar (see Figure 7-2) to the right to reveal more sheet tabs (consequently making the horizontal scroll bar shorter). If you don’t care at all about using the horizontal scroll bar, you can maximize the number of sheet tabs in view by actually getting rid of this scroll bar. To do this, drag the Tab split bar to the right until it’s smack up against the vertical split bar.
When you want to restore the horizontal scroll bar to its normal length, you can either manually drag the Tab split bar to the left or simply double-click it.

**Editing en masse**

Each time you click a sheet tab, you select that worksheet and make it active, enabling you to make whatever changes are necessary to its cells. You may encounter times, however, when you want to select bunches of worksheets so that you can make the same editing changes to all of them simultaneously. When you select multiple worksheets, any editing change that you make to the current worksheet — such as entering information in cells or deleting stuff from them — affects the same cells in all the selected sheets in exactly the same way.

In other words, suppose you need to set up three worksheets in a new workbook, all of which contain the names of the 12 months, in row 3 starting in column B. Prior to entering *January* in cell B3 and then using the AutoFill handle (as described in Chapter 2) to fill in the rest of the 11 months across row 3, you would select all three worksheets (say Sheet1, Sheet2, and Sheet3, for argument’s sake). Do this, and Excel inserts the names of the 12 months in row 3 of all three selected worksheets when you enter them once in the third row of the first sheet. (Pretty slick, huh?)

Likewise, suppose you have another workbook in which you need to get rid of Sheet2 and Sheet3. Instead of clicking Sheet2, clicking Home | Delete | Delete Sheet on the Ribbon or pressing Alt+HDS, and then clicking Sheet3 and repeating the Delete Sheet command, select both worksheets and then zap them out of existence in one fell swoop by clicking Home | Delete | Delete Sheet on the Ribbon or pressing Alt+HDS.
To select a bunch of worksheets in a workbook, you have the following choices:

✔ To select a group of neighboring worksheets, click the first sheet tab and then scroll the sheet tabs until you see the tab of the last worksheet you want to select. Hold the Shift key while you click the last sheet tab to select all the tabs in between — the old Shift-click method applied to worksheet tabs.

✔ To select a group of non-neighboring worksheets, click the first sheet tab and then hold down the Ctrl key while you click the tabs of the other sheets you want to select.

✔ To select all the sheets in the workbook, right-click the tab of the worksheet that you want active and choose Select All Sheets from its shortcut menu that appears.

Excel shows you worksheets that you select by turning their sheet tabs white (although only the active sheet’s tab name appears in bold) and displaying [Group] after the filename of the workbook on the Excel window’s title bar.

To deselect the group of worksheets when you finish your group editing, you simply click a nonselected (that is, grayed out) worksheet tab. You can also deselect all the selected worksheets other than the one you want active by right-clicking the tab of the sheet you want displayed in the workbook window and then clicking Ungroup Sheets on its shortcut menu.

**Don’t Short-Sheet Me!**

For some of you, the three worksheets automatically put into each new workbook that you start are as many as you would ever, ever need (or want) to use. For others of you, a measly three worksheets might seldom, if ever, be sufficient for the workbooks you create (for example, suppose that your company operates in 10 locations, or you routinely create budgets for 20 different departments or track expenses for 40 account representatives).

Excel 2007 makes it a snap to insert additional worksheets in a workbook (up to 255 total) — simply click the Insert Worksheet button that appears to the immediate right of the last sheet tab.

To insert a bunch of new worksheets in a row in the workbook, select a group with the same number of tabs as the number of new worksheets you want to add, starting with the tab where you want to insert the new worksheets. Next, click Home | Insert | Insert Sheet on the Ribbon or press Alt-HIS.
To delete a worksheet from the workbook, follow these steps:

1. **Click the tab of the worksheet that you want to delete.**

2. **Click Home | Delete | Delete Sheet on the Ribbon or press Alt+HDS or right-click the tab and choose Delete from its shortcut menu.**

   If the sheet you’re deleting contains any data, Excel displays a scary message in an alert box about how you’re going to permanently delete the selected sheets.

3. **Go ahead and click the Delete button or press Enter if you’re really sure that you won’t be losing any data you need when Excel zaps the entire sheet.**

   Just keep in mind that this is one of those situations where Undo is powerless to put things right by restoring the deleted sheet to the workbook.

To delete a bunch of worksheets from the workbook, select all the worksheets you want to delete and then click Home | Delete | Delete Sheet or press Alt+HDS or choose Delete from the tab’s shortcut menu. Then, when you’re sure that none of the worksheets will be missed, click the Delete button or press Enter when the alert dialog box appears.

If you find yourself constantly monkeying around with the number of worksheets in a workbook, either by adding a bunch of new worksheets or deleting all but one, you may want to think about changing the default number of worksheets in a workbook so that the next time you open a new workbook, you have a more realistic number of sheets on hand. To change the default number, click Office Button | Excel Options or press Alt+FI to open the Popular tab of the Excel Options dialog box and enter a new number between 1 and 255 in the Include This Many Sheets text box in the When Creating New Workbooks section of the tab or select a new number with the spinner buttons before you click OK.

---

**A worksheet by any other name . . .**

The sheet names that Excel comes up with for the tabs in a workbook (Sheet1 through Sheet3) are, to put it mildly, not very original — and are certainly not descriptive of their function in life! Luckily, you can easily rename a worksheet tab to whatever helps you remember what you put on the worksheet (provided that this descriptive name is no longer than 31 characters).

To rename a worksheet tab, just follow these steps:

1. **Double-click the sheet tab or right-click the sheet tab and then click Rename on its shortcut menu.**

   The current name on the sheet tab appears selected.
2. Replace the current name on the sheet tab by typing in the new sheet name.

3. Press Enter.

Excel displays the new sheet name on its tab at the bottom of the workbook window.

**A sheet tab by any other color . . .**

In Excel 2007, you can assign colors to the different worksheet tabs. This feature enables you to color-code different worksheets. For example, you could assign red to the tabs of those worksheets that need immediate checking and blue to the tabs of those sheets that you’ve already checked.

To assign a color to a worksheet tab, right-click the tab and highlight Tab Color on its shortcut menu to open a submenu containing the Tab Color pop-up palette. Then, click the new color for the tab by clicking its color square on the color palette. After you select a new color for a sheet tab, the name of the active sheet tab appears underlined in the color you just selected. When you make another sheet tab active, the entire tab takes on the assigned color (and the text of the tab name changes to white if the selected color is sufficiently dark that black lettering is impossible to read).

**Short and sweet (sheet names)**

Although Excel allows up to 31 characters (including spaces) for a sheet name, you want to keep your sheet names much briefer for two reasons:

✔ First, the longer the name, the longer the sheet tab. And the longer the sheet tab, the fewer tabs that can be displayed. And the fewer the tabs, the more tab scrolling you have to do to select the sheets you want to work with.

✔ Second, should you start creating formulas that use cells in different worksheets (see the section “To Sum Up . . .” later in this chapter, for an example of this), Excel uses the sheet name as part of the cell reference in the formula. (How else could Excel keep straight the value in cell C1 on Sheet1 from the value in cell C1 on Sheet2?!?) Therefore, if your sheet names are long, you end up with unwieldy formulas in the cells and on the Formula bar even when you’re dealing with simple formulas that only refer to cells in a couple of different worksheets.

So remember: As a general rule, the fewer characters in a sheet name, the better. Also remember that each name must be unique — no duplicates allowed.
To remove a color from a tab, right-click the sheet tab and highlight the Tab Color option to open the Tab Color pop-up palette. Then, click No Color at the bottom of the Tab Color palette.

**Getting your sheets in order**

Sometimes, you may find that you need to change the order in which the sheets appear in the workbook. Excel makes this possible by letting you drag the tab of the sheet you want to arrange in the workbook to the place where you want to insert it. While you drag the tab, the pointer changes to a sheet icon with an arrowhead on it, and the program marks your progress among the sheet tabs (see Figures 7-3 and 7-4 for examples). When you release the mouse button, Excel reorders the worksheets in the workbook by inserting the sheet at the place where you dropped the tab off.

If you hold down the Ctrl key while you drag the sheet tab icon, Excel inserts a copy of the worksheet at the place where you release the mouse button. You can tell that Excel is copying the sheet rather than just moving it in the workbook because the pointer shows a plus sign (+) on the sheet tab icon containing the arrowhead. When you release the mouse button, Excel inserts the copy in the workbook, which is designated by the addition of (2) after the tab name.
For example, if you copy Sheet5 to another place in the workbook, the sheet tab of the copy is named *Sheet5 (2)*. You can then rename the tab to something civilized (see the section “A worksheet by any other name . . .” earlier in this chapter, for details).

You can also move or copy worksheets from one part of a workbook to another by activating the sheet that you want to move or copy and then choosing Move or Copy on its shortcut menu. In the Before Sheet list box in the Move or Copy dialog box, click the name of the worksheet in front of which you want the active sheet moved or copied.

To move the active sheet immediately ahead of the sheet you select in the Before Sheet list box, simply click OK. To copy the active sheet, be sure to select the Create a Copy check box before you click OK. If you copy a worksheet instead of just moving it, Excel adds a number to the sheet name. For example, if you copy a sheet named *Total Income*, Excel automatically names the copy of the worksheet *Total Income (2)*, and this name appears on its sheet tab.

### Opening Windows on Your Worksheets

Just as you can split up a single worksheet into window panes so that you can view and compare different parts of that same sheet on the screen (see Chapter 6), you can split up a single workbook into worksheet windows and
then arrange the windows so that you can view different parts of each worksheet on the screen.

To open up the worksheets that you want to compare in different windows, you simply insert new workbook windows (in addition to the one that Excel automatically opens when you open the workbook file itself) and then select the worksheet that you want to display in the new window. You can accomplish this with the following steps:

1. Click the New Window command button on the Ribbon’s View tab or press Alt+WN to create a second worksheet window; then click the tab of the worksheet that you want to display in this second window (indicated by the :2 that Excel adds to the end of the filename in the title bar).

2. Click the New Window command button or press Alt+WN again to create a third worksheet window; then click the tab of the worksheet that you want to display in this third window (indicated by the :3 that Excel adds to the end of the filename in the title bar).

3. Continue clicking the New Window command button or pressing Alt+WN to create a new window and then selecting the tab of the worksheet you want to display in that window for each worksheet you want to compare.

4. Click the Arrange All command button on the View tab or press Alt+WA and select one of the Arrange options in the Arrange Windows dialog box (as I describe next); then click OK or press Enter.

When you open the Arrange Windows dialog box, you are presented with the following options:

- **Tiled**: Select this option button to have Excel arrange and size the windows so that they all fit side by side on the screen in the order in which you open them. (Check out Figure 7-5 to see the screen that appears after you choose the Tiled option button to organize four worksheet windows.)

- **Horizontal**: Select this option button to have Excel size the windows equally and place them one above the other. (In Figure 7-6, you can see the screen that appears after you choose the Horizontal button to organize four worksheet windows.)

- **Vertical**: Select this option button to have Excel size the windows equally and place them next to each other. (Look at Figure 7-7 to see the screen that appears after you choose the Vertical option to arrange four worksheet windows.)
Cascade: Select this option button to have Excel arrange and size the windows so that they overlap one another with only their title bars showing. (See Figure 7-8 for the screen that appears after you select the Cascade option to arrange four worksheet windows.)
Windows of Active Workbook: Select this check box to have Excel show only the windows that you have open in the current workbook. Otherwise, Excel also displays all the windows in any other workbooks you have open. Yes, it is possible to open more than one workbook — as well as more than one window within each open workbook — provided that your computer has enough memory and you have enough stamina to keep track of all that information.
After you place windows in one arrangement or another, activate the one you want to use (if it’s not already selected) by clicking it. In the case of the cascade arrangement, you need to click the worksheet window’s title bar, or you can click its button on the Windows Vista or XP taskbar. Use the button’s screen tip to determine the number of the window when the buttons are too short to display this information.

When you click a worksheet window that has been tiled or placed in the horizontal or vertical arrangement, Excel indicates that the window is selected by highlighting its title bar and adding scroll bars to the window. When you click the title bar of a worksheet window you place in the cascade arrangement, the program displays the window on the top of the stack, as well as highlighting its title bar and adding scroll bars.

You can temporarily zoom the window up to full size by clicking the Maximize button on the window’s title bar. When you finish the work you need to do in the full-size worksheet window, return it to its previous arrangement by clicking the window’s Restore button.

To select the next tiled, horizontal, or vertical window on the screen or display the next window in a cascade arrangement with the keyboard, press Ctrl+F6. To select the previous tiled, horizontal, or vertical window or to display the previous window in a cascade arrangement, press Ctrl+Shift+F6. Note that these keystrokes work to select the next and previous worksheet window even when the windows are maximized in the Excel program window.

If you close one of the windows you’ve arranged by clicking Close (the X in the upper-right corner) or by pressing Ctrl+W, Excel doesn’t automatically resize the other open windows to fill in the gap. Likewise, if you create another window by clicking the New Window command button on the View tab, Excel doesn’t automatically arrange it in with the others. (In fact, the new window just sits on top of the other open windows.)

To fill in the gap created by closing a window or to integrate a newly opened window into the current arrangement, click the Arrange command button to open the Arrange Windows dialog box and click OK or press Enter. (The same option button you selected last time is still selected; if you want to choose a new arrangement, select a new option button before you click OK.)

Don’t try to close a particular worksheet window with Office Button | Close command or by pressing Alt+FC, because you’ll only succeed in closing the entire workbook file, while at the same time getting rid of all the worksheet windows you created.

When you save your workbook, Excel saves the current window-arrangement as part of the file along with all the rest of the changes. If you don’t want to
save the current window arrangement, close all but one of the windows (by
double-clicking their Control-menu buttons or selecting their windows and
then pressing Ctrl+W). Then click that last window’s Maximize button and
select the tab of the worksheet that you want to display the next time you
open the workbook before saving the file.

Comparing Two Worksheets Side by Side

You can use the View Side by Side command button (the one with picture of
two sheets side by side like tiny tablets of the Ten Commandments) on the
Ribbon’s View tab to quickly and easily do a side-by-side comparison of any
two worksheet windows that you have open. When you click this button (or
press Alt+WB after opening two windows, Excel automatically tiles them hori-
zontally (as though you had selected the Horizontal option in the Arrange
Windows dialog box) as shown in Figure 7-9.

If you have more than two windows open at the time you click the View Side
by Side command button (Alt+WB), Excel opens the Compare Side by Side
dialog box where you click the name of the window that you want to compare
with the one that’s active at the time you choose the command. As soon as
you click OK in the Compare Side by Side dialog box, Excel horizontally tiles
the active window above the one you just selected.
Immediately below the View Side by Side command button in the Window group of the View tab on the Ribbon, you find these following two command buttons useful when comparing windows side by side:

- **Synchronous Scrolling:** When this command button is selected (as it is by default), any scrolling that you do in the worksheet in the active window is mirrored and synchronized in the worksheet in the inactive window beneath it. To be able to scroll the worksheet in the active window independently of the inactive window, click the Synchronous Scrolling button a second time to de-select it.

- **Reset Window Position:** Click this command button after you manually resize the active window (by dragging its size box) to restore the two windows to their previous side-by-side arrangement.

---

**Moving and Copying Sheets to Other Workbooks**

In some situations, you need to move a particular worksheet or copy it from one workbook to another. To move or copy worksheets between workbooks, follow these steps:

1. **Open both the workbook with the worksheet(s) that you want to move or copy and the workbook that is to contain the moved or copied worksheet(s).**
   
   Click Office Button | Open or press Ctrl+O to open both the workbooks.

2. **Select the workbook that contains the worksheet(s) that you want to move or copy.**
   
   To select the workbook with the sheet(s) to be moved or copied, click its button on the Windows Vista or XP taskbar.

3. **Select the worksheet(s) that you want to move or copy.**
   
   To select a single worksheet, click its sheet tab. To select a group of neighboring sheets, click the first tab and then hold down Shift while you click the last tab. To select various nonadjacent sheets, click the first tab and then hold down Ctrl while you click each of the other sheet tabs.

4. **Right-click its sheet tab and then click Move or Copy on its shortcut menu.**
   
   Excel opens up the Move or Copy dialog box (similar to the one shown in Figure 7-10) in which you indicate whether you want to move or copy the selected sheet(s) and where to move or copy them.
5. In the To Book drop-down list box, select the name of the workbook to which you want to copy or move the worksheets.

If you want to move or copy the selected worksheet(s) to a new workbook rather than to an existing one that you have open, select the (new book) option that appears at the very top of the To Book pop-up list.

6. In the Before Sheet list box, select the name of the sheet that the worksheet(s) you’re about to move or copy should precede. If you want the sheet(s) that you’re moving or copying to appear at the end of the workbook, choose the (move to end) option.

7. Select the Create a Copy check box to copy the selected worksheet(s) to the designated workbook (rather than move them).

8. Click OK or press Enter to complete the move or copy operation.

If you prefer a more direct approach, you can move or copy sheets between open workbooks by dragging their sheet tabs from one workbook window to another. Note that this method works with a bunch of sheets as well as with a single sheet; just be sure that you select all their sheet tabs before you begin the drag-and-drop procedure.

To drag a worksheet from one workbook to another, you must open both workbooks. Click the Arrange All command button on the View tab or press Alt+WA and then select an arrangement (such as Horizontal or Vertical to put the workbook windows either on top of each other or side by side). Before you close the Arrange Windows dialog box, be sure that the Windows of Active Workbook check box is not selected, that is, does not contain a check mark.
After arranging the workbook windows, drag the worksheet tab from one workbook to another. If you want to copy rather than move the worksheet, hold down the Ctrl key while you drag the sheet icon(s). To locate the worksheet in the new workbook, position the downward-pointing triangle that moves with the sheet icon in front of the worksheet tab where you want to insert it; then release the mouse button.

This drag-and-drop operation is one of those that you can’t reverse by using Excel’s Undo feature (see Chapter 4). This means that if you drop the sheet in the wrong workbook, you’ll have to go get the wayward sheet yourself and drag it back and drop it into the place where it once belonged!

In Figures 7-11 and 7-12, I show how easy it is to move or copy a worksheet from one workbook to another using this drag-and-drop method.

In Figure 7-11, you see two workbook windows: the MGE – 2007 YTD Sales workbook (left pane) and the MGE – 2008 Projected Income workbook (right pane). I arranged these workbook windows with the View Side by Side command button on the View tab. To copy the Sprat Diet Ctr sheet from the MGE – 2008 Projected Income workbook to the MGE – 2007 YTD Sales workbook, I simply select the Sprat Diet Ctr sheet tab and then hold down the Ctrl key while I drag the sheet icon to its new position right before Sheet2 of the MGE – 2007 YTD Sales workbook.

Figure 7-11: Copying the worksheet to the MGE – 2007 YTD Sales workbook via drag-and-drop.
Now look at Figure 7-12 to see the workbooks after I release the mouse button. As you can see, Excel inserts the copy of the Sprat Diet Ctr worksheet into the MGE – 2004 YTD Sales workbook at the place indicated by the triangle that accompanies the sheet icon (in between Sheet1 and Sheet2 in this example).

![Figure 7-12: After inserting a copy of the worksheet between Sheet1 and Sheet2 of the MGE – 2008 YTD Sales workbook.](image)

**To Sum Up . . .**

I’d be remiss if I didn’t introduce you to the fascinating subject of creating a *summary worksheet* that recaps or totals the values stored in a bunch of other worksheets in the workbook.

The best way that I can show you how to create a summary worksheet is to walk you through the procedure of making one (entitled Total Income) for MGE – 2008 Projected Income workbook. This summary worksheet totals the projected revenue and expenses for all the companies that Mother Goose Enterprises owns.

Because the MGE – 2008 Projected Income workbook already contains nine worksheets, each with the 2008 projected revenue and expenses for one of these companies, and because these worksheets are all laid out in the same arrangement, creating this summary worksheet will be a breeze:
1. I insert a new worksheet in front of the other worksheets in MGE – 2008 Projected Income workbook and rename its sheet tab from Sheet1 to Total Income.

To find out how to insert a new worksheet, refer to this chapter’s section “Don’t Short-Sheet Me!” To find out how to rename a sheet tab, read through the earlier section “A worksheet by any other name . . .”


Do this by selecting cell A1 and then typing the text.

3. Finally, I copy the rest of the row headings for column A (containing the revenue and expense descriptions) from the Sprat Diet Ctr worksheet to the Total Income worksheet.

To do this, select cell A3 in the Total Income sheet, and then click the Sprat Diet Ctr tab. Select the cell range A3:A22 in this sheet; then press Ctrl+C, click the Total Income tab again, and press Enter.

I am now ready to create the master SUM formula that totals the revenues of all nine companies in cell B3 of the Total Income sheet:

1. I start by clicking cell B3 and then clicking the AutoSum button in the Editing group on the Ribbon’s Home tab.

Excel then puts =SUM( ) in the cell with the insertion point placed between the two parentheses.

2. I click the Sprat Diet Ctr sheet tab, and then click its cell B3 to select the projected revenues for the Jack Sprat Diet Centers.

The Formula bar reads =SUM('Sprat Diet Ctr'!B3) after selecting this cell.

3. Next I type a comma (,) — the comma starts a new argument. I click the J&J Trauma Ctr sheet tab, and then I click its cell B3 to select projected revenues for the Jack and Jill Trauma Centers.

The Formula bar now reads =SUM('Sprat Diet Ctr'!B3,'J&J Trauma Ctr'!B3) after I select this cell.

4. I continue in this manner, typing a comma (to start a new argument), and then selecting cell B3 with the projected revenues for all the other companies in the following seven sheets.

At the end of this procedure, the Formula bar now appears with the whopping SUM formula shown on the Formula bar in Figure 7-13.

5. To complete the SUM formula in cell B3 of the Total Income worksheet, I then click the Enter box in the Formula bar (I could press Enter on my keyboard, as well).
In Figure 7-13, note the result after using AutoFit to widen column B. As you can see in the formula bar, the master SUM formula that returns 6,681,450.78 to cell B3 of the Total Income worksheet gets its result by summing the values in B3 in all nine of the supporting worksheets.

All that’s left to do now is to use AutoFill to copy the master formula in cell B3 down to row 22 as follows:

1. With cell B3 still selected, I drag the AutoFill handle in the lower-right corner of cell B3 down to cell B22 to copy the formula for summing the values for the nine companies down this column.

2. Then I delete the SUM formulas from cells B4, B12, B14, B15, and B19 (all of which contain zeros because these cells have no income or expenses to be totaled).

In Figure 7-14, you see the first section of the final summary projected income worksheet after I copy the formula created in cell B3 and after I delete the formulas from the cells that should be blank (all those that came up 0 in column B).

Figure 7-13: The Total Income worksheet after I create a SUM formula to total projected revenues for all nine Mother Goose companies.
Figure 7-14: The Total Income worksheet after I copy the SUM formula and delete formulas that return zero values.
Part IV

Digging Data Analysis

The 5th Wave

By Rich Tennant

"I started running 'what if' scenarios on my spreadsheet, like, 'What if I were sick of this dirt-wad job and funneled some of the company's money into an off-shore account?"
In this part . . .

When the long work day is done, it’s not enough to merely know how to input vast amounts of data into a worksheet. You’ve also got to know how to analyze the information to foresee the trends so that you can take advantage of opportunities and avoid the pitfalls inherent in your type of business.

Part IV contains two chapters designed to help you do just that. In Chapter 8, you find out how to use Excel’s basic what-if analysis tools in your spreadsheets so that you can better predict the changes you need to make to achieve desired goals, as well as to avoid unwanted results. In Chapter 9, you’re introduced to Excel’s most versatile summary tool — the pivot table and its associated pivot chart. Here, you find out how to use these extraordinary tools to obtain varied perspectives on the data you work with — perspectives that can enable you to quickly uncover and easily spot both trends with potentially disastrous consequences as well as those packed with golden opportunities.
Chapter 8
Doing What-If Analysis

In This Chapter
► Performing what-if analysis with one- and two-variable data tables
► Performing what-if analysis with goal seeking
► Looking at different cases with the Scenario Manager

It would be a big mistake to regard Excel 2007 merely as a fancy calculator that shines at performing static computations, for the program excels (if you don’t mind the pun) at performing various types of more dynamic what-if analysis as well. What-if analysis enables you to explore the possibilities in a worksheet by inputting a variety of promising or probable values into the same equation and letting you see the possible outcomes in black and white (or, at least, in the cells of the spreadsheet).

In Excel 2007, what-if analysis comes in a fairly wide variety of flavors (some of which are more involved than others). In this chapter, I introduce you to these three simple and straightforward methods:

► **Data tables** enable you to see how changing one or two variables affect the bottom line (for example, you may want to know what happens to the net profit if you fall into a 25 percent tax bracket, a 35 percent tax bracket, and so on).

► **Goal seeking** enables you to find out what it takes to reach a pre-determined objective, such as how much you have to sell to make a $15 million profit this year.

► **Scenarios** let you set up and test a wide variety of cases, all the way from the best-case scenario (profits grow by 8.5 percent) to the worst-case scenario (you don’t make any profit and actually lose money).
Playing what-if with Data Tables

Data tables enable you to enter a series of possible values that Excel then plugs into a single formula. Excel supports two types of data tables, a one-variable data table that substitutes a series of possible values for a single input value in a formula and a two-variable data table that substitutes series of possible values for two input values in a single formula.

Both types of data tables use the very same Data Table dialog box that you open by clicking Data | What-If Analysis | Data Table on the Ribbon or pressing Alt+AWT. The Table dialog box contains two text boxes: Row Input Cell and Column Input Cell.

When creating a one-variable data table, you designate one cell in the worksheet that serves either as the Row Input Cell (if you’ve entered the series of possible values across columns of a single row) or as the Column Input Cell (if you’ve entered the series of possible values down the rows of a single column).

When creating a two-variable data table, you designate two cells in the worksheet and therefore use both text boxes: one cell that serves as the Row Input Cell (that substitutes the series of possible values you’ve entered across columns of a single row and another that serves as the Column Input Cell (that substitutes the series of possible values you’ve entered down the rows of a single column).

Creating a one-variable data table

Figure 8-1 shows a 2008 Sales Projections spreadsheet for which a one-variable data table is to be created. In this worksheet, the projected sales amount in cell B5 is calculated by adding last year’s sales total in cell B2 to the amount that we expect it to grow in 2008 (calculated by multiplying last year’s total in cell B2 by the growth percentage in cell B3), giving you the formula:

$$=B2+(B2*B3)$$

Because I clicked the Create From Selection command button on the Ribbon’s Formulas tab after making A2:B5 the selection and accepted the Left Column check box default, the formula uses the row headings in column A and so actually reads:

$$=\_2007\_Total\_Sales+(_2007\_Total\_Sales*Annual\_Growth\_Rate)$$
As you can see, I entered a column of possible growth rates ranging from 1% all the way to 5.5% down column B in the range B8:B17. Now, in order to create a one-variable data table shown in Figure 8-2 that plugs each of these values in to the sales growth formula, I follow these simple steps:

1. **Copy the original formula entered in cell B5 into cell C7 by typing = (equal to) and then clicking cell B5 to create the formula =_2008_Projected_Sales.**

   The copy of the original formula (into which the series of different growth rates in B8:B17 is to be substituted) is now the column heading for the one-variable data table.

2. **Select the cell range B7:C17.**

   The range of the data table includes the formula along with the various growth rates.

3. **Click Data | What-If Analysis | Data Table on the Ribbon.**

   Excel opens the Data Table dialog box.

4. **Click the Column Input Cell text box in the Data Table dialog box and then click cell B3, the Annual_Growth_Rate cell with the original percentage, in the worksheet.**

   Excel inserts the absolute cell address, $B$3, into the Column Input Cell text box.
5. Click OK to close the Data Table dialog box.

As soon as you click OK, Excel creates the data table in the range C8:C17 by entering a formula using its `TABLE` function into this range. Each copy of this formula in the data table uses the growth rate percentage in the same row in column B to determine the possible outcome.

6. Click the Format Painter command button in the Clipboard group on the Home tab, then click cell C6 to pick up its Comma Style number formatting before dragging through the cell range C8:C17.

Excel copies the Comma Style number format to the range of possible outcomes calculated by this data table.

A couple of important things to note about the one-variable data table created in this spreadsheet:

- If you modify any of the growth rate percentages in the cell range B8:B17, Excel immediately updates the associated projected sales result in data table — to prevent Excel from updating the data table until you click the Calculate Now (F9) or Calculate Sheet command button (Shift+F9) on the Formulas Tab, click the Calculation Options button on the Formulas tab and then click the Automatic Except for Data Tables option (Alt+MXE).

- If you try to delete any single `TABLE` formula in the cell range C8:C17, Excel displays a Cannot Change Part of a Data Table alert dialog box — you must select the entire range of formulas (C8:C17 in this case) before you press Delete or click the Clear or Delete button on the Home tab.
Creating a two-variable data table

To create a two-variable data table, you enter two ranges of possible input values for the same formula: a range of values for the Row Input Cell in the Data Table dialog box across the first row of the table and a range of values for the Column Input Cell in the dialog box down the first column of the table. You then enter the formula (or a copy of it) in the cell located at the intersection of this row and column of input values.

Figure 8-3 illustrates this type of situation. In this version of the projected sales spreadsheet, two variables are used in calculating the projected sales for year 2008: a growth rate as a percentage of increase over last year’s sales (in cell B3 named Annual_Growth_Rate) and expenses calculated as a percentage of last year’s sales (in cell B4 named Expenses_Sales). In this example, the original formula created in cell B5 is a bit more complex:

\[ \text{=}_2007\text{Total_Sales} + (\text{$_2007$Total_Sales} \times \text{Annual_Growth_Rate}) - (\text{$_2007$Total_Sales} \times \text{Expenses_Sales}) \]

To set up the two-variable data table, I added a row of possible Expenses percentages in the range C7:F7 to a column of possible Annual_Growth_Rate percentages in the range B8:B17. I then copied the original formula named _2008_Projected_Sales entered into cell B5 to cell B7, the cell at the intersection of this row of Expenses_Sales percentages and column of Growth_Rate percentages with the formula:

\[ \text{=}_2008\text{Projected_Sales} \]
And with these few steps, I created the two-variable data table you see in Figure 8-4:

1. Select the cell range B7:F17.
   
   This cell incorporates the copy of the original formula along with the row of possible expenses and growth rate percentages.

2. Click Data | What-If Analysis | Data Table on the Ribbon.
   
   Excel opens the Data Table dialog box with the insertion point in the Row Input Cell text box.

3. Click cell B4 to enter the absolute cell address, $B$4, in the Row Input Cell text box.

4. Click the Column Input Cell text box and then click cell B3 to enter the absolute cell address, $B$3, in this text box.

5. Click OK to close the Data Table dialog box.
   
   Excel fills the blank cells of the data table with a TABLE formula using B4 as the Row Input Cell and B3 as the Column Input Cell.

6. Click cell B7, then click the Format Painter command button in the Clipboard group on Home tab and drag through the cell range, C8:F17 to copy the Accounting number format with no decimal places to this range.
This Accounting number format is too long to be displayed given the current width of columns C through F — indicated by the ####### symbols. While the range, C8:F17, is still selected from using the Format Painter, Step 7 fixes this problem.

7. Click the Format command button in the Cells group of the Home tab and then click AutoFit Column Width on its drop-down menu.

The array formula (see the sidebar “Array formulas and the TABLE function in data tables” earlier) \{=\text{TABLE(B4:B3)}\} that Excel creates for the two-variable data table in this example specifies both a Row Input Cell argument (B4) and a Column Input Cell argument (B3). Because this single array formula is entered into the entire data table range of C8:F17, keep in mind any editing (in terms of moving or deleting) is restricted to this range.

**Playing What-If with Goal Seeking**

Sometimes when doing what-if analysis, you have a particular outcome in mind such as a target sales amount or growth percentage. When you need to do this type of analysis, you use Excel’s Goal Seek feature to find the input values needed to achieve the desired goal.
To use the Goal Seek feature located on the What-If Analysis button’s drop-down menu, you need to select the cell containing the formula that will return the result you’re seeking (referred to as the set cell in the Goal Seek dialog box) and then indicate the target value you want the formula to return as well as the location of the input value that Excel can change to reach this target.

Figures 8-5 and 8-6 illustrate how you can use the Goal Seek feature to find out by how much sales must increase to realize first quarter income of $300,000 (given certain growth, cost of goods sold, and expense assumptions) in a Sales Forecast table.

To find out how much sales must increase to return a net income of $300,000 in the first quarter, you first select cell B7, which contains the formula that calculates the forecast for the first quarter of 2008 before you click Data | What-If Analysis | Goal Seek on the Ribbon or press Alt+AWG.

This action opens the Goal Seek dialog box, similar to the one shown in Figure 8-5. Because cell B7 is the active cell when you open this dialog box, the Set Cell text box already contains the cell reference B7. You then select the To Value text box and enter 300000 as the goal. Then, you click the By Changing Cell text box and click cell B3 in the worksheet (the cell that contains the first quarter sales) to enter the absolute cell address, $B$3, in this text box.
Figure 8-6 shows you the Goal Seek Status dialog box that appears when you click OK in the Goal Seek dialog box to have Excel go ahead and adjust the sales figure to reach your desired income figure. As this figure shows, Excel increases the sales in cell B3 from $250,000 to $576,923.08, which, in turn, returns $300,000 as the income in cell B7.

The Goal Seek Status dialog box informs you that goal seeking has found a solution and that the current value and target value are now the same. When this is not the case, the Step and Pause buttons in the dialog box become active, and you can have Excel perform further iterations to try to narrow and ultimately eliminate the gap between the target and current value.

If you want to keep the values entered in the worksheet as a result of goal seeking, click OK to close the Goal Seek Status dialog box. If you want to return to the original values, click the Cancel button instead. If you change the value by clicking OK, remember that you can still switch between the “before” and “after” input values and results by clicking the Undo command button on the Quick Access toolbar (that has the ScreenTip, Undo Goal Seek) or by pressing Ctrl+Z.

To flip back and forth between the “after” and “before” values when you’ve closed the Goal Seek Status dialog box, click the Undo button or press Ctrl+Z to display the original values before goal seeking and click the Redo button or press Ctrl+Y to display the values engendered by the goal seeking solution.
Examining Different Cases with Scenario Manager

Excel's Scenario Manager option on the What-If Analysis button’s drop-down menu on the Data tab of the Ribbon enables you to create and save sets of different input values that produce different calculated results as named scenarios (such as Best Case, Worst Case, and Most Likely Case). Because these scenarios are saved as part of the workbook, you can use their values to play what-if simply by opening the Scenario Manager and having Excel show the scenario in the worksheet.

After setting up the various scenarios for a spreadsheet, you can also have Excel create a summary report that shows both the input values used in each scenario as well as the results they produce in your formula.

Setting up the various scenarios

The key to creating the various scenarios for a table is to identify the various cells in the data whose values can vary in each scenario. You then select these cells (known as changing cells) in the worksheet before you open the Scenario Manager dialog box by clicking Data | What-If Analysis | Scenario Manager on the Ribbon or by pressing Alt+AWS.

Figure 8-7 shows the Sales Forecast table for 2008 after selecting the three changing cells in the worksheet — G3 named Sales_Growth, G4 named COGS (Cost of Goods Sold), and G6 named Expenses — and then opening the Scenario Manager dialog box (Alt+AWS).

I want to create three scenarios using the following sets of values for the three changing cells:

- **Most Likely Case** where the Sales_Growth percentage is 5%, COGS is 20%, and Expenses 25%
- **Best Case** where the Sales_Growth percentage is 8%, COGS is 18%, and Expenses 20%
- **Worst Case** where the Sales_Growth percentage is 2%, COGS is 25%, and Expenses 35%

To create the first of these three scenarios, I click the Add button in the Scenario Manager dialog box to open the Add Scenario dialog box, then enter Most Likely Case in the Scenario Name Box and click OK (remember that three cells currently selected in the worksheet, G3, G4, and G6, are already listed in the Changing Cells text box of this dialog box).
Excel then displays the Scenario Values dialog box where I enter the following values in each of the three text boxes, Sales_Growth, COGS, and Expenses before clicking its Add button:

- **0.05** in the Sales_Growth text box
- **0.20** in COGS text box
- **0.25** in the Expenses text box

Always assign range names as described in Chapter 6 to your changing cells before you begin creating the various scenarios that use them. That way, Excel always displays the cell's range names rather than their addresses in the Scenario Values dialog box.

After clicking the Add button, Excel redisplay the Add Scenario dialog box where I enter the name for the Best Case scenario and then in the Scenario Values dialog box, I change the value as follows:

- **0.08** in the Sales_Growth text box
- **0.18** in the COGS text box
- **0.20** in the Expenses text box
After making these changes, I click the Add button again. Doing this opens the Add Scenario dialog box where I enter Worst Case as the name and then, in the Scenario Values dialog box I change the values as follows:

- 0.02 in the Sales_Growth text box
- 0.25 in the COGS text box
- 0.35 in the Expenses text box

Because this is the last scenario I want to add, I then click the OK button instead of Add. Doing this opens Scenario Manager dialog box again, this time displaying the names of all three scenarios, Most Likely Case, Best Case, and Worst Case in its Scenarios list box. To have Excel plug the changing values assigned to any of these three scenarios in to the Forecast Sales table, I click the scenario name in this list box followed by the Show button.

After adding the various scenarios for a table in your spreadsheet, don’t forget to save the workbook after closing the Scenario Manager dialog box. That way, you’ll have access to the various scenarios each time you open the workbook in Excel simply by opening the Scenario Manager, selecting the scenario name, and clicking the Show button.

**Producing a summary report**

After adding your scenarios to a table in a spreadsheet, you can have Excel produce a summary report like the one shown in Figure 8-8. This report displays the changing and resulting values not only for all the scenarios you’ve defined but also the current values that are entered into the changing cells in the worksheet table at the time you generate the report.

To produce a summary report, open the Scenario Manager dialog box (Data | What-If Analysis | Scenario Manager or Alt+AWS) and then click the Summary button to open the Scenario Summary dialog box.

This dialog box gives you a choice between creating a (static) Scenario Summary (the default) and a (dynamic) Scenario PivotTable Report (see Chapter 9). You can also modify the range of cells in the table that are included in the Results Cells section of the summary report by adjusting the cell range in the Result Cells text box before you click OK to generate the report.
After you click OK, Excel creates the summary report for the changing values in all the scenarios (and the current worksheet) along with the calculated values in the Results Cells on a new worksheet (named Scenario Summary). You can then rename and reposition the Scenario Summary before you save it as part of the workbook file.

Performing what-if analysis with the Solver add-in

In addition to the straightforward what-if analysis offered by the Scenario Manager, Goal Seek, and Data Table options on the What-If Analysis button’s drop-down menu on the Data tab of the Ribbon, Excel 2007 supports a more complex what-if analysis in the form of the Solver add-in program (see Chapter 12 for information on add-ins). With the Solver, you can create models that not only involve changes to multiple input values but impose constraints on these inputs or on the results themselves. For details on using the Solver in Excel 2007, see my Microsoft Office Excel 2007 All-In-One Desk Reference For Dummies by Wiley Publishing.
Pivot table is a name given to a special type of summary table that’s totally unique to Microsoft Excel. Pivot tables are great for summarizing particular values in a data list or database because they do their magic without making you create formulas to perform the calculations. They also enable you to quickly and easily examine and analyze relationships inherent in their data sources (either data lists you maintain in Excel or external database tables such as those you maintain with a standalone program such as Microsoft Office Access).

Pivot tables also let you play around with the arrangement of the summarized data — even after you generate the table. It’s this capability of changing the arrangement of the summarized data on the fly simply by rotating row and column headings that gives the pivot table its name. And if you’re the type who relates better to data represented in pictorial form, Excel enables you to summarize your data list graphically as a pivot chart using any of the many, many chart types now supported by the program.

Pivot Tables: The Ultimate Data Summary

Pivot tables are so very versatile because they enable you to summarize data by using a variety of summary functions (although totals created with the SUM function will probably remain your old standby). When setting up the
original pivot table (as described in the following section) you make several
decisions: what summary function to use, which columns (fields) the sum-
mary function is applied to, and which columns (fields) these computations
are tabulated with.

Pivot tables are perfect for cross-tabulating one set of data in your data list
with another. For example, you can create a pivot table from an employee
database table that totals the salaries for each job category cross-tabulated
(arranged) by department or job site.

**Producing a Pivot Table**

Creating a pivot table has never been as easy as it is in Excel 2007: simply
open the worksheet that contains the data list (see Chapter 11) you want
summarized by the pivot table, position the cell cursor somewhere in the
cells of this list, and then click the PivotTable command button on the
Ribbon’s Insert tab or press Alt+NVT.

Excel then opens the Create PivotTable dialog box, while at the same time
selecting all the data in the list containing the cell cursor indicated by a mar-
quee around the cell range. You can then adjust the cell range in the
Table/Range text box under the Select a Table or Range option button, if the
marquee does not include all the data to be summarized in the pivot table. By
default, Excel builds the new pivot table on a new worksheet it adds to the
workbook. If, however, you want the pivot table to appear on the same work-
sheet, click the Existing Worksheet option button and then indicate the loca-
tion of the first cell of the new table in the Location text box, as shown in
Figure 9-1. (Just be sure that this new pivot table isn’t going to overlap any
existing tables of data).

If the data source for your pivot table is an external database table created
with a separate database management program such as Access, you need to
click the Use an External Data Source option button, then click the Choose
Connection button and then click the name of the connection in the Existing
Connections dialog box (see Chapter 11 for information on establishing
a connection with an external file and importing its data through a query).

After you indicate the source and location for the new pivot table in the
Create PivotTable dialog box and click its OK button, the program adds a
blank grid for the new table and displays a Pivot Table Field List task pane on
the right side of the Worksheet area (see Figure 9-2). This Field List task pane
is divided into two areas: the Choose Fields to Add to Report list box with the
names of all the fields in the data list you selected as the source of the table preceded by an empty check box at the top and an area divided into four drop zones (Report Filter, Column Labels, Row Labels, and Values) at the bottom.

**Figure 9-1:** Indicate the data source and pivot table location in the Create PivotTable dialog box.

**Figure 9-2:** New pivot table displaying the blank table grid and the Pivot Table Field List task pane.
To complete the new pivot table, all you have to do is assign the fields in the Pivot Table Field List task pane to the various parts of the table. You do this by dragging a field name from the Choose Fields to Add to Report list box and dropping it in one of the four areas below called drop zones:

✅ **Report Filter:** This area contains the fields that enable you to page through the data summaries shown in the actual pivot table by filtering out sets of data — they act as the filters for the report. So, for example, if you designate the Year Field from a data list as a Report Filter, you can display data summaries in the pivot table for individual years or for all years represented in the data list.

✅ **Column Labels:** This area contains the fields that determine the arrangement of data shown in the columns of the pivot table.

✅ **RowLabels:** This area contains the fields that determine the arrangement of data shown in the rows of the pivot table.

✅ **Values:** This area contains the fields that determine which data are presented in the cells of the pivot table — they are the values that are summarized in its last column (totaled by default).

To better understand how these various zones relate to a pivot table, look at the completed pivot table in Figure 9-3.
For this pivot table, I assigned the Gender field from the data list (a field that contains F (for female) or M (for male) to indicate the employee’s gender to the Report Filter, the Dept Field (that contains the names of the various departments in the company) to the Column Labels, the Location Field (that contains the names of the various cities with corporate offices) to the Row Labels, and the Salary Field to the Values. As a result, this pivot table now displays the sum of the salaries for both the men and women employees in each department (across the columns) and then presents these sums by their corporate location (in each row).

As soon as you create a new pivot table (or select the cell of an existing table in a worksheet), Excel selects Options tab of the PivotTable Tools contextual tab that it automatically adds to the Ribbon (see Color Plate 10). Among the many groups on this tab, you find the Show/Hide group that contains the following useful command buttons:

- **Field List** to hide and redisplay the Pivot Table Field List task pane on the right side of the Worksheet area
- **+- Buttons** to hide and redisplay the expand (+) and collapse (-) buttons in front of particular Column Fields or Row Fields that enable you to temporarily remove and then redisplay their particular summarized values in the pivot table
- **Field Headers** to hide and redisplay the fields assigned to the Column Labels and Row Labels in the pivot table

### Formatting a Pivot Table

Excel 2007 makes formatting a new pivot table you’ve added to a worksheet as quick and easy as formatting any other table of data or list of data. All you need to do is click a cell of the pivot table to add the PivotTable Tools contextual tab to the Ribbon and then click its Design tab to display its command buttons.

The Design tab on the PivotTable Tools contextual tab is divided into three groups:

- **Layout** group that enables you to add subtotals and grand totals to the pivot table and modify its basic layout
- **PivotTable Style Options** group that enables you to refine the pivot table style you select for the table using the PivotTable Styles gallery to the immediate right
- **PivotTable Styles** group that contains the gallery of styles you can apply to the active pivot table by clicking the desired style thumbnail
Figure 9-4 shows the pivot table created for the Employee Data List in Figure 9-3 after applying the Pivot Style Medium 10 in the PivotTable Styles gallery to it. This style applies a light version of background color (rose) to the Gender Report Filter field and a darker version to the Values Label (Sum of Salary), Dept Column Labels, and Location Row Labels (so dark in fact, that Excel automatically reverses the label text to white).

**Refining the Pivot Table style**

Keep in mind that after applying any style from the Light, Medium, or Dark group in the PivotTable Styles gallery, you can then use Live Preview to see how the pivot table would look in any style that you mouse over in the gallery.

After selecting a style from the gallery in the PivotTable Styles group on the Design tab, you can then refine the style using the check box command buttons in the PivotTable Style Options group. For example, you can add banding to the columns or rows of a style that doesn’t already use alternate shading to add more contrast to the table data by putting a check mark in the Banded Rows or Banded Columns check box or remove this banding by clearing these check boxes of their check marks.
Formatting the values in the pivot table

To format the summed values entered as the data items of the pivot table with an Excel number format, you follow these steps:

1. Click the name of field in the table that contains the words “Sum of” followed by the name of the field whose values are currently summarized there and then click the Field Settings command button on the Options tab under the PivotTable Tools Contextual tab.

   Excel opens the Value Field Settings dialog box.

2. Click the Number Format button in the Value Field Settings dialog box to open the Number tab of the Format Cells dialog box.

3. Click the type of number format you want to assign to the values in the pivot table on the Category list box of the Number tab.

4. (Optional) Modify any other options for the selected number format such as Decimal Places, Symbol, and Negative Numbers that are available for that format.

5. Click OK twice, the first time to close the Format Cells dialog box and the second to close the Value Field Settings dialog box.

Sorting and Filtering the Pivot Table Data

When you create a new pivot table, you'll notice that Excel automatically adds drop-down buttons to the Report Filter field as well as the labels for the Column and Row fields. These drop-down buttons, known officially as filter buttons (see Chapter 11 for details), enable you to filter out all but certain entries in any of these fields, and in the case of the Column and Row fields, to sort their entries in the table.

If you've added more than one Column or Row field to your pivot table, Excel adds collapse buttons (-) that you can use to temporarily hide subtotal values for a particular secondary field. After clicking a collapse button in the table, it immediately becomes an expand button (+) that you can click to redisplay the subtotals for that one secondary field.
Filtering the report

Perhaps the most important filter buttons in a pivot table are the ones added to the Report Filter field(s). By selecting a particular option on the dropdown lists attached to one of these filter buttons, only the summary data for that subset you select is then displayed in the pivot table itself.

For example, in the example pivot table (refer to Figure 9-3) that uses the Gender field from the Employee Data list as the Report Filter field, you can display the sum of just the men’s or women’s salaries by department and location in the body of the pivot table doing either of the following:

✔ Click the Gender field’s filter button and then click M on the drop-down list before you click OK to see only the totals of the men’s salaries by department.

✔ Click the Gender field’s filter button and then click F on the drop-down list to see only the totals of the women’s salaries by department.

When you later want to redisplay the summary of the salaries for all the employees, you then re-select the (All) option on the Gender field’s drop-down filter list before you click OK.

When you filter the Gender Report Filter field in this manner, Excel then displays M or F in the Gender Report Filter field instead of the default (All). The program also replaces the standard drop-down button icon with a cone-shaped filter icon, indicating that the field is currently being filtered to show only some of the values in the data source.

Filtering individual Column and Row fields

The filter buttons on the Column and Row fields attached to their labels enable you to filter out entries for particular groups and, in some cases, individual entries in the data source. To filter the summary data in the columns or rows of a pivot table, click the Column or Row field’s filter button and start by clicking the check box for the (Select All) option at the top of the drop-down list to clear this box of its check mark. Then, click the check boxes for all the groups or individual entries whose summed values you still want displayed in the pivot table to put back check marks in each of their check boxes. Then click OK.

As with filtering a Report Filter field, Excel replaces the standard drop-down button icon for that Column or Report field with a cone-shaped filter icon, indicating that the field is currently being filtered and only some of its
summary values are now displayed in the pivot table. To redisplay all the values for a filtered Column or Report field, you need to click its filter button and then click (Select All) at the top of its drop-down list. Then click OK.

Figure 9-5 shows the sample pivot table after filtering its Gender Filter Report Field to women and its Dept Column Field to Accounting, Administration, and Human Resources.

Notice in Figure 9-5 that after filtering the pivot table by selecting F in the Gender Filter Report field and selecting Accounting, Administration, and Human Resources departments as the only Column fields, the filtered pivot table no longer displays salary summaries for all of the company’s locations (Santa Rosa, Seattle, and Atlanta locations are missing). You can tell that the table is missing these locations because there are no women employees in the three selected departments. That isn’t a result of filtering the Row field because the Location drop-down button still uses the standard icon and not the cone filter icon now shown on the right of the Gender Filter Report and Dept Column fields.
Sorting the pivot table

You can instantly reorder the summary values in a pivot table by sorting the table on one or more of its Column or Row fields. To resort a pivot table, click the filter button for the Column or Row field you want to use in the sorting and then click either the Sort A to Z option or the Sort Z to A option at the top of the field’s drop-down list.

Click the Sort A to Z option when you want the table reordered by sorting the labels in the selected field alphabetically or in the case of values from the smallest to largest value or in the case of dates from the oldest to newest date. Click the Sort Z option when you want the table reordered by sorting the labels in reverse alphabetical order (Z to A), values from the highest to smallest, and dates from the newest to oldest.

Modifying a Pivot Table

Pivot tables are much more dynamic than standard Excel data tables because they remain so easy to manipulate and modify. Excel makes it just as easy to change which fields from the original data source are displayed in the table as well as it did originally adding them when the table’s first created. In addition, you can instantly restructure the pivot table by dragging its existing fields to new positions on the table. Add to that the ability to select a new summary function using any of Excel’s basic Statistical functions and you have yourself the very model of a flexible data table!

Modifying the pivot table fields

To modify the fields used in your pivot table, first you display the Field list by following these steps:

1. Click any of the pivot table’s cells.
   Excel adds the PivotTable Tools contextual tab with the Options and Design tabs to the Ribbon.

2. Click the Options tab under the PivotTable Tools Contextual tab to display its buttons on the Ribbon.

3. Click the Field List button in Show/Hide group.
   Excel displays the PivotTable Field List task pane, showing the fields that are currently used in the pivot table as well as to which areas they’re currently assigned.
After displaying the Field List task pane, you can make any of the following modifications to the table’s fields:

- To remove a field, drag its field name out of any of its drop zones (Report Filter, Column Labels, Row Labels, and Values) and, when the mouse pointer changes to an x, release the mouse button or click its check box in the Choose Fields to Add list to remove its check mark.

- To move an existing field to a new place in the table, drag its field name from its current drop zone to a new zone (Report Filter, Column Labels, Row Labels, or Values) at the bottom of the task pane.

- To add a field to the table, drag its field name from the Choose Fields to Add list and drop the field in the desired drop zone (Report Filter, Column Labels, Row Labels, or Values) — note that all you want to do is add a field to the pivot table as an additional Row Labels field, you can also do this by simply clicking the field’s check box in Choose Fields to Add list to add a check mark.

**Pivoting the table’s fields**

As the name *pivot* implies, the fun of pivot tables is being able to restructure the table simply by rotating the Column and Row fields. For example, suppose that after making the Dept Field the Column Field and the Location Field the Row Field in the example pivot table, I now decide I want to see what the table looks like with the Location Field as the Column Field and the Dept Field as the Row Field?

No problem at all: In the PivotTable Field List pane, I simply drag the Dept Field label from the Row Labels drop zone to the Column Labels drop zone and the Location Field from the Column Labels drop zone to the Row Labels drop zone.

Voilà — Excel rearranges the totaled salaries so that the rows of the pivot table show the departmental grand totals and the columns now show the location grand totals.

You can switch Column and Row fields by dragging their labels to their new locations directly in the pivot table itself. Before you can do that, however, you must select the Classic PivotTable Layout (Enables Dragging of Fields in the Grid) check box on the Display tab of the PivotTable Options dialog box (opened by clicking the Options button on the Options tab underneath the PivotTable Tools Contextual tab).
Modifying the table’s summary function

By default, Excel uses the good old SUM function to create subtotals and grand totals for the numeric field(s) that you assign as the Data Items in the pivot table.

Some pivot tables, however, require the use of another summary function, such as the Average or Count. To change the summary function that Excel uses, simply double-click the Sum of field label that’s located at the cell intersection of the first Column and Row Field in a pivot table. Doing this opens the Value Field Settings dialog box for that field similar to the one shown in Figure 9-6.

After you open the Value Field Settings dialog box, you can change its summary function from the default Sum to any of the following functions by selecting it in the Summarize By list box:

- **Count** to show the count of the records for a particular category (note that Count is the default setting for any text fields that you use as Data Items in a pivot table)
- **Average** to calculate the average (that is, the arithmetic mean) for the values in the field for the current category and page filter
- **Max** to display the largest numeric value in that field for the current category and page filter
- **Min** to display the smallest numeric value in that field for the current category and page filter
- **Product** to display the product of the numeric values in that field for the current category and page filter (all non-numeric entries are ignored)
- **Count Numbers** to display the number of numeric values in that field for the current category and page filter (all non-numeric entries are ignored)
After you select the new summary function to use in the Summarize Value Field By list box on the Summarize By tab of the Value Field Settings dialog box, click the OK button to have Excel apply the new function to the data present in the body of the pivot table.

Get Smart with a Pivot Chart

After creating a pivot table, you can create a pivot chart to display its summary values graphically in literally two really simple steps:

1. Click the PivotChart command button in the Tools group on the Options under the PivotTable Tools Contextual tab to open the Create Chart dialog box.

   Remember that the PivotTable Tools contextual tab with its two tabs — Options and Design — automatically appears whenever you click any cell in an existing pivot table.

2. Click the thumbnail of the type of chart you want to create in the Create Chart dialog box and then click OK.

As soon you click OK after selecting the chart type, Excel displays three things in the same worksheet as the pivot table:

- **Pivot chart** using the type of chart you selected that you can move and resize as needed (officially known as an embedded chart — see Chapter 10 for details)

- **PivotChart Filter Pane** containing three drop-down lists — Axis Fields (Categories), Legend Fields (Series), and Report Filter — along with a Values field at the very bottom listing the name of the field whose values are summarized in the chart

- **PivotChart Tools contextual tab** divided into four tabs — Design, Layout, Format, and Analyze — each with its own set of buttons for customizing and refining the pivot chart
**Moving a pivot chart to its own sheet**

Although Excel automatically creates all new pivot charts on the same worksheet as the pivot table, you may find it easier to customize and work with it if you move the chart to its own chart sheet in the workbook. To move a new pivot chart to its own chart sheet in the workbook, you follow these steps:

1. **Click the Design tab under the PivotChart Tools Contextual tab to bring its tools to the Ribbon.**
   
   If the PivotChart Tools contextual tab doesn’t appear at the end of your Ribbon, click anywhere on the new pivot chart to make this tab reappear.

2. **Click the Move Chart button, the sole selection in the Location group at the far right of the Design tab.**
   
   Excel opens a Move Chart dialog box.

3. **Click the New Sheet option button in the Move Chart dialog box.**

4. **(Optional) Rename the generic Chart1 sheet name in the accompanying text box by entering a more descriptive name there.**

5. **Click OK to close the Move Chart dialog box and open the new chart sheet with your pivot chart.**

Figure 9-7 shows a clustered column pivot chart after moving the chart to its own chart sheet in the workbook and docking the PivotChart Filter Pane (see the following sidebar for details).
Filtering a pivot chart

When you graph the data in a pivot table using a typical chart type such as column, bar, or line that uses both an x- and y-axis, the Row labels in the pivot table appear along the x- or category-axis at the bottom of the chart and the Column labels in the pivot table become the data series that are delineated in the chart’s legend. The numbers in the Values field are represented on the y- or value-axis that goes up the left side of the chart.

You can use the drop-down list boxes in the PivotChart Filter Pane to filter the charted data represented in this fashion like you do the values in the pivot table. As with the pivot table, remove the check mark from (Select All) or (All) option and then add a check mark to each of the fields you still want represented in the filtered pivot chart.

Click the following drop-down buttons to filter a different part of the pivot chart:

- **Axis Fields (Categories)** to filter the categories that are charted along the x-axis at the bottom of the chart
- **Legend Fields (Series)** to filter the data series shown in columns bars, or lines in the chart body and identified by the chart legend
- **Report Filter** to filter the values charted along the y-axis on the left side of the chart

Formatting a pivot chart

The command buttons on the Design, Layout, and Format tabs attached to the PivotChart Tools Contextual tab make it easy to further format and customize your pivot chart. Use the Design tab buttons to select a new chart style for your pivot chart or even a brand new chart type. Use the Layout tab buttons to further refine your pivot chart by adding chart titles, text boxes, and gridlines. Use the Format tab buttons to refine the look of any graphics you’ve added to the chart as well as select a new background color for your chart.

To get specific information on using the buttons on these tabs, see Chapter 10, which covers creating charts from regular worksheet data — the Chart Tools contextual tab that appears when you select a chart you’ve created contains the same Design, Layout, and Format tabs with comparable command buttons.
Part V

Life Beyond the Spreadsheet

The 5th Wave
By Rich Tennant

At FEMA, employees often use Excel’s custom format function to create formulas for disaster.
Don’t let anybody kid you: Spreadsheets are the bread and butter of Excel 2007. And for many of you, creating, editing, and printing spreadsheets is the be-all and end-all of Excel. Who could ask for anything more? But don’t get the wrong impression. Just because Excel is a whiz at spreadsheets doesn’t mean that it’s a one-trick pony. And just because spreadsheets may be the only thing that you churn out in your present job doesn’t mean that someday you won’t be moving to a job where you need to chart spreadsheet data, create and maintain Excel data lists, and — who knows — even create your own macros.

I created this part just in case you need to stray beyond the confines of the spreadsheet into such exotic areas as creating charts and adding graphic images, creating, sorting, and filtering data lists, and loading and using add-in programs, linking sheets with hyperlinks, and recording command sequences as macros. Between the entertaining information in Chapter 10 about making charts, the fact-filled information in Chapter 11 on working with Excel data lists, and the tips and tricks on using add-ins, creating hyperlinks, and recording and running macros in Chapter 12, you’ll be more than ready should the day arise (or already be here) when you are forced to go beyond the pale of the good old Excel spreadsheet.
Chapter 10

Charming Charts and Gorgeous Graphics

In This Chapter

- Creating great-looking charts with just a few clicks
- Customizing the chart from the Design, Layout, and Format tabs on the Chart Tools contextual tab
- Adding a text box and arrow to a chart
- Inserting Clip Art in your worksheets
- Adding Word Art and Smart Art to a worksheet
- Printing a chart without printing the rest of the worksheet data

As Confucius was reported to have said, “A picture is worth a thousand words” (or, in our case, numbers). By adding charts to worksheets, you not only heighten interest in the otherwise boring numbers but also illustrate trends and anomalies that may not be apparent from just looking at the values alone. Because Excel 2007 makes it so easy to chart the numbers in a worksheet, you can also experiment with different types of charts until you find the one that best represents the data — in other words, the picture that best tells the particular story.

Making Professional-Looking Charts

I just want to say a few words about charts in general before taking you through the steps for making them in Excel 2007. Remember your high-school algebra teacher valiantly trying to teach you how to graph equations by plotting different values on an x-axis and a y-axis on graph paper? Of course, you were probably too busy with more important things like cool cars and rock ‘n’ roll to pay too much attention to an old algebra teacher. Besides, you probably told yourself, “I'll never need this junk when I’m out on my own and get a job!”
Well, see, you just never know. It turns out that even though Excel automates almost the entire process of charting worksheet data, you may need to be able to tell the x-axis from the y-axis, just in case Excel doesn’t draw the chart the way you had in mind. To refresh your memory and make your algebra teacher proud, the x-axis is the horizontal axis, usually located along the bottom of the chart; the y-axis is the vertical one, usually located on the left side of the chart.

In most charts that use these two axes, Excel plots the categories along the x-axis at the bottom and their relative values along the y-axis on the left. The x-axis is sometimes referred to as the time axis because the chart often depicts values along this axis at different time periods, such as months, quarters, years, and so on.

Also, keep in mind that worksheet values represented graphically in the chart remain dynamically linked to the chart so that, should you make a change to one or more of the charted values in the worksheet, Excel automatically updates the affected part of the chart to suit.

**Creating a new chart**

Excel makes the process of creating a new chart in a worksheet as painless as possible:

1. **Click a cell in the table of data you want graphed, or, when you only want to graph a part of the data in a table, select the cell range including headings and data.**

   If you find that Excel selects too much or too little table data completing these steps and creating the new chart, click the Edit Data Source button on the Design tab (see “Customizing the chart and style from the Design tab” later in this chapter) and correct the Chart Data Range in the Edit Source Data dialog box.

2. **On the Insert tab of the Ribbon, click the button in the Charts group for the type of chart you want to create: Column, Line, Pie, Bar, Area, XY (Scatter), or Other Charts.**

   Excel then displays a drop-down chart gallery with thumbnails showing all the different styles you can choose for the type of chart you select.

3. **Click the thumbnail with the style of Column, Line, Pie, Bar, Area, XY (Scatter), or Other — Surface, Doughnut, Bubble, or Radar — chart you want to create.**
As soon as you click one of the styles in a chart’s drop-down style gallery, Excel immediately creates a free-floating chart (called an embedded chart) on the same worksheet as the table of data the chart represents graphically.

Figure 10-1 shows an embedded two-dimensional clustered column chart upon creation immediately after clicking the Clustered Column chart style thumbnail, the first one on the Column chart style gallery. Because this chart graphs only the first quarter sales in 2008 (without the totals), I selected the range A2:D11 in the table, clicked the Column button on the Insert tab and then clicked the Clustered Column chart style thumbnail on the drop-down Column gallery.

Instant charts

If you just don’t have time to fool with the Chart buttons on the Insert tab of the Ribbon, position the cell cursor in the table of data or select the portion to be charted and then just press F11. Excel then creates a new Clustered Column chart using the table’s data or cell selection on its own chart sheet (Chart1) that precedes all the other sheets in the workbook, which you can then customize as described later in this chapter.

As soon as you click one of the styles in a chart’s drop-down style gallery, Excel immediately creates a free-floating chart (called an embedded chart) on the same worksheet as the table of data the chart represents graphically.

Figure 10-1 shows an embedded two-dimensional clustered column chart upon creation immediately after clicking the Clustered Column chart style thumbnail, the first one on the Column chart style gallery. Because this chart graphs only the first quarter sales in 2008 (without the totals), I selected the range A2:D11 in the table, clicked the Column button on the Insert tab and then clicked the Clustered Column chart style thumbnail on the drop-down Column gallery.
Moving and resizing an embedded chart in a worksheet

Right after you create a new chart in a worksheet, you can easily move or resize the embedded chart because the chart is still selected. (You can always tell when a graphic object, such as a chart, is selected because you see selection handles — those tiny dots — around the edges of the object.)

Whenever an embedded chart is selected (as it is automatically immediately after creating it or after clicking any part of it), the Chart Tools contextual tab with its Design, Layout, and Format tabs appears on the Ribbon, and Excel outlines each group of cells represented in the selected chart in a different color in the worksheet.

When an embedded chart is selected in a worksheet, you can move or resize it as follows:

- To move the chart, position the mouse pointer somewhere inside the chart and drag the chart to a new location.
- To resize the chart (you may want to make it bigger if it seems distorted in any way), position the mouse pointer on one of the selection handles. When the pointer changes from the arrowhead to a double-headed arrow, drag the side or corner (depending on which handle you select) to enlarge or reduce the chart.

When the chart is properly sized and positioned in the worksheet, set the chart in place by deselecting it (simply click the mouse pointer in any cell outside the chart). As soon as you deselect the chart, the selection handles disappear, as does the Chart Tools contextual tab from the Ribbon.

To re-select the chart later on to edit, size, or move it again, just click anywhere on the chart with the mouse pointer. The moment you do, the sizing handles return to the embedded chart and the Chart Tools contextual tab to the Ribbon.

Moving an embedded chart onto its own chart sheet

Although Excel automatically embeds all new charts on the same worksheet as the data they graph (unless you create using the F11 trick), you may find it easier to customize and work with it if you move the chart to its own chart sheet in the workbook. To move an embedded chart to its own chart sheet in the workbook, follow these steps:
1. Click the Move Chart button on the Design tab under the Chart Tools Contextual tab to open the Move Chart dialog box.

If the Chart Tools Contextual tab doesn’t appear at the end of your Ribbon, click anywhere on the new chart to select the chart and make this tab appear.

2. Click the New Sheet option button in the Move Chart dialog box.

3. (Optional) Rename the generic Chart1 sheet name in the accompanying text box by entering a more descriptive name.

4. Click OK to close the Move Chart dialog box and open the new chart sheet with your pivot chart.

If, after customizing the chart on its own sheet, you decide you want the finished chart to appear on the same worksheet as the data it represents, click the Move Chart button on the Design tab again and this time click the Object In option button and then select the name of the worksheet in its associated drop-down list box before you click OK.

**Customizing the chart type and style from the Design tab**

You can use the command buttons on the Design tab of the Chart Tools contextual tab (see Color Plate 9) to make all kinds of changes to your new chart. The Design tab contains the following groups of buttons to use:

- **Type:** Click the Change Chart Type button to change the type of chart and then click the thumbnail of the new chart type in the Change Chart Type dialog box that shows all the kinds of charts in Excel. Click the Save As Template button to open the Save Chart Template dialog box where you save the current chart’s formatting and layout (usually after thoroughly customizing) as a template to use in creating future charts.

- **Data:** Click the Switch Row/Column button to immediately interchange the worksheet data used for the Legend Entries (series) with that used for the Axis Labels (Categories) in the selected chart. Click the Select Data button to open the Select Data Source dialog box where you can not only interchange the Legend Entries (series) with the Axis Labels (Categories) but also edit out or add particular entries to either category.

- **Chart Layouts:** Click the More button (the last one with the horizontal bar and triangle pointing downward) to display all the thumbnails on the Chart Layouts drop-down gallery and then click the thumbnail of the new layout style you want applied to the selected chart.
Chart Styles: Click the More button (the last one with the horizontal bar and triangle pointing downward) to display all the thumbnails on the Chart Styles drop-down gallery and then click the thumbnail of the new chart style you want applied to the selected chart.

Note that the Chart Layout and the Chart Styles galleries do not utilize the Live Preview feature. This means that you have to click a thumbnail in the gallery and actually apply it to the selected chart in order to see how its style looks.

Figure 10-2 shows the original clustered column chart (created in Figure 10-1) after clicking the Layout 9 thumbnail on the Chart Layouts drop-down gallery and the Style 42 thumbnail on the Chart Styles drop-down gallery. Selecting Style 42 gives the clustered column chart its high contrast, whereas selecting Layout 9 adds the generic chart titles and positions as shown in Figure 10-2.

Figure 10-2: Embedded clustered column chart after selecting a new chart layout and color style from the Edit tab.

Customizing chart elements from the Layout tab

The command buttons on the Layout tab under the Chart Tools Contextual tab make it easy to customize particular parts of your chart. This customization can include:
Repositioning discrete chart elements including the legend and x- and y-axis as well as the display of data labels and data tables in the chart

Adding, removing, and repositioning the titles in the chart, including the chart and x- and y-axis titles

Modifying the display of the chart’s background including the plot area for 2-D charts and the chart wall, floor, and view for 3-D charts

To make a change to a particular chart element from the Layout tab, click its command button and then click the option you want to use from the drop-down menu (note that some options have continuation drop-down menus attached to them). If none of the preset options fits your needs, click the More option at the bottom of the drop-down list to open a format dialog box for the selected chart element normally containing Fill, Line, Line Style, Shadow, 3-D Format, and Alignment tabs with oodles of options that you can use to customize the chart element.

For example, to add a title to a chart (when you’ve selected a chart style that doesn’t automatically add one) or reposition or customize an existing title, you click the Chart Title button on the Layout tab to display the following options on its drop-down list:

- **None** to remove an existing chart title from the chart
- **Centered Overlay Title** to add or reposition the chart title so that it appears centered at the top of the plot area
- **Above Chart** to add or reposition the chart title so that it appears centered above the plot area
- **More Title Options** to open the Format Chart Title dialog box where you can use the options on its Fill, Line, Line Style, Shadow, 3-D Format, and Alignment tabs to customize the appearance of the chart title

The Properties group at the end of the Layout tab contains a sole Chart Name text box that you can use to modify the generic name chart name (Chart 1, Chart 2, and so forth) to something more descriptive. If your worksheet contains more than one chart, you may find it advantageous to give it a more descriptive name so that it’s easy to identify in the Selection Pane.

**Adding data labels to the series in a chart**

Data labels displays values from the worksheet represented in the chart at each of its data points. To add data labels to your selected chart and position them, click the Data Labels button on the Layout tab and then click one of the following options on its drop-down menu:
Center to position the data labels in the middle of each data point

Inside End to position the data labels inside each data point near the end

Inside Base to position the data labels at the base of each data point

Outside End to position the data labels outside of the end of each data point

More Data Label Options to open the Format Data Labels dialog box where you can use the options on Label Options, Number, Fill, Line, Line Style, Shadow, 3-D Format, and Alignment tabs to customize the appearance and position of the data labels.

To remove all data labels from the data points in a selected chart, click the None option at the top of the Data Labels button’s drop-down menu on the Layout tab of the Chart Tools contextual tab.

Adding a data table to a chart

Sometimes, instead of data labels that can easily obscure the data points in the chart, you’ll want Excel to draw a data table beneath the chart showing the worksheet data it represents in graphic form. To add the worksheet data to your selected chart, click the Data Table button on the Layout tab and then click one of these options:

Show Data Table to have Excel draw the table at the bottom of the chart

Show Data Table with Legend Keys to have Excel draw the table at the bottom of the chart including the color keys used in the legend to differentiate the data series in the first column

More Data Table Options to open the Format Data Table dialog box where you can use the options on the Data Table Options, Fill, Line, Line Style, Shadow, and 3-D Format tabs to customize the appearance and position of the data table.

Figure 10-3 illustrates how the sample clustered column chart looks with a data table added to it. This data table includes the legend keys as its first column.

If you decide that having the worksheet data displayed in a table at the bottom of the chart is no longer necessary, simply click the None options on the Data Table button’s drop-down menu on the Layout tab of the Chart Tools contextual tab.
Editing the titles in a chart

When Excel first adds titles to a new chart, it gives them generic names such as Chart Title and Axis Title (for both the x- and y-axis title). To replace these generic titles with the actual chart titles, click the title in the chart itself or click the name of the title on the Chart Elements drop-down list (Chart Elements is the very first command button in the Current Selection group on the Format tab under Chart Tools — its combo box displays the name of the element currently selected in the chart). Excel lets you know that a particular chart title is selected by placing selection handles around its perimeter.

After you select a title, you can click the insertion point in the text and then edit as you would any worksheet text or you can triple-click to select the entire title and completely replace it with the text you type. To force part of the title onto a new line, click the insertion point at the place in the text where the line break is to occur. After the insertion point is positioned in the title, press Enter to start a new line.

After you finish editing the title, click somewhere else on the chart area to de-select it (or a worksheet cell, if you’ve finished formatting and editing the chart).
Formatting chart elements from the Format tab

The Format tab under the Chart Tools Contextual tab contains command buttons that make it easy to format particular chart elements after you select them.

Excel gives you a choice of methods for selecting individual chart elements:

- Click the element directly in the chart to select it — use the ScreenTip that appears at the mouse pointer to identify the chart object before you click to select it.
- Click the name of the chart element on the Chart Elements drop-down list in the Current Selection group on the Format tab — Excel shows you which element is currently selected by displaying its name inside the Chart Elements combo box.

After you select an element in the chart by clicking it, you can cycle through and select the other elements in succession by pressing the ↑ and ↓ keys. Pressing the → key selects the next object; pressing the ← key selects the previous object.

You can tell when an element is selected in the chart itself because selection handles appear around it and its name appears in the Chart Elements combo box on the Format tab.

After you select a chart element, you can then make any of the following changes to it:

- Format the element by selecting the appropriate command button in the Shapes Style group or by clicking the Format Selection button in the Current Selection group to open the Format dialog box for that element and use its options to make the desired changes.
- Move the element within the chart by positioning the arrowhead pointer in their midst and then dragging their boundary — with some elements, you can use the selection handles to resize or reorient the object.
- Remove the element from the chart by pressing the Delete key.

All chart elements have shortcut menus attached to them. If you know that you want to choose a command from the shortcut menu as soon as you select a part of the chart, you can both select the object and open the shortcut menu by right-clicking the chart object. (You don’t have to click the object with the left button to select it and then click again with the right to open the menu.)
Formatting the chart titles

When you add titles to your chart, Excel uses the Calibri (Body) font for the chart title (in 18-point size) and the x- and y-axis (in 10-point size). To change the font used in a title or any of its attributes, select the title and then use the appropriate command buttons in the Font group on the Home tab.

Use Live Preview to see how a particular font or font size for the selected chart title looks in the chart before you select it. Simply, click the Font or Font Size drop-down buttons and then highlight different font names or sizes to have the selected chart title appear in them.

If you need to change other formatting options for the titles in the chart, you can do so using the command buttons on the Format tab of the Chart Tools contextual tab. To format the entire text box that contains the title, click one of the following buttons in the Shape Styles group:

- **Shape Styles** thumbnail in its drop-down gallery to format both the text and text box for the selected chart title
- **Shape Fill** button to select a new color for the text box containing the selected chart title from its drop-down palette
- **Shape Outline** button to select a new color for the outline of the text box for the selected chart text from its drop-down palette
- **Shape Effects** button to apply a new effect (Shadow, Reflection, Glow, Soft Edges, and so on) to the text box containing the selected chart title from its drop-down list

To format just the text in chart titles, click one of the various buttons in the WordArt Styles group:

- **WordArt Styles** thumbnail in its drop-down gallery to apply a new WordArt style to the text of the selected chart title
- **Text Fill** button (the one with the A) to select a new fill color for the text in the selected chart title from its gallery
- **Text Outline** button (immediately below the Text Fill button) to select a new outline color for the text in the selected chart title from its drop-down palette
- **Text Effects** button (immediately below the Text Outline button) to apply a text effect (Shadow, Reflection, Glow, Bevel, and so on) to the text of the selected chart title from its drop-down list

Figure 10-4 shows the example clustered column chart after selecting Fill Accent 1, Inner Shadow – Accent 1 on the Shape Fill button’s gallery.
Formatting the Category x-axis and Value y-axis

When charting a bunch of values, Excel isn’t too careful how it formats the values that appear on the y-axis (or the x-axis when using some chart types such as the 3-D Column chart or the XY Scatter chart).

If you’re not happy with the way the values appear on either the x-axis or y-axis, you can easily change the formatting as follows:

1. Click the x-axis or y-axis directly in the chart or click the Chart Elements button (the very first button in the Current Selection group of the Format tab) and then click Horizontal (Category) Axis (for the x-axis) or Vertical (Value) Axis (for the y-axis) on its drop-down list.

   Excel surrounds the axis you select with selection handles.

2. Click the Format Selection button in the Current Selection group of the Format tab or press Ctrl+1.

   Excel opens the Format Axis dialog box containing the following tabs: Axis Options, Number, Fill, Line, Line Style, Shadow, 3-D Format, and Alignment.

3. To change the scale of the axis, the appearance of its tick marks, and where it crosses the other axis, change the appropriate options on the Axis Options tab (automatically selected when you first open the Format Axis dialog box) as needed.
These options include those that fix the maximum and minimum amount for the first and last tick mark on the axis, display the values in reverse order (highest to lowest), apply a logarithmic scale, display units on the axis (hundreds, thousands, and millions, and so forth) and divides the values by those units, reposition the tick marks on the axis, and modify the value at which the other axis (y-axis when modifying the x-axis and x-axis when modifying the y-axis) crosses.

4. To change the number formatting for all values on the selected axis, click the Number tab; then click the number format you want to apply in the Category list box followed by the appropriate options associated with that format.

For example, to select the Number format with the comma as the thousands separator and no decimal places, you select Number in the Category list box; then leave the Use 1000 Separator (,) check box selected and enter 0 in the Decimal Places text box or select 0 with the spinner buttons.

5. To change the alignment and orientation of the labels on the selected axis, click the Alignment tab and then indicate the new orientation by clicking the desired vertical alignment in the Vertical Alignment dropdown list box and desired text direction in the Text Direction dropdown list.

6. Click Close or press Enter to close the Format Axis dialog box.

As you choose new options for the selected axis, Excel 2007 shows you the change in the chart. These changes are, however, only set in the chart when you click Close in the Format Axis dialog box.

To change the default font, font size, or other text attribute for entries along the selected x- or y-axis, click the appropriate command buttons in the Font group on the Home tab (see Chapter 3 for details).

**Adding Great Looking Graphics**

Charts are not the only kind of graphic objects you can add to a worksheet. Indeed, Excel lets you spruce up a worksheet with a whole bevy of graphics including text boxes, Clip Art drawings supplied by Microsoft, as well as graphic images imported from other sources such as digital photos, scanned images, and pictures downloaded directly from the Internet.

In addition to these graphics, Excel 2007 supports the creation of fancy graphic text called WordArt as well as a whole new generation of organizational diagrams known collectively as SmartArt graphics.
**Telling all with a text box**

Text boxes, as their name implies, are boxes in which you can add commentary or explanatory text to the charts you create in Excel. They’re like Excel comments (see Chapter 6) that you add to worksheet cells except that with text boxes you have add the arrow if you want it to point to something in the chart.

In Figure 10-5, you see an Area chart for the Mother Goose Enterprises – 2008 First Quarter Sales. I added a text box with an arrow that points out how extraordinary the sales were for the Hickory, Dickory, Dock Clock Repair shops in this quarter and formatted the values on the y-axis with the Comma style number format with zero decimal places.

![Figure 10-5: Clustered Column chart, with added text box and formatted y-axis values.](image)

**Adding and formatting a text box**

To add a text box like the one shown in Figure 10-6 to the chart when a chart is selected, click the Text Box command button in the Insert group on the Layout tab under the Chart Tools Contextual tab. If the chart is not selected, you can click the Text Box command button on the Ribbon’s Insert tab.
Excel then changes the mouse pointer to a narrow vertical line with a short cross near the bottom. Click at the place where you want to draw the text box and then draw the box by dragging its outline. When you release the mouse button after dragging this mouse pointer, Excel draws a text box in the shape and size of the outline.

After creating a horizontal text box, the program positions the insertion point at the top left, and you can then type the text you want to appear within it. The text you type appears in the text box and wraps to a new line when you reach the right edge of the text box. You can press Enter when you want to force text to appear on a new line. When you finish entering the message for your text box, click anywhere outside the box to deselect it.

After adding a text box to a chart or worksheet while it’s still selected, you can edit it as follows:

- Move the text box to a new location in the chart by dragging it.
- Resize the text box by dragging the appropriate selection handle.
- Rotate the text box by dragging its rotation handle (the green circle at the top) in a clockwise or counterclockwise direction.
- Modify the formatting and appearance of the text box using the various command buttons in the ShapeStyles group on the Format tab under the Drawing Tools Contextual tab.
- Delete the text box by clicking its perimeter so that the dotted lines connecting the selection handles become solid and then pressing the Delete key.

Adding an arrow to a text box

When creating a text box, you may want to add an arrow to point directly to the object or part of the chart you’re referencing. To add an arrow, follow these steps:

1. **Click the text box to which you want to attach the arrow in the chart or worksheet to select.**
   
   Selection handles appear around the text box and the Format tab under the Drawing Tools Contextual tab is selected on the Ribbon.

2. **Click the Arrow command button in the Insert Shapes drop-down gallery at the very beginning of the Format tab.**
   
   The Arrow command button is the second from the left in the first row of shapes (with the picture of an arrow). When you click this button, it becomes selected in the palette (indicated by the new color) and the mouse pointer assumes the crosshair shape.
3. Drag the crosshair mouse pointer from the place on the text box where the end of the arrow (the one *without* the arrowhead) is to appear to the place where the arrow starts (and the arrowhead will appear) and release the mouse button.

As soon as you release the mouse button, Excel draws two points, one at the base of the arrow (attached to the text box) and another at the arrowhead. At the same time, the contents of the Shape Styles drop-down gallery changes to line styles.

4. Click the More button in the lower-right corner of the Shapes Styles drop-down gallery to display the thumbnails of all its line styles and then mouse over the thumbnails to see how the arrow would look in each.

As you mouse through the different line styles in this gallery, Excel draws the arrow between the two selected points in the text box using the highlighted style.

5. Click the thumbnail of the line style you want the new arrow to use in the Shape Styles gallery.

Excel then draws a new arrow using the selected shape style, which remains selected (with selection handles at the beginning and end of the arrow). You can then edit the arrow as follows:

- Move the arrow by dragging its outline into position.
- Change the length of the arrow by dragging the selection handle at the arrowhead.
- Change the direction of the arrow by pivoting the mouse pointer around a stationary selection handle.
- Change the shape of the arrowhead or the thickness of the arrow’s shaft by clicking a thumbnail on the Shape Styles drop-down gallery or clicking a new option on the Shape Fill, Shape Outline, and Shape Effects button on the Format tab of the Drawing Tools contextual tab or by opening the Format Shape dialog box (Ctrl+1) and then selecting the appropriate options on its Fill, Line, Line Style, Shadow, 3-D Format, 3-D Rotation, Picture, and Text Box tabs.
- Delete the arrow by pressing the Delete key.

**The wonderful world of Clip Art**

Clip Art is the name given to the over 150,000 readymade illustrations offered by Microsoft for use in its various Microsoft Office programs, including Excel 2007. Clip Art drawings are now so numerous that the images are classified into a bunch of different categories ranging from Abstract to Web Elements.
To bring in a piece of Clip Art included with Office 2007, you click the Clip Art button on the Ribbon’s Insert tab or press Alt+N. When you do this, Excel 2007 displays the Clip Art task pane (similar to the one shown in Figure 10-6) from which you search for the type of art you want to use. To locate the clip(s) you want to insert into the current worksheet in the Clip Art task pane, you follow these steps:

1. **Click the Search For text box at the top, and then enter the keyword(s) for the type of Clip Art you want to find.**
   
   When you enter keywords for finding particular types of Clip Art, try general, descriptive terms such as trees, flowers, people, flying, and the like.

2. **(Optional) Click the Search In drop-down button and remove (deselect) check marks from any Clip Art collections that you don’t want to search.**
   
   By default, Excel searches all the collections of Clip Art (including the Media Gallery Online collection on the Web). To limit your search, you need to make sure that only the Clip Art collections you want to include in the search have check marks before their names.

3. **(Optional) To limit the search to Clip Art only, click the Results Should Be drop-down button and remove check marks from the All Media Types, Photographs, Movies, and Sounds categories.**
   
   You can further limit the types of Clip Art files included in the search by clicking the plus sign in front of Clip Art and then removing check marks from any and all types of clips (such as CorelDraw or Macintosh PICT) that you don’t want or need to use.

4. **Click the Go button to the immediate right of the Search For text box to initiate the search.**

   The first time you search for Clip Art, when you click the Go button, Excel displays an alert dialog box asking you if you want to include thousands of additional Clip Art images and photos from Microsoft Office Online in your search. If you click Yes, Excel includes these images in your search. Otherwise, Excel simply searches all of the places you specify in the Search In list before displaying the thumbnails of the search results in the Clip Art task pane.

   To insert one of the thumbnails displayed in the Clip Art task pane into the current worksheet (see Figure 10-7), click the thumbnail. You can also insert an image by positioning the mouse over it to display its drop-down button, clicking the drop-down button, and then choosing Insert at the top of its drop-down menu.
When you insert a Clip Art image into the worksheet, it is automatically selected (indicated by the selection handles around its perimeter and its rotation handle at the top). To de-select the Clip Art image and set it in the worksheet, click anywhere in the worksheet outside of the image.
Inserting pictures from graphics files

If you want to bring in an image such as a digital photo or a scanned image saved in its own graphics file, click the Picture button on the Insert tab of the Ribbon or press Alt+NP. This opens the Insert Picture dialog box (which works just like opening an Excel workbook file in the Open dialog box) where you select the graphics file and then import into the worksheet by clicking its Insert button.

If you want to bring in a graphic image created in another graphics program that’s not saved in its own file, you select the graphic in that program and then copy it to the Clipboard (press Ctrl+C). When you get back to your worksheet, place the cursor where you want the picture to go and then paste the image in place (press Ctrl+V or click the Paste command button at the very beginning of the Home tab).

When you insert a picture from a graphics file into the worksheet, it’s automatically selected (indicated by the selection handles around its perimeter and its rotation handle at the top). To deselect the graphic image and set it in the worksheet, click anywhere in the worksheet outside of the image.

Editing Clip Art and imported pictures

While a Clip Art image or a picture that you’ve inserted into your worksheet is still selected (indicated by the appearance of the selection handles around its perimeter and a rotation handle at the top), you can make any of the following editing changes to it:

- Move the Clip Art image or imported picture to a new location in the chart by dragging it.
- Resize the Clip Art image box or imported picture by dragging the appropriate selection handle.
- Rotate the Clip Art image or imported picture by dragging its rotation handle (the green circle at the top) in a clockwise or counterclockwise direction.
- Delete the Clip Art image or imported picture by pressing the Delete key.

Formatting Clip Art and imported pictures

In addition, when a Clip Art image or imported picture is selected, Excel adds the Picture Tools Contextual tab to the Ribbon and automatically selects the sole Format tab under it (see Color Plate 8).
The Format tab is divided into four groups: Adjust, Picture Styles, Arrange, and Size. The Adjust group contains the following important command buttons:

- **Brightness** to increase or decrease the picture’s brightness by selecting a new preset positive percentage (to increase) or negative percentage (to decrease) where 0% is normal or to open the Picture tab of the Format Shape dialog box where you can adjust it with the Brightness slider.

- **Contrast** to increase or decrease the picture’s contrast by selecting a new preset positive percentage (to increase) or negative percentage (to decrease) where 0% is normal or to open the Picture tab of the Format Shape dialog box where you can adjust it with the Contrast slider.

- **Recolor** to open a drop-down menu where you can select a new color for the image or select a transparent color that drops out of the picture.

- **Compress Pictures** to open the Compress Pictures dialog box compress all images in the worksheet or just the selected graphic image to make them more compact and thus make the Excel workbook somewhat smaller when you save the images as part of its file.

- **Change Picture** to open the Insert Picture dialog box where you can select an image in a new graphics file to replace the picture — when replacing the currently selected picture with the new image, Excel automatically sizes and formats the new image with the settings applied to the old.

- **Reset Picture** button to remove all formatting changes made and return the picture to the state it was in when you originally inserted it into the worksheet.

You can also format a selected Clip Art image or imported picture by opening the Format Shape dialog box (Ctrl+1) and then selecting the appropriate options on its Fill, Line, Line Style, Shadow, 3-D Format, 3-D Rotation, Picture, and Text Box tabs.

In addition to the command buttons in the Picture Tools group, you can use the command buttons in the Picture Styles group. Click a thumbnail on the Picture Styles drop-down gallery to select a new orientation and style for the selected picture. You can also modify any of the following:

- **Border shape** on the Picture Shape button’s drop-down palette
- **Border color** on the Picture Border button’s drop-down color palette
- **Shadow or 3-D rotation effect** on the Picture Effects button’s drop-down menus
Figure 10-8 shows the imported cell phone Clip Art image as it’s being formatted in Live Preview with Snip Diagonal Corner, White highlighted on the Picture Styles drop-down gallery. Note that in this style, Excel snips off the lower-left and upper-right corners of the image while at the same time enclosing the image in a white border.

Adding preset graphic shapes

In addition to Clip Art images and pictures imported from graphics files, you can insert preset graphic shapes in your chart or worksheet by selecting their thumbnails on the Shapes drop-down gallery on the Insert tab of the Ribbon (see Figure 10-9).

When you open the Shapes gallery by clicking the More button in the Shapes group at the beginning of the Insert tab on the Ribbon, you see that it is divided into nine sections: Recently Used Shapes, Lines, Rectangles, Basic Shapes, Block Arrows, Equation Shapes, Flowchart, Stars and Banners, and Callouts.

After you click the thumbnail of one of preset shapes in this drop-down gallery, the mouse pointer becomes a crosshair and you use it to draw the graphic by dragging it until it’s approximately the size you want.
After you release the mouse button, the shape you’ve drawn in the worksheet is still selected. This is indicated by the selection handles around its perimeter and the rotation handle at the top, which you can use to reposition and resize it, if need be. In addition, the program activates the Format tab on the Drawing Tools contextual tab and you can use Shape Styles gallery or other command buttons to further format the shape until it’s exactly the way you want it. To set the shape and remove the selection and rotation handles, click anywhere in the worksheet outside of the shape.

**Working with WordArt**

If selecting gazillions of preset shapes available from the Shapes gallery doesn’t provide enough variety for jazzing up your worksheet, you may want to try adding some fancy text using the WordArt gallery opened by clicking the WordArt command button in the Text group of the Insert tab.

You can add this type of “graphic” text to your worksheet by following these steps:

1. **Click the WordArt command button on the Ribbon’s Insert tab or press Alt+NW.**
   
   Excel displays the WordArt drop-down gallery dialog box, as shown in Figure 10-10.
2. **Click the A thumbnail in the WordArt style you want to use in the WordArt drop-down gallery.**

   Excel inserts a selected text box containing *Your Text Here* in the center of the worksheet with this text in the WordArt style you selected in the gallery.

3. **Type the text you want to display in the worksheet in the Text text box.**

   As soon as you start typing, Excel replaces the *Your Text Here* text in the selected text box with the characters you enter.

4. *(Optional) To format the background of the text box, use Live Preview in the Shape Styles drop-down gallery on the Format tab to find the style to use and then set it by clicking its thumbnail.*

   The Format tab under the Drawing Tools contextual tab is automatically added and activated whenever WordArt text is selected in the worksheet.

5. **After making any final adjustments to the size, shape, or orientation of the WordArt text with the selection and rotation handles, click a cell somewhere outside of the text to deselect the graphic.**

   Note that Excel automatically compresses the text to fill the shape and size of its text box. To put more space between the words and the characters in each word, make the text box wider by dragging the sizing handle on either side of the text box.

   When you click outside of the WordArt text, Excel deselects the graphic, and the Drawing Tools contextual tab disappears from the Ribbon. *(If you ever want this tab to reappear, all you have to do is click somewhere on the WordArt text to select the graphic.)*

   Figure 10-11 shows the name of my company, Mind over Media, Inc. after creating the text in the Fill – Accent 2, Warm Matte Bevel style.
You can change the size of WordArt text and the font it uses after creating it by dragging through the WordArt text to select and then using the Font and Font Size command buttons on the Home tab to make your desired changes. Keep in mind, however, that Excel does not automatically resize the WordArt text box to suit the new font and font size. This means that you can easily make the WordArt text too small or too large for its text box. If this happens, use the sizing handles around the text box to resize and reshape it as needed to suit the new text size.

**Make mine SmartArt**

Excel 2007’s SmartArt is a whole new breed of graphic object that gives the ability to quickly and easily construct fancy graphical lists and diagrams in your worksheet. SmartArt lists and diagrams come in a wide array of configurations (including a bunch of organizational charts and various process and flow diagrams) that enable you to combine your own text with the predefined graphic shapes.

To insert a SmartArt list or diagram into the worksheet, click the SmartArt button on the Insert tab or press Alt-NM to open the Choose a SmartArt Graphic dialog box (shown in Figure 10-12) and then click category in the navigation pane on the left followed by the list’s or diagram’s thumbnail in the center section before you click OK.
Excel then inserts the basic structure of the list or diagram into your worksheet along with an outline box (with “Type Your Text Here” on its title bar) to its immediate left and [Text] in the shapes in the diagram itself where you can enter the text for the various parts of the list or diagram (as shown in Figure 10-13). At the same time, the Design tab of the SmartArt Tools contextual tab with Layouts and Quick Styles galleries for the particular type of SmartArt list or diagram you originally selected appears on the Ribbon.

**Filling in the text for a new SmartArt graphic**

To fill in the text for the first section of the new list or diagram in the outline text box that already contains the insertion point, simply type in the text. Then, press the ↓ key or click the next list or diagram section to set the insertion point there.
Don’t press the Tab key or the Enter key to complete a text entry in the list or diagram as you naturally do in the regular worksheet — in a SmartArt list or diagram, pressing the Enter key inserts a new section of the list or diagram (at the same level in hierarchical diagrams such as an org chart) and Tab either indents the level of the current section on the outline (in hierarchical diagrams) or it does nothing except beep at you.

When you finish entering the text for your new diagram, click the close button (with an X) on the outline text box in the upper left-hand corner of the opposite the title, “Type Your Text Here” (you can always reopen this box if you need to edit any of the text by clicking the button that appears in the middle of the left side of the selected list or diagram after you close the outline text box).

If the style of the SmartArt list or diagram you select comes with more sections than you need, you can delete the unused graphics by clicking them to select them (indicated by the selection and rotation handles around it) and then pressing the Delete key.

**Formatting a SmartArt graphic**

After you close the text outline box attached to your SmartArt list or diagram, you can still format its text and graphics. To format the text, select all the graphic objects in the SmartArt list or diagram that need the same type of text formatting — remember you can select several objects in the list or diagram by holding down Ctrl as you click them and then clicking the appropriate command buttons in the Font group on the Home tab of the Ribbon.

To refine or change the default formatting of the graphics in a SmartArt list or diagram, you can use the Layouts, Colors Schemes, and Quick Styles drop-down galleries available on the Design tab of the SmartArt Tools contextual tab:

- Click the More button in the Layouts group and then click a thumbnail on the Layouts drop-down gallery to select an entirely new layout for your SmartArt list or diagram.

- Click the Change Colors button in the Quick Styles group and then click a thumbnail in the drop-down Color Schemes gallery to change the color scheme for the current layout.

- Click the More button in the Quick Styles group and then click a thumbnail on the Quick Styles drop-down gallery to select a new style for the current layout, using the selected color scheme.
Figure 10-14 shows my fully formatted organizational chart after selecting Hierarchy 6 in the Layouts gallery, Colorful 5 in the Color Schemes gallery, and finally 3-D Style 7 in the Quick Styles gallery.

Figure 10-14: Worksheet with completed and formatted organizational chart.

**Theme for a day**

Through its themes, Excel 2007 introduces a whole new way to format uniformly all the graphics you add to a worksheet. You can do this by simply clicking the thumbnail of the new theme you want to use in the Themes drop-down gallery (Color Plate 13) opened by clicking the Themes button on the Page Layout tab of the Ribbon or by pressing Alt+PTH.

Use Live Preview to see how the graphics you’ve added to your worksheet appear in the new theme before you click its thumbnail.

Excel Themes combine three default elements: the color scheme applied to the graphics, the font (body and heading) used in the graphics, and graphic effects applied. If you prefer, you can change any or all of these three elements in the worksheet by clicking their command buttons in the Themes group at the start of the Page Layout tab:

- **Colors** to select a new color scheme by clicking its thumbnail on the drop-down palette — click the Create New Theme Colors at the bottom of this palette to open the Create New Theme Colors dialog box where you can customize each element of the color scheme and save it with a new descriptive name.
Fonts to select a new font by clicking its thumbnail on the drop-down list — click Create New Theme Fonts at the bottom of this list to open the Create New Theme Fonts dialog box where you can customize the body and heading fonts for both Latin and East Asian text and save it with a new descriptive name.

Effects to select a new set of graphics effects by clicking its thumbnail in the drop-down gallery.

To save your newly selected color scheme, font, and graphic effects as a custom theme that you can reuse in other workbooks, click the Themes command button and then click Save Current Theme at the bottom of the gallery to open the Save Current Theme dialog box. Edit the generic Theme1 filename in the File Name text box (without deleting the .thmx filename extension) and then click the Save button. Excel then adds the custom theme to a Custom Themes section in the Themes drop-down gallery and you can apply it to any active worksheet simply by clicking its thumbnail.

**Controlling How Graphic Objects Overlap**

In case you haven’t noticed, graphic objects float on top of the cells of the worksheet. Most of the objects (including charts) are opaque, meaning that they hide (without replacing) information in the cells beneath. If you move one opaque graphic so that it overlaps part of another, the one on top hides the one below, just as putting one sheet of paper partially on top of another hides some of the information on the one below. This means that most of the time, you should make sure that graphic objects don’t overlap one another or overlap cells with worksheet information that you want to display.

**Reordering the layering of graphic objects**

When graphic objects (including charts, text boxes, Clip Art, imported pictures, drawn shapes, and SmartArt graphics) overlap each other, you can change how they overlay each other by sending the objects back or forward so that they reside on different (invisible) layers.

Excel 2007 enables you to move a selected graphic object to a new layer in one of two ways:

✔ For a select Clip Art image, picture, or graphic shape, click the Bring to Front or Send to Back command button on the Format tab under the Drawing Tools or Picture Tools contextual tab to bring the selected
object to the topmost or bottommost layer of the stack respectively. For a smart art diagram, you need to click the Arrange command button on the Format tab under the SmartArt Tools contextual tab to display a drop-down menu with the Bring to Front and Send to Back buttons.

Click the Selection Pane command button in the Arrange group on the Format tab under the Drawing Tools or Picture Tools contextual tab to display the Selection and Visibility task pane (on the Format tab under SmartArt Tools, you need to click the Arrange button and then click Selection Pane on its drop-down menu). Then, click the Bring Forward or Send Backward buttons at the bottom of this task pane in the Re-order section until the selected graphic object appears on the desired layer.

**Grouping graphic objects**

Sometimes you may find that you need to group several graphic objects together so that they act as one unit (like a text box with its arrow). That way, you can move these objects or size them together in one operation.

To group objects together, you need to Ctrl-click each object to be grouped to select them all. Next, click the Group button (the second in the right-hand column of the Arrange group with the picture of two entwined squares) on the Format tab under the Drawing Tools or Picture Tools contextual tab and then click Group on its drop-down menu.

After grouping several graphic objects, whenever you click any part of the mega-object, every part is selected (and selection handles appear only around the perimeter of the combined object).

Should you later decide that you need to independently move or size objects that have been grouped together, you can ungroup them by right-clicking the grouped object and then choosing Grouping: Ungroup on the object’s shortcut menu or by clicking the Format | Group | Ungroup on the Format tab under the Drawing Tools or Picture Tools contextual tab.

**Hiding graphic objects**

The Selection and Visibility task pane enables you not only to change the layering of various graphic objects in the worksheet but also to control whether they are hidden or displayed.
The way you open the Selection and Visibility task pane depends upon the type of graphic object you’ve selected in the worksheet:

- **Charts**: click the Selection Pane button on the Format tab of the Chart Tools contextual tab or press Alt+JOAP
- **Text Boxes and Shapes**: click the Selection Pane button on the Format tab under the Drawing Tools contextual tab or press Alt+JDAP
- **Clip Art and Pictures**: click the Selection Pane button on the Format tab under the Picture Tools contextual tab or press Alt+JDAP
- **SmartArt**: click Selection Pane on the Arrange button’s drop-down palette on the Format tab of the SmartArt Tools contextual tab or press Alt+JOZAAP

After you open the Selection and Visibility task pane, you can temporarily hide any of the graphic objects listed by clicking its eye check box (to remove the eye icon). To remove the display of all the charts and graphics in the worksheet, click the Hide All button at the bottom of the Selection and Visibility task pane instead.

To redisplay a hidden graphic object, simply click its empty eye check box to put the eye icon back into it. To redisplay all graphic objects after hiding them all, click the Show All button at the bottom of the task pane.

If you hide all the charts and graphics in a worksheet by clicking the Hide All button and then close the Selection and Visibility task pane by clicking its close button, you’ll have no way of redisplaying this task pane so that you can bring back their display by clicking the Show All button. That’s because you have no graphic objects left to select in the worksheet and therefore no way to get the contextual tabs with their Selection Pane buttons to appear on the Ribbon.

In this dire case, the only way I know to get back the Selection and Visibility task pane so that you can click the Show All button is to create a dummy (pardon my French) graphic object in the worksheet (such as an arrow or oval in the Shapes group on the Insert tab) and then click the Selection Pane button on the Format tab of its Drawing Tools contextual tab. With the Selection and Visibility task pane open, click the Show All button to bring back the display of all the charts and graphics you want to keep and get rid of the still-selected dummy graphic object by pressing the Delete key (whew, that was a close one!).

---

**WARNING!**

**Tip**
**Printing Just the Charts**

Sometimes, you may want to print only a particular chart embedded in the worksheet (independent of the worksheet data it represents or any of the other stuff you’ve added). To do this, first open the Selection and Visibility task pane (as described in the preceding section) and make sure that any hidden charts are displayed in the worksheet by putting the eye icon back in their check boxes.

Next, click the chart to select it in the worksheet and then click Office Button | Print or press Ctrl+P to open the Print dialog box where you see that the Selected Chart option button under Print What is selected. By default, Excel prints the chart at full size on the page. This may mean that all of the chart cannot be printed on a single page — be sure to click the Preview button to make sure that your entire chart fits on one page.

If you find in Print Preview that you need to change the printed chart size or the orientation of the printing (or both), click the Page Setup button in the Print Preview window. To change the orientation of the printing (or the paper size), click the Page tab in the Page Setup dialog box and change these options. To change the print quality or print a color chart in black and white, click the Chart tab and change these options. When everything looks good in the Print Preview window, start printing the chart by clicking the Print button.
Chapter 11

Getting on the Data List

In This Chapter
► Setting up a data list in Excel
► Entering and editing records in the data list
► Sorting records in the data list
► Filtering records in the data list
► Importing external data into the worksheet

The purpose of all the worksheet tables that I discuss elsewhere in this book has been to perform essential calculations (such as to sum monthly or quarterly sales figures) and then present the information in an understandable form. But you can create another kind of worksheet table in Excel: a data list (or less accurately and more colloquially known as a database). The purpose of a data list is not so much to calculate new values but rather to store lots and lots of information in a consistent manner. For example, you can create a data list that contains the names and addresses of all your clients, or you can create a list that contains all the essential facts about your employees.

Creating a Data List

Creating a new data list in a worksheet is much like creating a worksheet table except that it has only column headings and no row headings. To set up a new data list, follow these steps:

1. Click the blank cell where you want to start the new data list and then enter the column headings (technically known as field names in database parlance) that identify the different kinds of items you need to keep track of (such as First Name, Last Name, Street, City, State, and so on) in the columns to the right.

After creating the fields of the data list by entering their headings, you’re ready to enter the first row of data.
2. Make the first entries in the appropriate columns of the row immediately following the one containing the field names.

These entries in the first row beneath the one with the field names constitute the first record of the data list.

3. Click the Format as Table button in the Styles group of Ribbon’s Home tab and then click a thumbnail of one of the table styles in the drop-down gallery.

Excel puts a marquee around all the cells in the new data list including the top row of field names. As soon as you click a table style in the drop-down gallery, the Format As Table dialog box appears listing the address of the cell range enclosed in the marquee in the Where Is the Data for Your Table text box.

4. Click the My Table Has Headers check box to select it.

5. Click the OK button to close Format As Table dialog box.

Excel formats your new data list in the selected table format and adds filter (drop-down buttons) to each of the field names in the top row (see Figure 11-1).

---

Figure 11-1: Creating a new data list by formatting the field names and the first record as a table.
Adding records to a data list

After creating the field names and one record of the data list and formatting them as a table, you’re ready to start entering the rest of its data as records in subsequent rows of the list. The most direct way to do this is to press the Tab key when the cell cursor is in the last cell of the first record. Doing this causes Excel to add an extra row to the data list where you can enter the appropriate information for the next record.

When doing data entry directly in a data list table, press the Tab key to proceed to the next field in the new record rather than the ← key. That way, when you complete the entry in the last field of the record, you automatically extend the data list and add a new record and position the cell cursor in the first field of that record — if you press ← to complete the entry, Excel simply moves the cell cursor to the next cell outside of the data list table.

Adding the Form button to the Quick Access toolbar

Instead of entering the records of a data list directly in the table, you can use Excel’s data form to make the entries. The only problem with using the data form is that the command to display the form in a worksheet with a data list is not part of the Ribbon commands. You can access the data form only by adding its command button to the Quick Access toolbar. To do this, you must follow these steps:

1. Click Office Button | Excel Options | Customize or press Alt+FIC.

The Form command button you want to add is only available when you click the Commands Not in the Ribbon option on the Choose Commands From drop-down list.

Calculated field entries

When you want Excel to calculate the entries for a particular field by formula, you need to enter that formula in the correct field in the first record of the data list. In the sample Employee Data list, for example, the Years of Service field in cell I2 of the first record shown in Figure 11-1 is calculated by the formula =YEAR(TODAY())-YEAR(H2). Cell H2 contains the date of hire that this formula uses to compute the number of years that an employee has worked. Excel then inserts the result of this calculation into the cell as the field entry.
2. Click the Commands Not in the Ribbon option near the bottom of the Choose Commands From drop-down list.

3. Click Form in the Choose Commands From list box and then click the Add button.

Excel adds the Form button to the very end of the Quick Access toolbar. If you so desire, you can click the Move Up and Move Down buttons to reposition the Form button on this toolbar.

4. Click OK to close the Excel Options dialog box and return to the worksheet with the data list.

Adding records to a data list using the data form

The first time you click the custom Form button you added to the Quick Access toolbar, Excel analyzes the row of field names and entries for the first record and creates a data form. This data form lists the field names down the left side of the form with the entries for the first record in the appropriate text boxes next to them. In Figure 11-2, you can see the data form for the new Little Bo Peep Pet Detectives clients’ database; it looks kind of like a customized dialog box.

The data form Excel creates includes the entries you made in the first record. The data form also contains a series of buttons (on the right side) that you use to add, delete, or find specific records in the database. Right above the first button (New), the data form lists the number of the record you’re looking at followed by the total number of records (1 of 1 when you first create the data form).

All the formatting that you assign to the particular entries in the first record is automatically applied to those fields in subsequent records you enter and is used in the data form. For example, if your data list contains a telephone field, you only need to enter the ten digits of the phone number in the Telephone field of the data form if the initial telephone number entry is
formatted in the first record with the Special Phone Number format. (See Chapter 3 for details on sorting number formats.) That way, Excel takes a new entry in the Telephone file such as 3075550045, for example, and automatically formats it so that it appears as (307) 555-0045 in the appropriate cell of the data list itself.

The process for adding records to a data list with the data form is simple. When you click the New button, Excel displays a blank data form (marked New Record at the right side of the data form), which you get to fill in.

After you enter the information for the first field, press the Tab key to advance to the next field in the record.

Whoa! Don’t press the Enter key to advance to the next field in a record. If you do, you’ll insert the new, incomplete record into the database.

Continue entering information for each field and pressing Tab to go to the next field in the database.

- If you notice that you’ve made an error and want to edit an entry in a field you already passed, press Shift+Tab to return to that field.
- To replace the entry, just start typing.
- To edit some of the characters in the field, press → or click the I-beam pointer in the entry to locate the insertion point; then edit the entry from there.

When entering information in a particular field, you can copy the entry made in that field from the previous record by pressing Ctrl-’ (apostrophe). Press Ctrl-’, for example, to carry forward the same entry in the State field of each new record when entering a series of records for people who all live in the same state.

When entering dates in a date field, use a consistent date format that Excel knows. (For example, enter something like 7/21/98.) When entering zip codes that sometimes use leading zeros that you don’t want to disappear from the entry (such as zip code 00102), format the first field entry with the Special Zip Code number format (refer to Chapter 3 for details on sorting number formats). In the case of other numbers that use leading zeros, you can put an ’ (apostrophe) before the first 0. The apostrophe tells Excel to treat the number like a text label but doesn’t show up in the database itself. (The only place you can see the apostrophe is on the Formula bar when the cell cursor’s in the cell with the numeric entry.)
Press the ↓ key when you’ve entered all the information for the new record. Or, instead of the ↓ key, you can press Enter or click the New button (see Figure 11-2). Excel inserts the new record as the last record in the database in the worksheet and displays a new blank data form in which you can enter the next record (see Figure 11-3).

When you finish adding records to the database, press the Esc key or click the Close button at the bottom of the dialog box to close the data form.

**Editing records with the data form**

After the database is under way and you’re caught up with entering new records, you can start using the data form to perform routine maintenance on the database. For example, you can use the data form to locate a record you want to change and then make the edits to the particular fields. You can also use the data form to find a specific record you want to remove and then delete it from the database.

- Locate the record you want to edit in the database by bringing up its data form. See the following two sections “Moving through the records in the data form” and “Finding records with the data form” and Table 11-1 for hints on locating records.
To edit the fields of the current record, move to that field by pressing Tab or Shift+Tab and replace the entry by typing a new one.

Alternatively, press ← or → or click the l-beam cursor to reposition the insertion point, and then make your edits.

To clear a field entirely, select it and then press the Delete key.

To delete the entire record from the database, click the Delete button in the data form. Excel displays an alert box with the following dire warning:

```
Displayed record will be permanently deleted
```

To go ahead and get rid of the record displayed in the data form, click OK. To play it safe and keep the record intact, click the Cancel button.

Please keep in mind that you cannot use the Undo feature to bring back a record you removed with the Delete button! Excel is definitely not kidding when it warns permanently deleted. As a precaution, always save a back-up version of the worksheet with the database before you start removing old records.

**Moving through the records in the data form**

In the data form, you can use the scroll bar to the right of the list of field names or various keystrokes (both summarized in Table 11-1) to move through the records in the database until you find the one you want to edit or delete.

- **To move to the data form for the next record in the data list:** Press ↓, press Enter, or click the down scroll arrow at the bottom of the scroll bar.

- **To move to the data form for the previous record in the data list:** Press ↑, press Shift+Enter, or click the up scroll arrow at the top of the scroll bar.

- **To move to the data form for the first record in the data list:** Press Ctrl+↑, press Ctrl+PgUp, or drag the scroll box to the very top of the scroll bar.

- **To move to a new data form immediately following the last record in the database:** Press Ctrl+↓, press Ctrl+PgDn, or drag the scroll box to the very bottom of the scroll bar.
### Table 11-1 Ways to Get to a Particular Record

<table>
<thead>
<tr>
<th>Keystrokes or Scroll Bar Technique</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Press ↓ or Enter or click the down scroll arrow or the Find Next button</td>
<td>Moves to the next record in the data list and leaves the same field selected</td>
</tr>
<tr>
<td>Press ↑ or Shift+Enter or click the up scroll arrow or the Find Prev button</td>
<td>Moves to the previous record in the data list and leaves the same field selected</td>
</tr>
<tr>
<td>Press PgDn</td>
<td>Moves forward ten records in the data list</td>
</tr>
<tr>
<td>Press PgUp</td>
<td>Moves backward ten records in the data list</td>
</tr>
<tr>
<td>Press Ctrl+↑ or Ctrl+PgUp or drag the scroll box to the top of the scroll bar</td>
<td>Moves to the first record in the data list</td>
</tr>
<tr>
<td>Drag the scroll box to almost the bottom of the scroll bar</td>
<td>Moves to the last record in the data list</td>
</tr>
</tbody>
</table>

**Finding records with the data form**

In a really large data list, trying to find a particular record by moving from record to record — or even moving ten records at a time with the scroll bar — can take all day. Rather than waste time trying to manually search for a record, you can use the Criteria button in the data form to look it up.

When you click the Criteria button, Excel clears all the field entries in the data form (and replaces the record number with the word *Criteria*) so that you can enter the criteria to search for in the blank text boxes.

For example, suppose that you need to edit Sherry Caufield’s profit sharing status. Unfortunately, her paperwork doesn’t include her ID number. All you know is that she works in the Boston office and spells her last name with a *C* instead of a *K*.

To find her record, you can at least use the information you have to narrow down the search to all the records where the last name begins with the letter *C* and the Location field contains *Boston*. To limit your search in this way, open the data form for the client database, click the Criteria button, and then type the following in the text box for the Last Name field:

```
C*
```
Also enter the following in the text box for the Location field (see Figure 11-4):

Boston

When you enter search criteria for records in the blank text boxes of the data form, you can use the ? (for single) and * (for multiple) wildcard characters.

Now click the Find Next button. Excel displays in the data form the first record in the database where the last name begins with the letter C and the Status field contains Active. As shown in Figure 11-5, the first record in this database that meets these criteria is for William Cobb. To press on and find Sherry’s record, click the Find Next button again. Sherry Caufield’s record shows up in Figure 11-6. Having located Caufield’s record, you can then edit her profit sharing status from No to Yes in the text box for the Profit Sharing field. When you click the Close button, Excel records her new Yes profit sharing status in the data list.
When you use the Criteria button in the data form to find records, you can include the following operators in the search criteria you enter to locate a specific record in the database:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Not equal to</td>
</tr>
</tbody>
</table>

For example, to display only those records where a client’s total due is greater than or equal to $50,000, enter >=50000 in the text box for the Total Due field and then click the Find Next button.

When specifying search criteria that fit a number of records, you may have to click the Find Next or Find Prev button several times to locate the record you want. If no record fits the search criteria you enter, the computer beeps at you when you click these buttons.

To change the search criteria, first clear the data form by clicking the Criteria button again and then clicking the Clear button. Then select the appropriate text boxes and clear out the old criteria before you enter the new. (You can just replace the criteria if you’re using the same fields.)

To switch back to the current record without using the search criteria you enter, click the Form button. (This button replaces the Criteria button as soon as you click the Criteria button.)
**Sorting Records in a Data List**

Every data list you put together in Excel will have some kind of preferred order for maintaining and viewing the records. Depending on the list, you may want to see the records in alphabetical order by last name. In the case of a database of clients, you may want to see the records arranged alphabetically by company name. In the case of the Employee Data list, the preferred order is in numerical order by the ID number assigned to each employee when he or she is hired.

When you initially enter records for a new data list, you no doubt enter them either in the preferred order or the order in which you get ahold of their records. However you start out, as you will soon discover, you don’t have the option of adding subsequent records in that preferred order. Whenever you add a new record, Excel tacks that record onto the bottom of the database by adding a new row.

Suppose you originally enter all the records in a client data list in alphabetical order by company (from *Acme Pet Supplies* to *Zastrow and Sons*), and then you add the record for a new client: *Pammy’s Pasta Palace*. Excel puts the new record at the bottom of the barrel — in the last row right after *Zastrow and Sons* — instead of inserting it in its proper position, which is somewhere after *Acme Pet Supplies* but definitely well ahead of Zastrow and his wonderful boys!

And this isn’t the only problem you can have with the original record order. Even if the records in the data list remain fairly stable, the preferred order merely represents the order you use *most* of the time. But what about those times when you need to see the records in another, special order?

---

**Up and down the ascending and descending sort orders**

When you use the ascending sort order on a field in the data list that contains many different kinds of entries, Excel places numbers (from smallest to largest) before text entries (in alphabetical order), followed by any logical values (FALSE and TRUE), error values, and finally, blank cells. When you use the descending sort order, Excel arranges the different entries in reverse: numbers are still first, arranged from largest to smallest; text entries go from Z to A; and the TRUE logical value precedes the FALSE logical value.
For example, if you usually work with a client data list in numerical order by case number, you might instead need to see the records in alphabetical order by the client’s last name to quickly locate a client and look up his or her balance due in a printout. When using records to generate mailing labels for a mass mailing, you want the records in zip code order. When generating a report for your account representatives that shows which clients are in whose territory, you need the records in alphabetical order by state and maybe even by city.

To have Excel correctly sort the records in a data list, you must specify which field’s values determine the new order of the records. (Such fields are technically known as the sorting keys in the parlance of the database enthusiast.) Further, you must specify what type of order you want to create using the information in these fields. Choose from two possible orders:

- **Ascending order**: Text entries are placed in alphabetical order from A to Z, values are placed in numerical order from smallest to largest, and dates placed in order from oldest to newest.
- **Descending order**: This is the reverse of alphabetical order from Z to A, numerical order largest to smallest, and dates newest to oldest.

### Sorting records on a single field

When you only need to sort the data list on one particular field (such as the Record Number, Last Name, or Company field), you simply click that field’s filter button and then click the appropriate sort option on its drop-down list:

- **Sort A to Z** or **Sort Z to A** in a text field
- **Sort Smallest to Largest** or **Sort Largest to Smallest** in a number field
- **Sort Oldest to Newest** or **Sort Newest to Oldest** in a date field

Excel then reorders all the records in the data list in accordance with the new ascending or descending order in the selected field. If you find that you’ve sorted the list in error, simply click the Undo button on the Quick Access toolbar or press Ctrl+Z right away to return the list to its order before you selected one of these sort options.

Excel 2007 shows when a field’s been used in sorting the data list by adding an up or down arrow to its filter button — an arrow pointing up indicates that the ascending sort order was used and one pointing down indicates that the descending sort order was used.
Sorting records on multiple fields

You need to use more than one field in sorting when the first field you use contains duplicate values and you want a say in how the records with duplicates are arranged. (If you don’t specify another field to sort on, Excel just puts the records in the order in which you entered them.)

The best and most common example of when you need more than one field is when sorting a large database alphabetically in last-name order. Suppose that you have a database that contains several people with the last name Smith, Jones, or Zastrow (as is the case when you work at Zastrow and Sons). If you specify the Last Name field as the only field to sort on (using the default ascending order), all the duplicate Smiths, Joneses, and Zastrows are placed in the order in which their records were originally entered. To better sort these duplicates, you can specify the First Name field as the second field to sort on (again using the default ascending order), making the second field the tie-breaker, so that Ian Smith’s record precedes that of Sandra Smith, and Vladimir Zastrow’s record comes after that of Mikhail Zastrow.

To sort records in a data list on multiple fields, follow these steps:

1. **Position the cell cursor in one of the cells in the data list table.**

2. **If the Home tab on the Ribbon is selected, click Custom Sort on the Sort & Filter button’s drop-down list (Alt+HSU). If the Data tab is selected, click the Sort command button (Alt+AS).**

   Excel selects all the records of the database (without including the first row of field names) and opens the Sort dialog box, shown in Figure 11-7.

   ![Figure 11-7: Set up to sort records alphabetically by surname or first name.](image)

3. **Click the name of the field you first want the records sorted by in the Sort By drop-down list.**

   If you want the records arranged in descending order, remember also to click the descending sort option (Z to A, Smallest to Largest, or Oldest to Newest) Order drop-down list to the right.
4. (Optional) If the first field contains duplicates and you want to specify how the records in this field are sorted, click the Add Level button to insert another sort level. Select a second field to sort on in the Then By drop-down list and select either the ascending or descending option in its Order drop-down list to its right.

5. (Optional) If necessary, repeat Step 4, adding as many additional sort levels as required.

6. Click OK or press Enter.

Excel closes the Sort dialog box and sorts the records in the data list using the sorting fields in the order of their levels in this dialog box. If you see that you sorted the database on the wrong fields or in the wrong order, click the Undo button on Quick Access toolbar or press Ctrl+Z to immediately restore the database records to their previous order.

Check out how I set up my search in the Sort dialog box in Figure 11-7. In the Bo Peep Client database, I chose the Last Name field as the first field to sort on (Sort By) and the First Name field as the second field (Then By) — the second field sorts records with duplicate entries in the first field. I also chose to sort the records in the Employee Data list in alphabetical (A to Z) order by last name and then first name. See the Employee Data list right after sorting (in Figure 11-8). Note how the Edwards — Cindy and Jack — are now arranged in the proper first name/last name alphabetical order.
Filtering the Records in a Data List

Excel’s Filter feature makes it a breeze to hide everything in a data list except the records you want to see. To filter the data list to just those records that contain a particular value, you then click the appropriate field’s filter button to display a drop-down list containing all the entries made in that field and select the one you want to use as a filter. Excel then displays only those records that contain the value you selected in that field. (All other records are temporarily hidden.)

For example, in Figure 11-9, I filtered the Employee Data List to display only those records in which the Location is either Boston or San Francisco by clicking the Location field’s filter button and then clicking the (Select All) check box to remove its check mark. I then clicked the Boston and San Francisco check boxes to add check marks to them before clicking OK. (It’s as simple as that.)

After you filter a data list so that only the records you want to work with are displayed, you can copy those records to another part of the worksheet to the right of the database (or better yet, another worksheet in the workbook). Simply select the cells, then click the Copy button on the Home tab or press Ctrl+C, move the cell cursor to the first cell where the copied records are to appear, and then press Enter. After copying the filtered records, you can then redisplay all the records in the database or apply a slightly different filter.

Sorting something besides a data list

The Sort command is not just for sorting records in the data list. You can use it to sort financial data or text headings in the spreadsheet tables you build as well. When sorting regular worksheet tables, just be sure to select all the cells with data to be sorted (and only those with the data to be sorted) before you open the Sort dialog box by clicking Custom Sort on the Sort & Filter button’s drop-down list on the Ribbon’s Home tab or the Sort button on the Data tab.

Also note that Excel automatically excludes the first row of the cell selection from the sort (on the assumption that this row is a header row containing field names that shouldn’t be included). To include the first row of the cell selection in the sort, be sure to click the My Data Has Headers check box before you click OK to begin sorting.

If you want to sort worksheet data by columns, click the Options button in the Sort dialog box. Click the Sort Left to Right option button in the Sort Options dialog box and then click OK. Now you can designate the number of the row (or rows) to sort the data on in the Sort dialog box.
If you find that filtering the data list by selecting a single value in a field drop-down list box gives you more records than you really want to contend with, you can further filter the database by selecting another value in a second field’s drop-down list. For example, suppose that you select CA as the filter value in the State field’s drop-down list and end up with hundreds of California records still displayed in the worksheet. To reduce the number of California records to a more manageable number, you could then select a value (such as San Francisco) in the City field’s drop-down list to further filter the database and reduce the records you have to work with on-screen. When you finish working with the San Francisco, California, records, you can display another set by displaying the City field’s drop-down list again and changing the filter value from San Francisco to some other city (such as Los Angeles).

When you’re ready to once again display all the records in the database, click the filtered field’s filter button (indicated by the appearance of a cone filter on its drop-down button) and then clicking the (Select All) option at the top of the drop-down list before you click OK.

Note that you can temporarily remove the filter buttons from the cells in the top row of the data list containing the field names and later redisplay them by clicking the Filter button on the Data tab or by pressing Alt+AFF.

**Using readymade number filters**

Excel contains a number filter option called Top 10. You can use this option on a number field to show only a certain number of records (like the ones with the ten highest or lowest values in that field or those in the ten highest or lowest percent in that field). To use the Top 10 option to filter a database, follow these steps:
1. Click the Filter button on the numeric field you want to filter with the Top 10 option. Then highlight Number Filters in the drop-down list and click Top 10 on its submenu.

Excel opens the Top 10 AutoFilter dialog box. By default, the Top 10 AutoFilter chooses to show the top ten items in the selected field. You can, however, change these default settings before filtering the database.

2. To show only the bottom ten records, change Top to Bottom in the leftmost pop-up list box.

3. To show more than the top or bottom ten records, enter the new value in the middle text box (that currently holds 10) or select a new value by using the spinner buttons.

4. To show those records that fall into the Top 10 or Bottom 10 (or whatever) percent, change Items to Percent in the rightmost pop-up list box.

5. Click OK or press Enter to filter the database by using your Top 10 settings.

In Figure 11-10, you can see the Employee Data list after using the Top 10 option (with all its default settings) to show only those records with salaries that are in the top ten. David Letterman would be proud!

**Figure 11-10:** The data list after using the Top 10 AutoFilter to filter out all records except for those with the 10 highest salaries.

**Using readymade date filters**

When filtering a data list by the entries in a date field, Excel makes available a variety of date filters that you can apply to the list. These readymade filters include Tomorrow, Today, Yesterday as well as Next, This, and Last Week for the Month, Quarter, and Year. In addition, Excel offers a Year to Date and All Dates in the Period filters. When you select the All Dates in the Period filter, Excel enables you to choose between Quarter 1 through 4 or any of the twelve months, January through December, as the period to use in filtering the records.
To select any of these date filters, you click the date field’s filter button, then highlight Date Filters on the drop-down list and click the appropriate date filter option on the continuation menu(s).

**Getting creative with custom filtering**

In addition to filtering a data list to records that contain a particular field entry (such as *Newark* as the City or *CA* as the State), you can create custom AutoFilters that enable you to filter the list to records that meet less-exacting criteria (such as last names starting with the letter *M*) or ranges of values (such as salaries between $25,000 and $50,000 a year).

To create a custom filter for a field, you click the field’s filter button and then highlight Text Filters, Number Filters, or Date Filters (depending upon the type of field) on the drop-down list and then click the Custom Filter option at the bottom of the continuation list. When you select the Custom Filter option, Excel displays a Custom AutoFilter dialog box, similar to the one shown in Figure 11-11.

You can also open the Custom AutoFilter dialog box by clicking the initial operator (Equals, Does Not Equal, Greater Than, and so on) on the field’s Text Filters’, Number Filters’, or Date Filters’ submenu.

**Figure 11-11:**

Use the Custom AutoFilter to display records with entries in the Salary field between $25,000 and $75,000.

In this dialog box, you first select the operator that you want to use in the first drop-down list box. (See Table 11-2 for operator names and what they locate.) Then enter the value (text or numbers) that should be met, exceeded, fallen below, or not found in the records of the database in the text box to the right.
If you only want to filter records in which a particular field entry matches, exceeds, falls below, or simply is not the same as the one you enter in the text box, you then click OK or press Enter to apply this filter to the database. However, you can use the Custom AutoFilter dialog box to filter the database to records with field entries that fall within a range of values or meet either one of two criteria.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Example</th>
<th>What It Locates in the Database</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals</td>
<td>Salary equals 35000</td>
<td>Records where the value in the Salary field is equal to $35,000</td>
</tr>
<tr>
<td>Does not equal</td>
<td>State does not equal NY</td>
<td>Records where the entry in the State field is not NY (New York)</td>
</tr>
<tr>
<td>Is greater than</td>
<td>Zip is greater than 42500</td>
<td>Records where the number in the Zip field comes after 42500</td>
</tr>
<tr>
<td>Is greater than or</td>
<td>Zip is greater than or equal to 42500</td>
<td>Records where the number in the Zip field is equal to 42500 or comes after it</td>
</tr>
<tr>
<td>equal to</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Is less than</td>
<td>Salary is less than 25000</td>
<td>Records where the value in the Salary field is less than $25,000 a year</td>
</tr>
<tr>
<td>Is less than or</td>
<td>Salary is less than or equal to 25000</td>
<td>Records where the value in the Salary field is equal to $25,000 or less than $25,000</td>
</tr>
<tr>
<td>equal to</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Begins with</td>
<td>Begins with d</td>
<td>Records with specified fields have entries that start with the letter d</td>
</tr>
<tr>
<td>Does not begin with</td>
<td>Does not begin with d</td>
<td>Records with specified fields have entries that do not start with the letter d</td>
</tr>
<tr>
<td>Ends with</td>
<td>Ends with ey</td>
<td>Records whose specified field have entries that end with the letters ey</td>
</tr>
<tr>
<td>Does not end with</td>
<td>Does not end with ey</td>
<td>Records with specified fields have entries that do not end with the letters ey</td>
</tr>
<tr>
<td>Contains</td>
<td>Contains Harvey</td>
<td>Records with specified fields have entries that contain the name Harvey</td>
</tr>
<tr>
<td>Does not contain</td>
<td>Does not contain Harvey</td>
<td>Records with specified fields have entries that don’t contain the name Harvey</td>
</tr>
</tbody>
</table>
To set up a range of values, you select the “is greater than” or “is greater than or equal to” operator for the top operator and then enter or select the lowest (or first) value in the range. Then make sure that the And option button is selected and select “is less than” or “is less than or equal to” as the bottom operator and enter the highest (or last) value in the range.

Check out Figures 11-11 and 11-12 to see how I filter the records in the Employee Data list so that only those records where Salary amounts are between $25,000 and $75,000 are displayed. As shown in Figure 11-11, you set up this range of values as the filter by first selecting “is greater than or equal to” as the operator and 25,000 as the lower value of the range. Then, with the And option button selected, you select “is less than or equal to” as the operator and 75,000 as the upper value of the range. The results of applying this filter to the Employees Data list are shown in Figure 11-12.

To set up an either/or condition in the Custom AutoFilter dialog box, you normally choose between the “equals” and “does not equal” operators (whichever is appropriate) and then enter or select the first value that must be met or must not be equaled. Then you select the Or option button and select whichever operator is appropriate and enter or select the second value that must be met or must not be equaled.

For example, if you want to filter the data list so that only records for the Accounting or Human Resources departments in the Employee Data list, you select “equals” as the first operator and then select or enter Accounting as
the first entry. Next, you click the Or option button, select “equals” as the second operator, and then select or enter Human Resources as the second entry. When you then filter the database by clicking OK or pressing Enter, Excel displays only those records with either Accounting or Human Resources as the entry in the Dept field.

**Importing External Data**

Excel 2007 makes it easy to import data into a worksheet from other database tables created with standalone database management systems such as Microsoft Office Access, a process known as making an *external data query*.

You can also use Web queries to import data directly from various Web pages containing financial and other types of statistical data that you need to work with in the Excel worksheet.

**Querying an Access database table**

To make an external data query to an Access database table, you click the From Access command button on the Ribbon’s Data tab or press Alt+AFA. Excel opens the Select Data Source dialog box where you select the name of the Access database (using an * .mdb file extension) and then click Open. The Select Table dialog box then appears from which you can select the data table that you want to import into the worksheet.

After you click the name of the Access data table and click OK, the Import Data dialog box appears. This table contains the following option buttons from which to select:

- **Table** to have the data in the Access data table imported into an Excel table in either the current or new worksheet — see Existing Worksheet and New Worksheet entries that follow
- **PivotTable Report** to have the data in the Access data table imported into a new pivot table (see Chapter 9) that you can construct with the Access data
- **PivotChart and PivotTable Report** to have the data in the Access data table imported into a new pivot table (see Chapter 9) with an embedded pivot chart that you can construct with the Access data
- **Existing Worksheet** (default) to have the data in the Access data table imported into the current worksheet starting at the current cell address listed in the text box below
- **New Worksheet** to have the data in the Access data table imported into a new sheet that’s added to the beginning of the workbook
Figure 11-13 shows you an Excel worksheet after importing the Orders data table from the sample Northwind Access database as a new data table in Excel. After importing the data, you can then use the Filter buttons attached to the various fields to sort and filter the data (as described earlier in this chapter).

Excel keeps a list of all the external data queries you make so that you can reuse them to import updated data from another database or Web page. To reuse a query, click the Existing Connections button on the Data tab (Alt+AX) to open the Existing Connections dialog box to access this list and then click the name of the query to repeat.

Databases created and maintained with Microsoft Office Access are not, of course, the only external data sources on which you can perform external data queries. To import data from other sources, you click the From Other Sources button on the Data tab or press Alt+AFO to open a drop-down menu with the following options:

- **From SQL Server** to import data from an SQL Server table
- **From Analysis Services** to import data from an SQL Server Analysis cube
- **From XML Data Import** to import data from an XML file that you open and map
Performing a New Web query

To make a Web page query, you click the From Web command button on the Data tab of the Ribbon or press Alt+AFW. Excel then opens the New Web Query dialog box containing the Home page for your computer’s default Web browser (Internet Explorer 7 in most cases). To select the Web page containing the data you want to import into Excel, you can:

- Type the URL Web address in the Address text box at the top of the Home page in the New Web Query dialog box.
- Use the Search feature offered on the Home page or its links to find the Web page containing the data you wish to import.

When you have the Web page containing the data you want to import displayed in the New Web Query dialog box, Excel indicates which tables of information you can import from the Web page into the worksheet by adding a check box with an arrowhead pointing right. To import these tables, you simply click this check box to add a check mark to it (see Figure 11-14).

After you finish checking all the tables you want to import on the page, click the Import button to close the New Web Query dialog box. Excel then opens a version of the Import Data dialog box with only the Table option button available where you can indicate where the table data is to be imported by selecting one of these two options buttons:

- **Existing Worksheet** (default) to have the data in the Access data table imported into the current worksheet starting at the current cell address listed in the text box
- **New Worksheet** to have the data in the Access data table imported into a new sheet that’s added to the beginning of the workbook

After you click OK in the Import Data dialog box, Excel closes the box and then imports all the tables of data you selected on the Web page into a new worksheet starting at cell A1 or in the existing worksheet starting at the cell whose address was entered in the text box in the Import Data dialog box.
Figure 11-15 shows the results of Web query initiated in the New Web Query dialog box shown in Figure 11-14. As you can see, Excel brings this data from the Top Performers 1-Year, 3-Year, and 5-Year tables into the new worksheet as cell ranges rather than as Excel Tables. If you then want to be able to sort or filter these imported data, you then need to select each range in turn and then use the Format as Table button on the Home tab to format them and add the requisite filter buttons (see Chapter 3 for details).

You can only make Web queries when your computer has Internet access. So, if you're using Excel on a laptop computer that can't connect to the Web at the moment, you won't be able to perform a new Web query until you are in a place where you can connect.
At your first reading of the chapter title, you might have the impression that this is just a catch-all, potpourri chapter, containing the last bits of program information that don’t fit anywhere else in the book. Actually, however, this is not the case as this chapter has a very definite theme, and that theme is how you go about extending the power of Excel.

It just so happens that add-ins, hyperlinks, and macros are three major ways to make Excel more vigorous and versatile: add-ins through the extra features they give Excel 2007; hyperlinks through links to other worksheets, Office documents; and Web pages and macros through complex automated command sequences that you can play back whenever needed.

**Using Add-Ins in Excel 2007**

Add-in programs are small modules that extend the power of Excel by giving you access to a wide array of features and calculating functions not otherwise offered in the program. There are three different types of add-ins:

- ✔ Built-in add-ins available when you install Excel 2007
- ✔ Add-ins that you can download for Excel 2007 from Microsoft’s Office Online Web site (http://www.office.microsoft.com)
- ✔ Add-ins developed by third-party vendors for Excel 2007 that often must be purchased
When you first install Excel 2007, the built-in add-in programs included with Excel are not loaded and therefore are not yet ready to use. To load any or all of these built-in add-in programs, you follow these steps:

1. **Click the Office Button, then click Excel Options or press Alt+FI to open the Excel Options dialog box and then click the Add-Ins tab.**  
   The Add-Ins tab lists all the name, location, and type of the add-ins to which you have access.

2. **Click the Go button while Excel Add-Ins is selected in the Manage drop-down list box.**  
   Excel opens the Add-Ins dialog box (similar to the one shown in Figure 12-1) showing all the names of the built-in add-in programs you can load.

3. **Click the check boxes for each add-in program that you want loaded in the Add-Ins Available list box.**  
   Click the name of the add-in in the Add-Ins Available list box to display a brief description of its function at the bottom of this dialog box.

4. **Click the OK button to close the Add-Ins dialog box.**  
   An alert dialog box appears, asking you if you want to install each selected add-in.

5. **Click the OK button in each alert dialog box to install its add-in.**

![Figure 12-1: Activating built-in add-ins in the Add-Ins dialog box.](image)

After activating add-ins in this manner, Excel automatically places command buttons for the add-ins in either an Analysis group on the Ribbon’s Data tab or in a Solutions group on the Formulas tab, depending upon the type of add-in. For example, when you activate the Analysis ToolPak or Solver Add-in, Excel places their command buttons in the Analysis group on the Data tab. When you activate the Conditional Sum Wizard, Euro Currency Tools, or Lookup Wizard add-ins, Excel places their command buttons in the Solutions group on the Formulas tab.
If you end up never using a particular add-in you’ve loaded onto the Add-Ins tab, you can unload it (and thereby free up some computer memory) by following the previously outlined procedure to open the Add-Ins dialog box and then clicking the name of the add-in to remove the check mark from its check box. Then click OK.

**Adding Hyperlinks to a Worksheet**

Hyperlinks automate Excel worksheets by making the opening of other Office documents and Excel workbooks and worksheets just a mouse click away. It doesn’t matter whether these documents are located on your hard drive, a server on your LAN (Local Area Network), or Web pages on the Internet or a company’s intranet. You can also set up e-mail hyperlinks that automatically address messages to co-workers with whom you routinely correspond, and you can attach Excel workbooks or other types of Office files to these messages.

The hyperlinks that you add to your Excel worksheets can be of the following types:

- Text entries in cells (known as hypertext normally formatted as underlined blue text)
- Clip art and imported graphics from files you’ve inserted into the worksheet (see Chapter 10)
- Graphics you’ve created from the Shapes drop-down gallery on the Insert tab (see also Chapter 10) — in effect, turning the graphic images into buttons

When creating a text or graphic hyperlink, you can make a link to another Excel workbook or other type of Office file, a Web site address (using the URL address — you know, that monstrosity that begins with http://), a named location in the same workbook, or even a person’s e-mail address. The named location can be a cell reference or named cell range (see Chapter 6 for details on naming cell ranges) in a particular worksheet.

To add the hyperlink to the text entry made in the current cell or a selected graphic object (see Chapter 10) in your worksheet, follow these steps:

1. **Click the Hyperlink button on the Ribbon’s Insert tab or press Alt+NI, or simply press Ctrl+K.**

   Excel opens the Insert Hyperlink dialog box (similar to the one shown in Figure 12-2) in which you indicate the file, the Web address (URL), or the named location in the workbook.
2a. To have the hyperlink open another document, a Web page on a company’s intranet, or a Web site on the Internet, click the Existing File or Web Page button if it isn’t already selected; then enter the file’s directory path or Web page’s URL in the Address text box.

If the document you want to link to is located on your hard drive or a hard drive that is mapped on your computer, click the Look In dropdown button and select its folder and then select the file in the list box below. If you’ve recently opened the document you want to link to, you can click the Recent Files button and then select it from the list box.

If the document you want to link to is located on a Web site and you know its Web address (the www.dummies.com/excel2k.htm–like thing), you can type it into the Address text box. If you recently browsed the Web page you want to link to, you can click the Browsed Pages button and then select the address of the page from the list box.

2b. To have the hyperlink move the cell cursor to another cell or cell range in the same workbook, click the Place in This Document button. Next, type in the address of the cell or cell range in the Type the Cell Reference text box or select the desired sheet name or range name from the Or Select a Place in This Document list box (shown in Figure 12-3).
2c. To open a new e-mail message addressed to a particular recipient, click the E-mail Address button and then enter the recipient’s e-mail address in the E-mail Address text box (as shown in Figure 12-4).

Figure 12-4: Linking to an e-mail address page in the Insert Hyperlink dialog box.

In most cases, your e-mail program is Windows Mail on Windows Vista or Outlook Express on Windows XP or Microsoft Outlook 2007 if you purchased a version of Microsoft Office 2007 that includes this personal information manager plus e-mail program.

As soon as you begin typing the e-mail address in the E-mail Address text box, Excel inserts the text \texttt{mailto:} in front of whatever you’ve typed. (\texttt{mailto:} is the HTML tag that tells Excel to open your e-mail program when you click the hyperlink.)

If you want the hyperlink to add the subject of the e-mail message when it opens a new message in your e-mail program, enter this text in the Subject text box.

If the recipient’s address is already displayed in the Recently Used E-mail Addresses list box, you can enter it into the E-mail Address text box simply by clicking that address in this list box.

3. (Optional) To change the hyperlink text that appears in the cell of the worksheet (underlined and in blue) or add text if the cell is blank, type the desired label in the Text to Display text box.

4. (Optional) To add a ScreenTip to the hyperlink that appears when you position the mouse pointer over the hyperlink, click the ScreenTip button, type in the text that you want to appear next to the mouse pointer in the ScreenTip Text box, and click OK.

5. Click OK to close the Insert Hyperlink dialog box.

After you create a hyperlink in a worksheet, you can follow it to whatever destination you associated with the hyperlink. To follow a hyperlink, position the mouse pointer over the underlined blue text (if you assigned the hyperlink to text in a cell) or over the graphic image (if you assigned the hyperlink
to a graphic inserted in the worksheet). When the mouse pointer changes to a hand with the index finger pointing upward, click the hypertext or graphic image, and Excel makes the jump to the designated external document, Web page, cell within the workbook, or e-mail message.

After you follow a hypertext link to its destination, the color of its text changes from the traditional blue to a dark shade of purple (without affecting its underlining). This color change indicates that the hyperlink has been used. (Note, however, that graphic hyperlinks do not show any change in color after you follow them.) Also, Excel automatically restores this underlined text to its original (unfollowed) blue color the next time that you open the workbook file.

If you need to edit a hyperlink attached to worksheet cell or graphic object, you must be careful that, when getting Excel into Edit mode so that you can change the text, you don’t inadvertently follow the link. When dealing with hypertext in a cell, you must click and hold down the mouse button a few seconds to select the cell (if you click and release immediately, you follow the link). When dealing with a graphic object you’re best off right-clicking the image and then clicking the appropriate editing command (Edit Hyperlink or Remove Hyperlink) on its shortcut menu.

### Automating Commands with Macros

Macros automate the Excel worksheet by enabling you to record complex command sequences. By using macros that perform routine tasks, you not only speed up the procedure considerably (because Excel can play back your keystrokes and mouse actions much faster than you can perform them manually), but you are also assured that each step in the task is carried out the same way each and every time you perform the task.

Excel 2007’s macro recorder records all the commands and keystrokes that you make in a language called Visual Basic for Applications (VBA), which is a special version of the BASIC programming language developed and refined by the good folks at Microsoft for use with all their Office application programs. You can then later learn how to use Excel’s Visual Basic Editor to display and make changes to the macro’s VBA code.

### Recording new macros

The Status bar at the bottom of the Excel 2007 program window contains a Record Macro button (the red dot to the immediate left of the Ready status indicator) that you can click to turn on the macro recorder, and the View tab contains a Macros command button with a drop-down menu containing a Record Macro option.
In addition, Excel 2007 enables you to add an optional Developer tab to the Ribbon that contains its own Record Macro command button (among other command buttons that are very useful when doing more advanced work with macros). To add the Developer tab to the Excel 2007 Ribbon, follow these two steps:

1. **Click Office Button | Excel Options or press Alt+FI to open the Excel Options dialog box.**
   
2. **Click the Show Developer tab in the Ribbon check box on the Personalize tab to put a check mark in it and then click OK.**

When you turn on the macro recorder either by clicking the Record Macro button on the Status bar, clicking the Record Macro option on the Macros button’s drop-down menu (Alt+WMR), or clicking the Record Macro button on the Developer tab (Alt+LR), the macro recorder records all your actions in the active worksheet or chart sheet as you make them.

Note that the macro recorder doesn’t record the keystrokes or mouse actions that you take to accomplish an action — only the VBA code required to perform the action itself. This means that mistakes that you make while taking an action that you rectify won’t be recorded as part of the macro; for example, if you make a typing error and then edit it while the macro recorder is on, only the corrected entry shows up in the macro without the original mistakes and steps taken to remedy them.

The macros that you create with the macro recorder can be stored either as part of the current workbook, in a new workbook, or in a special, globally available Personal Macro Workbook named `PERSONAL.XLSB` that’s stored in a folder called `XLSTART` on your hard drive. When you record a macro as part of your Personal Macro Workbook, you can run that macro from any workbook that you have open (this is because the `PERSONAL.XLSB` workbook is secretly opened whenever you launch Excel, and although it remains hidden, its macros are always available). When you record macros as part of the current workbook or a new workbook, you can run those macros only when the workbook in which they were recorded is open in Excel.

When you create a macro with the macro recorder, you decide not only the workbook in which to store the macro but also what name and shortcut keystrokes to assign to the macro that you are creating. When assigning a name for your macro, use the same guidelines that you use when you assign a standard range name to a cell range in your worksheet. When assigning a shortcut keystroke to run the macro, you can assign

- The Ctrl key plus a letter from A to Z, as in Ctrl+Q
- Ctrl+Shift and a letter from A to Z, as in Ctrl+Shift+Q

You can’t, however, assign the Ctrl key plus a punctuation or number key (such as Ctrl+1 or Ctrl+?) to your macro.
To see how easy it is to create a macro with the macro recorder, follow these steps for creating a macro that enters the Company Name in 12-point, bold type and centers the company name across rows A through E with the Merge and Center feature:

1. **Open the Excel workbook that contains the worksheet data or chart you want your macro to work with.**

   If you’re building a macro that adds new data to a worksheet (as in this example), open a worksheet with plenty of blank cells in which to add the data. If you’re building a macro that needs to be in a particular cell when its steps are played back, put the cell pointer in that cell.

2. **Click the Record Macro button on the Status bar.**

   The Record Macro dialog box opens, similar to the one shown in Figure 12-5, where you enter the macro name, define any keystroke shortcut, select the workbook in which to store the macro, and enter a description of the macro’s function.

3. **Replace the Macro1 temporary macro name by entering your name for the macro in the Macro Name text box.**

   Remember that when naming a macro, you must not use spaces in the macro name and it must begin with a letter and not some number or punctuation symbol. For this example macro, you replace Macro1 in the Macro Name text box with the name Company_name.

   Next, you can enter a letter between A and Z that acts like a shortcut key for running the macro when you press Ctrl followed by that letter key. Just remember that Excel has already assigned a number of Ctrl+letter keystroke shortcuts for doing common tasks, such as Ctrl+C for copying an item to the Clipboard and Ctrl+V for pasting an item from the Clipboard into the worksheet (see the Cheat Sheet at the beginning of this book for a complete list). If you assign the same keystrokes to the macro that you’re building, your macro’s shortcut keys override and, therefore, disable Excel’s ready-made shortcut keystrokes.
4. (Optional) Click the Shortcut key text box and then enter the letter of the alphabet that you want to assign to the macro.

For this example macro, press Shift+C to assign Ctrl+Shift+C as the shortcut keystroke (so as not to disable the ready-made Ctrl+C shortcut).

Next, you need to decide where to save the new macro that you’re building. Select Personal Macro Workbook on the Store Macro In drop-down list box to be able to run the macro anytime you like. Select This Workbook (the default) when you need to run the macro only when the current workbook is open. Select New Workbook if you want to open a new workbook in which to record and save the new macro.

5. Click the Personal Macro Workbook, New Workbook, or This Workbook option on the Store Macro In drop-down list to indicate where to store the new macro.

For this example macro, select the Personal Macro Workbook so that you can use it to enter the company name in any Excel workbook that you create or edit.

Next, you should document the purpose and functioning of your macro in the Description list box. Although this step is purely optional, it is a good idea to get in the habit of recording this information every time you build a new macro so that you and your coworkers can always know what to expect from the macro when they run it.

6. (Optional) Click the Description list box and then insert a brief description of the macro’s purpose in front of the information indicating the date and who recorded the macro.

Now you’re ready to close the Record Macro dialog box and start recording your macro.

7. Click OK to close the Record Macro dialog box.

The Record Macro dialog box closes and the circular red Record Macro button on the Status bar and the Developer tab becomes a square blue Stop Recording button.

On the Macros button’s drop-down menu on the Ribbon’s View tab and Code group on the Developer tab, you find a Use Relative References option. You click this drop-down menu item or command button when you want the macro recorder to record the macro relative to the position of the current cell. For this example macro that enters the company name and formats it in the worksheet, you definitely need to click the Relative Reference button before you start recording commands. Otherwise, you can use the macro only to enter the company name starting in cell A1 of a worksheet.
8. (Optional) Click the Use Relative Reference option on the Macros button’s drop-down menu on the View tab or click the User Relative Reference button on the Developer tab if you want to be able to playback the macro anywhere in the worksheet.

9. Select the cells, enter the data, and choose the Excel commands required to perform the tasks that you want recorded just as you normally would in creating or editing the current worksheet, using either the keyboard or the mouse or a combination of the two.

For the example macro, all you do is type the company name and click the Enter button on the Formula bar to complete the entry in the current cell. Next, click the Bold button and then click 12 on the Font Size drop-down list in the Font group on the Home tab. Finally, drag through cells A1:E1 to select this range and then click the Merge and Center command button, again on the Home tab.

After you finish taking all the actions in Excel that you want recorded, you’re ready to shut off the macro recorder.

10. Click the Stop Recording button on the Status bar or Developer tab on the Ribbon.

The square blue Stop Recording button on the Status bar and the Developer tab change back into circular red Record Macro buttons, letting you know that the macro recorder is now turned off and no further actions will be recorded.

**Running macros**

After you record a macro, you can run it by clicking the View Macros option on the Macros button’s drop-down menu on the View tab, the Macros button on the Developer tab of the Ribbon, or by pressing Alt+F8 to open the Macro dialog box (see Figure 12-6). As this figure shows, Excel lists the names of all the macros in the current workbook and in your Personal Macro Workbook (provided you’ve created one) in the Macro Name list box. Simply click the name of the macro that you want to run and then click the Run button or press Enter to play back all its commands.

If you assigned a shortcut keystroke to the macro, you don’t have to bother opening the Macro dialog box to run the macro: Simply press Ctrl plus the letter key or Ctrl+Shift plus the letter key that you assigned and Excel immediately plays back all of the commands that you recorded.
The reason that Macros you record in the Personal Workbook are always available in any Excel workbook is because the PERSONAL.XLSB workbook is also open — you just don’t know it because Excel hides this workbook immediately after opening it each time you launch the program. As a result, if you try to edit or delete a macro in the Macro dialog box saved in the Personal Workbook, Excel displays an alert dialog box telling you that you can’t edit a hidden workbook.

To unhide the Personal Workbook, first clear the alert dialog box and close the Macro dialog box; then click the Unhide button on the View tab (Alt+WU) and click the OK button in the Unhide dialog box while PERSONAL.XLSB is selected. Excel then makes the Personal Workbook active, and you can open the Macro dialog box and edit or delete macros you’ve saved in it. After you finish, close the Macro dialog box and then click the Hide button on the View tab (or press Alt+WH) to hide the Personal Workbook once more.

**Assigning macros to the Quick Access toolbar**

If you prefer, instead of running a macro by selecting it in the Macro dialog box or by pressing shortcut keys you assign to it, you can assign it to a custom button on the Quick Access toolbar and then run it by clicking that custom button.

To assign a macro to a custom button on the Quick Access toolbar, follow these steps:
1. Click Microsoft Office Button | Excel Options | Customization or press Alt+FIN to open the Customization tab of the Excel Options dialog box.

2. Click Macros in the Choose Commands From drop-down list box.

Excel lists the names of all the macros created in the current workbook and saved in the PERSONAL.XLSB workbook in the Choose Commands From list box.

3. Click the name of the macro to add to a custom button on the Quick Access toolbar in the Choose Commands From list box and then click the Add button.

4. Click OK to close the Excel Options dialog box.

After you close the Excel Options dialog box, a custom button sporting a generic macro icon (picturing a standard command flowchart icon) appears on the Quick Access toolbar. To see the name of the macro assigned to this custom macro button as a ScreenTip, position the mouse pointer over the button. To run the macro, click the button.
Part VI

The Part of Tens

The 5th Wave

By Rich Tennant

“My girlfriend ran a spreadsheet of my life, and generated this chart. My best hope is that she’ll change her major from ‘Computer Sciences’ to ‘Rehabilitative Services’.”
Finally, you come to the fun part of this book where the chapters all consist of lists with the top ten Excel tips on this, that, and everything in between. In homage to David Letterman (Indiana’s favorite son), you’ll find chapters on the top ten new features in Excel 2007 and the top ten beginner basics. And, in homage to Cecil B. deMille, Moses, and a much higher power, I’ve even included a chapter with the Ten Commandments of Excel 2007 that, although not written in stone, when followed faithfully are guaranteed to give you heavenly results.
If you’re looking for a quick rundown on what’s new and what’s cool in Excel 2007, look no further! Here it is — my official Top Ten Features list. Just a cursory glance down the list tells you that the thrust of the features is graphics, graphics, graphics!

And just in case you’re interested in more than just a brief feature description, I’ve included a cross-reference to any place in this book where I cover the feature in more detail.

10. **Conditional Formatting:** Yes, I know conditional formatting is technically not a new Excel feature, having existed in many of the previous versions. However, the conditional formatting in Excel 2007 is definitely not your mother’s conditional formatting. For, in addition to giving you the ability to define formatting when the values in cells meet certain conditions, you can now instantly apply one of many different Data Bars, Color Scales, and Icon Sets to the cell selection merely by clicking the set’s thumbnail in their respective pop-up palettes. When you apply a set of Data Bars to a cell range, the length of each bar in the cell represents its value relative to the others. When you apply a set of Color Scales, each shade of color in the cell represents its value relative to the others. And when you apply one of the Icon Sets, each icon in the cell represents its value relative to the others. See Color Plate 1 for a full-color example and Chapter 3 for details on setting up conditional formatting in your spreadsheets.

9. **Cell Styles:** Comparing the six measly and bland cell styles offered in previous versions of Excel to the more than 40 colorful readymade styles offered in Excel 2007, I’m here to tell you that in Excel 2007 you finally have cell styles. Moreover, these are styles you can preview in the worksheet with Live Preview (see Number 1 that follows) to see how they look on the data before you apply them and which you apply to the cell selection by quickly and easily clicking its thumbnail in Cells Styles gallery (see Number 3 in the list). Take a gander at Color Plate 12 to see the Cell Styles gallery and Chapter 3 for info on applying readymade styles and creating some of your own.
8. **Formatting and Editing from the Home tab:** The Home tab of the new Excel Ribbon (see Number 2 that follows) literally brings home all the commonly-used formatting and editing features. Gone are the days when you have to fish for the right button on some long, drawn-out toolbar or on some partially-deployed pull-down menu. Now all you have to do is find the group that holds the command button you need and click it — what could be easier! See Chapter 3 for more on using the formatting command buttons in the Font, Alignment, Number, and Styles groups on the Home tab and Chapter 4 for more on using the editing commands in the Clipboard, Cells, and Editing groups on this tab.

7. **Charts right from the Insert tab:** Charts have been a part of Excel since I first wrote this book for Excel 4 back in 1993 but it feels like not until Excel 2007 did they come into their own. Excel 2007 retires the Chart Wizard and in its place offers you direct access to all the major types of charts on the Ribbon’s Insert tab. Simply select the data to be charted, click the command button for the chart type on the Insert tab and then select the style you want for that chart type. And with a little help from the many command buttons and galleries on the Design, Layout, and Format tabs on its Chart Tools contextual tab, you have a really professional-looking chart ready for printing! See Chapter 10 for details on creating charts in Excel 2007.

6. **Format As Table:** This brand new feature is a real keeper. By formatting a table of data with one of the many table styles available on the Table Styles drop-down gallery, you’re assured that all new entries made to the table are going to be formatted in the same manner as others in similar positions in the table. Better yet, all new entries to the table are automatically considered as part of the table when it comes to formatting, sorting, and filtering. By the way, filtering the table’s data is made real easy by the automatic addition of filter buttons to the top row of column headings. See Chapter 3 for more on formatting a range as a table and Chapter 11 for more on sorting and filtering its data.

5. **The Zoom Slider:** So, how’d we ever get along without the new Zoom slider that’s now always there to use on the Excel 2007 Status bar? Instead of having to select a new magnification percentage for the worksheet from a drop-down menu on some obscure Zoom tool (something you can still do with the Zoom button on the View tab, if you really want to), you can zoom in and out on the spreadsheet in the blink of eye (actually faster) simply by dragging the Zoom slider right or left. See Chapter 5 for more on using the nifty, new Zoom slider to keep all your spreadsheet data clearly in focus.

4. **Page Layout View:** Page Layout View in the Excel worksheet is just what the doctor ordered when it comes to visualizing the paging of printed reports. When you turn on this view by clicking the Page Layout View
button on the Status bar, Excel doesn’t just show the page breaks as measly dotted lines as in earlier versions but as actual separations. In addition, the program shows the margins for each page including headers and footers defined for the report (which you can both define and edit directly in the margin areas while the program is in this view) and as an extra nice touch throws in a pair of horizontal and vertical rulers to accompany the standard column and row headers. Couple this great feature with the Zoom slider (see Number 5 in list) and the Page Break Preview feature and you’re going to actually enjoy getting the spreadsheet ready to print. See Chapter 5 for details on using Page Layout Preview and defining headers and footers for your printed reports.

3. **Style Galleries:** Excel 2007 is jammed full of different style galleries that make it a snap to apply new sophisticated (and, in many cases, very colorful) formatting to tables and lists of data, charts, and various and sundry graphics you add to your worksheets. Coupled with the Live Preview feature (see Number 1 in the list), Excel’s style galleries go a long way toward encouraging you to create better-looking, more colorful, and interesting spreadsheets.

2. **The Ribbon:** The Ribbon is the heart of the new Excel 2007 user interface. Based on a core of standard tabs to which various so-called contextual tabs are added as needed in formatting and editing of specific elements (such as data tables, charts, pivot tables, and graphic objects), the Ribbon brings together most every command you’re going to need when performing particular tasks in Excel. Refer to Color Plates 1-7, and 8-10 for examples of the tabs you can encounter on the Ribbon and their particular command buttons. Also, check out Chapter 1 for more on the Ribbon.

1. **Live Preview:** You simply can’t say enough about Live Preview and how much easier it makes formatting the worksheet. Live Preview works with all the style galleries (see Number 3 in the list) as well as Font and Font Size pull-down menus in the Font group on the Home tab. It enables you to see how the data in the current cell selection would look with a particular formatting, font, or font size before you actually apply the formatting to the range. All you have to do is mouse over the thumbnails in the drop-down menu or gallery to see how each of its styles will look on your actual data. As an extra nice feature, many of the larger style galleries sport spinner buttons that enable you to bring new rows of thumbnails in the gallery into view so that you can preview their styles without obscuring any part of the cell selection (as would be the case if you actually open the gallery by clicking its More drop-down button). And when you finally do see the formatting that fits your data to a tee, all you have to do is click its thumbnail to immediately apply it to the selected cell range.
Chapter 14

Top Ten Beginner Basics

If these ten items are all you ever really master in Excel 2007, you’ll still be way ahead of the competition. When all is said and done, this top ten list lays out all the fundamental skills required to successfully use Excel 2007.

10. To start Excel 2007 from the Windows Vista taskbar, click the Start button, type ex in the Start Search text box and then with Microsoft Office Excel 2007 selected in the Programs section, press Enter. To start the program from the Windows XP or 2000 taskbar, click the Start button, highlight All Programs on the Start menu, and then highlight Microsoft Office on the All Programs continuation menu. Finally, click Microsoft Office Excel on the Microsoft Office continuation menu.

9. To automatically launch Excel 2007 at the same time that you open an Excel workbook that needs editing (in the Documents window in Windows Vista or My Documents window in Windows XP), simply locate the folder containing the Excel workbook you want to edit and double-click its file icon.

8. To locate a part of a worksheet that you cannot see on-screen, click the scroll bars at the right and bottom of the workbook window to bring new parts of the worksheet into view.

7. To start a new workbook (containing three blank worksheets) using the Excel default template, simply press Ctrl+N. To open a new workbook from another template, click Microsoft Office Button | New or press Alt+FN and then select the template to use in the New Workbook dialog box (you can also download new templates from Microsoft’s Web site from this dialog box). To add a new worksheet to a workbook (should you need more than three), click the Insert Worksheet button to the immediate right of the last tab at the bottom of the Worksheet area.

6. To activate an open workbook and display it on-screen (in front of any others you have open), click the Ribbon’s View tab, then click the window to activate in the Switch Windows button’s drop-down menu (or press Alt+WW followed by the window’s number). To locate a particular worksheet in the active workbook, click that worksheet’s sheet tab at the bottom of the workbook document window. To display more sheet tabs, click the sheet scrolling arrows on the left side of the bottom of the workbook window.
5. **To enter stuff in a worksheet**, select the cell where the information should appear; then begin typing. When you finish, click the Enter button on the Formula bar (the one with the check mark) or press Tab, Enter, or one of the arrow keys.

4. **To edit the stuff you’ve already entered into a cell**, double-click the cell or position the cell pointer in the cell and press F2. Excel then locates the insertion point at the end of the cell entry and goes into Edit mode (see Chapter 2 for details). When you finish correcting the entry, click the Enter button on the formula bar or press Tab or Enter or one of the arrow keys.

3. **To choose one of the many Excel commands on the Ribbon**, click the tab and then locate the group containing the command button and click it. (Or, press the Alt key to display the hot keys on the Ribbon and then type the letter of the tab you want to select followed by the letter(s) of the command button to use.) To choose a command on the File pull-down menu, click the Microsoft Office Button and then click its menu option or press Alt+F followed by the option’s hot key letter. To choose a command on the Quick Access toolbar, click its command button.

2. **To save a copy of your workbook on disk the first time around**, click the Save button on the Quick Access toolbar or press Ctrl+S; then designate the drive and folder directory where the file should be located, replace the temporary `Book1.xlsx` filename in the File Name text box with your own filename (up to 255 characters long, including spaces), and then click the Save button. To save a workbook so that older versions of Excel can open it, highlight the Save As option on the Office pull-down menu, then click the Excel 97-2003 Workbook option in its submenu or press Alt+FF9.

1. **To exit Excel when you’re done working with the program**, click Office Button | Exit Excel or press Alt+FX. If the workbook you have open contains unsaved changes, Excel 2007 asks whether you want to save the workbook before closing Excel and returning to Windows. Before you shut off your computer, be sure to use the Shut Down command on the Start menu to shut down the Windows operating system.
Chapter 15

The Ten Commandments of Excel 2007

When working with Excel 2007, you discover certain do’s and don’ts that, if followed religiously, can make using this program just heavenly. Lo and behold, the following Excel Ten Commandments contain just such precepts for eternal Excel bliss.

10. Thou shalt commit thy work to disk by saving thy changes often (clicketh the Save button on the Quick Access toolbar or presseth Ctrl+S). If thou findest that thou tendeth to be lax in the saving of thy work, thou shalt maketh sure that thy AutoRecover feature is engaged. Clicketh Office Button | Excel Options | Save or presseth Alt+FIS and then maketh sure that the Save AutoRecover Information check box hath a check mark and that its text box is set to no more than 10 minutes.

9. Thou shalt nameth thy workbooks when saving them the first time with filenames of no more than twelve score and fifteen characters (255), including spaces and all manner of weird signs and symbols. So, too, shalt thou mark well into which folder thou savest thy file lest thou thinkest in error that thy workbook be lost when next thou hast need of it.

8. Thou shalt not spread wide the data in thy worksheet, but rather shalt thou gather together thy tables and avoideth skipping columns and rows unless this is necessary to make thy data intelligible. All this shalt thou do in order that thou may conserve the memory of thy computer.

7. Thou shalt begin all thy Excel 2007 formulas with = (equal) as the sign of computation. If, however, ye be formerly of the Lotus 1-2-3 tribe, thou shalt haveth special dispensation and can commence thy formulas with the + sign and thy functions with the @ sign.

6. Thou shalt select thy cells before thou bringeth any Excel command to bear upon them, just as surely as thou doth sow before thou reapeth.
5. Thou shalt useth the Undo feature (clicketh the Undo button on the Quick Access toolbar or presseth Ctrl+Z) immediately upon committing any transgression in thy worksheet so that thou mayest clean up thy mess. Should thou forgeteth to useth thy Undo feature straightaway, thou must select the action that thou wouldst undo from the pop-up menu attached to the Undo command button on the Quick Access toolbar. Note well that any action that thou selectest from this drop-down list will undo not only that action but also the actions that precedeth it on this menu.

4. Thou shalt not delete, neither shalt thou insert, columns and rows in a worksheet lest thou hast first verified that no part as yet undisplayed of thy worksheet will thereby be wiped out or otherwise displaced.

3. Thou shalt not print thy spreadsheet report lest thou hath first previewed its pages by clicking the Page Layout View button (the middle button of the three to the immediate left of the Zoom Slider on the Status bar) and art satisfied that all thy pages are upright in the sight of the printer. If thou art still unsure of how thy pages break, clicketh the Page Break Preview button to its immediate right on the Status bar to seeth how Excel doth divide thy pages.

2. Thou shalt changeth the manner of recalculation of thy workbooks from automatic to manual (clicketh Formulas | Options | Manual or presseth Alt+MXM) when thy workbook groweth so great in size that Excel sloweth down to a camel crawl whenever thou doeth anything in any one of its worksheets. Woe to thee, should thou then ignoreth the Calculate message on the Status bar and not presseth the Calculate Now key (F9) or clicketh Formulas | Calculate Now before such time as thou mayest print any of thy workbook data.

1. Thou shalt protecteth thy completed workbook and all its worksheets from corruption and iniquities at the hands of others (clicketh Review | Protect Sheet or Protect Workbook). And if thou be brazen enough to addeth a password to thy workbook protection, beware lest thou forgeteth thy password in any part. For verily I say unto thee, on the day that thou knowest not thy password, that day shalt be the last upon which thou lookest upon thy workbook in any guise.
Index

• Symbols •

* (asterisk wildcard), 222
/ (division sign), 64
= (equal sign), 64, 83, 363
- (minus sign), 64
* (multiply sign), 64
#DIV/0! error value, 69
#NAME? error value, 69
#NULL! error value, 69
#NUM! error value, 70
# (overflow indicator), 117
#REF! error value, 70
#VALUE! error value, 70
+ (plus sign), 64
? (question mark wildcard), 222
^ (raise number to exponential power), 64
~ (tilde), 222

• A •

absolute cell reference, 157–159
Access database table, querying, 339–341
Accounting Number Format button
(Number group), 44, 112, 116
activating
open workbook and displaying
on-screen, 361
worksheet for editing, 27
active cell, 100
Active Sheet(s) option (Print dialog box), 180
Add to Dictionary option (Spelling dialog box), 168
Add to Selection mode (Shift+F8), 106
add-in, using, 343–345
adding
arrow to text box, 301–302
command button to Quick Access toolbar, 18–19
comment to cell, 212–213
data labels to series in chart, 293–294
data table to chart, 294–295
header or footer, 189, 190–194
hyperlink to worksheet, 345–348
macro to Quick Access toolbar, 21
non-Ribbon command to Quick Access toolbar, 20–21
pivot table field, 279
preset graphic shape, 307–308
Quick Print button to Quick Access toolbar, 177–178
records to data list, 321–324
Ribbon command to Quick Access toolbar, 19–20
text box, 300–301
text replacement to AutoCorrect feature, 71
title to chart, 293
Add-Ins command, 39
Add-Ins dialog box, 344
Add-Ins tab (Excel Options dialog box), 344
adjusting size
of column, 123–124, 155
of row, 124
Adobe Reader software, 95
Advanced command, 39
Advanced tab (Excel Options dialog box), 54
Align Left button (Alignment group), 111
Align Right button (Alignment group), 111
aligning header or footer, 189
alignment, altering, 128–131
Alignment group command buttons, 111–112
Alignment tab (Format Cells dialog box), 132, 133–134
All option (Print dialog box), 179
Allow Users to Edit Ranges command, 39
Alt key, selecting command using, 17
<table>
<thead>
<tr>
<th>Keyboard Shortcuts</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+AFA</td>
<td>(Select Data Source dialog box), 339</td>
</tr>
<tr>
<td>Alt+AFF</td>
<td>(redisplay filter buttons), 334</td>
</tr>
<tr>
<td>Alt+AFO</td>
<td>(From Other Sources), 340–341</td>
</tr>
<tr>
<td>Alt+AFW</td>
<td>(New Web Query dialog box), 341</td>
</tr>
<tr>
<td>Alt+AS</td>
<td>(Sort), 331</td>
</tr>
<tr>
<td>Alt+AWS</td>
<td>(Scenario Manager), 264</td>
</tr>
<tr>
<td>Alt+AWT</td>
<td>(Data Table dialog box), 256</td>
</tr>
<tr>
<td>Alt+AX</td>
<td>(Existing Connections dialog box), 340–341</td>
</tr>
<tr>
<td>Alt+AW</td>
<td>(alternating header or footer, creating), 195–196</td>
</tr>
<tr>
<td>Alt+F</td>
<td>(File pull-down menu), 7</td>
</tr>
<tr>
<td>Alt+F4</td>
<td>(exit), 32</td>
</tr>
<tr>
<td>Alt+F8</td>
<td>(Macro dialog box), 50, 352</td>
</tr>
<tr>
<td>Alt+FA</td>
<td>(Save As), 91</td>
</tr>
<tr>
<td>Alt+FIC</td>
<td>(Customize tab), 354</td>
</tr>
<tr>
<td>Alt+FIS</td>
<td>(Save AutoRecover Information), 363</td>
</tr>
<tr>
<td>Alt+FN</td>
<td>(New Workbook), 361</td>
</tr>
<tr>
<td>Alt+FO</td>
<td>(Open), 142</td>
</tr>
<tr>
<td>Alt+FP</td>
<td>(Print dialog box), 179</td>
</tr>
<tr>
<td>Alt+FWV</td>
<td>(Print Preview), 175</td>
</tr>
<tr>
<td>Alt+FX</td>
<td>(Exit), 32, 362</td>
</tr>
<tr>
<td>Alt+HDS</td>
<td>(Delete Sheet), 237</td>
</tr>
<tr>
<td>Alt+HFDF</td>
<td>(Find), 220</td>
</tr>
<tr>
<td>Alt+HFDG</td>
<td>(Go To dialog box), 217</td>
</tr>
<tr>
<td>Alt+HFDR</td>
<td>(Replace), 223</td>
</tr>
<tr>
<td>Alt+HSU</td>
<td>(Sort &amp; Filter), 331</td>
</tr>
<tr>
<td>Alt+MMD</td>
<td>(New Name dialog box), 219</td>
</tr>
<tr>
<td>Alt+MXA</td>
<td>(automatic recalculation), 226</td>
</tr>
<tr>
<td>Alt+MXM</td>
<td>(manual recalculation), 226, 364</td>
</tr>
<tr>
<td>Alt+NI</td>
<td>(Insert Hyperlink), 345</td>
</tr>
<tr>
<td>Alt+NM</td>
<td>(Choose a SmartArt Graphic dialog box), 310–311</td>
</tr>
<tr>
<td>Alt+NP</td>
<td>(Insert Picture dialog box), 305</td>
</tr>
<tr>
<td>Alt+NVT</td>
<td>(Create PivotTable dialog box), 270</td>
</tr>
<tr>
<td>Alt+NW</td>
<td>(WordArt gallery), 308</td>
</tr>
<tr>
<td>Alt+PBA</td>
<td>(Reset All Page Breaks), 198</td>
</tr>
<tr>
<td>Alt+PBI</td>
<td>(Insert Page Break), 198</td>
</tr>
<tr>
<td>Alt+PBR</td>
<td>(Remove Page Break), 198</td>
</tr>
<tr>
<td>Alt+PRS</td>
<td>(define Print Area), 181</td>
</tr>
<tr>
<td>Alt+RA</td>
<td>(Show All Comments), 214</td>
</tr>
<tr>
<td>Alt+RC</td>
<td>(New Comment), 213</td>
</tr>
<tr>
<td>Alt+RPS</td>
<td>(Protect Sheet), 227</td>
</tr>
<tr>
<td>Alt+RR</td>
<td>(Research task pane), 224</td>
</tr>
<tr>
<td>Alt+Tab</td>
<td>(Flip), 146</td>
</tr>
<tr>
<td>Alt+WB</td>
<td>(View Side by Side), 245</td>
</tr>
<tr>
<td>Alt+WFF</td>
<td>(Freeze Panes), 210</td>
</tr>
<tr>
<td>Alt+WH</td>
<td>(Hide), 353</td>
</tr>
<tr>
<td>Alt+WI</td>
<td>(Page Break Preview), 197</td>
</tr>
<tr>
<td>Alt+WMV</td>
<td>(Macro dialog box), 50</td>
</tr>
<tr>
<td>Alt+WN</td>
<td>(New Window), 241</td>
</tr>
<tr>
<td>Alt+WP</td>
<td>(Page Layout View), 174</td>
</tr>
<tr>
<td>Alt+WQ</td>
<td>(Zoom dialog box), 206</td>
</tr>
<tr>
<td>Alt+WS</td>
<td>(Split), 208</td>
</tr>
<tr>
<td>Alt+UW</td>
<td>(Unhide), 353</td>
</tr>
<tr>
<td>anchoring cell cursor, 106</td>
<td></td>
</tr>
<tr>
<td>arguments of function, 83</td>
<td></td>
</tr>
<tr>
<td>Arrange command, 40</td>
<td></td>
</tr>
<tr>
<td>Arrange Windows dialog box, 241–243</td>
<td></td>
</tr>
<tr>
<td>array formula, 259, 261</td>
<td></td>
</tr>
<tr>
<td>arrow, adding to text box, 301–302</td>
<td></td>
</tr>
<tr>
<td>arrow key</td>
<td></td>
</tr>
<tr>
<td>completing cell entry and, 55, 82</td>
<td></td>
</tr>
<tr>
<td>data list and, 325–326</td>
<td></td>
</tr>
<tr>
<td>repositioning insertion point using, 72</td>
<td></td>
</tr>
<tr>
<td>selecting chart element using, 296</td>
<td></td>
</tr>
<tr>
<td>ascending sort order, 329</td>
<td></td>
</tr>
<tr>
<td>assigning</td>
<td></td>
</tr>
<tr>
<td>color to worksheet, 238–239</td>
<td></td>
</tr>
<tr>
<td>constant to range name, 219</td>
<td></td>
</tr>
<tr>
<td>General number format to cell, 121</td>
<td></td>
</tr>
<tr>
<td>macro to Quick Access toolbar, 50, 353–354</td>
<td></td>
</tr>
<tr>
<td>shortcut keystroke to macro, 349, 350</td>
<td></td>
</tr>
<tr>
<td>asterisk (*) wildcard, 222</td>
<td></td>
</tr>
<tr>
<td>AutoCalculate button (Status bar), 28</td>
<td></td>
</tr>
<tr>
<td>AutoCalculate indicator, value of text entry in, 56</td>
<td></td>
</tr>
<tr>
<td>AutoComplete feature, 73–75</td>
<td></td>
</tr>
<tr>
<td>AutoCorrect feature, 70–71</td>
<td></td>
</tr>
<tr>
<td>AutoCorrect option (Spelling dialog box), 168</td>
<td></td>
</tr>
<tr>
<td>AutoCorrect Options command, 39</td>
<td></td>
</tr>
<tr>
<td>AutoFill feature</td>
<td></td>
</tr>
<tr>
<td>copying formula to range of cells, 155–159</td>
<td></td>
</tr>
<tr>
<td>copying with, 78</td>
<td></td>
</tr>
<tr>
<td>custom lists, creating, 79–80</td>
<td></td>
</tr>
<tr>
<td>overview of, 75–77</td>
<td></td>
</tr>
<tr>
<td>spaced series, 77–78</td>
<td></td>
</tr>
<tr>
<td>AutoFilter, custom, creating, 336–339</td>
<td></td>
</tr>
<tr>
<td>AutoFit feature, 123–124</td>
<td></td>
</tr>
</tbody>
</table>
AutoFit Row Height command, 37
AutoRecover feature, 96, 363
AutoSelect feature, 102–104, 105
AutoSum tool, 87–89
Average function, 280

B
Background button (Page Setup group), 182
Background command, 38
Backspace key, 71, 72
beginner basics, 361–362
binary file format, 95
blowing up worksheet, 204–206
Bold button (Font group), 110
bold formatting, 112
border, adding to cell, 135–136
Border tab (Format Cells dialog box), 136
Borders button (Font group), 111
Bottom Align button (Alignment group), 44, 111
Breaks button (Page Setup group), 182
Brightness option (Picture Tools contextual tab), 306
browser, opening file in, 149
built-in add-in programs, 344
buttons. See command buttons
Buttons section (Formula bar), 21

C
Calculate Now button, 226
calculating field entry, 321
Calculation Options button (Ribbon), 226
Cancel box (Formula bar), 55
Cancel button (Printing dialog box), 178
canceling print job, 178
Cascade option (Arrange Windows dialog box), 242, 243
case, Find and Replace dialog box and, 220
cell
active, 100
clearing, 164–165
comment, adding to, 212–213
current, indications of, 22
deleting, 165–166
deselecting, 101
editing, 71–73
inserting with drag and drop technique, 154–155
locking, 227
naming, 216–217
selecting, 67, 81–82, 100–107, 363
unlocking, 229
Cell contents section (Formula bar), 21
cell cursor/pointer
anchoring and unanchoring, 106
data entry and, 53, 54
moving, 23–24, 82
cell range
applying Data Bars to, 357
copying formula to, 155–159
copying text entry to, 78
inserting, 166
moving to using Zoom feature, 206
naming, 216–217
selecting multiple, 106
cell reference, linking to, 346
Cell Styles command, 38
Cell Styles gallery, 138, 357
Cells command, 37
center alignment, 130
centering header or footer, 189
Change All option (Spelling dialog box), 168
Change option (Spelling dialog box), 168
Change Picture option (Picture Tools contextual tab), 306
changing
appearance of icon, 143–144
cell reference, 158, 159
default file location for saving workbook, 93–94
default number of worksheets in workbook, 237
font, 126–128, 215
order of worksheets in workbook, 239–240
Recent Documents list, 146–147
units for ruler, 174
chart. See also embedded chart; pivot chart creating, 288–289
data labels, adding to series in, 293–294
data table, adding to, 294–295
elements, customizing, 292–295
elements, formatting, 295–299
Insert tab and, 358
moving and resizing, 290–291
overview of, 287–288
title, adding to, 293
title, editing, 295
type and style, customizing, 291
Chart Layouts option (Chart Tools contextual tab), 291, 292
chart sheet, moving embedded chart to, 290–291
Chart Styles option (Chart Tools contextual tab), 292
Chart Tools contextual tab
Design tab, 291–292
embedded chart and, 290
Format tab, 296–299
Layout tab, 292–295
overview of, 16
checking spelling, 167–169
Clear All command, 36
Clear Comments command, 36
Clear Contents command, 36
Clear Formats command, 36
clearing
cell, 164–165
comments, 215
Office Clipboard, 162
Print Area, 181
print titles from report, 187
click-and-drag cell selection, 102
Clip Art
editing, 305–307
formatting, 305–307
searching for and inserting, 302–304
Clipboard, pasting from, 160, 161–162
Close command, 36
Close Print Preview option (Print Preview), 177
closing
Excel, 32–33, 362
worksheet window, 244
collapse buttons, pivot table, 275
Collate option (Print dialog box), 180
color
assigning to worksheet, 238–239
of font, changing, 128
of hyperlink, 348
Color Scales, applying, 357
column
adjusting width of, 123–124, 155
changing margins and, 183–184
deleting, 165–166, 364
hiding, 125–126
inserting, 167, 364
labeling, 22
selecting all cells in, 102
sorting worksheet data by, 333
Column field
filtering, 276–277
pivoting, 279
sorting on, 278
Column Labels drop zone, 272
Column Width command, 38
Comma Style button (Number group), 112
Comma Style format, 117–118
command buttons. See also specific buttons
adding on Quick Access toolbar, 18–19
Alignment group, 111–112
Font group, 110–111
Header & Footer Elements group, 192
Number group, 112
Page Setup group, 182
commands. See also specific commands
Excel 2007 equivalents for, 35–41
selecting on Ribbon, 362
comment
adding to cell, 212–213
editing, 215
overview of, 212
printing, 216
viewing all, 214
Compare Side by Side dialog box, 245–246
comparing worksheets side by side, 245–246
completing cell entry, 55
Compress Pictures option (Picture Tools contextual tab), 306
conditional formatting, 357
Conditional Formatting command, 38
Consolidate command, 40
constant, naming, 218–219
contextual tools, 16
Contrast option (Picture Tools contextual tab), 306
Convert Text to Table command, 40
converting precision of values to displayed form, 120–121
copy, opening file as, 149
Copy command, 42
copying
AutoFill, using for, 78
custom style between workbooks, 138–139
with cut and paste technique, 159–164
with drag and drop technique, 153–154
filtered records, 333
formatting between cells, 140
formula to range of cells, 155–159
formula using range name, 219
worksheet, 239–240, 246–249
correcting error in data entry, 70–73
Count function, 280
Count Numbers function, 280
Create from Selection command, 37
Create PivotTable dialog box, 270, 271
Criteria button (data form), 326–328
cross-reference to another section or chapter, 2
cross-tabulating data, 270
Ctrl key
cell selection and, 101–102
keyboard shortcuts using, 17
using with arrow key, 24
Ctrl+= (Calculate Now), 226
Ctrl+` (move from one corner of range to another), 82
Ctrl+` (toggle between displays), 199
Ctrl+1 (Format Cells dialog box), 114
Ctrl+B (bold), 112
Ctrl+F (Find), 220
Ctrl+F1 (minimize Ribbon display), 35
Ctrl+F12 (Open), 142
Ctrl+G (Go To dialog box), 217
Ctrl+H (Replace tab), 223
Ctrl+I (italics), 112
Ctrl+K (Insert Hyperlink), 345
Ctrl+N (New Workbook), 361
Ctrl+O (Open), 142
Ctrl+P (Print dialog box), 179
Ctrl+Page Down (next worksheet), 27, 235
Ctrl+Page Up (previous worksheet), 27, 235
Ctrl+S (Save), 90, 96, 362
Ctrl+Shift+` (assign General number format), 121
Ctrl+U (underline), 112
Ctrl+X (Cut), 159
Ctrl+Y (Redo Clear), 150–151
Ctrl+Z (Undo), 150, 364
Current Date button (Header & Footer Elements group), 192
Current Time button (Header & Footer Elements group), 192
Custom AutoFilter dialog box, 336–339
custom series, creating, 79–80
Custom Sort command, 39
Customize Quick Access Toolbar button, 18
Customize Quick Access Toolbar drop-down menu, 18–19
Customize tab (Excel Options dialog box), 19, 20, 354
customizing
cell pointer, 54
chart, 291–295
Quick Access toolbar, 18–21, 46–48
cut and paste technique
moving cell selection, 159–160
Paste Options button, 160–161
Paste Special command, 162–164
pasting from Clipboard, 161–162
pasting multiple times, 160
Cut command, 42

- Data Bars, applying to cell range, 357
data entry
AutoComplete feature, 73–75
AutoFill feature, 75–80
correcting errors in, 70–73
in data list table, 321–324
formatting and, 99
overview of, 362
special symbol, inserting, 80–81
speeding up, 82–83
tips for, 52–55
### Excel 2007 For Dummies

<table>
<thead>
<tr>
<th>Page</th>
<th>Location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>370</td>
<td>Excel 2007 For Dummies</td>
<td>Excel 2007 For Dummies</td>
</tr>
</tbody>
</table>
Dictionary Language option (Spelling dialog box), 168
Different First Page check box (Header & Footer Tools contextual tab), 195
Different Odd & Even Pages check box (Header & Footer Tools contextual tab), 195–196
disabling AutoComplete feature, 75
displaying
  all files in folder, 143
  comments, 213–214
  formulas, 198
  hidden graphic objects, 316
  workbooks on-screen, 27
DIV/0! error value, 69
division sign ( /), 64
document recovery feature, 96
drag and drop technique
  copying, 153–154
  inserting, 154–155
  overview of, 151–152
dragging
  cell selection, 75
  column marker to change margin, 183–184
  sheet tab to move worksheet, 247–248
Drawing toolbar, 43

**E**

Edit menu commands, 36
Edit mode, 72
Edit Name dialog box, 219
editing
  activating worksheet for, 27
  array formula, 259, 261
  arrow in text box, 302
  AutoFill and, 155–156
  checking spelling, 167–169
  Clip Art, 305
  comment, 215
  constant name, 219
  cut and past technique, 159–164
  data in cell, 71–73
  deleting, 164–166
  drag and drop technique, 151–155
  function with Function Wizard button, 87
Home tab and, 358
hyperlink, 348
inserting, 166–167
locked cell, 228
multiple worksheets, 235–236
overview of, 362
picture, 305
pivot table fields, 278–279
records in data list, 324–325
replacing entry, 223–224
text box, 301
Text to Speech feature, 169–171
titles in chart, 295
Undo command and, 150
worksheet, 142
e-mail address page, linking to, 347
E-mail command, 18, 36, 42
embedded chart
  description of, 281, 289
  moving and resizing, 290–291
  printing, 317
enabling preview feature, 144
End key
  repositioning insertion point using, 72
  using with arrow key, 24
Enter box (Formula bar), 55
Enter key
  completing cell entry and, 54, 55
  moving cell cursor with, 82
Enter mode, 53
entering. See also data entry
  data into workbook, 52–55
  numeric value, 58–59
Entire Column option
  Delete dialog box, 165
  Insert dialog box, 166
Entire Row option
  Delete dialog box, 165
  Insert dialog box, 166
Entire Workbook option (Print dialog box), 180
equal sign ( =), 64, 83, 363
Error Checking command, 38
error in data entry, correcting, 70–73
error value, 68–70
Excel Options button, 12
Excel Options command, 39
Excel Options dialog box
  Add-Ins tab, 344
  Advanced tab, 54
  Customize tab, 19, 20, 354
  Save tab, 93
Exit Excel button, 12
extending Excel, 32–33, 362
Extend mode, 105
extending cell selection, 105
extending power of Excel add-in, using, 343–345
hyperlink, adding to worksheet, 345–348 with macros, 348–354
external data, importing, 339–342

• F •
F1 (Help window), 33
F2 (edit cell entry), 71–72
F4 (change cell reference), 158, 159
F5 (Go To dialog box), 23, 106–107, 217
F8 (Extend mode), 105
F9 (Calculate Now), 226
F11 (Clustered Column chart), 289
field. See also Column field; Row field
  sorting records on multiple, 331–332
  sorting records on single, 330
field name, 319
file
  opening, 149–150
  saving, 49–50, 94–96
file format
  binary, 95
  migrating to Excel from earlier versions and, 49–50
  .XLS compared to .XLSX, 94
File menu commands, 35–36
File Name button (Header & Footer Elements group), 192
File Path button (Header & Footer Elements group), 192
File pull-down menu, opening, 7
fill color, applying, 136–138
Fill Color button (Font group), 111
Fill Effects dialog box, 137
Fill tab (Format Cells dialog box), 137
filling in text for SmartArt graphic, 311–312
filter buttons, pivot table, 275
Filter command, 39
filtering
  Column and Row fields, 276–277
custom filter, creating, 336–339
date filter options, 335–336
number filter options, 334–335
pivot chart, 283
pivot chart report, 276
records in data list, 333–334
Find and Replace dialog box replacing using, 223–224
searching using, 220–223
Find command, 36
Find Format dialog box, 221
finding records in data list, 326–328
First sheet button, 26
First tab scroll button, 234
first-page header or footer, creating, 195
Fixed Decimal setting, 60, 61
fixing number of decimal places, 59–60
Flip feature, 146
folder
  opening, 145
  opening workbook in, 143
  selecting to save workbook file in, 91–93
following hyperlink, 347–348
font, changing
  chart title, 297
comment text, 215
  Font group on Home tab, using, 126–128
WordArt, 310
Font button (Font group), 110
Font Color button (Font group), 111
Font group command buttons, 110–111
Font Size button (Font group), 110
Font tab (Format Cells dialog box), 127
footer
  adding, 189
  adding Auto Header, 190–191
  alternating, creating, 195–196
custom, creating, 192–196
  for first page, creating, 195
Form button, adding to Quick Access toolbar, 321–322
Format as Table command, 38
Format as Table dialog box, 107–108
Format as Table feature, 107–109, 358
Format Cells dialog box
  Alignment tab, 132, 133–134
  Border tab, 136
  Fill tab, 137
  Font tab, 127
  Indent text box, 130
  Number tab, 114–119
  opening, 114
  Special category, 122–123
Format menu commands, 37–38
Format Painter button (Home tab), 139–140
Format Painter command, 42
Format Picture button (Header & Footer Elements group), 192
Format tab
  Chart Tools contextual tab, 296–299
  Picture Tools contextual tab, 305–307
  PivotChartTools contextual tab, 283
formatting
  alignment, 128–130
  borders, 135–136
  cell selection and, 100–107
  Clip Art, 305–307
  column or row, 123–126
  conditional, 357
  data entry and, 99
  fill colors, patterns, and gradient effects, 136–138
Find and Replace dialog box and, 221
  font, 126–128
  Home tab and, 109–112, 358
  indentation, 130
  mini toolbar feature and, 113
  orientation of text, 133–134
  picture, 305–307
  pivot chart, 283
  pivot table, 273–274, 275
  Shrink to Fit, 134
  SmartArt graphic, 312–313
  styles, 138–139
  text box, 300–301
  text wrap, 131–132
  themes, using, 313–314
  values and, 119–121
Formatting toolbar buttons, Excel 2007 equivalents for, 43–44

formula. See also function
  array, 259, 261
  copying to range of cells, 155–159
  entering, 64–67
  equal sign (=) and, 363
  error values from, 68–70
  naming, 217–218
  order of operations, altering, 67–68
  printing, 198–199
Formula bar
  Cancel box, 55
  editing cell contents using, 73
  Enter box, 55
  illustration of, 13
  reactivating, 72
  sections of, 21
Formulas tab, 15
  fraction, entering, 59
Freeze Panes command, 40
  freezing heading, 209–212
From Other Sources command, 40
Full Screen command, 36
function
  editing with Function Wizard button, 87
  inserting with Function Wizard button, 84–87
  overview of, 83–84
  summary, modifying in pivot table, 280
Function Arguments dialog box, 85–87
Function Wizard button (Formula bar), 84–87

• G •

General number format, 115, 121
  global search-and-replace operations, 224
Go To dialog box
  cell selection and, 106–107
  named cell or cell range and, 217
  opening, 23
Goal Seek, 255, 261–263
Goal Seek Status dialog box, 263
gradient effect, applying, 136–138
graphic object
  grouping, 315
  hiding, 315–316
  reordering layering of, 314–315
graphics. See also chart
adding preset shapes, 307–308
Clip Art, 302–304
editing, 305
formatting, 305–307
overview of, 299
pictures, 305
SmartArt, 310–313
text box, 300–302
themes, 313–314
WordArt, 308–310
gridline, printing, 135
Group command, 40
grouping graphic objects, 315

• H •

handle, AutoFill, 75
header. See also title
adding, 189
adding Auto Header, 190–191
alternating, creating, 195–196
custom, creating, 192–196
for first page, creating, 195
Header & Footer command, 36
Header & Footer Tools contextual tab
Auto Header & Footer group, 190–191
Header & Footer Elements, 192–196
heading, freezing, 209–212
Height command, 37
height of row, setting, 124
Help on this Function hyperlink, 84
Help window, opening and using, 33–34
Hide Columns command, 38
Hide command, 40
Hide Rows command, 37
Hide Sheet command, 38
hiding. See also unhiding
column or row, 125–126
graphic object, 315–316
Home key, 72
Home tab
Alignment group, 111–112, 128–134
AutoSum tool, 87, 88
cell formatting from, 109–112
Cell Styles button, 138
description of, 15
Font group, 110–111, 126–128,
135–136, 137
Format as Table command button, 107
Format Painter button, 139–140
formatting and editing from, 358
Formatting toolbar button equivalents
and, 43–44
Header & Footer Elements group, 192
Number group, 112
Page Setup group, 182
Paste Options button, 160–161
Horizontal option (Arrange Windows
dialog box), 241, 242
horizontal scroll bar, 25
horizontal split bar, 208
hot key combination, 6, 17. See also
keystroke shortcuts
hyperlink, adding to worksheet, 345–348
Hyperlink command, 37, 42

• I •

I-beam shape, 154–155
icon, changing appearance of, 143–144
Icon Sets, applying, 357
Ignore All option (Spelling dialog box), 168
Ignore Once option (Spelling dialog
box), 168
Ignore Print Areas option (Print dialog
box), 180
Import Data dialog box, 339, 341
importing external data, 339–342
Increase Decimal button (Number group),
112, 119
Increase Font button (Home tab), 44
Increase Font Size button (Font group), 110
Increase Indent button (Alignment group),
111, 130
indentation, 130
Insert Cells command, 37
Insert dialog box, 166
Insert Function dialog box, 84–85
Insert Hyperlink dialog box, 345–347
Insert key, 72
Insert menu commands, 37
Insert Page Break command, 37
Insert Sheet Columns command, 37
Insert Sheet command, 37
Insert Sheet Rows command, 37
Insert tab (Ribbon)
  Chart buttons, 288–289
  charts, 358
description of, 15
Shapes gallery, 307–308
WordArt gallery, 308–310
Insert Worksheet button, 26
inserting
cell range, 166
Clip Art, 303, 304
column or row, 167, 364
drag and drop technique for, 154–155
function with Function Wizard button, 84–87
manual page break, 198
picture, 305
SmartArt list or diagram, 310–311
special symbol, 80–81
worksheet into workbook, 236
insertion point, repositioning, 72, 86
Internet Fax command, 36
Italic button (Font group), 110
italics formatting, 112

keyboard, switching between worksheets with, 235
keyboard cell selection, 104–107
keystroke shortcuts
  assigning to macro, 349, 350
  for button commands, 35–41
  for editing cell data, 72
  for moving cell cursor, 23–24
  for navigating data list, 325–326
  for Standard toolbar button equivalents, 41–43

labeling column, 22
Landscape option (Page Layout tab), 184–185
Last sheet button, 26
Last tab scroll button, 234
launching Excel automatically, 361
layering of graphic objects, reordering, 314–315
layout, protecting, 228
Layout button (Status bar), 28
Layout tab
  Chart Tools contextual tab, 292–295
  PivotChart Tools contextual tab, 283
left alignment, 130
linking
  to e-mail address page, 347
  to worksheet range name or cell reference, 346
Live Preview
  Design tab and, 108
  overview of, 359
loading built-in add-in programs, 344
locking cell, 227–229

macro
  adding to Quick Access toolbar, 21
  assigning to Quick Access toolbar, 353–354
  migrating to Excel from earlier versions and, 50
  overview of, 348
  recording new, 348–352
  running, 352–353, 354
Macro dialog box, 50, 352, 353
Macro Recording button (Status bar), 27, 28
Macros command, 39
magnifying worksheet, 204–206
Margins button (Page Setup group), 182–184
Margins tab (Page Setup dialog box), 183
marquee, 159
mathematical operators, 64
Max function, 280
Maximize button (title bar), 244
memory conservation in worksheet, 53, 363
menu commands, Excel 2007 equivalents for, 35–41
Merge and Center button (Alignment group), 112, 128–130
Microsoft Office Online Web site, 343
Middle Align button (Alignment group), 44, 111
migrating to Excel from earlier versions file formats, 49–50
Formatting toolbar button equivalents, 43–44
macros, 50
overview of, 34
pull-down menu command equivalents, 35–41
Quick Access toolbar and, 45–48
Standard toolbar button equivalents, 41–43
Min function, 280
mini toolbar feature, 113
minimizing
- Function Arguments dialog box, 86
- Ribbon interface, 14–15, 35
minus sign (−), 64
Mode button (Status bar), 27, 28
modifying.
- See editing
- months, entering row of, 76
- More Controls button (Quick Access toolbar), 48
mouse
- cell selection with, 100–104
- wheeled, and scrolling, 25
Move or Copy dialog box, 246–247
Move or Copy Sheet command, 36
moving.
- See also repositioning
cell cursor, 23–24, 82
embedded chart, 290–291
Function Arguments dialog box, 86
insertion point, 72, 86
to new cell range using Zoom feature, 206
pivot chart to its own sheet, 282
pivot table field, 279
Quick Access toolbar, 18
range of cell entries, 152–153
worksheet, 240, 246–249
multiply sign (×), 64

Name box section (Formula bar), 21
#NAME? error value, 69
Name Manager command, 37
naming. See also renaming
cell or cell range, 216–217
constant, 218–219
formula, 217–218
macro, 350
workbook, 363
narrow margins, setting, 182–183
navigating
- Print Preview window, 175–177
- records in data list, 325–326
- search results, 222–223
- workbook, 26–27
- Worksheet area, 22–25
negative number, entering, 58
nesting parentheses in formula, 68
New command, 18, 35, 41
New Comment command, 37
New Name dialog box, 219
New Web Query dialog box, 341–342
New Window command, 40
New Window command button (Ribbon), 241
Next sheet button, 26
Next tab scroll button, 234
nonadjacent/noncontiguous selection, 100, 101–102, 106
#NULL! error value, 69
#NUM! error value, 70
Num Lock indicator, 28
number filter options, 334–335
Number Format button (Number group), 44, 112
Number group command buttons, 112
Number of Copies option (Print dialog box), 180
Number of Pages button (Header & Footer Elements group), 192
Number tab (Format Cells dialog box)
Accounting Number format, 116
Comma Style format, 117–118
overview of, 114–115
Percent Style format, 118–119
numeric keypad, 61–62
numeric value, entering, 58–59

• O •
object, selecting and deselecting, 16
Office Button
File pull-down menu and, 7
illustration of, 13
manipulating, 12–13
Office Clipboard, pasting from, 160, 161–162
Office menu, 12
one-variable data table, creating, 256–258
Open button (Open dialog box), 149–150
Open command, 18, 35, 41
Open dialog box
Open button, 149–150
Windows Vista, 142–144, 147
Windows XP, 144–146
opening
Custom AutoFilter dialog box, 336
Data Table dialog box, 256
Excel automatically, 361
File pull-down menu, 7
folder, 145
Format Cells dialog box, 114
Go To dialog box, 217
Help window, 33
macro recorder, 349
multiple workbooks, 146
Office Clipboard, 162
Page Break Preview, 197
Page Layout View, 174
Print dialog box, 179
Print Preview, 175
recently edited workbooks, 146–147
recovered version of workbook, 96
Research task pane, 224
Scenario Manager, 264
Spelling dialog box, 167
workbook, 52, 142
worksheets in window panes, 240–245
operators
for Criteria button, 328
for Custom AutoFilter dialog box, 337
order of mathematical operations, altering, 67–68
Orientation button
Alignment group, 111
Home tab, 44
Page Setup group, 182, 184–185
orienting cell entry, 133–134
overflow indicator (#), 117

• P •
Page Break Preview, 196–198
Page Layout tab (Ribbon)
description of, 15
Page Setup group, 182–187
Scale to Fit group, 188
Sheet Options group, 188–189
Themes group, 313–314
Page Layout View, 174–175, 358–359
Page Number button (Header & Footer Elements group), 192
Page Setup dialog box
defining Print Area from, 181
Margins tab, 183
Page tab, 188
Sheet tab, 186–187
Page Setup group, command buttons, 182
Page Setup option (Print Preview), 177
Page tab (Page Setup dialog box), 188
Page(s) option (Print dialog box), 179
paging worksheet, 174
parentheses in formula, 68
password
for protecting shared workbook, 229
for protecting worksheet, 227, 228
remembering, 364
Paste command, 42
Paste Options button (Home tab), 160–161
Paste Special command, 162
Paste Special dialog box, 163–164
pasting from Clipboard, 160, 161–162
pattern, applying, 136–138
PDF file, saving workbook as, 95
Percent Style button (Number group), 112
Percent Style format, 118–119
percentage, entering, 59
Personal Macro Workbook, 349, 353
Phone Number format, 122
picture
   editing, 305
   formatting, 305–307
   inserting, 305
Picture button (Header & Footer Elements group), 192
Picture command, 37
Picture Styles group, 306–307
pivot chart
   creating, 281
   filtering, 283
   formatting, 283
   moving to its own sheet, 282
pivot table
   creating, 270–273
   as data summary, 269–270
   formatting, 273–274, 275
   modifying, 278–281
   overview of, 269
   sorting and filtering data, 275–278
   style, selecting for, 274
Pivot Table Field List task pane, 270–272, 279
PivotChart Filter Pane, 282
PivotTable Tools contextual tab, 273
PivotTable/PivotChart command, 40
plus sign (+), 64
point-and-click cell selection, 100–104
pointing, 67
Portrait option (Page Layout tab), 184
positive number, entering, 58
preset graphic shape, adding, 307–308
preview feature, enabling, 144
preview pane, displaying, 146
Previous sheet button, 26
Previous tab scroll button, 234
Print Area button (Page Setup group), 182
Print Area, clearing, 181
Print command, 36
Print dialog box
   overview of, 178
   Print Range, Print What, and Copies sections, 179–180
Print option (Print Preview), 177
Print Preview command, 18, 42
Print Preview feature, 175–177
Print Preview tab, Show Margins check box, 183
Print Titles button (Page Setup group), 182, 185–187
printing. See also footer; header; Print dialog box
canceling, 178
comments, 216
embedded charts, 317
formulas, 198–199
gridlines, 135
overview of, 173–174
Page Break Preview and, 196–198
Page Layout tab and, 181–189
Page Layout View and, 174–175
previewing before, 364
Print Preview and, 175–177
worksheets using Quick Print button, 177–178
Product function, 280
program window, 13
Protect Shared Workbook dialog box, 229
Protect Sharing command, 39
Protect Sheet command, 39
Protect Sheet dialog box, 227
Protect Structure and Windows dialog box, 228
Protect Workbook command, 39
protecting document, 227–229, 364

querying
   Access database table, 339–341
   Web page, 341–342
question mark (?) wildcard, 222
Quick Access toolbar
   assigning macro to, 50, 353–354
   buttons, 18
   command buttons, adding, 18–19
   customizing, 46–48
dividing buttons into groups, 48
Form button, adding, 321–322
illustration of, 13
location of, 7
macro, adding, 21
migrating to Excel 2007 and, 45–48
non-Ribbon commands, adding, 20–21
Quick Print button, adding, 177–178
Redo button, 18, 150–151
Ribbon commands, adding, 19–20
Save button, 18, 90, 96, 362
Speak Cells command buttons, 169, 170
Undo button, 18, 150, 151
Quick Launch toolbar, adding Excel
desktop shortcut to, 32
Quick Print button (Quick Access toolbar),
42, 177–178
Quick Print command, 18

raise number to exponential power (^), 64
range
 extending with AutoFill feature, 75–76
 selecting, 81–82
range name, linking to, 346
read-only file, opening, 149
Ready mode, 53
recalculation, manual, 226, 364
Recent Documents list, 146–147
Recolor option (Picture Tools contextual
tab), 306
Record Macro dialog box, 350–351
recording new macro, 348–352
records in data list
 adding, 321–324
 editing, 324–325
 filtering, 333–339
 finding, 326–328
 moving through, 325–326
 sorting, 328–333
Redo button (Quick Access toolbar),
18, 42, 150–151
Redo command, 19
#REF! error value, 70
relative cell reference, 156–157
removing. See also deleting
 border in worksheet, 136
color from worksheet tab, 239
calendar button from Quick Access
toolbar, 19, 20
data labels from chart, 294
page break, 198
protection from worksheet or
workbook, 229
Rename Sheet command, 38
renaming. See also naming
data table, 109
workbook, 91
worksheet, 237–238
reordering layering of graphic objects,
314–315
repairing file before opening, 150
Replace command, 36
replacing cell entry, 71, 223–224
Report Filter drop zone, 272
repositioning. See also moving
comment, 215
insertion point, 72, 86
Research command, 38, 42
Research task pane, 224–225
Reset Picture option (Picture Tools
contextual tab), 306
Reset Window Position option (Compare
Side by Side dialog box), 246
resetting page breaks, 198
resizing
 comment text box, 215
 embedded chart, 290
 horizontal scroll bar, 25
 WordArt, 310
Restore button (title bar), 244
Review tab (Ribbon interface), 15, 214
Reviewing toolbar, 214
Ribbon interface. See also Quick Access
toolbar; Status bar
Calculation Options button, 226
command buttons, 17
command sequences, 5–6
components of, 14–15
Define Name button, 219
Developer tab, adding, 349
Ribbon interface (continued)
- Formula bar, 13, 21, 55, 72–73
- Freeze Panes button, 210
- illustration of, 13
- Insert tab, 15, 288–289, 307–310, 358
- minimizing, 14–15, 35
- New Window command button, 241
- Office Button, 7, 12–13
- overview of, 12, 359
- Page Layout tab, 15, 181–189, 313–314
- Protect Sharing button, 229
- Protect Sheet button, 227
- Protect Workbook button, 228
- Review tab, 214
- selecting command on, 362
- Show Formulas button, 198
- Split button, 208
- tabs, 15–16
- View Side by Side command button, 245
- Worksheet area, 13, 14, 22–27, 206–209
- right alignment, 130
- rotating text, 133–134
- row
  - adjusting height of, 124
  - deleting, 165–166, 364
  - hiding, 126
  - inserting, 167, 364
  - selecting all cells in, 102
- Row field
  - filtering, 276–277
  - pivoting, 279
  - sorting on, 278
- Row Labels drop zone, 272
- ruler, changing units for, 174
- running macro, 349, 352–353, 354

\*

- S -

Save As command, 36
Save As dialog box
  - accessing, 90
  - default file location, changing, 93–94
  - in Windows Vista, 91–92
  - in Windows XP, 92–93
  - .XLSX compared to .XLS file format, 94
Save button (Quick Access toolbar), 18, 90, 96, 362
Save command, 18, 35, 41
Save tab (Excel Options dialog box), 93
saving
  - copy of workbook, 362
  - importance of, 363
  - macro, 351
  - recovered version of workbook, 96
  - scenarios, 266
  - theme, 314
  - worksheet windows, 244–245
saving file
  - format for, 49–50
  - importance of, 96
  - as PDF file, 95
  - in .XLS format, 94
Scale to Fit group (Page Layout tab), 188
Scenario Manager
  - overview of, 255, 264
  - setting up various scenarios, 264–266
  - summary report, producing, 266–267
Scenario Summary dialog box, 266–267
scientific notation, 58
scroll arrow buttons (Formula bar), 73
scroll bar, using in Worksheet area, 25–26, 361
Scroll Lock key, 24–25
Search Results dialog box, 149
Search text box (Open dialog box), 147
search-and-replace operation, global, 224
searching
  - for Clip Art, 303, 304
  - Find and Replace dialog box, using, 220–223
  - for function, 85
  - records in data list, 326–328
  - Research task pane and, 224–225
searching for workbook
  - in Windows Vista, 147–148
  - in Windows XP, 148–149
selecting
  - cell, 67, 81–82, 100–107, 363
  - chart, 290
  - chart element, 296
  - command on Ribbon, 17
file to open, 146
keyboard, 104–107
multiple worksheets, 235–236
object, 16
point-and-click, 100–104
worksheet window, 244
Selection and Visibility task pane, 315–316
selection handle, 290
Selection option (Print dialog box), 180
series
adding data labels to, 293–294
built-in, created with AutoFill, 77–78
custom, creating for AutoFill, 79–80
set cell, 262
setting margins, 182–185
Shapes gallery, 307–308
sharing workbook, 229
sheet. See worksheet
Sheet Name button (Header & Footer Elements group), 192
Sheet Options group (Page Layout tab), 188–189
Sheet tab (Page Setup dialog box), 186–187
Sheet Tab scroll buttons, 26, 27
sheet tab (workbook)
dragging to move worksheet, 247–248
switching worksheets using, 232–233
Shift Cells Down option (Insert dialog box), 166
Shift Cells Left option (Delete dialog box), 165
Shift Cells Right option (Insert dialog box), 166
Shift Cells Up option (Delete dialog box), 165
Shift key
cell selection and, 101, 104–105
scrolling and, 25
Shift+F5 (Find), 220
Shift+F8 (Add to Selection mode), 106
Shift+F9 (Calculate Sheet), 226
shortcut menu for chart element, 296
shortcuts. See keystroke shortcuts
Show All Comments command button (Ribbon), 214
Show Formulas button (Ribbon), 198
Show Margins check box (Print Preview), 183
Show Margins option (Print Preview), 177
showing hidden graphic object, 316
Shrink to Fit text control, 134
sidebar, information in, 2
Size button (Page Setup group), 182
sizing. See resizing
SmartArt, 310–313
Social Security Number format, 123
Solver add-in and what-if analysis, 267
Sort A to Z command, 42
Sort Ascending command, 19
Sort command, 333
Sort Descending command, 19
Sort dialog box, 331, 333
Sort Z to A command, 43
sorting
pivot table, 278
records in data list, 329–333
worksheet data by columns, 333
space conservation in worksheet, 52–53, 363
Speak Cells command buttons (Quick Access toolbar), 169, 170
special symbol, inserting, 80–81
speeding up data entry, 82–83
spelling, checking, 167–169
Spelling command, 18, 38, 42
Spelling dialog box, 167–169
split bar, 207–208
Split button (Ribbon), 208
Split command, 40
splitting
workbook into worksheet windows, 240–245
Worksheet area window, 206–209
spreadsheet. See workbook; worksheet
Standard toolbar buttons, Excel 2007 equivalents for, 41–43
Start Inking command, 42
Start menu
pinning Excel to, 30
starting Excel from, 29
starting Excel
  with desktop shortcut, 30–32
  from Windows Vista, 29, 361
  from Windows XP, 29, 361
starting new workbook, 361
Status bar
  areas of, 27–28
  illustration of, 13
  messages in, 6
  Page Layout View button, 358–359
  Record Macro button, 348, 350
  Stop Recording button, 352
  Zoom slider, 204–206, 358
StdDev function, 281
StdDevp function, 281
Stop Recording button (Status bar), 352
styles
  chart, 291, 292
  overview of, 138–139, 357
  pivot table, 274
Subtotal command, 40
Sum command, 42
summary.
  See pivot table
summary function, modifying in pivot table, 280
summary report for Scenario Manager, producing, 266–267
summary worksheet, 249–252
switching between worksheets
  with keyboard, 235
  with sheet tab, 232–233
  Tab scrolling buttons, 233–234
Symbol command, 37
Symbol dialog box, 80–81
Synchronous Scrolling option (Compare Side by Side dialog box), 246

● T ●

Tab Color command, 38
Tab key
  completing cell entry and, 55
  moving cell cursor with, 82
  Tab scrolling buttons, 233
Tab split bar, 208, 234
table. See also data table; pivot table
  entering data in new worksheet, 81–82
  organizing data into, 52
  selecting cells in, 102–104, 105
Table gallery, 107–109
Table option (Print dialog box), 180
Table Styles Options group (Design tab), 109
ten-key method, 61–62
text
  adding hyperlink to, 345–346
  AutoComplete feature, 73–75
  breaking into lines, 132
  copying throughout cell range, 78
  overview of, 56–57
  reorienting, 133–134
text replacement, adding to AutoCorrect feature, 71
text to Speech feature, 169–171
text wrap, 131–132
theme, 313–314
thumbnail and Live Preview, 359
tilde (~), 222
Tiled option (Arrange Windows dialog box), 241, 242
time axis, 288
time format, 62, 121–122
title. See also header
  adding to chart, 293
  editing in chart, 295
  formatting, 297
title bar, 244
Tools menu commands, 38–39
Top Align button (Alignment group), 44, 111
Top 10 filter, 334–335
Track Changes command, 39
turning off AutoComplete feature, 75
two-variable data table, creating, 259–261
Type option (Chart Tools contextual tab), 291
unanchoring cell cursor, 106
Underline button (Font group), 111
underlining, 112
Undo button (Quick Access toolbar), 18, 41, 150, 151
Undo Clear ToolTip, 150
Undo command, 18
Undo feature
   deleting record from data list and, 325
   deleting worksheet and, 237
   moving worksheet and, 248
   overview of, 364
unfreezing window pane, 211
Ungroup command, 40
ungrouping graphic objects, 315
Unhide Columns command, 38
Unhide command, 40
Unhide Rows command, 37
Unhide Sheet command, 38
unhiding. See also hiding
   column or row, 125–126
   Personal Macro Workbook, 353
unloading built-in add-in programs, 345
unlocking cell, 229
unprotecting worksheet or workbook, 229
Use in Formula command, 37
Use Relative References option (Macro button drop-down menu), 351–352
user interface, 11. See also Ribbon interface

Web page query, 341–342
Web sites
   Adobe Reader software, 95
   Microsoft Office Online, 343
searching, 225
what-if analysis
   Data Tables, 256–261
   Goal Seek, 261–263
   overview of, 255
   Scenario Manager, 264–267
   Solver add-in, 267
width of column, setting, 123–124
wildcard, 222
Window menu commands, 40
window pane
   freezing, 209–212
   opening worksheets in, 240–245
   splitting, 206–209
   unfreezing, 211
   uses of, 209
Windows of Active Workbook option
   (Arrange Windows dialog box), 243
Windows Vista
   creating desktop shortcut for, 30–31
   Open dialog box, 142–144
   Save As dialog box in, 91–92
searching for workbook in, 147–148
starting Excel from, 29, 361
Windows XP
creating desktop shortcut for, 31–32
Open dialog box, 144–146
Save As dialog box in, 92–93
searching for workbook in, 148–149
starting Excel from, 29, 361
WordArt, 308–310
workbook
activating and displaying, 27
changing default number of worksheets in, 237
changing order of worksheets in, 239–240
deleting worksheet from, 237
description of, 231
entering data into, 52–55
inserting worksheet into, 236
naming, 363
navigating, 26–27
opening, 52, 142
opening more than one, 146
opening recently edited, 146–147
organizing worksheets in, 232
protecting shared, 229
renaming, 91
starting new, 361
worksheet
activating for editing, 27
adding to workbook, 26–27
assigning color to, 238–239
breaking into pages for printing, 174
changing order of, 239–240
comparing two, 245–246
copying, 239–240, 246–249
deleting from workbook, 237
description of, 231
editing, 142
editing multiple, 235–236
hyperlink, adding, 345–348
inserting into workbook, 236
moving, 240, 246–249
moving pivot chart to its own, 282
opening in window pane, 240–245
printing from Print dialog box, 178–180
printing using Quick Print button, 177–178
renaming, 237–238
selecting multiple, 235–236
space conservation in, 52–53
summary, creating, 249–252
working with multiple, 232–238
Worksheet area
display of, 14
illustration of, 13
navigating, 22–25
scroll bars, using, 25–26
splitting, 206–209
workbook, navigating, 26–27
Wrap Text button (Alignment group), 44, 111, 131

• X •
x-axis, 288, 298–299
.XLS file format, 49, 94
.xlsb filename extension, 95
.XLSX file format, 49–50, 94

• Y •
y-axis, 288, 298–299

• Z •
Zip Code format, 122
Zoom button (Status bar), 28
Zoom command, 43
Zoom dialog box, 206
Zoom slider, 204–206, 358