COMPUTER COURSE FOR WORKING PROFESSIONALS

Centre for Electronics Design & Technology of India
A Scientific Society under Department of Electronics, Govt. of India, New Delhi
FOREWORD

The information technology and telecom sectors have suddenly opened up avenues, which require a very large specially trained manpower. These sectors are highly dynamic and need training and re-training of manpower at a rapid rate. The growing gap of requirement of the industry and its fulfillment has created a challenging situation before manpower training institutes of the country. To meet this challenge most effectively, Centre for Electronics Design and Technology of India (CEDTI) has launched its nation-wide franchising scheme.

Centre for Electronics Design and Technology of India (CEDTI) is an Autonomous Scientific Society under the Govt. of India, Department of Electronics with its Headquarters at New Delhi. It operates seven centres located at Aurangabad, Calicut, Gorakhpur, Imphal, Mohali, Jammu and Tezpur. The scheme will be implemented and coordinated by these centres.

The scheme endeavours to promote high quality computer and information technology education in the country at an affordable cost while ensuring uniform standards in order to build a national resource of trained manpower. Low course fees will make this education available to people in relatively small, semi urban and rural areas. State-of-the-art training will be provided keeping in view the existing and emerging needs of the industrial and Govt. sectors. The examinations will be conducted by CEDTI and certificates will also be awarded by CEDTI. The scheme will be operated through all the seven centres of CEDTI.

The CEDTI functions under the overall control and guidance of the Governing Council with Secretary, Department of Electronics as its Chairman. The members of the council are drawn from scientific, government and industrial sectors. The Centres have separate executive committees headed by Director General, CEDTI. The members of these committees are from academic/professional institutes, state governments, industry and department of electronics.

CEDTI is a quality conscious organisation and has taken steps to formally get recognition of the quality and standards in various activities. CEDTI, Mohali was granted the prestigious ISO 9002 certificate in 1997. The other centres have taken steps to obtain the certification as early as possible. This quality consciousness will assist CEDTI in globalizing some of its activities. In keeping with its philosophy of ‘Quality in every Activity’, CEDTI will endeavour to impart state of the art – computer and IT training through its franchising scheme.

The thrust of the Software Courses is to train the students at various levels to carry out the Management Information System functions of a medium sized establishment, manufacture Software for domestic and export use, make multimedia presentations for management and effectively produce various manufacturing and architectural designs.
The thrust of the Hardware Courses at Technician and Telecommunication Equipment Maintenance Course levels is to train the students to diagnose the faults and carry out repairs at card level in computers, instruments, EPABX, Fax etc. and other office equipment. At Engineer and Network Engineer levels the thrust is to train them as System Engineers to install and supervise the Window NT, Netware and Unix Networking Systems and repair Microcontrollers / Microprocessor based electronic applications.

An Advisory Committee comprising eminent and expert personalities from the Information Technology field have been constituted to advise CEDTI on introduction of new courses and revising the syllabus of existing courses to meet the changing IT needs of the trade, industry and service sectors. The ultimate objective is to provide industry-specific quality education in modular form to supplement the formal education.

The study material has been prepared by the CEDTI, document centre. It is based on the vast and rich instructional experience of all the CEDTI centres. Any suggestions on the improvement of the study material will be most welcome.

(R. S. Khandpur)
Director General (CEDTI)
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>UNIT</th>
<th>CHAPTER NAME</th>
<th>PAGE NO.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>IT Tools: An Overview &amp; Computer Systems</td>
<td>09</td>
</tr>
<tr>
<td>2</td>
<td>Windows 95</td>
<td>21</td>
</tr>
<tr>
<td>3</td>
<td>Word Processing</td>
<td>35</td>
</tr>
<tr>
<td>4</td>
<td>Excel</td>
<td>55</td>
</tr>
<tr>
<td>5</td>
<td>Presentations</td>
<td>81</td>
</tr>
<tr>
<td>6</td>
<td>Networking and Internet</td>
<td>95</td>
</tr>
<tr>
<td>7</td>
<td>E-Commerce</td>
<td>127</td>
</tr>
</tbody>
</table>
PREFACE

Generation of high quality skilled manpower in computer software area assumed great significance in the context of the changed global scenario. In India, the 1980s witnessed a rapid growth and transformation of Information Technology generating tremendous career opportunities in its wake.

Obsolescence in the computer field is an accepted fact. In this context, the need for updating syllabus, keeping the requirements of the industry, assumes significance.

The rapid spread of Information Technology, in the late eighties, generated ample career opportunities. To fill this escalating demand for computer professionals, a large number of Private Institutions mushroomed, with varying degrees of excellence from very good to abysmally bad; the latter charging exorbitant fees without extending commensurate training to their students.
“The moment man first picked up a stone or a branch to use it as a tool, he altered irrevocably the balance between him and his environment. While the number of these tools remained small, their effect took a long time to spread and to cause change. But as they increased, so did their effects: the more the tools, the faster the rate of change.”

IT TOOLS : AN OVERVIEW

COMPETENCY OBJECTIVES

The objective of this Section is to make students aware of the basics tools involved in the Information Technology. At the end of the course, a student should be able to :-

- Understand the importance of computers in personal and professional fields.
- Understand and relate the concepts of Software and Hardware.
- Understand the basics of Operating Systems.
- Familiarise with the basic components of the Computer System and use the various Input/Output devices effectively.
WHAT IS A COMPUTER?

A computer is a general-purpose machine that processes input according to a set of instructions. A personal computer refers to a small electronic data processing machine meant for individual use. The computer as a machine and all other equipment associated with it constitutes hardware. The instructions that tell the computer what to do are called software.

The main components of a computer are
1. Central Processing Unit
2. Input Devices/media
3. Output Devices/media
Some special purpose devices and media are also available.

Central Processing Unit (CPU)

1. Is the brain of the computer.
2. Its basic function is to perform calculations and various logical functions
3. It consists of three parts: Control Unit, ALU, Memory Unit.
**Control Unit**

- Consists of electronic circuits.
- Selects interprets and executes instructions.
- Governs Input/Output (I/O) operations, data transfer to and from storage and guides the routing of data between storage location and the arithmetic and logic unit.

**Arithmetic and Logic Unit (ALU)**

- Consists of electronic circuits.
- Performs calculations and comparisons.
- Works at tremendous speed and executes millions of instructions per second.

**Memory or Storage**

- Also called internal storage or main memory or random access memory (RAM).
- Consists of very fast memories like magnetic core memory or semiconductor memory.
- Stores program instructions or part of data for immediate need.
- Data is stored in a computer memory of words, bytes and bits.

Memory is divided into small parts called locations. Each location has a unique address. Location is further subdivided into bits. Different computers have a different location size varying from 8 to 64 bits.

```
0 2 3 4 5 6 7 8 9 10 11 12 13 14
```

The smallest unit of memory measurement is known as bit. Each bit is represented by 0 or 1.

**Bytes**

Number of consecutive bits combine to make a byte. Most commonly used combination is of 8 bits. Size of main memory is given in KB or MB.

- Kilobyte (KB) = 1024 bytes = 2^10 bytes
- Megabyte (MB) = 1024 KB = 1024 x 1024 bytes = 2^20 bytes
- Gigabyte (GB) = 1024 MB = 1024 x 1024 KB = 1024x1024x1024 bytes

**Data**

Data is a general term used to denote any or all facts number letter, symbols etc. that can be processed or manipulated or produced by a computer.

Data is divided into two categories

- Numeric
- Alphanumeric

Numeric data are there represented by only 0-9. Examples of Numeric data are 100, 20025 and 10.20
Alpha Numeric data are those represented by the computer of 0-9, A-Z and special character ( -, $, 1 etc).
Examples of Alphanumeric data are A25 – 001, Ram Kumar

**DATA PROCESSING CYCLE**

All computer systems perform the following five basic operations:

1. **Input process**: Data is collected and entered into the computer. This is called input process.
2. **Storage process**: What is entered into the computer is stored in its main memory. This storage is temporary i.e. the contents of the memory are lost when the power is switched off. Another memory, called secondary memory, is used to store the information of the main memory permanently.
3. **Processing**: The sequence of actions that are performed on the data stored in the main memory, to get results is called processing. Results are stored in the main memory till they are transferred to an output device.
4. **Output Process**: Stored results are taken out of the main memory. This process is known as output.

![Fig. 1.2](image)

5. **Controlling**: Directing the manner and sequence in which all of the above operations are performed is called controlling

**HARDWARE**

Hardware refers to the physical components of a data processing system. Input, storage, processing and control devices are hardware professionals deal with the manufacturing and maintenance of computers

**SOFTWARE**

Software refers to a set of computer programs and procedures for the effective operation of a data processing system. Without software, hardware is of no use; It cannot produce any results. Software engineers (Programmers, systems analysts) develop and maintain software.

**WHAT IS A PROGRAM?**

A program is a set of instructions, given to the computer in a particular sequence for solving a given problem.
It consists of a set of operations (add, subtract, multiply, divide, move, compare etc.) to be performed by the computer on the data to produce necessary results.

Programming is done in one of the computer languages.

Persons doing this job, called programmers, should have the knowledge of the instruction set required for solving the problem and the computer language(s) required to be used to write these instructions.

There are two broad categories of software:
- Application software
- System software.

**Application Software**

Refer to programs or sets of programs that perform a specific processing application. For example, an application package for processing examination results produces mark sheets as the major output, along with other reports such a merit lists, total number of students passed etc. Other examples are payroll packages, inventory control etc.

**System Software**

Consists of sets of general programs designed to control the operation of a computer system. Without system software, application packages cannot be executed. Examples are control program, processing programs etc.

**OPERATING SYSTEM (OS)**

Operating system is a set of programs written specially to manage all the resources and operations of a computer. Operating System manages automatically all the application programs, special programs needed in between the application programs and the data needed by these application programs, by calling them whenever needed. It also takes care of hardware functioning.

On the basis of functioning and facilities provided by them, Operating System can be classified as follows:

**Single User Operating System**

These Operating Systems allow only one user to work on a computer at a time. For example: *MS-DOS*

**Multi User Operating System**

These Operating Systems allow more than one user to work on the computer at the same time. These operating systems allocate memory in such a way that different users can work simultaneously without disturbing each other. It also allocates the processing time in such a way that every user gets a very quick response from the machine. These are also known as TimeSharing Operating System. For examples: *UNIX, XENIX, VMS, WINDOW NT SERVER, LAN.*
PROCESSING PROGRAMS

Processing programs are the programs which take care of application programs running on the computer. These programs work under the supervision of control programs. They help the application program to do the actual data processing. These are basically of two types:

- **Language Translators** are system programs that translate program written by the user in high level language to machine language. Examples are compilers and assemblers.
- **Service Programs Or Utility Programs** are a set of programs which execute tasks frequently required in data processing. Those tasks are of a routine nature that all computer users require their machine to perform from time to time (storing, copying etc.) Examples are sort/merge programs to arrange unsequenced data into specified sequence, debugging tools to help the user to locate and correct logical errors in the program etc.

SOME PROCESSING PROGRAMS

**Linker**
A program that links the separately translated modules to form an absolute load module to be run as a unit.

**Loader**
A program that loads the absolute load module into main memory.

**Interpreter**
A program that translated each instruction of high level language and also executes instructions before passing on to the next instruction.

BASIC COMPONENTS OF A COMPUTER SYSTEM

The five major functional units of a digital computer are:

- **CPU**
- **Peripheral**
- **Storage Devices**
- **Media**
- **Communication interface**

Central Processing Unit (CPU)

The CPU is the brain of a computer. Its primary function is to execute programs. Besides executing programs, the CPU also controls the operation of all other components such as memory, input and output devices. Under its control, programs and data are stored in the memory and outputs are displayed on the CRT screen or printed on paper, once processing has taken place.
The CPU of a small computer has a single microprocessor. The CPU of a large computer may contain a number of microprocessors on one or more circuit boards. Each microprocessor in a large CPU performs a specific task. A microprocessor contains a control unit and an arithmetic and logic unit (ALU). When main memory is added to a microprocessor, it forms a CPU.

The major sections of a CPU are:

a) Primary Memory
b) Arithmetic and Logic unit (ALU)
c) Control unit
Primary Memory

Memory is the computer’s working storage. It is one of the most important parts of the computer, as it determines the size and number of programs that can be simultaneously held within the computer, as well as the amount of data that can be processed immediately. Primary memory is a fast random access memory (RAM). It also stores the necessary programs of system software, which are required to execute user programs. The main memory is directly addressed by the CPU. There are two types of memories from technology point of view:

a) Analog memory or magnetic core memory
b) Digital memory or IC memory

Analog Memory

This type of memory was used in computers built during 1960s. The basic storage device in this type of memory consists of a small toroidal (ring shaped) piece of magnetic material called a magnetic core. Each magnetic core in a memory is capable of storing one binary digit of digital information. Depending on the direction of the current through the input winding, the core will become magnetized in either clockwise or counter-clockwise direction. The retentivity of the core material is such that when the magnetizing force is removed, the core remains magnetized, retaining a large part of its flux. These memory devices are now obsolete and have been taken over by digital memory devices which consume very little power.

Digital Memory or Semiconductor Memory

Semiconductor memories are static, lighter, cheaper than magnetic core memories. These are volatile and data stored in them is lost when power supply to the machine is switched off.

Digital memory can be divided into the following two types:
- RAM (random access memory)
- ROM (read only memory)

RAM (Read/Write)

RAM is a read/write memory. Information can be written into and read from a RAM. It is a volatile memory. It retains the stored information as long as it is supplied with power. When power supply is switched off or interrupted the stored information in the RAM is lost. RAMs of various capacities are available, for example, 1K 4K, 16K, 64K, 1M, 4M, and so on. Intel 21019 is a dynamic RAM of 1 MB x 9-bit capacity.

Static and Dynamic RAM

There are two important types of RAMs: static RAM and dynamic RAM. Static RAMs retain stored information only as long as the power supply is on. But a dynamic RAM loses its stored information in a very short time (a few milliseconds) even though the power supply is on. Therefore, dynamic RAMs have to be refreshed periodically, generally every 2 milliseconds. The dynamic RAMs are cheaper and have high packing density and moderate speed. They consume less power. They are used where large capacity memories is needed. Static RAMs are costlier and consume more power. They do not need
refreshing circuitry. They have higher speeds than dynamic RAMs. Static RAM and dynamic RAM are also written as SRAM and DRAM respectively.

ROM

ROM is a permanent type memory. Its contents are not lost when power supply is switched off. The user cannot write into a ROM. Its contents are written into at manufacturing time. ROMs store permanent programs and other types of information which are needed by the computer to execute user programs. ROMs store functions such as sine, cosine, logarithm, square root, exponential and code conversion tables, etc. An example of a ROM is Toshiba Mask ROM, TCS 534000, 512K x 8 bits.

PROM

Programmable ROMs called PROMs are also available. Further, different types of PROMs such as erasable PROM called EPROM, electrically erasable PROM called E2 PROM are available. Users can write information in PROMs, EPROMS and E2PROMs. Once programmed the recorded information into an EPROM or E2PROM can be erased to record different information, whereas in a PROM the information once written by the user cannot be changed. Such information is required while executing user programs. An example of PROM is 74S287.

Volatility of Memory

Volatile memory is memory whose contents are lost when power is switched off. A computer’s main memory, made up of dynamic RAM or static RAM chips, loses its contents immediately upon interruption of power. A random access memory (RAM) is volatile but core memory containing magnetic elements is not volatile.

Arithmetic Logic Unit (ALU)

The arithmetic logic unit of computer system is the place where the actual execution of instruments place during the processing operation. To be more precise, all calculations are performed and all comparisons decisions are made in the ALU. The date and instructions, stored in the primary storage prior to processing, are transferred, as and when needed, to the ALU where processing takes place. No processing is done in the primary storage unit. Intermediate results generated in the ALU are temporarily stored in the primary storage until needed again at a take time.

INPUT – OUTPUT DEVICES

Data and instructions are entered into a computer through input devices. Similarly, the computer system needs and output device to communicate the processed information to the user. Common types of output devices are monitor, printer etc. But there are certain devices which can serve as input as well output devices like tape drive, floppy drive, disk drive etc.
**Computer Fundamentals**

**Keyboard**

Computer keyboard is an electromechanical component designed to create special standardized electronic codes when a key is pressed. The codes are transmitted along the cable that connects the keyboard to the computer system unit or terminal, where the incoming code is analysed and converted into the appropriate computer usable code.

Keyboards come in a variety of sized and shapes having a number of features in common:
1. Standard Type Writer keys
2. Function keys
3. Special purpose keys
4. Cursor movement keys
5. Numeric keys

**Mouse**

The mouse is an input device that is much in use nowadays in graphics as well as when working with a GUI (Graphical User Interface). A mouse is also a pointing device. It is held in one hand and mouse access a flat surface. Its movement and the direction of the permanent is detected by two wheels on the underside of the mouse.

**Video Display Units (VDU)**

Video display units are the most popular I/O Devices used today in direct access processing application. A typewriter like keyboard is used to enter data into the computer, and a cathod ray tube (CRT) that looks like a television screen is used to display the input data as well as the messages and processed output from the computer.

**Printers**

Printers are the most popular output devices. They provide information in a permanent readable form. They produce printed outputs of results, programs and data. A character printer prints one character of the text at a time. They are low-speed printers. Their printing speed lies in the range of 30-600 characters per second. The character printers can be classified as:

a) Impact printers
b) Non-impact printers
Impact printers use an electro-mechanical mechanism that causes hammers or pins to strike against a ribbon and paper to print the text. Two types of impact character printers are available: dot-matrix printers and letter quality printers. Non-impact printers do not use any electro-mechanical printing head to strike against ribbon and paper. They use thermal, chemical, electrostatic, laser beam or inkjet technology for printing the text. Usually a non-impact type printer is faster than an impact type. The disadvantage of non-impact type printers is that they produce only a single copy of the text whereas impact printers produce multiple copies of the text.
"The successful organisation of the next decade will be the ones that use digital tools to re-invent the way they work. These companies will make decisions quickly, act efficiently and directly touch their customers in positive ways."

WINDOWS 95

COMPETENCY OBJECTIVES

The objective of this Section is to make students understand the Microsoft® Windows 95 Operating system and the easy-to-use features of Graphics User Interface. At the end of the course, a student should be able to :-

- Boot up and Shut down in Windows
- Appreciate various Windows features
- Work effectively in various applications and Accessories available with Windows
- Handle various Files format
- Use Windows Help
Microsoft Windows 95 is a powerful operating environment that enables you to access the power of computers without memorizing operational commands and their syntax. Windows 95 uses Graphical User Interface (GUI) so that you can easily see on screen the tools that you need to complete specific file and program management tasks.

As soon as the booting is done through a Windows 95 Operating system you get the following screen.

![Microsoft Windows Desktop Screen](image)

**Fig. 2-1 : Microsoft Windows Desktop Screen**

Depending on how your computer is set up, various items appear on your desktop when you start Windows. Here are four important ones:-

**My Computer**

On double-clicking this icon you see the computer’s contents and subsequently you can manage your files. Your documents and programs are stored in folders, which you can see in My Computer and Windows Explorer. In previous versions of Windows, folders were called directories.

**Network Neighborhood**

If you are using a network, the Network Neighborhood icon appears on your desktop. Double-click it to browse through the computers in your workgroup and the computers on your entire network.
Recycle Bin

The Recycle Bin is a temporary storage place for deleted files. So whatever is to be omitted can be sent to the Recycle Bin. Even after sending the unwanted files to Recycle Bin, if you feel at some later stages that you need the same files again, you can always restore the files by entering the Bin and giving the Restore command. You can also use this property to retrieve the files deleted in error.

Start Button

You can click the Start button on the taskbar to start a program, open a document, change system settings, get Help, find items on your computer, and much more.

TO START AND SHUTDOWN WINDOWS’ 95

The first thing you need to known about Windows 95 is how to start the software. However, before you can start Windows 95, it must be installed on your computer.

To Start Windows 95

In most cases, Windows starts automatically when you turn on your computer.

When you start the Windows program, a Microsoft Windows 95 banner displays for a few seconds; then a desktop appears (see figure 2.1)

Program icons that were created during installation (such as My Computer, Recycle Bin) are displayed on the desktop. Other icons may also appear, depending on how your system is set up. Shortcuts to frequently used objects (documents, printers and networks) can be placed on the desktop. The taskbar appears along the bottom edge of the desktop. The Start button appears at the left end of the taskbar.

To Shutdown Windows 95

You need to shut down Windows before you turn off or restart your computer. That way you can be sure your work is saved to your hard disk.

To avoid damaging files, always shut down Windows before you turn off your computer.

1. Click on the Start button, and then click on the Shut Down option.
2. Now click on the Yes option. If you forgot to save changes to documents, Windows prompts you to save changes.
A screen message lets you know when you can safely turn off your computer.

![Shutdown Windows dialog box](image)

**Fig. 2-2 : Shutdown Windows**

**Fig. 2-3 : Shutdown Dialog Box Options**

**WINDOWS EXPLORER**

A Windows Explorer is a Windows 95 based package for File Management and Program Management.

To start Windows Explorer, follows the below steps:

1. Click on `Start` button on the left corner of your Windows.
2. Select *Programs > Windows Explorer*, then press ENTER key.
Fig. 2-4: To start Windows Explorer

Windows displays Explorer window. The left portion of the screen is known is Folders span and the right side portion is known as Files and Folders span.

Creating A Folder

1. In My Computer or Windows Explorer, open the folder in which you want to create a new folder.
2. On the File menu, point towards New, and then click Folder. The new folder appears with a temporary name.
3. Type a name for the new folder, and then press ENTER.
Changing the Name of a File or Folder

1. In *My Computer* or *Windows Explorer*, click the file or folder you want to rename. You need not open it.
2. On the *File* menu, click *Rename*.
3. Type the new name, and then press ENTER key.

Note: A filename can contain up to 255 characters, including spaces. But it cannot contain any of the following characters: 
\/: * ? " < > |
Copy A File or Folder

1. Select the file or folder (that you want to copy) inside My Computer or Windows Explorer.
2. Click on Copy from the Edit Menu (or press Ctrl+C)
3. Open the destination folder or disk (by double clicking the icon) where are you want to put the copy.
4. Click Paste from the Edit menu.

If you want to select more than one file or folder to copy, hold down the CTRL key, and then click your desired items (one by one).

Moving A File or Folder

1. Select the file or folder (which you want to move) from My Computer or Windows Explorer.
2. Select Cut option or press Ctrl+X from the Edit menu.
3. Open the destination folder or disk where you want to put the file or folder.
4. Click Paste from the Edit menu.
Deleting A File or Folder

1. Locate the file or folder (which you want to delete) from \textit{My Computer} or \textit{Windows Explorer}.
2. Select the file or folder.
3. Select \textit{Delete} from the \textit{File} menu.

![Fig.2-10: Deleting a File or Folder](image)

Note: If you want to retrieve a deleted file, check inside the Recycle Bin. Your deleted file remains in the Recycle Bin until you empty it.

You can also drag the file or folder icons onto the Recycle Bin icon. If you press \textit{SHIFT} while dragging, the item will be deleted from your computer without being stored in the Recycle Bin.

Retrieving Deleted Files or Folders

1. Double-click the Recycle Bin icon on the desktop.
2. Select the file or folders or shortcut you want to retrieve. To retrieve more than one item, hold down the \textit{CTRL} key while clicking each one.
3. Select \textit{Restore} from the \textit{File} menu.

![Fig.2-11: Retrieving deleted files or folders](image)
Note: If you delete a folder, only the files within that folder appear in the Recycle Bin. If you restore a file that was originally located in a deleted folder, Windows recreates the folder and then restores the file to it.

Copying A File to Floppy Disk

1. Insert the floppy disk inside the floppy disk drive.
2. Select the file (you want to copy) inside My Computer or Windows Explorer.
3. On the File menu, point to Send To, and then click the drive you want to copy the file to.

FINDING A FILE OR FOLDER

For locating the name of a File/Folder or path of a File/Folder the following steps are to be followed. Even if you forget the path, you’ll learn in this chapter how to use this feature for finding files.

1. Click on the Start button, and then point towards Find.
2. Click Files or Folders.
3. In the Named box, type all or part of the file’s name.
If you do not know the name of a file or want to re-find the search, click the Date Modified or Advanced tab.
If you want to specify where the Windows should begin its search, click the option Browse.

**USING HELP**

Online help is very useful tool when you are learning and using Windows as Operating System. There are two kinds of Help: *Help about a specific procedure* and *Help that gives you information about what you see on the screen*.

Click on the Start button, and select the *Help* option.

The list of the help topics appears as shown below. You can use tabs in *Help* to search information in many ways.

When you open help by using the Start menu, or the Help in My Computer or Windows Explorer, you see Help for Windows in general. If you use Help menu in a program, such as Wordpad, Paint, or Microsoft Word, the Help which you see is for that particular program.
SETTING DATE AND TIME

To set a date & time, click on the Setting option and goto the Control Panel.

1. Select Date/Time option and double click on it.
A network is a group of computers connected to each other or to a central server so they can share resources such as documents and printers.

Your connection to a network can change the way you work:
1. You can use programs and documents from another computer without passing floppy disk back and forth.
2. You can print documents on a printer attached to another computer, or use another computer’s fax modem, just as if they were connected to your computer.
3. You can gain access to the Internet.
4. You may also be able to send and receive messages by using electronic-mail, or connect to your work computer from home.

If your computer is setup to use a network, the Network Neighborhood icon appears on the Desktop.

When you double-click Network Neighborhood, you might see the computers in your workgroup or any Netware servers you are connected to.

You can see other computers on the Network- those not in your workgroup- by double-clicking the Entire Network icon, which appears in Network neighborhood.

1. Click the Start button, point to Setting, and then click Control Panel.
2. Double-click Network.
3. Click Add
4. Click Adapter and then click Add.
5. Follows the instructions on your screen. If you don’t known what kind of adapter you have, check the documentation that came with it.

Fig.2-17: Network Component Type Window
To Share a Folder

1. Locate the folder you want to share and then click it.
2. On the File menu, click Sharing. (If sharing is not on the menu, you need to install file and printer sharing)
3. Click the options you want.

To Share your Printer

1. Click the Start button, point to Setting, and then click Printers.
2. In the Printers window, click the printer you want to share.
3. On the File menu, click Sharing.
4. Click the options you want.

To use a Share Folder

1. Double-click Network Neighborhood.
2. Double-click the Icon for the computer that contains the folder you want.
3. Double-click the folder that contains the document or program you want.

ASSIMILATION EXERCISE

1. Compare the various features of
   (i) DOS and WINDOWS 95
   (ii) WINDOWS 3.1 and WINDOWS 95
2. What is the purpose of control panel and what are the various settings available in it.
“IT has become the chief determinant of the progress of nations, communities and Individuals. It is a tool that will enable India to achieve the goal of becoming a strong, prosperous and self confident nation. IT will enable India to occupy a position of honour and pride in the comity of nations.”

WORD PROCESSING

COMPETENCY OBJECTIVES

The objective of this Section is to introduce the students to the basic principles of MS-Office and the salient features of the Microsoft® Word. At the end of the course, a student should be able to :-

- Appreciate the requirement of MS-Word for the Office Documentation work.
- Understand & implement salient features involved for using Mail-Merge.
- Carry out the printing jobs efficiently.
WHAT IS MICROSOFT WORD’97?

MS Word 97 is the most full-featured word processing program in use today. Word 97 makes use of all of the features available to programs designed specially to run under Windows 95 and Windows NT.

To start MS Word 97, go to the **Start > Program > Microsoft Word**.

ANATOMY OF THE WORD SCREEN

When you start Word two Windows appears on the screen, one nested within the other. The larger of the two is called Application windows, while the smaller one is the document window.

The application window is used to communicate with the Word Program. You use the document window to create and edit your Word document. At the top of Application window are the two rows of buttons and ruler that are designed to speed your work. Each of these rows is independent of each other and can be turned ON and OFF at your will. Each document that you open is displayed in its own Window. You can size a document and display more than one document within the Word Application window.
When you start Word, a new document window automatically opens, providing you with a blank text area, in which you can type your document.

Typing Text

Typing the following quotation. Do’t worry if you also make other typing mistakes; you will learn how to fix them in a moment.

*The difference between the right word and the almost right word is the difference between lighting and the lighting bug.*

Watch the screen as you type. Notices that Word automatically moves text down to the next line when it runs out of room near the right edge of the screen. This is called automatic word wrap, a common and useful word-processing feature.

Selecting Text

Word lets you do a lot with text after you have typed it. You can change its appearance, move it arrround, delete it, and copy it. The first step is always to tell Word which text you want to work with. This is done by selecting it. You can select text in many, many ways in Word. For instance, you can drag your mouse pointer over the text while holding down the primary mouse button. There are shortcuts for selecting individual words, lines, sentences, and paragraphs, which you will read about in a moment.

Deleting Text

To delete unwanted text, there are several ways. If you had spotted your mistake right after typing it, pressing Backspace key to delete it.

Even if you did not make the correction earliar, it is easy to go back now, select the undesired text, and remove it. Follow these steps:

1. Double-click one the word to be deleted. The entire word and the space following it become highlighted.
2. Press the Delete key once.
3. You can use Undo Clear if you accidentaly delete something of value.

Inserting Text

Word offers several ways to insert new text into an existing document. The most straightforward approach is to move the insertion point to the desired location and start typing. Word accomodates the new text by pushing the exiting text to the right and down as necessary.

Replacing Text

Word also makes it easy to replace text. It combines the steps of deleting unwanted text, positioning the insertion point, and inserting replacement text. Simply highlight the unwanted text and start typing. The old text disappears, and the new text snakes across the screen as you type it.
CREATING AND SAVING A NEW DOCUMENT

1. Select **File** menu, and click on New menu item.
2. Select **Blank Document** from the displayed dialog box.
3. Type the desired document text.
4. Save the document with **File>Save** command.

OPEN A DOCUMENT

1. Click **Open** from the **File** menu.
2. In the Look in box, click the drive, folder that contain the document.
3. Locate your folder from the folder list, double click folders until you open the folder that contains the document you want.
4. Double click the file name to open the file or type file name into file name text box and Click **Open** button.

SAVE A FILE USING A NEW NAME

To save your opened file with new file name, select **File>Save As..** command. Just pick the desired disk and file path, type the new file name and click **Save** button.
COPYING AND MOVING TEXT

Word supports all the usual Windows techniques for copying and moving information. It also provides a feature called drag-and drop, a handy one-step, mouse assisted mover.

Cut, Copy and Paste

The traditional way to move or duplicating things in Windows programs is to select the item, cut or copy it to the Clipboard, move the insertion point to the new location, and paste in the item.

Here are the steps:
1. Start by selecting the desired text.
2. Choose Edit > Cut or Press Ctrl+X. You can also click on the Cut button on the toolbar.
3. The selected text will disappear from the screen and will be placed on the Clipboard.
4. Now place the insertion point at the desired location(point and click).
5. Choose Edit->Paste or press Ctrl+V, or click on the Paste button to insert the word. The text will flow to the right and down as the Clipboard’s contents move into place.

PRINTING

Printing option is used to print your document on printer. To print an open document, choose File > Print command or Ctrl+P as the shortcut command.

The output of Print Dialog box looks as given below in the figure, just type the number of copies, range of pages and the printer source and paper size and choose OK.
Before we can take final hard-copies of a document, it is necessary to have an idea of how the document will appear in print. The Print Preview command from the file menu gives us a bird’s eye-view of the document. This feature of Word can save us a lot of paper and time. The preview shows us exactly how the document will get printed on paper. Moreover, the print preview is fully editable and allows us to see multiple pages on the screen. On executing the Print Preview… command of the File menu, the appearance of the screen changes. The screen shows a white page on which the entire document appears in fine print. In the single page view we get to see only one page at a time. But, the multiple page button allows us to specify as many pages as we want to fit on the screen.

The Zoom percentage list box allows us to view a page in different sizes.

**FORMATTING CHARACTERS AND PARAGRAPHS**

There are following steps to format selected characters or paragraphs.

**Changing the Font**

To change the font of selected text, just use **Format > Font** command and select your desired font name, size and their style from the font dialog box.
For example, here, we are changing the font size of My Document text to Times New Roman, size 20 and Bold face.

**My Document**

**Text Alignment**

The set the text alignment. Alignment can be set by using the following buttons on the formatting Toolbar. The buttons stand for Left, Center, Right and Justified alignment respectively. We can achieve the effect of using these buttons by using the following keystrokes:

<table>
<thead>
<tr>
<th>Short-cut key</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+F</td>
<td>Change Font</td>
</tr>
<tr>
<td>Ctrl+Shift+P</td>
<td>Change Point Size</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Bold</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Italics</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Underline</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Left Align</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Centre Align</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Right Align</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>Justify</td>
</tr>
<tr>
<td>Shift+F3</td>
<td>Change Case</td>
</tr>
</tbody>
</table>

**Changing Case**

Very often we need to change the case of text. This can be done through the Change Case command. On executing it the following dialog box gets displayed:

![Change Case dialog box]

**Paragraph Setting**

Adjust paragraph spacing:
1. Select the paragraphs whose spacing you want to change.
2. On the Format menu, click Paragraph, and then click the Indents and Spacing tab.
3. To add spacing before or after each paragraph, enter the spacing you want in the Before and After boxes under Spacing.

To change the spacing between each line, select the type of spacing you want in the Line spacing box.
Working With Columns

To set the number of columns into your document.

The Format > Columns menu selection to specify the number of columns, the space between columns, and whether or not the column setting should apply to the entire document, from the current point forward, or the current section.

You can also insert a line between columns by picking the Line between check box.

SPELL CHECKER

Checks spelling in the active document, including text in headers, footers, footnotes etc.

To quickly check spelling in a document, click the Spelling button on the Standard toolbar or Spelling from the Tools menu (F7 is the Shortcut key).

On running the spell check, the following dialog box is displayed. If the document is completely error free, the above box will not be displayed.
FIND AND REPLACE

Find Text
 Searches for specified text. Choose **Find** from the Edit menu

**Dialog Box Options**

**Find What**
Type, or insert the information you want to find, or click the down arrow, and then select from the last four entries. For information on searching for formatted text, see Finding text and formatting.

**Search**
Set the direction of the search.

**Match Case**
Finds only those occurrences with the exact combination of uppercase and lowercase letters specified in the Find What box. Word considers only the case of letters as they were originally typed, even if they have been capitalized with the Small Caps or All Caps character format.

**Find Next**
Finds and selects the next occurrence of the text or formatting specified in the Find What box.

**Replace**
Opens the Replace dialog box, retaining any information typed in the Find What box. In the Replace With box, type the replacement text, and then specify any formatting you want to apply.

**Replace Text**
Replace the searched text with the specified text.
From the Edit menu, choose **Replace**.

or

In the Find dialog box, choose **Replace** button. After typing the search text, do one of the following:

<table>
<thead>
<tr>
<th>Description</th>
<th>Button</th>
</tr>
</thead>
<tbody>
<tr>
<td>Replace text and find the next occurrence.</td>
<td>Replace All</td>
</tr>
<tr>
<td>Change all occurrence without confirmation.</td>
<td>Replace All</td>
</tr>
<tr>
<td>Leave the text unchanged and search for the next occurrence.</td>
<td>Find Next</td>
</tr>
</tbody>
</table>

**WORKING WITH TABLES**

A table is simply information arranged in rows and columns. In Word, to create a table, draw a table into your document a Table menu is available.

To insert a new table into your document; select **Insert Table** from Table menu or insert Table button from the toolbar.

To use the **Insert Table** button; drag the desired number of rows and columns, and release the button. A blank table is inserted at the cursor position.

Using the **Insert Table Dialog box**; lets you specify how many columns and rows you want. You can also define the table outlook by AutoFormat button.

Using the **Convert Text to Table Dialog box**; If you have tabular text or numbers in which columns seperated by tabs, you can select the tabular text and then use the **Table|Convert Text to Table** dialog box.
Change the Column Width

1. Select the columns whose width you want to adjust.
2. Select **Cell Height and Width** from Table menu, and then click the Column tab.
3. To specify an exact measurement, enter a number in the Width of column box.

To make the column width fit the contents, click **AutoFit**.

Sum a Rows or Columns of Numbers

1. Click the cell in which you want the sum to appear.
2. On the Table menu, click **Formula**.

If the cell you selected is at the bottom of a column of numbers. Word proposes the formula=SUM(ABOVE). Click OK if this is correct.

If the cell you selected is at the right end of numbers. Word proposes the formula=SUM(LEFT). Click OK if this is correct.

<table>
<thead>
<tr>
<th>Emp No</th>
<th>Name of Employee</th>
<th>Designation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ITD01</td>
<td>Rakesh Soni</td>
<td>S/w Engineer</td>
</tr>
<tr>
<td>ITD02</td>
<td>Ram Naresh Mahapatra</td>
<td>H/w Engineer</td>
</tr>
</tbody>
</table>

WORKING WITH CHARTS AND GRAPHS

This section introduces you to Microsoft Graph 97 Chart, or simply “Graph”, which is an easy-to-use Office 97 add-in that gives you the ability to create and insert charts into your documents.

The Graph program displays a datasheet table and graph when first launched.

Creating a Chart

1. In Microsoft Word, click **Insert|Object** command, and click the Create New tab.
2. In the Object dialog box, click **Microsoft Graph 97**.
3. To place the object in the drawing layer, where you can position it by using commands on the **Draw** menu on the Drawing toolbar, select Float over text check box.
4. Click OK.
5. To replace the sample data, click a cell on the datasheet, and then type the information you want.
6. To return to Word, click the Word document.
Add a Title to a Chart or Axis

1. In Word, double click the chart to which you want to add a title.
2. On the Chart menu, click Chart Options, and then click the Title tab.
3. To add a chart title, click in the Chart Title box, and then type the text you want.
   To add one or more axis titles, click in the appropriate box for each title, and then type the text you want.
4. To return to Word, click the Word document.

Enter data on a Datasheet in Microsoft Graph

1. In Word, double click the chart to which you want to add data. The menus and toolbars change to show the Microsoft Graph menus and buttons.
2. Switch to the datasheet.
3. Click a cell, and then type the text or numbers you want.
4. To return to Word, click the Word document.
Select a different Chart Type

1. In Word, double click the chart you want to change.
2. To change the chart type of a data series, click the data series.
   To change the chart type of the entire chart, don’t anything in the chart.
3. On the Chart menu, click Chart Type.
4. To return to Word, click the Word document.

VIEWS

Views allow us to see the same document in many different forms. Changing the view does not change the document in any way. The document just gets displayed differently. We can change the view using the View menu or by clicking on the view button along the horizontal scroll bar. The illustrations given below will make the point clear.

The Normal View
This is the view in which we work normally. It is in this view that all the typing and editing is done. It just shows the text which has been typed with the applied formatting. The text runs from one end of the screen to the other. No margins, headers/footers will be shown in this view. Only the Horizontal Ruler is available in the normal view.

The Page Layout View
The Page Layout view shows the document in the way it will be printed. It shows the page in the background and also shows all the headers, footers, margins and frames at the positions they will appear.

The Outline View
In the outline view, we can collapse a document to see only the main headings or expand it to see the entire document. This makes it easy to move and copy text and to recognize long documents.

The Full Screen View
This allows us to see only a document on the screen. There are no rulers, toolbars, and other screen elements. In full screen view, we can choose commands with shortcut keys and display shortcut menus while we work. If we want to return to the previous view, we can click the Full Screen button in the bottom-right corner of the screen or press ESC.

The Print Preview
Print preview shows us entire pages at a reduced size so that we can view one or more pages at a time, check page breaks, and make changes to text and formatting.

HEADER AND FOOTERS

Headers and Footers are used to put such information as document or chapter title or page number at the top or bottom of each page.
The View > Header and Footer menu selection is used to create header and footer. A header is displayed and printed at the top of your page, while a footer is positioned at the bottom.

When a document is viewed in the Normal mode, the Header|Footer text is not displayed. In the Page Layout mode, Header|Footer text is displayed in light gray. You can double click on header or footer text to activate and edit it. Click Close to return to the document.

Inserting Date and Time

To insert a date and time, use the Insert > Date & Time… command.

After appearance of Date and Time dialog box, select the date or time format style and click OK. The desired date or time will appear at the current cursor position.

Inserting Page Number

To insert a page number, use Insert > Page Numbers command.

Define the Position, where do you want to insert page number and their alignment from the available list.

Removing Page Numbers

To remove page numbers.
1. Open a Header and Footers containing page numbers.
2. Choose Edit-> Select All or Press Ctrl+A.
3. Delete a Page number. The rest will disappear.
SETTING TABS

To set tabs with the dialog box:

1. Select **Format > Tabs** to display the Tabs dialog box.
2. To set tab, type its position in the Tab Set Position box and Select **Set**.

WORKING WITH PICTURES/GRAPHICS

Word can import graphics in a wide variety of formats, position the insertion point where you want the graphic then choose **Picture** from the Insert menu. Select a File and then choose OK button.

Microsoft Office actually comes with some clipart gallery. Different drawing files created by another packages, scanners, and other graphics tools can also import into your documents.

1. Place the insertion point, where you want the picture to appear. Choose **Insert > Picture** menu selection.
2. Click the desired file to import, click to OK button to insert it.

WORKING WITH DRAWING

Word97 offers so many drawing objects. You can insert a line, Auto shapes, Flow chart symbols, and much more.
Add a border or a line to a Drawing Objects

1. Select the drawing object you want to change.
2. Click Drawing to display the drawing toolbar.
3. To add a color to the line or border, click the arrow next to Line Color, and then click the color you want.

Add or change gradient, patterned, textured, or picture fill in a Drawing Objects

1. Select the drawing object you want to change.
2. On the drawing toolbar, click the arrow next to Fill Color, click Fill Effects, and then click the Gradient, Texture, Pattern, or Picture tab.
3. Select the options you want.

Change a fill color in a Drawing Objects

1. Select the drawing object you want to change.
2. On the Drawing toolbar, click the arrow next to Fill Color.
3. Click the color you want.

Add or Change the 3-D effect of a Drawing Objects

1. Select the drawing object you want to change.
2. On the Drawing toolbar, click 3-D.

MAIL MERGE

In many kinds of business documents, we find that the same matter is sent, possibly with some minor modifications, to different recipients. A classic example is the letter that Reader’s Digest keeps sending to its half-million subscribers.

MS-Word provide a feature exclusively created to cater to such needs – Mail Merge. To use Mail Merge, we have to create two files - the Data source and Main document. The data source contains the details that differ from person to person, while the main document contains the body text which is constant. Placeholders in the main document indicate where the variable details are to appear. In word terminology, these placeholders are known as Fields.

There is one basic method that is used to Mail Merge files, though it can be applied in many ways. The simplest way is outlined below. The **Tools > Mail Merge** menu selection command is used to merge a list of information, such as name, address, city etc into a documents. The main document contains merge fields into which data is placed.
Create a Data File

1. Open a new blank document.
2. Create your data by either typing it into a table, worksheet, or importing from a database.
3. Save your document.

Merge Data File in a Document

1. Click the New Document.
2. Select Tools>Mail Merge to display the Mail Merge Helper dialog box.
3. Click the Create button to display a list of Mail Merge choices.
4. Pick Form Letters.
5. Use the Get Data button of the Mail Merge Helper dialog box to specify the data resources you want to use.
6. Now create a main document that resembles the following one, using the Insert Merge Fields button to pick the Insert the merge field names at the cursor position.

If you wish to print your document, Press Merge to Printer button to print it.

7. Save the document.
8. Use the View Merged Data, Next Record, Previous Record buttons to see how the data loads when merged.

Dear <<Fname>>,
Refer to your quotation number <<number>> dated <<date>>. We are sending our PO as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Quantity</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pen</td>
<td>10</td>
<td>3.50/-</td>
</tr>
</tbody>
</table>

PRINTING ENVELOPES & LABELS

Printing Envelopes

To open the Envelopes and Labels dialog box, choose Tools-> Envelopes and labels. In this dialog box you can:
Computer Fundamentals

- Print envelopes containing one-time addresses that you type into the dialog box itself.
- Copy and address from your document for envelope printing.
- Type envelope addresses and then insert them into your letters or other Word documents.
- Ready indexes
- Rotary cards
- Shipping labels
- Videotape labels
- WordSaver tabs

Printing Labels

Simple label printing is a lot like envelope printing. Here are the steps:

1. Select the address in your document if it has one.
2. To open the Envelopes and Labels dialog box, choose Tools-> Envelopes and labels.
3. Click on the Labels tab if it is not already foremost. You will see the options illustrated in the figure below.
4. If you selected and address in step 1 or if Word finds one on its own, you will see it in the dialog box; if not, type an address in the big box.

5. Choose the desired options in the main Labels tab. To print a single label on a multilabel sheet, click on Single Label and specify the row and column location of the label. Choose to print or not print the bar code and return address.
6. To select different label sizes, click either on the picture of a label or on the Options button.
7. Select the Label maker, label product number, and printer type.
8. Fine-tune Top and Side margins here if your printer prints all the labels of the current type too high or too far left or right. The other settings are probably correct if you selected the correct label type back in step 6. When you have made all your choices, click on OK once or twice as necessary to return to the Label tab of the Envelopes and Labels dialog box.
9. Insert a label sheet of labels in your printer.
10. Click on the Print button.
ASSIMILATION EXERCISE

Q.1 What do you mean by ‘Word Wrap’?

Q.2 How do you add the Borders Toolbar in the screen area?

Q.3 How do you convert a document file into a Template?

Q.4 You are on the top of the document which is 30 pages long. How do you reach at the end of the document without using the normal down arrows or the vertical scroll bar?

Q.5 How do you open a memorandum which comes as a complimentary part of MS-WORD ‘97?

Q.6 How do you change the page layout?
“India can be fully competitive in the area of IT with tremendous payoffs in terms of wealth creation and generation of high quality employment.”

**MS-EXCEL**

**COMPETENCY OBJECTIVES**

The objective of this Section is to make students understand the basics of Spreadsheet and to implement it in the practical applications effectively using the mathematical Functions & Charts, wherever necessary. At the end of the course, a student should be able to understand:

- The essentials of Spreadsheet.
- Outlining & Editing of the Spreadsheet.
- The usage of Functions and its implementation.
WHAT IS A SPREADSHEET?
The term spreadsheet was coined from an old financial accounting practice. Huge calculations, including those which could have major effects on other values, were manually performed on large sheets of paper to ease the process of erasing, changing and recalculating. These sheets were ruled into rows and columns. Huge collections of figures were set up in these “spread” sheets, and every time one of the variables changed, the entire set had to be recalculated and rewritten. This was obviously a very tedious process.

In 1976, Dan Bricklin developed a revolutionary computer program called VisiCalc. VisiCalc was an electronic spreadsheet: a collection of rows and columns that were displayed on the screen of a computer (the Apple computer, in those pre-PC days), into which figures and words could be typed. What made VisiCalc so popular was the fact that, unlike in manual spreadsheets, you could write formulae which were dependent on variable values. The advantage was that you did not have to do a single calculation! You just typed in the formula, and the computer did the calculating for you, that too, with great speed and accuracy. Most amazingly, if any of the values were changed, you did not have to rewrite everything. The computer automatically recalculated all the formulae for you.

The IBM-PC was launched in August 1981. Many applications, including VisiCalc, were ported over to this new computer. At this point of time, a new spreadsheet program, Lotus 1-2-3, was launched. Through the entire ‘80’s, the name “Lotus 1-2-3” was synonymous with the word spreadsheet. The ‘90’s, however, will be ruled by the Spreadsheet Supreme… Microsoft Excel.

WHAT DOES A SPREADSHEET DO?
Basically, a spreadsheet is useful to work with numbers, any work you would want to do with numbers, a spreadsheet is more oriented towards the application of numbers for business purposes, rather than scientific or mathematical applications. Activities like financial forecasting, budgeting, and performing financial analyses would be ideally done through a spreadsheet. On the other hand, a spreadsheet is not too good at solving differential equations, calculating integrals, and so on.

The most important feature of a spreadsheet is recalculation: the results of various formulae are recalculated automatically when any values that they depend on change in any way. As a result, once the basic “model” has been set up, you can experiment with different values of the variable factors to see how they reflect on the other figures. For example, after writing formulae which relate Net Profit to Production, Sales, Marketing Costs and Taxes, you may change any of these values to observe the
effect on Net Profit. This is something that is done quite often in real life, and Spreadsheeters worldwide have come up with the right term for it: “What-if Analysis”.

**SPREADSHEET BASICS**

A spreadsheet is a collection of text, numbers, formulae divided into horizontal rows and vertical columns. The intersection of a row and a column is called a *cell*. From this, it is evident that spreadsheets are extremely useful for tabulating data.

A typical spreadsheet may look as follows:

<table>
<thead>
<tr>
<th></th>
<th>Apr-Jun</th>
<th>Jul-Sep</th>
<th>Oct-Dec</th>
<th>Jan-Mar</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>6,000.00</td>
<td>5,000.00</td>
<td>6,000.00</td>
<td>7,000.00</td>
</tr>
<tr>
<td>Costs</td>
<td>3,500.00</td>
<td>4,000.00</td>
<td>2,000.00</td>
<td>4,500.00</td>
</tr>
<tr>
<td>Profit</td>
<td>2,500.00</td>
<td>1,000.00</td>
<td>4,000.00</td>
<td>2,500.00</td>
</tr>
</tbody>
</table>

Here, the horizontal series of items indicating Sales is contained in a *row*, the vertical one showing data for *Jul-Sep* is contained in a *column*, and the value *5,000.00* at the intersection of the row and column (The Sales for the period Jul-Sep) is contained in a *cell*.

**WHAT IS EXCEL?**

Microsoft Excel revolutionized the concept of spreadsheets from the moment it entered the market. First and foremost, it was written for the Microsoft Windows operating environment, which made it easier to use, and visually appealing. It actually made spreadsheeting fun. Then, it was WYSIWYG (What You See Is What You Get). You could actually see effects like bold, underline and italics to items directly on screen, combine figures and graphs on the same page, annotate with comments or pictures, and do just about anything else you could think of. The entire thing that you see on your monitor, will print out exactly as shown on paper. Being a Windows application, it made efficient use of computer memory and could handle huge amounts of data.

Subsequent releases of Excel have all introduced radical new concepts to the spreadsheet universe. The most widely used Microsoft Excel offers several additional tools to help in analyzing, arranging, and otherwise manipulating Worksheets. In addition to this, the Excel file which is called a *Workbook* can contain more than one Worksheets or charts, and even switching between these Worksheets or charts is just a click of a mouse button.

**STARTING EXCEL**

Since Excel is Microsoft Windows application, Windows has to be active to run Excel. Generally, Excel is found in a Program Manager group called Microsoft Excel 5.0 Double-click the group to open it up. Among other icons, you will see the Microsoft Excel icon.

Double-click the icon to start Excel.

**THE EXCEL SCREEN**

On starting Excel, the opening screen is displayed. It consists of two distinct parts: The *Application Window*, which is the outer window, and the *Workbook Window*, which is labeled “*Book 1*”. Both these windows have the regular control objects like the scroll bars, the control Menu box, the minimize and maximize buttons and so on. Thus, the windows can be moved, re-sized, and scrolled in the way.
Computer Fundamentals

(Most applications work with multiple data files. In such cases, the data files can be opened in several sub-Window within the main Application Window. These sub-Window are called Document Windows).

THE ANATOMY OF THE EXCEL SCREEN:

In the Application Window:
- **The Menu Bar**: The Menu bar contains various Menus that help us to control Excel’s actions and functions.
- **The Toolbar**: The Toolbar contains graphical buttons to represent simple, one-step actions.
- **The Formula Bar**: The Formula bar is divided into three sections, and is useful for editing a Worksheet. The first section shows you where you are in the Worksheet. The second and the third sections come into use when you are typing information into the Worksheet.
- **The Status Bar**: The Status bar, at the bottom of the screen, shows us various things about the current Status of Excel. For example, moving the help mouse pointer into a Toolbar button shows its function on the Status bar. Indicators like Caps Lock, Scroll Lock and Num Lock also show up on the Status bar. If you move the mouse pointer over an icon on the Toolbar, the Status bar will display a line of help describing the icon.

In the Workbook Window:
- **The Frame**: The Frame is the gray area stretching across the top and down the left side of the document window. It is marked with letters for the columns and numbers for the rows.
**The Gridlines**
The lines running down and across the document window are Gridlines. They separate the rows and the columns.

**The cells**
The rectangular boxes formed by intersecting Gridlines are the cells. A cell is the basic data unit in a Worksheet. Data is entered into a cell.

**The cell**
The dark rectangle around the first cell is the cell selector. It indicates **Selector** which cell we are on currently.

**The Sheet Tabs**
The Tabs located at the bottom of a workbook window indicating the Worksheets. When you click a sheet Tab, that sheet becomes the active sheet. The name on the active sheet Tab is always bold.

**The Tab Scrolling Buttons**
All Worksheet Tabs are not visible on the Sheet Tab scroll bar. The **Worksheet Tab Scrolling buttons** are used to scroll the Sheet Tabs one by one on the Sheet Tabs scroll bar. Tab Scrolling buttons just allow you to scroll through the Tabs to view them but they do not make that particular Worksheet active.

A workbook window dominates the Excel workspace. A new workbook originally consists of 16 individual Worksheets. Workbooks are great organizational tools. All Worksheets related to a specific project or maintained by an individual can be kept together in the same **Workbook**.

**CELL ADDRESSING**
You would have noticed that the Frame is marked with letters for columns, and numbers for rows. The Frame helps us to arrive at the **address** for a particular cell.

A cell is essentially an intersection of a row and a column. Since the cell is the basic data item in a spreadsheet, there ought to be a way to distinguish one cell from another. This is achieved using the cell address. Each cell has a unique address, which depends on its position in the Worksheet. A cell’s address is a combination of its column letter and its row number. Thus, the very first cell in the Worksheet is called cell **A1**. The one immediately to its right is **B1**, the one below it is **A2**, and so on.

How many cells can a Worksheet have? The row numbering starts at 1 and goes down to 65536. What about columns? The first twenty-six columns are marked with the letters A to Z. Columns thereafter proceed as follows: AA, AB, AC, AD…AZ, BA, BB, BC…and so on up to IV. This makes a total of 256 columns. The total number of cells in a Worksheet therefore, amount to $65536 \times 256$, which should be enough for **most** people.

**MOVING AROUND IN THE WORKSHEET**
At any given point of time, a user can work on only one cell. The cell selector always indicates this cell. Its address is also shown on the first section of the formula bar. There are several methods of moving the cell selector around in a Worksheet. Let us examine these methods.

**Using the Keyboard**
The arrow keys are used to move around the Worksheet one cell at a time. Tapping the Right Arrow once moves the cell selector to the next column. If you keep it pressed, the cursor will move steadily to the right. After reaching the extreme right of the screen, the Worksheet window scrolls to the left.
The Left, Up and Down arrows move the cursor one step in the indicated direction. The Ctrl-Home key is a handy shortcut to make the cursor jump from wherever it is to the first cell of the Worksheet which is the cell A1. The Home key will make the cursor jump to the first cell of the current row. The Pgdn key makes the Worksheet move up to display the next screenful of cells and the Pgup key shows you the previous screenful of cells.

To move to the upper-left cell of the current window, press the Scroll Lock key to prevent the Worksheet from Scrolling and then press the Home key. To move to the lower-right cell of the current window, turn on the Scroll Lock and press the End key. Ctrl-Right and Ctrl-down move the cell-selector to the last cell in the current row or current column respectively. Similarly Ctrl-Left and Ctrl-up move it to the first cell in the current row or current column respectively.

**Using The Go To Key**
If you know the exact address of the cell you want, you can rush there by using the “Go To” key which is the F5 function key. For example, to jump to the cell Z25, press F5. Now type the address Z25 in the Go To Dialog Box that appears on the screen and press Enter.

**Using The Mouse :**
In the Worksheet area the mouse pointer appears as a stout, shadowed Plus sign, which you can move over the Worksheet. Using the scroll bars you can go to any part of the Worksheet. Clicking on any cell, move the cell-selector to that cell.

**Note:** In addition to clicking with the mouse and using key combinations to select cells, you can use the name box to quickly select cells in the active sheet. The name box (located on the left end of the formula bar) displays the cell reference of the currently selected cell. Click in the name box, enter a cell reference, and press the Enter key, Microsoft Excel selects the specified cell.

**ENTERING DATA**
In an EXCEL Worksheet you can enter two types of data, namely :

- **Labels**
- **Values** (which can be of three types)
  - **Numbers**
  - **Functions**
  - **Formulae**

The keyboard has to be used to enter the data. The general process involved is as follows:

1. Move the cell-selector to the cell in which you want to enter data.
2. Type in the data.
3. Confirm by pressing the Enter key or by pressing any of the Arrow keys to move to the next cell in that direction.
NOTE: The moment you type something, the formula bar gets activated. The typed characters are shown in the current cell as well as on the formula bar. Also, a thin vertical blinking line called the formula bar cursor is shown in the formula bar. Three symbols in little boxes [X] [ü] [fx] also pop up at the left of the formula bar. The formula bar cursor is active till you confirm the data entered. The entry can be cancelled either by pressing Esc or by clicking the [X] symbol.

ENTERING LABELS
Any text item in the Worksheet is referred to as a label. All labels are by default left-aligned i.e. displayed starting from the extreme left of the cell. If the label entered is bigger than the size of the cell, only part of it will be displayed in the cell (but the formula bar will show the entire label. If the cells on the right of a long label are empty, the label gets displayed across the cells. A label entry can be up to 32000 characters in a cell. (It is possible to change the size of a column and also to make text wrap-around in a cell. We will see how to do that later on.)

ENTERING NUMBERS
Numbers are the “raw material” for spreadsheets. They are often referred to as constant values or simply values. You can type numbers into the current cell by using either the number keys above the letter keys on the keyboard or by using the numeric keypad in the Num Lock mode. In addition to the numerals 0-9, you can enter the following symbols: + ( ), $ % E e. Excel ignores an equal to or plus sign at beginning of a number, as well as commas embedded in the number. A number is considered to be negative if it is preceded with a minus sign or if it is enclosed in parentheses. It also accepts numbers typed in scientific format (1.2E+10). If an entry contains any character other than numbers and the special characters listed earlier, Excel treats it as text. Thus, the address 16 Janpath is a text entry. If you want to enter a number but have Excel treat it as text, simply precede it with an equal to (=) sign and enclose it in quotes, or precede it with an apostrophe (‘). (e.g. = “1998” or ‘1998’)

ENTERING FORMULAE
They are made up of numbers and mathematical operators. You can enter a formula just like you enter any other item of data. The point to be kept in mind is that a formula must begin with an equal to (=) sign. The formula should define the calculation to be made. Let us assume that the cells C1 and C2 contain the numbers 100 and 10 respectively. An example of a formula would be = 100-10 in cell A3. The formula bar as well as the cell shows the formula exactly as typed. But, after confirming, the result (i.e. 90) is shown in the cell, while the actual formula continues to be shown in the formula bar.

The formula we have seen is a simple numeric one. A formula can also contain cell addresses. In fact, formulae containing addresses are most used in a Worksheet because of their convenience. cell addresses being used in formulae also make typing mistakes less probable. In the above example, suppose we needed the difference between the contents of C1 and C2 to be displayed in C4, the following formula would have to be entered in C4: = C1-C2. This formula is self-explanatory. It means that cell C4 must contain the contents of C1 minus the contents of C2. Thus, C4 will also display the value 90.

The earlier formula is static one while the latter one is dynamic. That is, changing the value in A2 from 10 to 40, would make C4 recalculate and show the result as 60, while C3 would continue showing the result 90. It is evident that the dynamic formula in C4 (the one containing cell addresses) is of higher utility to us. Example C1+C2+C3+C4+C5: This formula can be entered using the “pointing” method as well, thus reducing your typing. Pointing does away with the typing of the cell-addresses. Instead, we just move the cell-selector to whichever cell we have to include in our formula after typing the = sign. (Both the keyboard as well as the mouse can be used for pointing.)
The above formula can be generated without typing the cell-addresses in the following way:

- Move to the cell which should contain the formula
- Start the formula with the equal to (=) sign.
- Use either the keyboard or the mouse to move the cell-selector to cell A1.
- Press the plus sign (+).
- Move the cell-selector again, this time to cell A2.
- Press the plus sign (+)
- Move the cell selector to A3.
- Press the plus sign (+) and so on.
- Finish by Confirming the generated formula.

The advantage of such a formula is its ease in entry and recalculation on change.

**CREATING A WORKSHEET**

Creating a Worksheet involves entering data – both numeric as well as labels. Appropriate formulae should be entered using functions and cell-addresses. Various formats and styles should be used to improve the appearance and readability of the spreadsheet. Special care should be taken while creating the formulae. Labels and headings should be descriptive and should aid understanding. Important totals, subtotals and calculations should be made prominent by underlining, italicizing. Various techniques involved in creating good working spreadsheets will be covered as we continue.

**BEST FIT**

Many a time, you may have to enter a label which is longer than the standard columnwidth. When you type a long label, it gets displayed on the current cell as well as the adjacent cell. To accommodate this long label in a single column, we have to change the width of the column.

Excel offers an excellent feature called *Best Fit*. This feature changes the size of the chosen column to exactly accommodate the longest entry present in that column. Best Fit is very simple to use. All you have to do is **double-click** the right edge of the column marker in the *Frame area*. On the edge of any column marker, the mouse pointer looks like a double-headed arrow with a thick line bisecting it.

**USING THE SUM FUNCTION**

Another method for performing calculations is to use *functions*. Excel provides a huge collection of functions to facilitate calculation. One of the simple functions is the SUM function. We could use = SUM (A1,A3,A4) in a cell to add the values contained in the cells listed in the parentheses. Here, the word SUM is the name of the function, the cell-addresses are the arguments and the result obtained is the returned value.

In the above example instead of using the formula = A1+A2+A3+A4+A5 we can make use the Sum function = SUM (A1,A2,A3,A4,A5) but since the cells A1 to A5 form a contiguous group of cells we can also use a **range** in the formula (=SUM(A1:A5)). We will come across the concept of ranges in the near future. Till then, we will just assume ranges to be groups of cells. The range A1:A5 can easily be understood as the group of cells from A1 through A5.
USING THE AUTO SUM TOOL

Excel provides us with various Toolbars. The Toolbars are collections of graphic icons, each of which represent a task to be done. A Tool always does a one-step operation. By default the Standard Toolbar is displayed in the application window. We will start using Tools by learning to use the AutoSum Tool, which is of great help while creating Worksheets. AutoSum helps us to find the sum of a group of cells. To a beginner, it appears to be amazing as it actually guesses the cells to be totalled (and quite often, manages to do so correctly).

The AutoSum Tool appears in the Standard Toolbar as a Sigma sign. All you have to do is take the cell-selector to the cell which should contain the total and click on the AutoSum Tool. Excel immediately tries to guess the group of cells which should be summed, and places a set of “marching ants” around it. Also, the SUM() function appears in the formula bar. If the cells chosen by AutoSum are the cells you want to sum, go ahead and confirm the formula. Otherwise, use the mouse to click and drag over the cells you want to sum, and then confirm.

Since we now know how to enter labels and values in the Worksheet, lets create the following sample Worksheet:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td><strong>Product</strong></td>
<td><strong>JAN</strong></td>
<td><strong>FEB</strong></td>
<td><strong>MAR</strong></td>
<td><strong>QTR</strong></td>
</tr>
<tr>
<td>4</td>
<td>P1</td>
<td>500</td>
<td>450</td>
<td>650</td>
<td>1800</td>
</tr>
<tr>
<td>5</td>
<td>P2</td>
<td>200</td>
<td>400</td>
<td>650</td>
<td>1150</td>
</tr>
<tr>
<td>6</td>
<td>P3</td>
<td>700</td>
<td>550</td>
<td>650</td>
<td>1900</td>
</tr>
<tr>
<td>7</td>
<td>P4</td>
<td>350</td>
<td>300</td>
<td>450</td>
<td>1100</td>
</tr>
</tbody>
</table>

MAKING THINGS LOOK BETTER

In the above Worksheet there are some labels which are in bold, underlined and italics. You can enhance the appearance of your Worksheet by changing the display formats of various parts. You can make the titles bold or certain figures italicized and underlined. Also, you can increase or decrease the size of the characters. This can be very easily done using the formatting Toolbar. There is a set of three tools as shown below:

The first tool is for Bold, the second one is for Italics and the third is for Underline. To apply these formats you simply select the cell or the group of cells to format and click on the formatting button you want.

**NOTE:** To select a group of cells, simply click and drag over the cells you want with the mouse pointer. The first cell in the group will always appear white while the remaining cells are highlighted.

Any one of the alignment buttons, on the formatting toolbar can be used to left align, right align and center align any label or values in a cell. Select the cells and then apply one of the alignments.
To change the font or font size of a label or value, select the cells to format and use the drop down list for the font and font size from the formatting toolbar.

Use these formatting techniques to format the sample Worksheet you have created.

**RENAME A WORKSHEET**
The Worksheet you have created has the name Sheet 1 which is the default used by Excel. To rename the Worksheet, double click on the sheet Tab of that Worksheet and a rename dialog box opens up. Type in the name and press enter. The new name can have up to 31 characters, including spaces. The name cannot be enclosed in square brackets, nor can it include the following characters, colon, slash mark, backslash, question mark.

**SAVING THE WORKBOOK**
The Worksheet which you have made is right now in the volatile memory of the computer. To save on a floppy disk or on the hard-disk, we have to use the **Save As** command. This command is available in the **File** Menu. Along with Save as..., you also have the **Save** command, which is slightly different. The first time you want to store your work you should use the Save as... command, as it allows you to give a name to your Workbook instead of the name Book 1. Save as... also allows you to specify the drive and the directory in which your workbook has to be saved.

Henceforth, whenever we have to save this Worksheet, we can use the Save option from the File Menu. We can also click on the Save Tool.

*Note*: By default, Excel Worksheets are given the extension XLS.

**EXITING EXCEL**
If you want to quit from Excel and get back to the Window Program Manager, you would have to choose the Exit option from the File Menu. Before exiting, it is a good practice to save and close the documents you are working on. If you have not saved the changes made or the new documents created
and try to quit, Excel will display a message box which will allow you to either save and quit, or quit without saving, or cancel the quit command itself.

COPYING AND MOVING SHEETS IN A WORKBOOK
Excel provides a very easy way to move a sheet from one place to another in the same workbook. In fact, all you have to do is click the sheet Tab you want to move with the mouse and then drag the sheet to its new location. When you drag a sheet, a small Worksheet icon appears, and a tiny arrow indicates where the sheet will be inserted in the Tab order. You can even move more than one sheet, by selecting the sheet Tabs and then dragging them.

You can also copy sheets using similar mouse techniques. First select the sheets you want to copy and then hold down the Ctrl key while you drag the sheet or sheets to a new location. As you drag a plus sign appears in the small Worksheet icon. However when you copy a sheet in the same workbook a number in brackets is added to the end of the name of the copied Worksheet to distinguish it from the original. For example, if you copy Sheet 1, the name of the copy will be Sheet 1 (2).

You can even move or copy sheets, using the Menu Move or Copy Sheets from the Edit Menu. Before selecting the command, select the sheets you want to move or copy. On selecting the command a Move or Copy dialog box appears.

In the Move or Copy dialog box, select the sheet in the Before Sheet list box, before which you want to move or copy your selected sheets. If you want to make a copy of the selected sheets, ensure that you have selected the check box Create A Copy.

MOVING AND COPYING WORKSHEETS BETWEEN WORKBOOKS
The same methods, as mentioned above, will be used while moving or copying sheets between workbooks. Suppose you have two workbooks arranged vertically (using the Arrange command from the Window Menu), to move a sheet from one workbook to another, simply drag the Worksheet Tab. To make a copy, hold the Ctrl key and then drag the selected Worksheet Tabs.

You can even use the move or copy command from the Edit Menu in the same way as explained earlier. The only difference being that you have to select the workbook to which you want to move or copy your selection in the To Book drop-down list box.
**WORKING WITH ROWS AND COLUMNS**
With respect to rows and columns, the two most important operations are deletion and insertion. Here, we will deal with these two operations in detail.

**DELETING ROWS AND COLUMNS**
An entire row or column can be removed from a workbook. This is different from clearing a part of a Worksheet. To understand the difference, let us consider the following example:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>PRODUCT</td>
<td>JAN</td>
<td>FEB</td>
<td>MAR</td>
<td>QTR</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>PRCD1</td>
<td>1000</td>
<td>1400</td>
<td>1600</td>
<td>4000</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>PRCD2</td>
<td>500</td>
<td>750</td>
<td>1000</td>
<td>2250</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>PRCD3</td>
<td>1200</td>
<td>1500</td>
<td>1700</td>
<td>4400</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>PRCD4</td>
<td>800</td>
<td>1000</td>
<td>1200</td>
<td>3000</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>PRCD5</td>
<td>800</td>
<td>850</td>
<td>1000</td>
<td>2450</td>
<td></td>
</tr>
</tbody>
</table>

A sample Worksheet is shown above. Let us say we want to delete the column C. After deletion, what happens is that the entire column C is removed from the Worksheet. The columns on the right of the deleted columns shift to take its place. Thus, the column numbering remains continuous, but the data gets reorganized. Also, all formulae involved get readdressed. (The formula in the cell calculating quarterly sales would change to = SUM(B5:C5) instead of = SUM(B5:D5).)

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>PRODUCT</td>
<td>JAN</td>
<td>MAR</td>
<td>QTR</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>PRCD1</td>
<td>1000</td>
<td>1600</td>
<td>2600</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>PRCD2</td>
<td>500</td>
<td>1000</td>
<td>1500</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>PRCD3</td>
<td>1200</td>
<td>1700</td>
<td>2900</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>PRCD4</td>
<td>800</td>
<td>1200</td>
<td>2000</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>PRCD5</td>
<td>800</td>
<td>1000</td>
<td>1600</td>
<td></td>
</tr>
</tbody>
</table>

On the other hand, clearing a column will have the following effect. Only the formulae and the formats will get removed. In place of the cleared data, there will be a blank area and the column numbering will remain as it was earlier.
We can delete an entire column or row by executing the **Delete** command from either the **Edit** Menu or the short-cut Menu. The row or the column in which the cell selector is present will get deleted according to the choice made by the user in the following dialog box.

The last two choices in the Delete dialog box are used to delete either a row or a column. The first two choices are used to delete cells. On deletion of cells their place is taken up by either the cells on their right or the cells below them corresponding to which of the first two options had been selected.

The easiest way to delete a row or a column is to select the entire row or column before executing the Delete command. This way the dialog box does not get displayed, as Excel already knows whether a row or a column has to be deleted. Also, more than one row or column can be deleted by this method. This is done by selecting all the rows or columns that have to be deleted. It should be noted that non-contiguous rows or columns cannot be deleted in one step.

**INSERTING ROWS AND COLUMNS**

Very often, it may be necessary to insert rows or columns in an existing Worksheet. The necessity may arise because we may have altogether forgotten to enter certain information, or may be just to enhance the appearance of the Worksheet. Whatever the reason for inserting rows or columns be, it is extremely easy to do so.

The **Insert cells...** command is very much like **Delete** command. It is available in both, the Insert Menu as well as the short-cut Menu. If the Insert command is executed without selecting a particular row or column the following dialog box gets displayed:

The later two options tell us that we can either insert an entire row or column. **The point to be remembered is that a row is always inserted above the current cell while a column is always inserted at the left of the current cell.** This should be kept in mind before we try to insert a row or a column.

Rows or columns can be inserted by selecting that many rows or columns and then choosing the Rows or Columns options from the Insert Menu.
CREATING WINDOW PANES
We may have a large Excel application that does not lend itself very well to multiple Worksheets. If this is the case, we can view different areas of a large Worksheet at the same time. For example, we can see range A1:H10 and A19:H24 at the same time. Creating different view of our Worksheet is known as creating panes, because we are separating our Worksheet’s window into sections. Unlike many Excel commands, we do not have to select a range before completing this procedure. It would be helpful, however, to display the portion of our Worksheet that we would want to view most of the time, before going ahead and creating the panes. We will also have to decide in advance whether we want two vertical panes, two horizontal panes, or four panes. We can create panes using the keyboard as well as the mouse.

MAKING PANES WITH THE MOUSE
Notice the small black rectangles at the top of the vertical scroll bar, and the far left of the horizontal scroll bar. If we move our mouse pointer to one of these areas, the pointer looks like a black double-headed arrow.

We can create two horizontal panes by moving our pointer to the rectangle above the vertical scroll bar – the Horizontal Split Box – and then dragging. As we do this, a gray horizontal line appears on our Worksheet, and moves with our mouse pointer. When we reach the position where we want the two panes to be separated, we stop and release the mouse button. We now have two horizontal panes in our Worksheet window.

Similarly, we can create two vertical panes by dragging on the rectangle at the far left of the horizontal scroll bar – the Vertical split Box.
If our window has already been split into two panes, we can quickly add two panes of the opposite kind. For example, if we decide we need four panes in our Worksheet and already have two horizontal panes, we can drag the vertical Split Box to add two vertical panes.

MAKING PANES WITH THE KEYBOARD
To make two Window panes with the keyboard, we use the Split option from the Window Menu. When we do so, four gray lines appear. We can use the up and down arrow keys to specify the location of the horizontal split, and the left and right arrow keys to place the vertical one. If we only want to split the Worksheet horizontally, we press the left arrow key until the vertical gray line disappears. Similarly, if we wish to get rid of the horizontal pane, we use the up arrow. When we have the panes the way we want them, pressing Enter will set the panes.

MOVING BETWEEN PANES
Moving the cell pointer between Window panes is an easy task. With the mouse, we could just click on any cell of the pane we want to move to. Pressing the F6 key on the keyboard moves the cell selector to the next pane in a clockwise direction. Shift-F6 moves the cell pointer anti-clockwise between panes.

REMOVING PANES WITH THE MOUSE
Click and drag the vertical split box all the way to the left of the horizontal bar, and release the mouse button to remove vertical panes. Similarly, click and drag the horizontal split box all the way to the left of the vertical scroll bar, and release the mouse button to remove horizontal panes.
REMOVING PANNES WITH THE KEYBOARD
This can be done with the Remove Split option of the Window Menu box. We can press the left arrow key until the vertical gray line disappears to remove the vertical panes. Similarly, if we wish to get rid of the horizontal panes, we use the up arrow. We have to press enter at the end of either operation.

FREEZING A PANE
When we display panes, and scroll our Worksheet, both panes scroll in the same direction together, i.e. they are synchronized. At times, however, we may want to hold the contents of one pane in place while the other scrolls. For example, we may have a Worksheet containing details of many items. As we move down our Worksheet, it is easy to lose track of which item we are referring to. A horizontal pane can be created to split the Worksheet into titles and details and then the upper Frame can be frozen such that the titles stay in place while we scroll through the details. This is also known as freezing titles. We can freeze column titles, row titles or both. This can be done by selecting the Freeze Panes command from the Window Menu. If the Worksheet is divided into horizontal panes all the titles in the top pane are frozen and you can move the cell selector only in the bottom pane. If the Worksheet is divided both horizontally and vertically then the titles in the top pane and the left pane are frozen.

UNFREEZING PANE
When we have a Worksheet that displays a frozen window pane, the Freeze Panes command becomes the Unfreeze Panes command. This can be used to unfreeze the panes in the Worksheet.

USING FIND AND REPLACE
Excel provides two commands that search our Worksheet for specific entries. The Find command simply locates what we are looking for. The Replace command gives you the option of replacing found items with a new label, value or formula. Both these commands are available in the Edit Menu.

THE FIND COMMAND
To search our Worksheet and locate specific entries, we can execute the Find command in the Edit Menu. Excel displays the dialog box shown below:

We can enter the label value or formula we want to search for in the Find What text box. Then we can select the appropriate options from the drop-down lists to specify the parameters for our search and then select FIND NEXT to begin.

If Excel finds an entry that matches our search parameters, it moves the cell selector to that cell. To resume searching, press F7.
THE REPLACE COMMAND
When we choose the Replace Command, Excel displays the dialog box shown below:

We can enter the item we want to find and also the label, value or formula we want to replace it with. We have to mark the option check boxes and select from the drop-down list as required in order to proceed.

The Replace All button is used to tell Excel to automatically find and replace all the items we have designated.

The Find Next and Replace buttons allow us to replace found entries on an individual basis. The Close button stops the operation.

CHECKING SPELLINGS
Excel lets us check the spelling of a selected word, a selected range or all the words on our Worksheet. Choose the Spelling command from the Tools Menu to display the Spelling dialog box shown below.

Excel finds and displays words that are not in its dictionary. If the spelling is correct, select the Ignore or Ignore All buttons. If we select the Suggest button, Excel displays a list of suggestions.

Checking the Always Suggest box tells Excel to make suggestions automatically. Excel also ignores words that have been typed in uppercase if the appropriate box is checked. To correct a word, type the
correct spelling in the Change To text box or select one of Excel’s suggestions and then click on the Change or Change All button. To add words to our personal dictionary (CUSTOM.DIC) or another dictionary listed in the Add Words To box, select the Add button.

To stop the spell checking process, select the Cancel button. When the checking operation is allowed to run to its close, the Cancel button changes to the Close button.

FUNCTIONS

WHAT ARE FUNCTIONS?
A function is a built-in formula that takes a series of values, uses it to perform an operation, and returns the result of the operation. It can be used as a part of a formula, i.e. we can create formulae which contain different functions along with numbers and cell-addresses.

11 CATEGORIES OF FUNCTIONS
Excel has eleven categories of functions. They are as follows:
- Most Recently Used
- All
- Financial
- Date & Time
- Math & Trig.
- Statistical
- Lookup & Reference
- DaTabase
- Text
- Logical
- Information

Though the number of functions available in each of the above categories is extremely large, we will be using only a few functions in our day-to-day work.

PARTS OF A FUNCTION
Functions usually have two parts – the function name and the arguments. The arguments have to be enclosed in a pair of round brackets. The function which has been used, usually performs a set of actions to arrive at a value. It returns this value. So, we can use a function in place of a value because the function used will return a value, Earlier, we had seen an example of a function called = SUM (…).

Here are some other simple functions:

- = AVERAGE () Returns the average of the values passed as arguments.
- = MAX () Returns the highest value from the ones passed as arguments.
- = MIN () Returns the lowest value from the ones passed as arguments.
= COUNT () Returns the number of not null entries passed as arguments.

= NOW () Returns the current date and time.

The above examples are simple functions which do some simple statistical operations. The arguments for these functions are to be specified in the brackets. These arguments could be a series of numbers, or they could be cell addresses or range addresses. We can also use range names as arguments.

Let us consider a simple example of a function. This is a mathematical function called SQRT (). It finds the square root of the argument and returns it. So, if a cell contains the formula =SQRT(144). It will display the value 12, whereas the formula bar will display the formula i.e. =SQRT(144). Instead of the number 144, we could also have given a cell address. Some functions do not require any arguments. An example of this type is the =NOW() function, which returns the system date and time.

ENTERING A FUNCTION
Now that we know what a function is made up of, we can go on to examine how functions can be entered. There are two ways of entering a function. They are as follows:

> Typing the function manually
> Pasting the function using the Function Wizard

TYPING A FUNCTION
Entering a function is no different from entering any other type of data. First, we select the cell which should contain the function. After that, we type the “=” sign. Then we type the function and the arguments.

A function can be as simple as the one below:

=SUM (A1:A10).

We can also have complex functions like the one mentioned below:


FUNCTION WIZARD
Another way we can enter functions into our Worksheet is using the function wizard. Earlier we had seen how we could paste Range Names to quickly create powerful formulae. Letting Excel help us enter functions by pasting them ensures that they are spelt correctly and reminds us of their argument requirements and the order in which the arguments are expected.

Typing a function and pasting it both begin in the same way: we first select the cell where we want the function to calculate a result. To paste a function, we choose the Function… command from the Insert Menu or by clicking on the Function Wizard Tool on the Standard ToolBar. This displays the Function Wizard dialog box. First we have to select the category of function we want from the list displayed in the Function Category Box. We can scroll through the Function Name box, which contains the list of functions in the selected category, select the function we want.
To enter the function, click **Next** or press **Enter**. Excel enters in the formula bar an equal sign, the function name, and a set of parentheses. Excel then moves to the second Function Wizard dialog box.

The second Function Wizard dialog box contains one edit box for each argument of the function you selected. A insertion point appears in the edit box of the argument you are entering.

The current value of the function appears in the upper right corner of the dialog box. When you click Finish or press Enter, the completed function appears in the formula bar.

Lets use some of these functions mentioned earlier in our sample Worksheet, to calculate the maximum, minimum and average sales in each month.

Type in the labels Maximum, Minimum and average in the cells A11 to A13. To calculate the maximum sales for Jan, select the cell B11 and click on the function wizard tool. Select the function called MAX and click on the button called Next. In the second step of the function wizard we have to specify the values from which the maximum value has to be extracted. In our example since the cells with the sales for month of Jan are in a range, we can specify the range address. The range address can either be typed in or selected by using the click and drag technique.
Once the range has been entered, just click on the Finish button. The function is pasted in the active selected cell. In the same way calculate the Minimum and Average Sales for Jan using MIN() and AVERAGE() functions. The arguments will be the same range address.

**THE IF() FUNCTION**

Finally, we will discuss an important Logical function. Logic mainly deals with conditions. Conditions can either evaluate to true or false. On the evaluation of conditions we do certain tasks, We can do things conditionally by using logic in Excel, too. The Excel function which allows us to use logic is IF(). Its syntax is shown below:

*IF (logical_test, value_if_true, value_if_false).*

Let us see an example of the IF function.

```
=IF (SUM(A1:A10)=SUM(B1:B10), "EQUAL", "NOT EQUAL")
```

The logical_test argument or the condition in this formula is SUM(A1:A10)=SUM(B1:B10). If it evaluates to True, the value_if_true, the label EQUAL is returned. On the other hand, if the logical_test evaluates to False, the value_if_false the label NOT EQUAL is returned. In formulae, a label has to be enclosed in a pair of quotes.

In our sample Worksheet, lets use the IF() function to calculate the commission earned, based on the Quarterly sales of each product. If the quarterly sales>1500 the commission will be 10% of the quarterly sales, otherwise, commission will be zero. Select the cell F5 where the function has to appear and select the function IF() using the function wizard. In the box for Logical_Test type in the condition as E5>1500 (the cell E5 contains the figure for the quarterly sales for the first product). In the value_if_true box the formula will be given as E5*10% and in the value_if_false box the value will be 0. In the cell F5 the function will evaluate as follows:

```
=IF(E5>1500, 10% * E5,0)
```

It should be understood that we can have nested Ifs (one IF within another). It is also possible to have functions as the value_if_true and value_if_false. This can be used to conditionally assign values to cells. But to select a function within another function we have to use the Function Wizard button, next to the appropriate argument box from within the Function Wizard Dialog Box.
If in the above example the commission was dependent on the following two conditions-

Qtr Sales > 1800 : Commission = 20% of Qtr Sales
Qtr Sales > 1300 : Commission = 10% of Qtr Sales

When we select the IF () function from the function wizard box, the value_if_false box will contain a nested IF () function which will be given using the function wizard button next to this argument box.

In the cell for commission the formula evaluates as follows:

\[ = \text{IF} (E5>1800, 20\% \times E5, \text{IF} (E5>1300, 10\% \times E5, 0)) \]

SALIENT THINGS YOU SHOULD KNOW ABOUT EXCEL

LINKING

CREATING LINKS:
A workbook can be linked to permit consolidation of values from supporting workbooks to a master workbook. The source workbook contains the original data. The dependent workbook is then updated whenever data in the source workbook is changed provided both the source and dependent workbooks are simultaneously opened.

Creating Workbook Links:
To place linked copy of cell from one Worksheet to other.

1. Make sure that both the source and destination workbooks are open.
2. To select the cell or range of cells which you wish to link in the source workbook.
3. Choose copy from Menu or press right mouse button on the selection.
4. Go to destination Worksheet and select the cell which will be upper left corner of the range of cells that will contain the linked cells.
5. Choose Paste link from edit drop-down Menu. Remember any change made in source workbook will be reflected in the destination.
6. To make successful link, save the source workbook before linking and rename linked workbook.
Updating Links:
When the dependent workbook containing the formulae with the links has been saved, a permanent
link to the source workbook is established. In other words, providing the source and the dependent
workbooks are open simultaneously, any changes in the source data will immediately take effect in the
dependent Worksheets.

Removing Links:
When a link is no longer needed, for example, if no further changes in the data will occur, the user can
freeze the current value in the dependent file and remove link.

EXCEL DATABASE MANAGEMENT
Microsoft, Excel has many advanced features that allows you to interact with the Worksheet with ease.
One of the important features of Excel is its database utility. A database is nothing more than a collection
of organised information, such as employee, customer, inventory records. A record corresponds to a
Worksheet row. And each record contains a collection of data that corresponds to columns. The row
and columns that contains data can be organized and queried upon.

A LOOK ON DATA MENU
This Menu is used to perform a number of powerful operations. Lets have a look at its contents.

Sort  It sorts out range of cells in ascending or descending order.

Filter  It is used to display or print only those records that match the criteria. This ability is
performed by Auto Filter.

Auto Filter  It gives you the ability to display the information that matches specified value and use
button to find, change, delete selected records.

Form  It is used to display the field of each record.

Subtotal  It is used to have calculations on selected numbers.

Table  It creates a Table of the database.

Text to Columns  It breaks the text information into columnwise.

Consolidate  It combines values of multiple Worksheet into selected cells. This can be used for
finding sums of more Worksheets.

Group and: Outline  It provides a detailed information such as hide, expand, combine or
group, ungroup outline and use of style.

Pivot Table  It summarizes information within a Worksheet.

Pivot Table Field  It sets properties for fields within a Table.
Computer Fundamentals

**Refresh**  
It refresh values within the selected Worksheet.

**DATA TABLE**  
Excel lets you create different kinds of Tables that are used in business and finance. It is based on a formula that contain one or more variables. A Table is a range of cells within a Worksheet that contains input values, formulae and the results of calculation.

**Types of Data Table**  
Generally there are two types of data Table:

1. **One Variable**  
   It operates with a formula having single variable.

2. **Two Variables**  
   It operates with a formula having two variables.

**DATA SORT**  
Excel lets you arrange the database with more than one sortkeys in either the ascending or descending order. To sort a database.

> Select all the data that you want to sort excluding field names with the help of mouse.
> Click on Sort option from the Data Menu.
> Click on row or column of Sort By option in which the output is to be organised.
> Specify the cell address to identify the column to sort by when sorting rows or columns and specify to sort the database in ascending or descending order.
> Specify the cell address in 2nd key if there are any values duplicated in the 1st key. Similarly specify 3rd key if there are any duplicates in the second key range.
> Click on OK button to perform the desired output.

**DATA QUERY**  
To query the database, Excel database lets you extract selected information of a database for reporting purpose. To perform Data Query follow the following steps:

> Select the range of cells that database content and column headings.
> Select Set Database option from Data Menu and then choose Form.
> To add a record, click on New form From Menu to display a blank form to enter the new records and enter the values in the fields.
> Once the data entry is completed press<Enter> to add the records at the end of the database.
> Choose Criteria to specify a condition for query. Find Previous, Next to view the records step by step.
> Delete to delete the currently displayed record and the same can not be restored.
MACRO
A Macro is nothing but a collection of keystrokes that is created and saved in an assigned control key. It is just like a “batch file” in DOS, that contains a series of commands to be executed. Macro is used to guide the data entry process. Macros can carry out sequences of actions much more quickly than done by the user himself.

How to create, store and run Macros
1. Excel has the capability of recording whatever the user does on an Excel sheet and to store these steps on a Macro sheet. Choose Tools-Record Macro.
2. And Record New Macro dialog box asks you for a Macro name. And option available in this Menu will lets you record Macro and store in three different ways.

ASSIMILATION EXERCISE

Q.1 What are the basic advantages of a Spreadsheet (MS Excel) ? List all the limitations of the same?
Q.2 Prepare a Worksheet having three Tables -

<table>
<thead>
<tr>
<th>Cost Price</th>
<th>Selling Price</th>
<th>Profit</th>
<th>Profit %</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>1800</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2000</td>
<td>2200</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3000</td>
<td>3000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The profit should be calculated using the formula (Selling Price - Cost Price) and the Profit % should be the ( Profit / Cost Price *100) ?

Q.3 List all the ways to fit a line which is bigger than your Column Width ?
Q.4 How do you generate a sequence of Natural no. each being entered in a separate Row. e.g:

| 1 |
| 2 |
| 3 |

and so on upto 100.

Q.5 Prepare a comparative statement of a tender which has five company’s rates and calculate the difference in the prices (as compared to the last year’s price, which is less than all of the current prices) by using the formula: \( \text{diff} = \text{current price} - \text{last year price}. \) On basis of this mark the company which has the minimum price.

Q.6 What are some of the statistical functions that Excel offers?
Q.7 What functions calculate the interest, principal and payment amount of a loan? Using these functions calculate the amount when principal = Rs.1000/-, rate of interest is 10% and time being 2 years. \( \text{Amount} = \text{Principal} + \text{S.I.} \) and \( \text{S.I.} = (\text{P*R*T}/100) \)

Q.8 Refer the figure given above and use the Excel Functions to calculate the following:

1. Sum of A and B separately and that should be displayed in col. C1 and C2 resp.
2. Average of A and B separately which should be displayed in C3 and C4 resp.

Now write a which compares the average amount of A & B and displays “A” if average of A is greater than B else displays “B”.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>13</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>15</td>
<td>8</td>
</tr>
<tr>
<td>3</td>
<td>50</td>
<td>12</td>
</tr>
<tr>
<td>4</td>
<td>40</td>
<td>14</td>
</tr>
<tr>
<td>5</td>
<td>10</td>
<td>24</td>
</tr>
<tr>
<td>6</td>
<td>20</td>
<td>41</td>
</tr>
<tr>
<td>7</td>
<td>57</td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
“IT will increase the efficiency and effectiveness of every man and every organisation.”

PRESENTATIONS

COMPETENCY OBJECTIVES

The objective of this Section is to make students understand the basics involved in making excellent presentations using MS-PowerPoint. At the end of the course, a student should be able to understand:

- The basics of PowerPoint.
- The tools required for making presentations.
- Creating presentation slides for some company in the most efficient manner.
INTRODUCTION
Welcome to the world of computerized desktop presentations. In this chapter, you will learn how to open an existing presentation & about various environments in which the presentation can be opened, viewed & worked. You will also learn about the Wizard & Template, options available in PowerPoint.

WHAT YOU CAN DO WITH POWERPOINT
With PowerPoint, you can make:

> **Presentations:** A power-point presentation is a collection of slides, handouts, speaker’s notes, & your outline, all in one file. As you create slides, you are creating a presentation - you are designing how your presentation should look and giving it a format that carries through from beginning to end.

> **Slides:** Slides are the individual “pages” of your presentation. Slides can have titles, texts, graphs, drawn object shapes, clip art, drawn art, and visuals created with other applications - and more. You can print slides as black and white or colour transparencies or have 35mm slides made using a film or service bureau.

> **Handouts:** To support your presentation you have the option of providing handouts for your audience. Handouts consist of smaller, printed versions of your slides (either two three of six slides per page). If you want, you can print additional information such as your company name, the date, and the page number on each page.

> **Speaker’s Notes:** You can create and print speaker’s notes. You can see a small image of the slide on each notes page, along with any notes you type.

> **Outlines:** While working on a presentation, you have the option of working with your presentation in outline, the title and main text appear, but not the art or the text type with the text tool. You can print your outline, too.

HOW TO START POWERPOINT
1. Click on Start button at the bottom left corner of the screen as shown below.
2 Select Programs, then Microsoft PowerPoint and Click on it.

Alternatively, You can start PowerPoint directly by Clicking on the Microsoft-Office Group’s icon on the top right corner of the screen.

3 Observe the tip of the day dialog box on your screen.
4 Click on OK to close the dialog box.
5 Observe the PowerPoint dialog box that appear on screen. (Again, this may not appear depending on your PowerPoint setup. If it does not skip to step 6). The options in this dialog box help to create a new presentation or open an existing presentation. Since we won’t be exploring presentation right now, we’ll close the dialog box.
6 Click on cancel to close the PowerPoint dialog box.
7 If the new slide dialog box appears, click on cancel to close it.

THE MAIN POWERPOINT WINDOW

A Window is a rectangular area on the screen, in which you view a program (e.g.: PowerPoint) or a document (e.g. a PowerPoint slide). PowerPoint uses two Windows; one nestled within the other. The outer Window is called application Window, it contains the PowerPoint programs main options and commands. (Note: The term application and program are synonymous). The inner Window called the presentation Window contains the current presentation file and the tools, options, commands and messages associated with this file. In the next two sections, we will discuss the PowerPoint application and presentation Windows in details.
Let us explore the PowerPoint application Window. Observe the elements as explained below:

**Control Menu**
Use it to change the size and position of the application Window or to close it.

**Title bar**
Contains the application title, Microsoft PowerPoint.

**Menu bar**
Displays PowerPoint's Menu options.

**Minimize button**
 Shrinks the application Window to a program icon.

**Maximize**
Maximize the application Window to its nonmaximised size and location.

**Standard ToolBar**
Click on its buttons to issue frequently used commands and utilities.

**Formatting ToolBars**
Click on its buttons to issue frequently used formatting commands.

**Drawing ToolBar**
Use its buttons to draw on slides.

**Status bar**
Reports information about the currently selected command.

**View Slide button**
Reports information about the current slide and view.

**New Slide button**
Use it to create a new slide. Note that this button is dimmed because it is unavailable in the current working context. You cannot create a new slide when no presentation is open.
Layout button
Use it to change a slide layout.

Template button
Use it to apply a Template to a presentation.

THE TOOLBARS
You can use ToolBars for quick access to commonly used commands and tools. When you first start PowerPoint and open a presentation, the standard and formatting ToolBars are displayed just below the Menu bar, and the draw ToolBar is displayed vertically on the left side of the Window. Different ToolBars appear automatically in each view.

You can display as many of the ToolBars as you want or none of them at all. More ToolBars can be added, customize ToolBars by adding or removing buttons. You can resize ToolBars and drag them to different locations. You can also create a custom toolbar that adjusts the buttons you use most often.

TOOLS FOR MAKING PRESENTATION

WIZARDS & TEMPLATES
Wizards are PowerPoint’s way of making it easy for you to quickly and efficiently create professional-looking presentations. Even if you know very little about PowerPoint, the Wizards can help you develop your ideas and design your presentation.

A wizard is a guided approach to create a presentation. All you do is answer the questions that appear on screen.
THE AUTO CONTENT WIZARD

The Auto content wizard starts with the title slide and then helps you choose from a selection of presentation categories-subjects such as selling a product, service, or an idea: Recommending a strategy; or communicating bad news.

Once you have a title and subject, PowerPoint makes an outline for you to follow, based on how you answered the wizard’s prompts. Then just type your information over the placeholder text. You can switch to slide view to see your slides and change the slide layout.

THE PICK A LOOK WIZARD

The pick a look wizard helps you create the look or the “style” of your presentation. Pick a Template from the collection of PowerPoint designs and then tell the wizard what kind of finishing touches you want, such as automatic page numbers. The wizard customises the slide master, based on your responses. You can use the pick a look wizard any time you want, not only for a new presentation. That means you can organise the contents of your presentation and then let the “pick a look wizard” help you design its appearance.

TEMPLATE

Start by selecting a presentation Template that determines the colour scheme, font, and other design features of the presentation.

BLANK PRESENTATION

As the name suggests, a blank presentation is displayed for you to create your own formats. Start with a blank presentation with all values for colour scheme, fonts and other design features set to default values.
Open an existing presentation
Displays a dialog box through which you can start with a presentation that had been saved.

THE PRESENTATION WINDOW
Now let’s reopen the PowerPoint presentation Window, so that we can examine it:

1. Choose File, New
2. Select the Blank Presentation option, and click on OK to open the new slide dialog box.
3. Click on OK to open a new presentation Window
4. If your presentation Window is maximized, click on the Restore button to restore the Window to its non maximized size and location.

Think of the PowerPoint Window as a workspace in which you create and edit your presentation slides. Observe the Window elements, as explained below and shown in the figure below.

Control menu box You use the control menu box to change the size and position of the presentation Window or to close it.

Title bar Contains the presentation’s title. Since you have not yet given a title to the new presentation you created in step 1, PowerPoint gives it the default title, presentation.

Slide workspace The large white area in the middle of the Window where you view, create and edit presentation slides.

View buttons Use these buttons to change the view in which the current presentation display.

Slide show button Use this button to run a slide show of the current presentation.
Previous slide button Use this to display the previous slide in the current presentation.
Next slide button Use this to display the next slide in the current presentation.

HOW TO OPEN A PRESENTATION FILE
A file is a collection of data (information) stored on a hard disk or floppy disk. A PowerPoint presentation file consists of one or more slides. Each slide can contain text, charts (graphs), drawing, clip-art and
Computer Fundamentals

graphics. In order to view, edit, add, or delete slides in an existing presentation, you must first open the presentation file in which these slides are stored.

Here is the general procedure for opening a presentation file:
> Choose File, Open to open the open dialog box
> If necessary, change the current drive that contains the presentation file you want to open.
> If necessary, change the current directory to the directory that contains the presentation file you want to open.
> In the filename list box, select the name of the presentation files you want to open.
> Click on OK.

POWERPOINT VIEW
As you create a presentation, you can switch among five views of your presentation. Each view gives you a different way looking at your work and offer different capabilities. To switch between views, click the button that represents the view you want. The view buttons are at the bottom of the PowerPoint window.

HOW TO CLOSE A PRESENTATION
When you are finished working on a presentation file, you should close it. Opening a file places a copy of it in your computer’s active memory (RAM); closing the file removes it from memory, freeing this memory for use by another presentation.

Here’s the general procedure for closing a presentation file.
Choose File, close
EXITING FROM POWERPOINT
When you finish a PowerPoint work session and want to turn off your computer or to run another program, you must first exit from PowerPoint. Here’s the general procedure to do this:
Choose **File, Exit.**

CREATING PRESENTATION AND SLIDES
All the skills you will learn in this chapter are geared towards helping you produce sophisticated-quality slide presentations. The following steps represent the general produce you’ll use to create the presentation.
1. Open a new, blank presentation in which to create your slides.

   ![New Presentation dialog box](image)

2. In the newly opened presentation, create new, blank slides and enter the text.
3. Save the presentation to a file on your disk.
4. Add design elements by drawing on slides, adding charts (graph) to slides, adding clipart to slides, and laying on it.
5. Generate output by running a slide show of the presentation; printing slide, notes, or handouts; and/or processing the presentation as 35-millimetre slides.

OPENING A NEW, BLANK PRESENTATION
You first step in creating a slide presentation is to open a new blank presentation. Here is the general procedure for doing this.

1. Choose File, New (or click on the new button in the standard toolbar) to open the New Presentation dialog box.
2. Select Blank presentation to open a new, blank presentation that uses the PowerPoint default slide format (appearance). Select Current presentation format to open a new, blank presentation; this option is only available if there is a presentation currently open.
3. Click on OK. The New slide dialog box appears.
4. Select your desired auto layout for the new presentation’s first slide.
5. Click on OK.
DIFFERENT TYPES OF AUTOLAYOUTS
Before we proceed further, let us have a look at the various auto layouts available. Using slide layouts lets you start with a format that matches what you want to create. Use the scroll bar to see more layouts. You can select the option depending on your requirement for that particular slide.

CREATING & ENTERING TEXT IN SLIDE VIEW
After opening a new presentation, your next step is to create blank slide and enter text in them. You can do this either in slide view or in Outline view. The advantage of entering slide text in slide view is that you can see what the actual looks like (the text size, style, layout, and so on), the disadvantages are that you can see only one slide at a time and that it is somewhat harder to enter and edit your text than in outline view.

The advantage of entering you slide text in Outline view is that you can see an overview of all the text in your presentation, the disadvantage is that you cannot see what the actual slides looks like.

CREATING NEW SLIDES IN SLIDE VIEW

Here’s the general procedure for creating a new slide view:

1. Display the slide directly after which you want to add your new slide to appear.
2. Click on the New slide button or choose insert, New slide to open the New slide dialog box.
3. Select the desired auto layout for your new slide.
4. Click on OK.

ENTERING SLIDE TEXT IN SLIDE VIEW
When you are in slide view, PowerPoint provides three different types of object in which you enter slide text. You enter a title in a title object, a subtitle in a subtitle object, any body text (bulleted items, descriptive paragraphs, and so on) in a bulleted-list-object.

Here’s the general procedure for entering text in slide view:

- Select (click on) the desired title, subtitle, or bulleted-list object.
- Type the desired title, subtitle, or body text.
- Press ESC to enter the text into the selected object.
- To deselect the object, press ESC again.
TEXT FORMATTING AND THE SLIDE MASTER
This format of the text you enter in a title, subtitle, or bulleted-list object is determined by the format setting in a special slide called the Slide Master. For example, the text you enter in a bulleted-list object is automatically formatted as a bulleted list, because this is the format of the bulleted-list text in the slide master. The bullet shape, size, and colour as well as the alignment of the bullet text items (left, right, center, or justified) are all determined by the Slide Master settings.

The Slide Master guarantees that all the title, subtitle and bulleted-list text in your presentation will be identically formatted, thus lending an overall consistency to the presentation. Similarly text can be entered in the slide in the outline view also.

DRAWING OBJECT IN POWERPOINT
PowerPoint provides three Drawing toolbars with buttons that give you quick access to the commands you use most often when draw. You can move any toolbar by clicking between buttons and then dragging or by dragging the title bar.

THE DRAWING TOOLBAR
The drawing toolbar contains the tools you use to draw all sorts of object such as lines, circles, boxes. You’ll also find tool, line on/off and the fill on/off example.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Used for</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto shapes tool</td>
<td>Draw predefined shapes(AutoShapes)</td>
</tr>
<tr>
<td>Fill Colour</td>
<td>Add or remove default fill colour from objects</td>
</tr>
<tr>
<td>Line On/Off tool</td>
<td>Add or remove default line colour from objects</td>
</tr>
<tr>
<td>Shadow On/Off tool</td>
<td>Add or remove default shadow colour from objects</td>
</tr>
</tbody>
</table>

An AutoShape is a shape that you draw automatically when you select its icon and then drag. AutoShapes appear in two places: on the Drawing toolbar and on the drawing toolbar, while the rest of AutoShape toolbar.
ADDING CLIP ART TO YOUR SLIDES
There are several ways to open the slide part gallery so you can find and copy the image you want. Use the method that seems easiest for you.

To Add clip art to your slides.

1. Click the insert clip art button on the standard toolbar. or double-click a clip art placeholder on an Auto layout. -or-
   From the insert Menu, choose clip art. The clipart gallery opens.
2. Select the image you want by double-clicking it or by selecting it and choosing OK.

The image appears on your slide.

INSERTING PICTURES ON YOUR SLIDES
You will find it easy to personalize your presentation by using the PowerPoint insert picture command to add all kinds of pictures, scanned Photographer and line art, photos and artwork from CD’s and so on. Artwork might include your company’s logo, even a piece of custom designed art. Any picture whether it is black-and-white or colour, can be inserted in to your presentations.

PowerPoint recognizes a number of different picture formats.

To insert a picture into a power point presentation.

1. Open your Power Point Presentation and go to the slide to which you want to add a picture.
2. From the insert Menu, choose Picture, Clip Art. The Clip Art Window appears. Click on the selected item (picture/sound/videos), click on insert button. The picture/sound/video appears on your slide.

From the insert Menu, choose Picture, from files the Insert Picture dialog box appears.
Notice that you do not have to specify which format your artwork is in. The default includes all the formats that Power Point recognizes and that are installed.

3. Go to the directory (Windows) in which you’ve stored your artwork.
4. Select the file, and then choose OK.
   The Picture appears on the slide.
   (You may see a dialog box before the picture appears.). You can now move it, resize it, add a border.

**Saving a New Presentation**

Until you save your presentation, it exists only in computer memory (RAM), a temporary storage place. For permanent storage, you must save the presentation to a file on a disk. To save a new presentation for the first time, you use the file, save as command. Here’s the general procedure for doing this:

> Choose File, Save As to open the save As dialog box.
> If necessary, change the current drive or directory.
> In the File Name text box, type your desired file name.
> Click on OK
> If the summary Info dialog box appears, fill in your desired summary information and click on OK

**ASSIMILATION EXERCISE**

Q.1 How does the Wizard facility help in making the presentation?
Q.2 Can you create a new image and use it in the same way in which the images from the clipart gallery can be created and used?
Q.3 Try making a presentation for presenting some technical paper on the topic “Making a Presentation”.
Q.4 Try implementing Q.3 in which your slides will change on :-
   (i) Mouse click
   (ii) Pressing any key of your keyboard.
   (iii) Automatically with the delay of 2 sec.
Q.5 Can you use your presentation which you have prepared in Q. 3 on some computer which does not have powerpoint installed on it? Give reasons to support your answer. If “yes”, how & if “no”, why?
Q.6 Can you chose different layout of the background for the different slides in the same file? Give reasons to support your answer.
“The successful organisations of the next decade will be the ones that use digital tools to re-invent the way they work. These companies will make decisions quickly, act efficiently and directly touch their customers in positive ways.”

NETWORKING, INTERNET & E-MAIL

The objective of this section is to make students aware of the basic concepts involved in Networking, which enable them to further understand the fundamentals involved in Internet and Electronic Mail. At the end of the course, a student should be able to assimilate the following :-

- Advantages/disadvantages of Networking and the basic fundamentals of a Local Area Network including the main Topologies involved.
- The concept of the various layers involved in message & packet interchange.
- Understanding the concept of Wide Area Network.
- Appreciate the concept of data distribution and effectively utilize it in the normal Network application.
- Understand the concepts of Repeaters, Bridges, Routers etc.
- The basic concepts of Internet and e-mail and how to effectively use the world wide web.
- The electronic messaging through e-mails and the basic concepts involved during Remote Logins.
- Surfing on the world wide web & effectively utilizing the best of the information available on the internet.
- Appreciate the usage of Internet for the common man and acknowledge its needs in the specialised fields.
NETWORKING OF COMPUTERS
A network is the inter-connection of two or more computers together by a cable so that they can exchange information with the help of a specially designed software for network control. This software also allows any user to access shared data storage and output device connected to the network.

* Each PC on the network contains a special network adapter card. A cable from this card connects the PC to the network.
* Each PC contains the network software.
* The PC’s on the network are referred to as clients and the shared devices (hardware or software) are referred to as servers.
* The clients & server on the network are referred to as network nodes.

Need and Advantages of Networking
1. To share Computer Files: Networks enable users to share files & data with others.
2. To Share Computer Equipment: Networks enable users to share expensive equipment like laser printer, large hard disk drives by networking microcomputers or workstations together.
3. To Enable Unlike Computer Equipment to Communicate: It is also possible to share files and send messages across machines that are connected through a network with or without floppy disks.
4. To improve Communication Speed and Accuracy: Sending messages through local area networks is instantaneous and there is less chance of a message being lost.
5. Low Cost of Transfer of Data: The cost of transfer of documents using computers connected on network is cheaper than other convention means like telegrams.
6. Multimedia Transfer: Pictures can also be sent along with text by integrating fax systems with network.
7. Advantage of Networking: Networks allow the high-speed exchange of essential information between key people in an organization.
8. Use of Electronics Mails.

Disadvantages of Networking
1. The financial cost of installing networking h/w & s/w is still very high in comparison with many other alternatives.
2. Networking software requires about 20% memory space in each of the computers used on the network.
3. Networking being complex users may have difficulty in learning the network commands.
4. Some control on the part of the user is lost as one may have to share a printer with other users.
5. Some type of security system must be implemented if it is important to protect private data.

**Defining System Needs including Training**
The reasons for installing a network should be logically defined. Facts like:

1. The number and type of computers that will be placed on the network.
2. The likely network utilization per workstation
3. A forecast of future expansion
4. The desired system response time
5. Idea of peak loading and traffic pattern should be thoroughly explored.

**Upkeep and Maintenance of the Network Systems**
A network system should be highly reliable the network should have feature to aid in maintenance and fault location.

**Security:** As networks increase exposure to unauthorized computer access, so it is important that user plans the system protection.

**LOCAL AREA NETWORKS (LAN’s)**
Networks used to interconnected computer with in a single building or campus of up to a few kilometers in size.

* LAN’s use a transmission technology consisting of a single cable to which all machines are attached.
* Rate of data transmission in LANs is very high (in Mega bits per second). The various ways the computers on a network can be linked together is referred to as topology.

**Token Ring Topology:** Information is divided into packets for transmission between nodes & each packet contains the address of the node that is to receive the information.

**Disadvantage:** Entire network goes down if one node fails

**Star Topology (It is a broadcast network):** The central node is the master (also called hub). Each node is linked to the master node or hub via separate links.
**Disadvantage** : Communication between various nodes occurs through the master node. And if, central node fails, the entire network goes down.

**Ethernet Bus : Bus-based broadcast network**

Workstations are connected by a transceiver cable & transceiver to the network’s main ethernet cable which acts as a data bus. The transceiver cable from the node goes into a vampire tap which is then fitted into the Ethernet Cable.

Computers on an ethernet can transmit Packets whenever they find the cable vacant. If two or more packets collide, each computer waits for a random time & tries again later. Each packets contains the destination node address.

**EPABX : Electronic Private Automatic Branch Exchange**

Used as Complementary to LANs

Available in 3 different formations
* Voice Only
* Data Only
* Integrated Voice cum data PBX’s
OPEN SYSTEM INTERCONNECTION

ISO-OSI Model (Functionality’s)
The OSI (Open System interconnection) model was developed by International Standards organization (ISO) to standardize the procedures for exchange of information between processing systems. It is a seven-layer communications protocol intended as a standard for the development of communications systems worldwide. The seven layered communications protocol represents a set of hardware & software guidelines which attempt to ease the complex process of enabling computers of different makes to communicate.

By the term protocol we mean the set of rules or standards designed to enable computers to connect with one another and to exchange information with as little error as possible. Protocol can describe low-level details of machine-to-machine (e.g. the order in which bits & bytes are sent a wire) or high-level exchange between allocation programs (e.g. the way in which two programs transfer a file across the internet.

Layer –7 Application Layer
Application layer is the set of messages the application programs use to request data and services from each other. Electronic mail and query languages are examples of this layer.

Layer-6 Presentation Layer
* Converts data from one format to another.

If one system uses ASCII character code & is communicating with a system using EBCDIC character code, the presentation layers perform the required conversions.

The International Standards Organization’s (ISO) seven layers of control for open systems
**Layer-5  Session Layer**
* Establishes session between two systems
* Queues the Incoming messages
* Recovers messages from abnormally terminated sessions
* Synchronizes data interchange between 2 systems

**Layer-4  Transport Layer**
* Converts Message into forms required for transmission over network.
* Ensure high level recovery system.
* Divides data in network to improve throughput
* Regulates information between slow receiver & fast sender

**Layer-3  Network Layer**
The network layer establishes the connection between two parties that are not connected together directly.
* Controls congestion of traffic
* Removes nobles problems due to data transmission within heterogeneous networks.

Layer-2 Data Link Layer
The data link layer is responsible for transmitting physical block of data from one device to another.

* Error checking is necessary to ensure an accurate transmission
* Divides data into frames. Transmits & retransmits lost frames.

Layer-1 Physical Layer
The physical layer defines the actual set of wires, plugs and electrical signals that connect the sending and receiving devices to the network.

WIDE AREA NETWORKS
WANs can be used to connect computers at separate sites, cities & countries. Also called Long Haul Networks (LHNs). In a WAN, having direct links between devices are not possible because of the large distances involved. So, communication takes place between source ^ destination through intermediate nodes which are equipped with switching capabilities to move data.

Techniques for Transmitting Data Through Nodes
1. Circuit Switching : Dedicated Communication path are their between sender & receiver through intermediate nodes.
2. Message Switching: Each Message which has a destination address is transmitted where the intermediate nodes check if for errors and queues if for the next available path.

Disadvantage : Data get delayed at each node because of rechecking of data at each node.

Packet Switching
The message is broken into equal sized packets each of which contains the destination address & sequence number. Each packet reaches the destination by a separate route where they are reassembled again according to the sequence numbers.

Advantages: Long messages do not block the network.

Advantages of WAN
* Spans greater geographical distance world wide.
* Direct physical connection between various computers may not be required.

Disadvantages
* High Cost
* Low Data Transmission speed
* More transmission errors compared to LAN

DISTRIBUTED DATABASE
In a distributed database system, the database is stored on several computers. The computers in a distributed system communicate with one another through various communication media, such as high-speed buses of telephone lines. They do not share main memory, nor do they share a clock.
The processors in a distributed system may vary in size and function. They may include small microcomputers, work stations, minicomputers, and large general-purpose computer system. These processors are referred to by a number of different names, such as sites, notes and computers.

The main difference between centralized and distributed database systems is that in the former, the data resides in one single location, while in the latter, the data resides in several locations. This distribution of data is the cause of many difficulties.

A distributed database system consists of a collection of sites, each of which maintains a local database system. Each site is able to process local transactions, those transactions that access data only in that single site. In addition, a site may participate in the execution of global transactions, those transactions that access data in several sites. The execution of global transactions requires communication among the sites.

The sites in the system can be connected physically in star, mesh or ring network.

**Trade-offs in Distributing the Database**

There are several reasons for building distributed database systems including sharing of data, reliability and availability, and speedup of query processing. Disadvantages, include software development cost, greater potential for bugs, and increased processing overhead.

**Advantages of Data**

The primary advantage of distributed database systems is the ability to share and access data in a reliable and efficient manner. Data sharing and distributed control, therefore not much load on Central Computer.

If a number of different sites are connected, then a user at one site may be able to access data available at another site. It is primary advantage of sharing data by means of a data distribution is that each site is able to retain a degree of control over data stored locally. In a centralized system, the database administrator of the central site controls the database. In a distributed system, there is a global database administrator responsible for the entire system. A part of these responsibilities is delegated to the local database administrator for each site.

1. **Speed Data Processing**: A user’s task can be divided up & distributed across a number of computers.
2. **Availability**: The failure of a site does not necessarily imply the shutdown of the system.
3. **Reliability**: If data items are replicated in several sites, a transaction needing a particular data item may find it in any of several sites. The failure of one site must be detected by the system, and appropriate action may be needed to recover from the failure.

Although recovery from failure is more complex in distributed system than in centralized systems, ability of most of the system to continue to operate despite the failure of one site results in increased availability. Availability is crucial for database systems used for real-time applications. Loss of access to data by, an airline may result in the loss of potential ticket buyers to competitors.
**Speed of Query Processing**
If a query involves data at several sites, it may be possible to split the query into subqueries that can be executed in parallel.

Specialized data & programs can be downloaded from central computer.

**Disadvantages of Data Distribution**
* Software Development Cost: It is more difficult to implement a distributed database system and, thus more costly.
* Greater Potential for Bugs: Since the sites that comprise the distributed system operate in parallel. It is harder to ensure the correctness of algorithms. The potential exists of extremely subtle bugs.
* Increased processing overhead: The exchange of messages and the additional computation required to achieve intersite coordination.

**ONLINE SYSTEMS**

Online systems are ones which can respond to queries by providing very fast answers & update the corresponding files immediately after each transaction is completed.
* Response time should be short but a delay would not be fatal.
* There have large disk storage which enables large storage & fast retrieval of information.

**Airline/Train Reservation**
Reservations for customer has to be made while he waits. Availability or non-availability of ticket information is provided online.

**Real Time Systems**
* Used in applications in which a computer is expected to control the operation of a physical system.
  * Works within strict time constraints.
  * Delay in response may lead to fatal failures.

*Example*: All satellite information (its position, velocity, acceleration & Spin Information) which revolves in an orbit is fed in a computer. The computer computes the orbit & then instructions to the rocket motor to correct the orbit are given. Any delay in processing information would prove disastrous.

**Banking Operations**
Various online services are provided to customers by typing their identification no or password such as:

* Making online withdraws & deposits
* Getting Transaction details at home
* Customer queries regarding balance answered at home
* Money in account can be put
* Electronic transfer of funds from one account to other
**Electronics Funds Transfer**
Routine financial transactions of departmental stores, hotels, shops etc. are done online.

A Debit Card given to the customer contains his account no. & his credit amount which when inserted in the terminal, causes data to be read & processing at CPU containing the account can be done from the terminal.

* **Smart Cards**: allows customer to keep electronic money with him to make purchases.
* **SWIFT**: (Society for Worldwide Interbank Financial Telecommunications)

It is cooperative international network which links banks in over 50 countries.

* **Videotex System**: many organizations provide subscribers a communication package which allows online access to the database by a I.D. No. & Password. Videotex is a service which provides graphic-rich database information electronically to customers on demand who possess the equipment to receive electronic information.

**EXPRESS NETWORK**

Gateway used to connect totally dissimilar networks. Protocol conversion for all seven layers of the OSI model is performed. I.e. a gateway reformats data so that it is acceptable to the system it is passing info.

* **Most Common Example**: Gateway used to connect a LAN and SNA mainframe computer. It changes protocols & Transmits packets between them.

* Gateway handle messages, address & protocol conversions necessary to deliver a message from one network to another.

**Tradeoffs**
* Higher Cost
* More Complex Design & Operation
* Additional Processes of Implementation
* More Maintenance
Repeater
Listens to signals coming down from one network cable, amplifies them & sends them to the other side.

Bridge
A bridge connects two fundamentally identical networks that have some different physical element. Supports LAN to LAN connection. E.g. connecting ethernet network & token ring network.

A bridge inspects each message that comes its way from one side of the bridge & broadcasts it on the other side of the bridge only if the message is intended for a computer that is on the other side.

Bridges Can Be
Local i.e. directly connect networks

Can be remote i.e. connecting network through

Router
A router apart from performing the function of a bridge (i.e. passing packet of information from source to destination), assures that the packet is sent through the best possible path.
INTERNET

It is a network connecting other network (LAN’s or WANs) of the world.

Why Use the Internet?
1. To exchange electronic mail
2. To participate in group discussions on topics of interest, through public news groups.
3. Universities, books stores, and libraries can share on-line information.
4. To Shop. One can order different products over the Internet.
5. One can publish information as technical or marketing literature.
6. To market & sell products.
Internet Connection Options
There are several ways to connect to the internet.
* Dedicated Internet Access
* PC dial-up access

Dedicated Internet Access
It needs dedicated a phone line connecting your LAN or PC to the Internet 24 Hours a day. A dedicated Internet access requires substantial initial investment in equipment and a monthly fee for the use of the line. It varies with line capacity, and line capacity determines how many users can connect to internet simultaneously.

PC Dial-up Access
This is the simplest type of connection to Internet. You need a computer modem (attached to a phone line) and any of the popular telecommunications packages. The user dials-in to an Internet service provider. Each user has an account on the Internet Services providers host computer. You ask the host computer to go out onto the Internet to do what you want to be done. Host providers will send & receiver E-mail, transfer files from a remote internet computer to the host from where you can then down load to your own computer.

ELECTRONIC MAIL
Electronic Mail (e-mail) is a system whereby a computer user can exchange messages with other computer users or group of users via a communications network.

Advantages :
* Delays of getting a physical document from one person to another are eliminated.
* The receivers need not be present on site when mail is sent to him.
* Mail can be sent to individuals or groups simultaneously.
* Some electronic mail packages have an “express mail” feature. When express mail is sent, the service is immediately notified on the PC’s status line that mail is waiting.

FEATURES OF JAVA
Simple : Unlike C & C++ Java does not support Goto statement. It provides labeled break and continue statements and exception handling. Java also eliminates the operator overloading and multiple inheritance features of C++.

Java does not use pointers. Java also implements automatic garbage collection, so the programmer does not have to worry about memory management issues.

Object oriented : Java is an Object-oriented programming language.

Distributed : Java being a distributed language supports applications on networks. With Java, it’s as easy to open a remote file on the internet as it is to open a local file.

Interpreted : The Java compiler generates byte-codes, rather than machine codes. You use the Java interpreter to execute or run the complied byte-code, so Java is an interpreted language. The code is designed to transport programs efficiently to multiple platforms.
Reliable: As Java does not support pointers, possibility of overwriting memory and corrupting data is eliminated. The Java interpreter also performs a number of run-time checks, such as verifying that all array and string accesses are within bounds. Exception handling in Java makes more robust programs.

Secure: Java implements several security mechanisms to protect you against code that might try to create a virus or invade your file system.

Architecture Neutral: Since Java programs are compiled to an architecture neutral byte-code format application in Java, can run on all platforms.

Multithreaded: Java is a multithreaded language. It can handle different tasks simultaneously.

Dynamic: It is a dynamic language. Java loads the classes as they are needed, even from across a network.

GOPHER: Gopher was developed by university of Minnesota.

* It is an internet navigation tool that allows the user to find & retrieve information using a menu system.
* The gopher protocol enables the gopher client to connect to a Gopher server & to traverse the Gopher space or other sites.
* Gopher Space Universe of Gopher servers connected to the internet. Each server has a location (internet address port number) of its own & links to other Gopher servers.

WORLD WIDE WEB (WWW) (Also called Web or W3)

It is a huge collection of interconnected hypertext documents (web page) residing on the various Web Servers.

* These documents contains links with each other & with other sites on the internet too
* With a Web browser, user can jump from one web page to another.
* These Web pages can be made available to user via URLs (Uniform Resource Locators)
* Web documents are made in HTML (hypertext language)
* WWW servers use HTTP (Hyper Text Transport Protocol) to deliver the called web page to the user.

(a) URL: (Uniform Resource Locator)
It’s a form of web address that all web browsers can understand.

Syntax form of URL:
e.g. gopher://dixie.aiss.vivc.edu:6969/xx/urban.legends.

Thells, the browser use the gopher protocol to connect to the host machine called “dixie.Aiss.vivc.edu and connect to port 6969.
There look in directory/xx & get the file “Urban legends”.

(b) **HTTP**
Protocol used by Web browsers to respond to the requests to transfer the web documents to the user, which the user makes via URLs. If this protocol is called, then instead of “gopher” we write “http://” in the above example.

Some other protocols are FLP, Telnet

(c) **HTML**
It is the format used for writing the hypertext web documents. Items in the document can be text, images, or links to other HTML documents. Hypertext documents have extension .html.

**MOSAIC**

It is the original graphical web browser. It is an easy way to reach audio, video, text & graphic documents. The original version is NSCA Mosaic *(NCSA, the national Centre for Super Computing Applications, is where Mosaic was first created).*

Other versions are spyglas Mosaic, Air Mosaic, compuserve Mosaic.

**INTERNET ADDRESS**
Every site on the internet has its own unique address which is given according to a domain naming.

* Domains are connected together to create a unique address for any site.
* Each system address goes from general to specific (when read backwards)
* The right most domains are either organizational or geographical in nature.

E.g. **vky@aaa.eed.bhel.edu**

- **.edu** : its an organizational domain representing an educational institution.
- **.bhel** : name of educational institution
- **.eed** : department with that institution. Here (Electrical engineering deptt.)
- **.aaa** : Specific computer within the department

The left most part, before @ represents a unique identifier. (Here, vky, may represent the name of a person)

There are seven standard organizational domains

<table>
<thead>
<tr>
<th>Domain</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>.com</td>
<td>Commercial entities</td>
</tr>
<tr>
<td>.edu</td>
<td>Educational Institutions</td>
</tr>
<tr>
<td>.gov</td>
<td>Non-military US Govt. Institutions</td>
</tr>
<tr>
<td>.net</td>
<td>Network resources</td>
</tr>
</tbody>
</table>
There are several standard geographic domain codes which consist of only two characters and represent countries.

e.g. .au Australia
     .it Italy
     .in India

THE TCP/IP REFERENCE MODEL
When satellite and radio networks were added as a part of internet, the existing protocols and trouble interworking with them. So, a new reference architecture was needed. This architecture was known as the TCP/IP Reference Model, named after its two primary protocols.

THE INTERNET LAYER
The internet layer holds the whole architecture together. Its job is to permit hosts to inject packets into any network and have them travel independently to the destination.

The internet layer defines a protocol called IP (Internet Protocol). The job of the internet layer is to deliver IP packet from source to destination hosts. The internet layer of TCP/IP model is very similar in functionality to the network layer of OSI Model.

<table>
<thead>
<tr>
<th>OSI</th>
<th>TCP/IP</th>
</tr>
</thead>
<tbody>
<tr>
<td>7 Applications</td>
<td>Application</td>
</tr>
<tr>
<td>6 Presentation</td>
<td>Not present in the model</td>
</tr>
<tr>
<td>5 Session</td>
<td>TCP/UDP Protocols</td>
</tr>
<tr>
<td>4 Transport</td>
<td>Internet</td>
</tr>
<tr>
<td>3 Network</td>
<td>IP Protocols</td>
</tr>
<tr>
<td>2 Data Link</td>
<td>Host-to-Network</td>
</tr>
<tr>
<td>1 Physical</td>
<td></td>
</tr>
</tbody>
</table>

The TCP/IP Reference Model

The Transport Layer: The layer above the internet layer in the TCP/IP model is the transport layer. It is designed to allow per entities on the source and destinations hosts to carry on a conversation, the same as in the OSI transport layer.

Two end-to-end protocols have been defined here. The first one, TCP (Transmission Control Protocols) is a reliable connection-oriented protocol that allows a byte stream originating on one machine to be delivered without error on any other machine in the internet. It fragments the incoming byte system into
discrete messages and passes each one onto the internet layer. At the destination, the receiving TCP process reassembles the received messages. TCP also handles flow control to make sure a fast sender cannot swamp a slow receiver with more messages than it can handle.

The second protocol in the layer UDP (User Diagram Protocol) is an unreliable, connectionless protocol. It is used for client-server type request-reply queries and applications in which prompt delivery is more important than accurate delivery, such as transmitting speech or video.

**Connection Oriented**
There is a dedicated connection between sender & receiver even when message is not being sent.

**Connectionless**
Connection between sender & receiver are established only when message is to be sent or received.

**INTRODUCTION TO INTERNET**

**What is the Internet ?**
The Internet is a collection of computer networks which have a common way of passing material between them, in effect creating a single world-wide network. For academic users this means access to an enormous range of resources, and much of this material is provided by individual users and departments at other academic sites around the world. Also, as more and more people have access to the Internet, it becomes an increasingly efficient way of making contact with others working in similar fields and of disseminating information to others who might be interested in it.

**BASIC INTERENT CONCEPTS**

**Clients & Servers :** Internet applications basically work by establishing a direct connection between two computers, the one you are working at and one at some other site, It requires co-operation between the two computers and this is achieved by having what is called “Client software at your end, which sends requests to a piece of “Server” software at the other end, which does what you ask. The computers at the two ends of the connection are therefore often called the “Client” and the “Server” (sometimes called the “remote host”).

**Sites, Hosts and Addresses :** All the information available on the Internet is located on specific computers (called “hosts”) at particular sites. Each host had a unique number – the “IP number”, which the average user doesn’t need to bother with (IP stands for “Internet Protocol”) – and a unique name, which functions as its address. That name (often called the “domain name”) is made up of a number of components (typically 4) separated by periods, as can be seen in the Internet address of the main UNIX server at Goldsmiths.

**scorpio.gold.ac.uk :** Here, Scorpio is the name of the individual server (we have others such as aries and libra), gold the name of the site the server is located at, and ac.uk refers to the UK academic domain in which that site is located. With the exception of internet sites in the USA, all Internet address end with a two letter country code. US addresses have as their final element not a country code, but a three letter abbreviation indication which network they are on, for example edu for Universities, gov for governmental servers, com for commercial enterprises, org for other types of organisation. These non-national top level domains are increasingly used outside the US. The IP number of scorpio, incidently,
is 155,223,1,1 and all computers in Goldsmiths connected to the Internet have IP numbers beginning 155,223,

When you contact a person or a host within the same domain as yourself, you can omit may common elements on the right hand side of the host name. So if you wanted to contact the Bulletin Board for libraries at Bath (a useful source of information about the Internet) from Goldsmiths you could use either its full Internet address bubl.bath.ac.uk or, since the college and BUBL are both part of ac.uk domain, you could omit the common part – just bubl.bath will work equally well.

When you wish to send something to or make contact with another Internet site, you will need to know the Internet address of that other site.

**URL’s :** Some Internet applications use what is called a “Uniform Resource Location” (URL) to locate resources on the Internet. This is in a sense simply a more elaborate form of address, specifying not only the Internet site name, but also the directory and file in which a resource is located as well as which method to use when retrieving it. Currently, only the World-wide Web uses URLs.

**Types of Internet Applications**

There are three main types of Internet applications :
1. Those based on sending and receiving mail messages
2. Those based on logging in to a remote Internet host.
3. Those based on browsing.

To some extent these are interchangeable, as Internet resources are increasingly available by more than one method. But from the user’s point of view they are used in very different ways.

To start the UNIX applications, simply type of the name of the application at the UNIX $ prompt. How you start the PC or Mac applications will depend whether you are using an Open Access machine or a networked machine in a department, so you will need to consult the computer services documentation.

If you are new to the Internet, you might wonder which of the applications discussed below you should start using first. Although three is no right answer to this, for most users the essential tools are :

* E-mail – this is the one absolutely essential Internet facility.
* A World-Wide Web Browser – this looks like becoming the dominant Internet application, and many other types of service can be accessed from a Web Browser.

**Understanding e-mail**

**Electronic Mail :** E-mail is much faster than the postal service and not much slower than fax or other means of message transmission: e-mail messages to anywhere in the world should arrive within 24 hours, within India it will normally be a matter of minutes. In addition, the e-mail software has facilities for sending computer files, so that images, word-processed documents and seven sound recordings can be attached to e-mail messages.
An e-mail message has the same parts as a memo: To, From, Subject, Date, body, and CC (or Copies To).

An E-mail address works like a normal postal address. To send someone e-mail, you must know their address or your mail will not be delivered. The parts of an e-mail address are the userid, node, site, and domain.

userid@node.site.domain

- The userid is the network name of the individual.
- The node is the name of the computer system.
- The site is the name of the organization.
- The domain is the abbreviation for the type of organization. Three common types include:
  - edu for educational
  - mil for military
  - com for commercial.

Tip: E-mail messages are different than Word or WordPerfect files. They are ASCII text files. ASCII files do not contain graphics or special formatting such as bold or underline. To retain formatting create your file in a word processor and then attach the file to your e-mail.

Reading a Message
1. Look in the “New Mail Folder.” If you have e-mail it will appear here.
2. Double-click on the message (or click on it once and click on the Open button).

Typing a New Message
1. Click on the Compose button. The message editing window appears.
2. Fill in the To: and the Subject: fields.
3. Click in the message editing window.
4. Type your message.
5. Click on the Send button.

Using Notepad to Type a Message
1. To open notepad, double-click on the Accessories icon.
2. Double-click on the Notepad icon.
3. Type the body of your message. (not the To:, From: or Subject: fields)
5. Select Select All. Your message will be highlighted
7. Select Copy.
8. Start e-mail.
9. Click on the Compose button.
10. Click in the message editing window.
11. Click on the Paste button.
12. Fill in the To: and the Subject: fields.

Tip: You can also use Word to type your message. Just remember to save the file as a ASCII (.txt) file!
13. Click on the Send button.
**Saving a Message**
1. Click on the message in the “New File Folder.”
2. Click the Save button.
3. In this window, select the drive and location.
4. Type a filename.
5. Click on the OK button.

**Deleting a Message**
1. Click on the message in the “New Mail Folder.”
2. Click on the Delete button.
3. Click on the Yes button.

**Printing a Message**
1. Click on the message in the “New Mail Folder.”
2. Click on the Print button. The print setup dialog window appears.
3. Click on the OK button.

**Replying**
If you receive an e-mail and want to send an answer, you can either compose a new message or use the reply option. The reply option is useful because you do not have to retype in the person’s e-mail address. Also, when you use reply, the original message stays on the screen.

1. Double-click on the message in the “New File Window” (or click once and press the Open button).
2. Click on the Reply button.
3. Type your message.
4. Click on the Send button.

**Attaching a File**
1. Type your message.
3. Select the file to attach and press Enter.
4. Another window will open, press the Tab key 3 times and press Enter.
5. Press Esc 7 to send your message.

**Quitting and Logging Out**
1. To quit Z-mail, return to the main screen by pressing Esc 8 and then press Esc 8 again.
2. At the unity% prompt, type logout.
3. At the TELNET window, click on the Close button.

**Applications:**
* UNIX : pine
* PC : Winsock Pine; or pine via UNIX
* Mac : Eudora
### Mailing Lists

E-mail has enabled the rise of a form of electronic discussion group called a “Mailing list” (often simply called a “list”). Each list provides a forum for discussion of a particular topic, and is generally available to anyone who has an e-mail address. There are mailing lists for a enormous range of subjects (and if there is no mailing list for a subject you think deserves one, it is possible to setup a new list). Mailing lists are invaluable in academic work, since they allow you to contact a world-wide forum of people interested in a particular area. In particular, mailing lists can be useful for new Internet users, since they are good ways of finding out about Internet resources relevant to a particular discipline. Of course, there are many mailing lists devoted to recreational topics, too.

You join a list by sending an appropriate e-mail message to the list manager (often not a person, but a computer), and thereafter you will receive a copy of every message subsequently mailed to the list by any other member, and any message you post to the list will be circulated likewise.

There are two types of list: Moderated and unmoderated. In a moderated list, the list manager usually compiles several messages into a single, longer mailing and may edit the messages before they are recirculated, where in an unmoderated list messages are circulated immediately and without editorial control. Moderated lists are usually intended for serious discussion amongst those working in the discipline. Unmoderated lists tend to be more if normal, but may not be. Many mailing lists also have facilities for retrieving files from their archive’s.

Bear in mind that some lists generate large numbers of messages every day, and it is easy to be overwhelmed by the volume of mail, through many high-volume lists are also available in a “digest” format – each day you receive a single message containing all recent contributions.

### Usenet News

Usenet news is a messaging system very similar to mailing lists except that:

* It is based around ”newsgroups” each devoted to a single topic, rather than “lists”;
* You do not need to “join” a newsgroup – you can read any message posted to any newsgroup which you Internet site accepts;
* There are many more newsgroups than mailing list;
* Newsgroups tend to be more informal than mailing lists;
* A much higher percentage of the messages in newsgroups is not worth reading.

It is impossible here to give an overview of the range of newsgroups available to users – over 3,000 – but it is useful to note that they are arranged in “hierarchies”, the most important of which are listed in the table below:

<table>
<thead>
<tr>
<th>Hierarchy</th>
<th>Type of Content</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>sci</td>
<td>discussion of academic subjects</td>
<td>sci.ling (for language &amp; linguistics)</td>
</tr>
<tr>
<td>soc</td>
<td>discussion of social and cultural issues</td>
<td>soc.culture.india</td>
</tr>
<tr>
<td>rec</td>
<td>recreational interests</td>
<td>rec.music.bluenote (jazz and blues)</td>
</tr>
<tr>
<td>alt</td>
<td>anything alternative, i.e. radical and/or non-serious</td>
<td>alt.flame.roommate (for complaining about your roommate)</td>
</tr>
</tbody>
</table>
There are also national hierarchies where discussion is likely to be in the native language, e.g. de.soc.studium for German-language discussion of German Universities.

Newsgroup names look like Internet address, consisting of a series of words or syllables separated by periods, but they read from left to right: rec includes all recreational groups, rec.music refers to all those concerned with music, rec.music.bluenote is an individual newsgroup. Some Web browsers also provide facilities for accessing newsgroups.

**REMOTE LOGIN**

**Telnet**
Telnet is a very basic but useful price of software which allows you to make a connection to a remote computer and log in to use it. There are two basic uses for Telnet:

§ Logging into your own account from elsewhere,
§ Logging into general access services (such as library catalogues).

In the first case you would have to be a registered user both at the site you telnet from and the one you are logging in to. This is typically used by people working away from their normal workplace.

**Applications**

§ UNIX telnet
§ PC telnet (Dos & Windows)
§ Mac telnet

**FTP**
FTP stands for File Transfer Protocol and is the name of a program which allows you to transfer files between computers on the Internet. There are two reasons why you might want to do this. First, if you have access to computing facilities at another institution, you may want to transfer your own files between that system and the Goldsmiths system.

Second, the Internet is a vast repository of publicly available files of very conceivable type: electronic scholarly journals; text files containing literary texts, bibliographies or episode guides to cult TV series; graphics files of great works of art; fonts for various operating systems; large amounts of free or shareware software. All of these can be downloaded to your local system. This service is called “anonymous ftp” and is a widely used method of making software, text, image and sound files available to anyone who is interested. It is called “anonymous ftp” because you log in to the remote host with the special username “anonymous” (giving you e-mail address as a password).

There are many specialist ftp servers, which collect resources relating to a particular subject or interest. There is no central list of the specialist servers, but many of the Internet books in the Library give a selection of ftp sites. Likewise, Internet magazines such as .net regularly include details of new or interesting ftp sites. Mailing lists and newsgroup discussion will often point.

**Gopher**
Gopher is a file viewing and retrieval system that works through a series of hierarchical menus. It is very easy to use, since all you have to know is how to move around the menu system.
The gopher software is capable of contacting hosts anywhere on the Internet, and the information displayed on the screen is not actually stored on the local system unless you explicitly save it in your filespace.

Applications
§ UNIX gopher
§ PC telnet to scorpio and use the UNIX gopher
§ Mac turbogopher

You can connect to any other gopher by typing gopher followed by the Internet address of that gopher server. Gopher also allows you to access certain other types of service such as telnet services.

World Wide Web
The World-Wide-Web (often referred to simply as the Web) is a multi-media hypertext system. In essence it resembles gopher, as it works by displaying individual documents from anywhere on the Internet, which in turn may provide links to other Internet documents, but it is considerably more sophisticated.

§ It is capable of dealing not just with text files but with graphics, sound and video files, which will be displayed or played on a Mac or PC with suitable hardware facilities and appropriate support applications;
§ It is capable of retrieving documents by a number of methods, so a Web browser can be used, for example, to retrieve files from an anonymous ftp site, to access a gopher server, or to log on to a library catalogue via a telnet connection;
§ Instead of using menus, it allows the creator of a Web page to make any word or image on the page into a “hot-spot” which will retrieve another document when it is selected (so it resembles the Apple Hyper Card application or the Windows Help System).

Applications
§ UNIX lynx (type lynx or www at the prompt)
§ PC netscape
§ Mac Netscape, Mac Web

Note: The UNIX Web Browser is not capable of displaying graphics or playing sound, but you to resources available via anonymous FTP.

In essence ftp is can be regarded as a very specific and restricted version of telnet; the only thing you can do with it is examine and copy files.

Applications:
§ UNIX ftp
§ PC ftp (Dos & Windows)
§ Mac fetch

If you are looking for ftp sites relating to a particular subject or interest, the best place to enquire is an
appropriate newsgroup or mailing list.

Archie
Archie is just a particular example of a service you can telnet to. It is a service run on only a handful of
hosts which allows you search a list of all the files and directories on all the ftp sites in the world, i.e. it
functions as an index to materials available by ftp. The Index is usually updated about once a week.

Applications
§ UNIX telnet to archie.doc.ic.ac.uk
§ PC telnet to archie.doc.ic.ac.uk
§ Mac Anarchie

Browsing
The remote login applications are fine if you know what you want, but ftp, for example, requires all the
files downloadable from a particular server to be physically present on a disk at the site, leading to a
substantial amount of duplication around the world. These problems have been solved by systems
called “browsers”, of which there are currently two: Gopher and the World Wide Web.

A browser presents you with a document on which you can select certain items. However, although
these items may be located on your local system, they can just as easily be anywhere else on the Internet.
Once you select an item, the system retrieves that item from wherever it is located on the Internet. You
do not need to know where anything is actually located (though it is possible to find out), because each
document itself “knows” about the locations of linked documents. You can connect to any other page
on the Web :

§ Typing lynx or www followed by the appropriate URL (UNIX)
§ Choosing Open Location from the File menu in Netscape (Windows/Mac)

How Do I find What I’m looking for ?
Although software tools like Archie and gopher allow you to find things, they only really work if you
have a rough idea of what it might be called or where it might be called or where it might be, if you
don’t know either, you seem to be stuck. There are 4 general approaches :
§ Ask others in your discipline who have had internet access for some time (mailing lists and
newsgroups are obvious places to ask);
§ Look at the Internet books and periodicals in the Library;
§ Find a gopher or Web server devoted to the approximate subject area and start browsing.
§ Use a “search engine” – there are both gopher and Web sites which provide key-word searching
facilities which should be able to provide a list of links you can follow; Archie can be sued for
finding ftp resources.

Etiquette
Since the Internet is not a single entity, there are no regulations or disciplinary procedures for misuse,
and it is governed more by “etiquette” than anything else. However, although “the Internet” cannot stop
you if you decide to behave undesirably, institutions can and do ban from their systems people who are
found to abuse the facilities. The following are some of the more obvious considerations :
§ Do not log on to a distant service if there is a local equivalent.
§ Do not send junk e-mail and do not post messages to a mailing list or newsgroup which are not relevant to its topic.
§ Do not be abusive to other users.

While users do not really need to know anything about how the Internet works in order to use the applications, it is important to remember that there are technical limitations to the capacity of the infrastructure. The connections on which the Internet relies are made over cable and, occasionally, satellite links, which can become very busy. Also, most of the computers connected to the Internet (like our system) are mainly intended for local users and there may be restrictions on when access is allowed to people coming in from outside. If you log on to a remote system and either cannot get in at all or find it unresponsive, just log off and try again later. (You will get better access outside local working hours, when the host machines tend to be less busy and many sites allow more off-campus users.)

To “surf” the Net, you just need 1 starting URL (Universal Resource Locator)
§ Browser comes configured with a starting URL: “Home Page”
§ You can reset the starting URL as you like (Options/Preferences/Styles in Netscape)
§ You can also “open” a URL (type it in :File/Open Location in Netscape)
§ From starting URL, you “surf” Web by clicking on the “links”
§ You can also “save” interesting URLs in a “hot list” or “bookmarks”

What is a Web page?
A Web page is a static or a dynamic page which can be documented with the following:
§ Plain (ASCII) text
§ Formatted text
§ Static graphics
§ Animated graphics
§ Sound
§ Movies
§ “links”
§ Executable scripts
§ Forms for passing data to applications
§ “applets”
§ Coded in HTML: Hypertext Markup Language

A Web Page has to be coded in HTML
§ This is called the “source” document
§ The WWW server transfers the whole “source” to client
§ It is up to client browser software to render the document on the screen
§ Consists of plain ASCII text, interspersed with markup “tags”
§ The surfer doesn’t see the “source”: just sees formatted text
§ You CAN ask your browser to show you the “source”: View/source in Netscape

AN INTERNET GLOSSARY

CGI (Common Gateway Interface)
A standard that allows Web servers to run External Applications such as search enginers.
Collaboration Software
A network-based application that lets participants share information.

Document Database
An organized collection of related documents.

Firewall
Hardware or software that restricts traffic to a private network from an unsecured network.

FTP (File Transfer Protocol)
An Internet protocol that allows a user on one host to transfer files to and from another host over a network.

Groupware
A network-based application that lets users collaborate.

Home Page
The first page of a Web site or of a logical group of HTML documents.

HTML (HyperText Markup Language)
The language with which World Wide Web documents are formatted. It defines fonts, graphics, hypertext links, and other details. HTML is an implementation of SGML.

HTTP (HyperText Transfer Protocol)
The protocol that negotiates document delivery to a Web browser from a Web server.

Hypertext
A way of presenting information in which there are links from one document to another. In a Web document, the link is a URL, pointing to another Web page or other resource.

Internet
A private network that uses Internet software and standards.
A web server programming interface for back-end applications developed by Microsoft and process Software Corp.

JAVA
An object-oriented language, developed by Sun Microsystems, for writing distributed Web applications.

NNTP (Network News Transfer Protocol)
A protocol for posting and retrieving news articles on Usenet newsgroups.

NSAPI (Netscape Server API)
A programming specification for Netscape’s Web servers to access back-end applications.

ODBC (Open Database Connectivity)
An interface developed by Microsoft to let clients access multiple database engines.

Perl
An interpreted scripting language, typically used in writing CGI scripts.

Replication
The process of synchronizing data stored on two or more computers.

SGML (Standard Generalized Markup Language)
A standard for defining and managing the structure and format of electronic documents.

S-HTTP (Secure HTTP)
An extension of HTTP for authentication and data encryption between a Web server and a Web browser.

SQL (Structured Query Language)
A standard language for requesting information from a relational database.

SSI (Secure Sockets layer)
A transport-level technology for authentication and data encryption between a web server and a Web...
browser.

TCP/IP (Transmission Control Protocol/Internet Protocol)
he collection of transport and application protocols used to communicate on the internet and other networks.

URL (Universal Resource Locator)
A standardized character string that identifies the location of an internet document.

Web Browser
Client software that requests and displays HTML documents and other internet or intranet resources.

Web Server
A server that stores and retrieves HTML documents and other Internet or intranet resources using HTTP. Also called an HTTP server.

Workflow
A set of formal rules for a specific process (such as billing) that are defined to improve efficiency.

World Wide Web
The Internet’s worldwide, HTML-based, hypertext-linked information system.

INTERNET
We all have heard about a monster called internet. We are aware that this monster is stalking somewhere nearby, but are not clear about its intentions, its hunger or its power. Every magazine whether Indian or Firangi, is dedicating a couple of pages to it. Everybody is talking about it, but everybody is talking about it, but very few really seem to be familiar with it. Even those who are, are not able to fully comprehend the potential of this monster. Below discuss the various aspects of this monster and try to bring from implications.

INTERNET BASICS
Firstly, lets clear this funda behind Web pages & web sites. The integrative version of the Internet that you (shall) be using is actually the World Wide Web(WWW). On the WWW there are millions of computers holding the information. All connected to one another. These servers are called Web Servers. However, for the Internet the actual hardware form of the Web Server has no relevance. What really matters is the virtual site residing on the server, recognized by the SPC URL dressing convention of the Net. Thus many sites may reside on the same server (ex:WWW.efy.com could be the URL of a Web site). On each web site there can be numerous Web pages i.e. documents containing information which are linked together.

INTERNET FOR ONE AND FOR ALL
For Student’s: A man who yearns for knowledge is always a student. Whether you are five years old or fifty, if you need any information on any subject it is the networe you should check out first. The net is the largest library that you can be a member of the net is for the libraries what paramatma is for the everything in the latter is bound to be there on the former. So whether you are doing your geography home work or research on the Bermuda Triangle, you are sure to find more information on the subject, then you could even handle. Therefore, any student with a of pc and modem should not miss out. In case you have computers in your academic institute, make sure to form a large group and pressure your principal to go for it.

For Business Society: A ordinary man/woman can develop his/her business/profession by the use of
internet for: market survey, products availability, scope and viability, marketing trend and market size, project implementation, PFR & relevant information on entrepreneurial – managerial - financial and technological aspects. You don’t need to have a business man of a MARWARI to realize the business potential of the Net. A simple logical mind will do. Some of the benefit of these Web pages will form the basic component of the whole scenario. Each aspect of your organization that you would like to be published will be placed in their web pages.

Hence, to set up a global office you will have to buy a Web site or Web pages and put your information there. You will need to constantly update your information or else users will stop visiting your site.

For Foreign Trade: For people dealing in foreign trade, the internet is of further advantage. Whether you are into imports or exports internet can reduce your communication costs as well as act as a direct interface between you and your clients.

For an importer the top two consideration for a deal are, the product and the price. ‘A simple search across the Web can fetch you more addresses of prospective sources than any directory you could buy in this world. On top of that, you could e-mail to the company your requirements, the conditions for the deal and the necessary details immediately and cut down the cost of the communications as well as the delay involved, in fact, there are high chances that you will get the response from the opposite side sooner than you could have imagined.

As for an exporter the greater the exposure the more business, the net is the media which tops in this criteria. You don’t even need a web site. A web page which costs around three thousand rupees will be sufficient. There are hundreds of web consultants who have set up shop in India and will eagerly do this task for you.

After this, anybody in the world who needs the items that you sell, will get your details as a part of his search list, whenever he conducts a search on the web. The rest is upto your organizations merit and competence, but whatever be the case the volume of your services is bound to increase and you automatically will become a global player in the true sense.

For Inter Corporate Communications: The internet facilities such as chat & tools which could reduce more than half of your communications bill. By simply using E-mail instead of fax and telex you can cut down the price of your telephone bills by 75%. Along with this you get a prompt and absolutely secure delivery of message.

The chat facility has the potential to not only reduce the costs of communication but also to improve its quality. On a normal phone call a maximum of three callers can talk simultaneously, but with chat, all your regional offices can have a conference and that too at the cost of local call. Just imagine no more of those STD if each of your offices gets and internet connection.

The software development community: The question that has been repetitively asked is that if India has one of the best programmers in the world, then why don’t we have an Indian Software which is a equivalent of Windows95 or JAVA? Why are none of the Indian products so famous? The reply has always been the lack of mega bucks to market. Now at least the Indian software developers have a platform where they are equivalent to their US counter-parts. The internet is open to all and anybody
may exhibit his/her products on it. Apart from begin a larger distribution channel, internet also opens new frontiers for after sales service and up-gradation facilities. An upgrade or a patch can easily be put on the net and the distribution costs can be reduced dramatically. This does sound to be a death knell for those forming a part of the software trade channel, but only time will tell. However, one thing is certain – these margins will grow thinner and the software will become cheaper and cheaper.

For Common Man: Is the internet useless for a common man? If you were to ask me the answer is far from No. In fact, the internet could be your future version of the household television or vice versa. You can get any information on the net, be it the news, your favorite recipes or the latest stock quotes. You could daily converse or exchange messages with your relatives anywhere in the world and get pay only for local calls.

You could choose the best place to spend your vacations and could even make the reservations in advance from your terminal itself.

And if you are one of the privileged ones to own a credit card, you could even go ahead and make a purchase over the net.

The possibilities are endless, the implications mind boggling. The facilities are just great.

WEB PAGE DESIGNING

ASSESSMENT OF NEEDS

A few fundamental questions need to be answered about the issues pertaining to Web site design before implementing the site.

What is the Web site all about?
It is important to identify the general idea of why the web site is wanted or needed.

What are the client’s particular needs?
Every customer has unique needs that need to be addressed to make the site a success.

What are the objectives of the site?
The general idea should be elaborated to formulate clear distinct objectives.

Design: A well done assessment of needs allows a smooth transition into design. The design should follow the essence of the needs. The most critical point that should always be kept in mind is that the ultimate reason of existence for a Web site is to maximise the number of visitors to the site.

Visualisation: This is beginning of a holistic approach to Web site design. It is important to be able to visualise the general structure of the site, how it will look, how it will feel, and how it will interact with the person at the Web site.

Story Board: A mock-up of the envisaged page, made either on paper or a painting program like Photoshop, to serve as a reference for the final design, which is to be done on an authoring tool. Also, to demonstrate the site to the client for approval and/or modifications.
**Style Guide**: A set of rules for typefaces, typographic and graphic conventions to establish a uniform and clean look to the site.

**THE SIX DEADLY SINS OF WEB SITE DESIGN**

**The First Deadly Sight Using Blank Lines as Paragraph Separators**: When you use blank lines as separators, the meaning of a blank line goes away. It turns into punctuation. In 3\textsuperscript{rd} generation typography, indents separate paragraphs, and the right amount of vertical white space, maybe a blank line, maybe a bit more-separates section, clumping paragraphs into logical groups for better reading.

**The Second Deadly Sight Horizontal Rules**: Horizontal rules are a weak substitute for proper hierarchy and organisation of vertical space on Web pages. There are millions of horizontal rules on the Web, doing nothing but taking up space, and breaking the natural flow of pages. Horizontal rules are not spacers; they are barriers.

**The Third Deadly Sight Background Images That Interfere**: Backgrounds on the web have reached epidemic proportions. Wall paper is nice, but reading the handwriting on the wall can be difficult. It’s like writing on gift paper not at all easy on the eye.

**The Fourth Deadly Sight The Slow Download**: Conversation between friends can survive long silent pauses, but few Web pages can take long to load. A good rule is that most pages in a site should be under 30K, a few can be 30-50K, and perhaps 1 or 2 can be 70K.

**The Fifth Deadly Sight Rough Looking Images**: Jagged lines around images, blurred text, etc., can often result from inappropriate testing with various browsers at the design stage. This means that at the design stage, the various aspects of the Web site should be considered.

**The Sixth Deadly Sight Paralysis**: Don’t overdo it. There is always the temptation to refine the Web page continuously. There will always be a few things more you would like to do. At some point, though, it is important to arrive at a final design.

**Implementation**: The key to implementation is making your site third generation. A definition of first, second, and third generation Web sites will help here.

1. **First Generation Web Sites**: These were linear. The format is top to bottom, left to right. There is a sequence of images, with little or no guidance as to how the site functions.
2. **Second Generation Web Sites**: Basically, these are first generation sites with icons replacing words. More colourful, but not much more sophisticated.
3. **Third Generation Web Sites**: These sites are designed to attract, entice, then guide the user through the site. A holistic approach.
4. **Hosting Issues**: It is important to know how your Web site will function before it is up and running. The important parameters to talk to your hosting service about are:-

**FTP Access**: Can you update the site on your own, anytime, from anywhere? You must have an FTP account in order to do this.
E-mail: How many aliases can you make? Is there forwarding of mail to your regular mailbox?

Auto-responders: Automatic responses to certain e-mail.

CGI/Bin Directory: Allows you to write custom CGI scripts. Essential for basic interactivity such as feedback forms and access counters.

Public FTP Access: Allows others to download/upload software.

Preinstalled CGI Scripts: CGI is cumbersome to write.


Domain Name: Your own domain name gives your site its own identity.

Kind of Server: As discussed, previously

Kind of Lines: As discussed, previously

Disk Space: At least 25-30 MB are offered as standard.

Count/Traffic Reports: The most important measure of the success of your site.

ASSIMILATION EXERCISE

Q.1 List down the merits and demerits of Hardware.
Q.2 Discuss the various topologies involved in hardware and bring out there advantages and limitations.
Q.3 Explain the various layers of the OSI model and list down the function of each.
Q.4 Explain the various techniques involved for transmission of data.
Q.5 What do you mean by data distribution? What are the different advantages and disadvantages of data distribution?
Q.6 Explain the following terms in context with networking:
   a. Repeater
   b. Bridge
   c. Router
Q.7 What do you understand by electronic mail? Give the URLs for three free electronic-mail sites.
Q.8 What do you mean by Internet? Giving examples, bring out the merits and demerits of Internet.
Q.9 What is a World Wide Web? Explain the transmission protocols involved.
Q.10 You're sending some important documents in a file with extension .doc. You don't want its setting to be altered or its extension to be changed. How will you send it. Explain the various steps involved.
Q.11 Explain the term “Remote Login”. List the various ways of doing so.
Q.12 With the help of a diagram explain the client-server architecture and illustrate how a request is sent to the server and how it reaches the client.
“The successful organisation of the next decade will be the ones that use Electronic Commerce to re-invent the way they work. These companies will make decisions quickly, act efficiently and directly touch their customers in positive ways. Hence for them the -  
Business will be @ rate of Thought Process”

E-COMMERCE

COMPETENCY OBJECTIVES

The objective of this Section is to make students understand the basic concepts of Electronic Commerce and acknowledge the movement of its tools towards enterprise integration. At the end of the course, a student should be able to :-

- Enable the users to familiarize with the Electronic Data Interchange.
- Understand the concepts of Internet & Electronic Funds Transfer.
- Conceptualize the working involved in Electronic Catalogues.
- To understand the concepts involved in Intranets and Bar Codes.
- Understand the basic concepts of Electronic Commerce and its tools which lead us towards Enterprise Integration.
Over the past few years, there has been a dramatic shift toward widespread implementation of Electronic Commerce (EC). In fact, within the commercial world, EC is fast becoming the norm. EC is the term that describes conducting business activities with the associated technical data via electronic and telecommunication technologies. EC is the tool that leads to “enterprise integration,”—for a company, for an industry and ultimately for the vast network of small businesses, government agencies, large corporations, and independent contractors. The vision of “enterprise integration” is a single community with the ability to communicate seamlessly across any computer platform.

Enterprise integration is multifaceted. It begins with implementing a commonly accepted strategic direction across all organizational levels. A standardized trajectory involves uniting all business processes across functional and organizational lines. It also means integrating internal functions with external trading partners. Standardizing data and sharing corporate information through a common infrastructure is fundamental for optimal business practices. There are many EC tools that facilitate the movement toward enterprise integration. These include:

**Electronic Data Interchange (EDI)**

**The Internet**

**Electronic Funds Transfer**

**Electronic Catalogs**

**Intranets**

**Bar Codes**

**ELECTRONIC DATA INTERCHANGE**

EDI is the computer to computer exchange of routine business information between trading partners in a standard format. The standard format most widely used in the United States is the ANSI X12 standard, which allows computers with installed EDI software to share data in a structured fashion. The X12 standard supports hundreds of documents that businesses routinely exchange with each other – generic documents like Requests for Quote, Purchase Orders, Invoices and Bills of Lading as well as industry specific documents like Mortgage Notes and Vehicle Shipping Orders. If two trading partners have disparate computer systems, they can still exchange these documents electronically. EDI software translates user friendly data entry screens into the X12 standard format for transmission; when an EDI message is received the software translates the coded message to the receiver’s user friendly format.
Most EDI transmissions go through a Value Added Network (VAN), a third party company that is able to handle multiple communication protocols. VANs enable companies to bundle many EDI messages into a single transmission. They also ensure high level security and ready access at all times.

Many industries, – auto, insurance, aerospace, electronics, textiles, retail, for example – make widespread use of EDI. Other economic sectors are just getting started. Usually large corporations with very high volumes of paperwork are the first in an industry to implement EDI, requiring that their suppliers, and often their customers, become EDI capable. As a result, EDI capability has spread throughout the commercial world. Over 100,000 companies are presently EDI capable, with projected geometric growth in the near future. Increasingly, industry associations, such as the Aerospace Industry Association, work to develop an industry-wide approach to EDI so that implementation is easier for smaller suppliers.

EDI’s contribution to enterprise integration goes beyond the ability to exchange and track business information electronically with trading partners. Much of the information that flows through a company’s internal applications – the order entry system, the accounting system, the inventory control system, etc. – comes from its trading partners. EDI Integration software gives a company the capacity to integrate the data that is exchanged with a trading partner into those internal systems. When a purchase order arrives electronically, the appropriate information can be moved automatically to each of the internal applications where it is needed to facilitate the transaction. Routine operations cease to require human intervention. The result is that companies can frequently eliminate bottlenecks in processing orders.

EDI can also be coupled with Electronic Funds Transfer (EFT) so that when a firm receives a payment notice it simultaneously receives the detailed information about that payment. This is known as Financial EDI (FEDI).

EDI offers many benefits to firms that deploy the technology, especially if the company integrates the trading partner information with its internal applications. These include:

- better cash management
- reduced order time
- reduced inventory
- lower document processing costs
- increased business opportunities
- more accurate records leading to better decisions
- greater customer satisfaction

THE INTERNET

The Internet is a burgeoning new communication medium that is a powerful asset to businesses and individuals. It connects approximately 60,000 independent networks into a vast inter-connected global network. With the number of Internet users growing at a rate of one million each month it is difficult to project the precise number of Internet users; however, experts estimate over 25 million people are currently on-line. The World Wide Web and developing technologies, such as Web TV, have generated widespread interest, offering user-friendly browser interfaces with advanced multimedia capabilities, including real time audio and video integration. People use the Internet for everything from electronic mail to discussion forums (newsgroups) and file transfer. It is also a superior resource for information search and retrieval. Companies recognize the Internet as a viable marketing tool, offering competitive
advantages and practical solutions. Some Internet based business opportunities include:

- advertising and promotion
- unaided products/service recall • get the word out about products and services
- customer support
- provide customers easy access to product or service information
- mailing lists
- communicate with existing and potential clientele about product development, launches, and special promotions offered
- customer orders and requests
- let customers order either regular or custom merchandise directly through a WWW site
- product specifications
- provide full details about products so customers can make knowledgeable decisions, and vendors and salespeople can have up-to-date information
- purchase products
- lower process time and inventory through an electronic point-of-purchase
- research
- access critical data for product development
- reach suppliers and potential customers
- keep current about industry developments
- see how competitors are using the WWW for marketing
- collaboration
- manage projects across companies

Some large corporations are using the Internet to manage their supplier chains throughout the full cycle of design, procurement and production of complex products. The developing AIMSNet (Agile Infrastructure for Manufacturing Systems Network) World Wide Web site is a joint effort of Lockheed Martin Missiles and Space Company, Rocketdyne, Texas Instruments, and other industry leaders. AIMSNet’s site creates a technological infrastructure on the Internet for companies with different but complementary core capabilities to come together as virtual corporations. Via this alliance, participants devise business practices that incorporate electronic commerce and other technologies. Users work together to remove roadblocks hindering rapid and efficient teaming arrangements.

Federal, state and local government agencies are also using the Internet to announce business opportunities and to provide suppliers with timely procurement regulations and practices.

An electronic catalog (published on the World Wide Web) provides a number of business advantages. As a cost effective, convenient medium, customers can access an on-line catalog 24 hours a day, seven days a week. By directly linking it to internal business applications like order entry, inventory, manufacturing and accounting systems, businesses can achieve business practice integration. Companies can save on print production and distribution costs associated with traditional catalogs. At the same time, electronic catalogs allow firms to inexpensively update and change content.

Companies are also starting to use the WWW to exchange EDI transactions. Using encryption technology, they are sending documents over the public access Internet instead of over the privately owned VANs. EDI over the Internet often can be cheaper and faster than over VANs. It also makes it easier for larger companies to get small businesses to “buy in” to using EDI. Yet, the transition process to Internet based
EDI has been slow due to security concerns and the need for partners to use the same proprietary software. Another option businesses are turning to is a combination of Web sites to attract trading partners, exchange information and take orders linked to back-end order-processing and financial systems via EDI.

INTRANETS

As companies find more and more ways to use the Internet to communicate with trading partners and to create an electronic face to the world, they have simultaneously turned inward to create Intranets as a means for distributing internal company information, such as:

- company news
- corporate policies
- employee information
- internal job postings
- bulletin boards
- phone directories
- press releases
- computer policies

Through Intranets, businesses can distribute company information far more cheaply than by any other method. The information is always current and any employee with a computer can access it. Companies are using Intranets to allow access to data stored on company databases, and to the technology at department and workgroup levels for information sharing.

Within a company, different information distribution approaches do not have the same benefits as an Intranet. For example, while file servers on a network can provide reliable access to files, it can be difficult to search, view, and edit files. E-mail as a means for sharing information has many limitations including difficulties with attachments across platforms and a user may not know everyone in the organization who should receive a copy. Paper documents are time consuming and inefficient, requiring additional process time with subsequent updates.

One feature of Intranets is hardware and software platform flexibility based on open standards. The technology is simple to use because of hyperlinking. Document access can easily be controlled. Furthermore, content developers can easily distribute information to interested users. Studies show that Intranets are extremely cost effective solutions. This Intranet use of browser and Internet technology has become possible because of the development of personal web-page authoring tools which make publishing a document on an Intranet web server comparable to saving a document in a desktop application.

ELECTRONIC FUNDS TRANSFER

Electronic Funds Transfer (EFT) coupled with Financial Electronic Data Interchange (FEDI) is changing the way businesses pay their bills. More than 23% of companies with annual sales over $1 billion, and 13% of companies with sales between $100,000 and $1 billion use FEDI/EFT.
Just as EDI uses the ANSI X12 standard for the transfer of data, EFT uses the NACHA (National Automated Clearing House Association) standard for the exchange of funds payment documents.

While traditional Purchase Order procedures offer document annotation and conventional support options without additional equipment, it is a labor intensive system. Slowed down by the mail and various departments (accounts payable, accounts receivable) that must perform operations for the billing/payment process to move forward, this approach is not efficient. It is error-prone because the same information is often entered and re-entered, with each data entry increasing the probability of mistakes. Another shortcoming of the traditional Purchase Order process is acknowledgment of cash flow changes is usually done in a monthly statement and there is no advance notice of discrepancies. Furthermore, checks may be lost or there may be security problems during processing steps.

Many of these problems are eliminated when a business adopts FEDI/EFT. FEDI/EFT allows a business to manage and improve cash flow and to take advantage of discounts by precisely scheduling payments. Discrepancies can be resolved immediately because advance notifications of payment accompany the transfer of funds. By combining EFT with EDI, the business eliminates the need to re-associate data about a payment with the payment since the information and the dollars are transmitted together. This convergence usually reduces labor costs and expenses associated with reconciling payments and invoices. It also leads to improved trading partner relationships as companies work together to implement the technology for mutual benefit.

**ELECTRONIC CATALOGS**

Electronic catalogs offer the utmost value to both purchasers and suppliers. Given the complexity of many manufactured items (autos, airplanes, computers) and the number of parts that may require replacement, a technician or engineer may have to keep catalogs from dozens of manufacturers on hand. As most manufacturers periodically update their catalogs, ensuring the one on hand is the latest and that the catalogs are organized in an easily located manner becomes time consuming. Industrial catalogs are often out-of-date shortly after distribution and they often lack all the specifications that a potential product user may need.

Conversely, an on-line catalog system allows a technician or engineer to click between screens, viewing the most up-to-date version and comparing product choices available. Technology today makes searching for particular product types easy. Virtually unlimited amounts of technical data about the product can be linked to the product’s listing. Further, electronic catalogs are capable of providing additional information like special contract pricing, and of linking to order entry and purchasing departments so that the entire transaction can be done on-line. From the supplier’s point of view, putting the product line into an electronic catalog on the WWW, can save the business an enormous amount in developing, printing, and distribution costs.

Moreover, the electronic catalog:
- can be updated as frequently as necessary with information about product announcements, special sales and inventory status
- can contain full specifications about each product listed.
can be available to existing and potential customers 7 days a week, 24 hours a day
• can give a company access to global markets without requiring a physical presence
• can facilitate better customer service

The catalog can also be integrated with other computer applications, like order entry, shipping, invoicing, inventory control, etc. to create a seamless electronic commerce system for the business. Electronic catalogs range in complexity. At the simplest end are catalogs that consist of data sheets or pages which are stored in HTML (Hypertext Markup Language) files. They provide simple search capabilities and the user’s only navigation tool are hyperlinks. More complex catalogs enter static information and search data in a database, making searching for and accessing information easier. These catalogs can be customized so that each customer (or group of customers) will be able to access specialized information such as exclusive contract pricing, or past history ordering information offering the potential for one-on-one marketing. More sophisticated catalogs allow the buyer to select and order products from the on-line catalog electronically, and allow the seller to verify credit status, and integrate the sale with the businesses back end ordering system.

BAR CODES

Bar codes are a machine-readable symbols. They can be “read” into any computer system that can import preprinted data. They can thus be used in many production and inventory environments. Some of the more common uses are:

• Materials handling
• Monitoring work-in-progress
• Point-of-sale record keeping
• Assembly verification
• Shipping and receiving
• Document tracking
• Airline baggage sorting
• Employee ID cards.

This list is merely a small sample of its possible applications. Other current practices exist and new bar coding practices continue to emerge.

Bar codes are read by a scanners, containing both a light source and a light detector. Focusing a spot of light on the symbol, the scanner uses the light detector to distinguish the reflexivity of the bars and spaces. Internal hardware and software determine if the pattern represents a valid bar code to be decoded.

Widely used in automobile and other complex manufacturing processes, bar codes are linked with just-in-time inventory and EDI to minimize inventories as well as to generate automatic inventory payment.
Technical Data Interchange (TDI)

Technical Data Interchange (TDI) refers to the standard electronic processes used in the exchange of technical information, drawings, manuals, and specifications. TDI enables secure, reliable communications. It also allows for interoperability of applications and information structures.

There are a number of benefits that result from exchanging electronic forms of technical data. For example, TDI makes it easier for designers and the manufacturing engineers to collaborate on projects. This approach accelerates the design cycle and reduces errors. Essentially, TDI reduces the procurement cycle and improves quality. At the same time, several types of production problems are reduced by using computer analysis for components and manufacturing process. Moreover, TDI creates opportunities for better customer support.

During the 1980’s, Continuous Acquisition and Life-Cycle Support (CALS) began as a Department of Defense initiative to exchange technical data with the government in electronic format rather than in paper. The CALS initiative is defined by the DoD as a core strategy for sharing integrated digital product data through a set of standards for more efficient business and operational missions.

The types of technical data are Product data, Engineering data, Technical documents and Technical illustrations. In the CALS initiative, some of the DoD’s MIL standards used for TDI include:

- MIL-D-28000A - Initial Graphics Exchange (IGES)
- MIL-M-28001B - Standard Group Markup Language (SGML)
- MIL-D-28002B - CALS Raster Graphics
- MIL-D-28003A - Computer Graphics Metafile (CGM)

The descriptions and specifications of these standards are available on the web at the Defense Information Systems Agency (DISA).

LEGACY DATA MANAGEMENT

Historically, companies, especially manufacturing companies, have had to track voluminous amounts of information over lengthy periods of time. As a result of this need, various practices and methodologies were developed to capture the continuously growing body of data. These processes came to be known as Legacy Data Management. Thus Legacy Data Management (LDM) is the process and methodologies developed to maintain, track, store and use the large volumes of data generated by businesses in a cost-effective manner.

The advent of the computer age greatly contributed to LDM efforts, as the new hardware and software being developed resulted in a diversity of formats and standards. With this diversity came another problem, often called “Islands of Automation”. Hardware and software were developed for specific areas of the enterprise such as CAD/CAM, accounting, manufacturing-resource planning etc. Each system had its own proprietary data formats and thus integration of the various systems became an expensive and difficult aspect of implementing computer technology. Legacy Data Management can help companies effectively and efficiently do the same.
LDM involves identifying and converting historical information (paper-based and archaic electronic formats) to current electronic standards. Companies implementing the above technology have greater efficiency and productivity because LDM results:

- Cost savings
- Occupies less storage space
- Enhanced data consistency
- Increased data availability
- Minimal data loss
- Improved responsiveness

Implementing LDM involves the following processes

- Performing a System Needs Analysis
- Performing a Cost Benefit Analysis
- Developing a conversion plan
- Implementing the plan

LDM is becoming even more significant with the surge of the internet as it will help corporation share and integrate historical data beyond company boundaries.

ASSIMILATION EXERCISE

Q.1 Explain the terminology involved in Electronic Commerce.
Q.2 List the various tools of E-commerce.
Q.3 Explain the concept of electronics data interchange.
Q.4 What do you understand by Electronic Funds Transfer. Give examples.
Q.5 List the importance of Electronic Catalogs.
Q.6 Explain the concept of bar-codes.